gnu: glib: Upgrade to 2.40.0.
[jackhill/guix/guix.git] / gnu / packages / nettle.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages nettle)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages multiprecision)
25 #:use-module (gnu packages m4))
26
27 (define-public nettle
28 (package
29 (name "nettle")
30 (version "2.7.1")
31 (source (origin
32 (method url-fetch)
33 (uri (string-append "mirror://gnu/nettle/nettle-"
34 version ".tar.gz"))
35 (sha256
36 (base32
37 "0h2vap31yvi1a438d36lg1r1nllfx3y19r4rfxv7slrm6kafnwdw"))))
38 (build-system gnu-build-system)
39 (arguments
40 ;; 'sexp-conv' and other programs need to have their RUNPATH point to
41 ;; $libdir, which is not the case by default. Work around it.
42 '(#:configure-flags (list (string-append "LDFLAGS=-Wl,-rpath="
43 (assoc-ref %outputs "out")
44 "/lib"))))
45 (native-inputs `(("m4" ,m4)))
46 (propagated-inputs `(("gmp" ,gmp)))
47 (home-page "http://www.lysator.liu.se/~nisse/nettle/")
48 (synopsis "C library for low-level cryptographic functionality")
49 (description
50 "GNU Nettle is a low-level cryptographic library. It is designed to
51 fit in easily in almost any context. It can be easily included in
52 cryptographic toolkits for object-oriented languages or in applications
53 themselves.")
54 (license gpl2+)))
55
56 (define-public nettle-3
57 ;; This version is not API-compatible with version 2. In particular GnuTLS
58 ;; cannot use it yet. So keep it separate.
59 (package (inherit nettle)
60 (version "3.0")
61 (source (origin
62 (method url-fetch)
63 (uri (string-append "mirror://gnu/nettle/nettle-"
64 version ".tar.gz"))
65 (sha256
66 (base32
67 "04yrpjz33vrj6j0zxc153b00f93i8hs41syr1ryp7sr64fyw0lcn"))))))