hcoop release
[hcoop/debian/courier-authlib.git] / debian / patches / 0005-libcourierauth-libraries-are-normal-shared-libraries.patch
1 From: =?utf-8?q?Ond=C5=99ej_Sur=C3=BD?= <ondrej@sury.org>
2 Date: Wed, 16 Mar 2016 10:16:21 +0100
3 Subject: libcourierauth* libraries are normal shared libraries,
4 treat them as such
5
6 ---
7 Makefile.am | 14 +++++++-------
8 1 file changed, 7 insertions(+), 7 deletions(-)
9
10 diff --git a/Makefile.am b/Makefile.am
11 index 6c17973..e41bcfd 100644
12 --- a/Makefile.am
13 +++ b/Makefile.am
14 @@ -18,9 +18,9 @@ modules=@LIBAUTHUSERDB@ \
15 pkglibexecdir=$(libexecdir)/courier-authlib
16 pkglibexec_SCRIPTS=authsystem.passwd
17
18 -pkglib_LTLIBRARIES=libcourierauth.la libcourierauthcommon.la \
19 - libcourierauthsasl.la libcourierauthsaslclient.la \
20 - $(modules)
21 +lib_LTLIBRARIES=libcourierauth.la libcourierauthcommon.la \
22 + libcourierauthsasl.la libcourierauthsaslclient.la
23 +pkglib_LTLIBRARIES=$(modules)
24 sbin_SCRIPTS=authdaemond
25 sbin_PROGRAMS=authtest authenumerate authpasswd
26 bin_PROGRAMS=courierauthconfig
27 @@ -62,7 +62,7 @@ libcourierauthcommon_la_SOURCES= \
28
29 libcourierauthcommon_la_DEPENDENCIES=libcourierauth.la
30 libcourierauthcommon_la_LIBADD=libcourierauth.la
31 -libcourierauthcommon_la_LDFLAGS=$(libcourierauthcommon_t:%=-Wl,%) -avoid-version
32 +libcourierauthcommon_la_LDFLAGS=$(libcourierauthcommon_t:%=-Wl,%) -version 0:0:0
33
34 libcourierauth_la_SOURCES=authdaemon.c authdaemonlib.c preauthdaemon.c \
35 authmoduser2.c authmoduser3.c debug.c \
36 @@ -70,7 +70,7 @@ libcourierauth_la_SOURCES=authdaemon.c authdaemonlib.c preauthdaemon.c \
37 authoption.c
38 libcourierauth_la_LIBADD=libs/libhmac/libhmac.la libs/md5/libmd5.la libs/sha1/libsha1.la libs/numlib/libnumlib.la \
39 libs/random128/librandom128.la libs/rfc822/libencode.la
40 -libcourierauth_la_LDFLAGS=@NETLIBS@ -avoid-version
41 +libcourierauth_la_LDFLAGS=@NETLIBS@ -version 0:0:0
42
43 # The userdb module
44
45 @@ -315,7 +315,7 @@ libcourierauthsasl_la_SOURCES=\
46 authsaslcram.c authsasllogin.c authsaslplain.c \
47 authsaslfrombase64.c authsasltobase64.c
48 libcourierauthsasl_la_LIBADD=libcourierauthcommon.la libcourierauth.la
49 -libcourierauthsasl_la_LDFLAGS=-export-symbols-regex '^auth_sasl|auth_sasl_ex|auth_sasl_extract_userid$$' -avoid-version
50 +libcourierauthsasl_la_LDFLAGS=-export-symbols-regex '^auth_sasl|auth_sasl_ex|auth_sasl_extract_userid$$' -version 0:0:0
51
52 libcourierauthsaslclient_la_SOURCES=courierauthsaslclient.h \
53 authsaslclient.c authsaslclient.h authsaslclientcram.c \
54 @@ -324,7 +324,7 @@ libcourierauthsaslclient_la_SOURCES=courierauthsaslclient.h \
55 authsaslclientexternal.c \
56 authsaslfrombase64.c authsasltobase64.c
57 libcourierauthsaslclient_la_LIBADD=libcourierauth.la
58 -libcourierauthsaslclient_la_LDFLAGS=-export-symbols-regex '^auth_sasl_client$$' -avoid-version
59 +libcourierauthsaslclient_la_LDFLAGS=-export-symbols-regex '^auth_sasl_client$$' -version 0:0:0
60
61 include_HEADERS=courier_auth_config.h courierauth.h courierauthsasl.h \
62 courierauthsaslclient.h courierauthdebug.h courierauthstaticlist.h