Merge branch 'master' into wip-particles
[clinton/guile-figl.git] / upstream-doc / spec / glx.spec
1 # Copyright (c) 1991-2005 Silicon Graphics, Inc. All Rights Reserved.
2 # Copyright (c) 2006-2010 The Khronos Group, Inc.
3 #
4 # This document is licensed under the SGI Free Software B License Version
5 # 2.0. For details, see http://oss.sgi.com/projects/FreeB/ .
6 #
7 # $Revision: 17025 $ on $Date: 2012-03-05 03:01:59 -0800 (Mon, 05 Mar 2012) $
8
9 required-props:
10 param: retval retained
11 dlflags: notlistable handcode nop
12 glxflags: client-handcode server-handcode
13 glxvendorglx: *
14 vectorequiv: *
15 category: pixel-rw bgn-end display-list drawing drawing-control feedback framebuf misc modeling pixel-op pixel-rw state-req xform glx glxopcode
16 glxopcode: *
17
18 ###############################################################################
19 #
20 # GLX1.0 commands
21 #
22 ###############################################################################
23 Render()
24 return void
25 category glx
26 dlflags notlistable
27 glxflags client-handcode server-handcode
28 glxopcode 1
29
30
31 RenderLarge()
32 return void
33 category glx
34 dlflags notlistable
35 glxflags client-handcode server-handcode
36 glxopcode 2
37
38
39 CreateContext(gc_id, screen, visual, share_list)
40 return void
41 param gc_id Int32 in value
42 param screen Int32 in value
43 param visual Int32 in value
44 param share_list Int32 in value
45 glxflags client-handcode server-handcode
46 category glx
47 dlflags notlistable
48 glxopcode 3
49
50
51 DestroyContext(context)
52 return void
53 param context Int32 in value
54 glxflags client-handcode server-handcode
55 category glx
56 dlflags notlistable
57 glxopcode 4
58
59
60 MakeCurrent(drawable, context)
61 return void
62 param drawable Int32 in value
63 param context Int32 in value
64 glxflags client-handcode server-handcode
65 category glx
66 dlflags notlistable
67 glxopcode 5
68
69
70 IsDirect(dpy, context)
71 return void
72 param dpy Int32 in value
73 param context Int32 in value
74 glxflags client-handcode server-handcode
75 category glx
76 dlflags notlistable
77 glxopcode 6
78
79
80 QueryVersion(major, minor)
81 return void
82 param major Int32 out reference
83 param minor Int32 out reference
84 category glx
85 dlflags notlistable
86 glxflags client-handcode server-handcode
87 glxopcode 7
88
89
90 WaitGL(context)
91 return void
92 param context Int32 in value
93 category glx
94 dlflags notlistable
95 glxflags client-handcode server-handcode
96 glxopcode 8
97
98
99 WaitX()
100 return void
101 category glx
102 dlflags notlistable
103 glxflags client-handcode server-handcode
104 glxopcode 9
105
106
107 CopyContext(source, dest, mask)
108 return void
109 param source Int32 in value
110 param dest Int32 in value
111 param mask Int32 in value
112 category glx
113 dlflags notlistable
114 glxflags client-handcode server-handcode
115 glxopcode 10
116
117
118 SwapBuffers(drawable)
119 return void
120 param drawable Int32 in value
121 category glx
122 dlflags notlistable
123 glxflags client-handcode server-handcode
124 glxopcode 11
125
126
127 UseXFont(font, first, count, list_base)
128 return void
129 param font Int32 in value
130 param first Int32 in value
131 param count Int32 in value
132 param list_base Int32 in value
133 category glx
134 dlflags notlistable
135 glxflags client-handcode server-handcode
136 glxopcode 12
137
138
139 CreateGLXPixmap(visual, pixmap, glxpixmap)
140 return void
141 param visual Int32 in value
142 param pixmap Int32 in value
143 param glxpixmap Int32 in value
144 category glx
145 dlflags notlistable
146 glxflags client-handcode server-handcode
147 glxopcode 13
148
149 GetVisualConfigs()
150 return void
151 category glx
152 dlflags notlistable
153 glxflags client-handcode server-handcode
154 glxopcode 14
155
156
157 DestroyGLXPixmap(pixmap)
158 return void
159 param pixmap Int32 in value
160 glxflags client-handcode
161 category glx
162 dlflags notlistable
163 glxopcode 15
164
165
166 VendorPrivate()
167 return void
168 glxflags client-handcode server-handcode
169 category glx
170 dlflags notlistable
171 glxopcode 16
172
173
174 VendorPrivateWithReply()
175 return void
176 glxflags client-handcode server-handcode
177 category glx
178 dlflags notlistable
179 glxopcode 17
180
181 ###############################################################################
182 #
183 # GLX1.1 commands
184 #
185 ###############################################################################
186 QueryExtensionsString(screen)
187 return void
188 param screen Int32 in value
189 glxflags client-handcode server-handcode
190 category glx
191 dlflags notlistable
192 glxopcode 18
193
194 QueryServerString(screen, name)
195 return void
196 param screen Int32 in value
197 param name Int32 in value
198 glxflags client-handcode server-handcode
199 category glx
200 dlflags notlistable
201 glxopcode 19
202
203 ClientInfo()
204 return void
205 glxflags client-handcode server-handcode
206 category glx
207 dlflags notlistable
208 glxopcode 20
209
210 ###############################################################################
211 #
212 # GLX1.3 commands
213 #
214 ###############################################################################
215 GetFBConfigs()
216 return void
217 category glx
218 dlflags notlistable
219 glxflags client-handcode server-handcode
220 glxopcode 21
221
222 CreatePixmap(config, pixmap, glxpixmap)
223 return void
224 param config Int32 in value
225 param pixmap Int32 in value
226 param glxpixmap Int32 in value
227 dlflags notlistable
228 glxflags client-handcode server-handcode
229 category glx
230 glxopcode 22
231
232 DestroyPixmap(glxpixmap)
233 return void
234 param glxpixmap Int32 in value
235 dlflags notlistable
236 glxflags client-handcode server-handcode
237 category glx
238 glxopcode 23
239
240 CreateNewContext(config, render_type, share_list, direct)
241 return void
242 param config Int32 in value
243 param render_type Int32 in value
244 param share_list Int32 in value
245 param direct Int32 in value
246 dlflags notlistable
247 glxflags client-handcode server-handcode
248 category glx
249 glxopcode 24
250
251 QueryContext()
252 return void
253 dlflags notlistable
254 glxflags client-handcode server-handcode
255 category glx
256 glxopcode 25
257
258 MakeContextCurrent(drawable, readdrawable, context)
259 return void
260 param drawable Int32 in value
261 param readdrawable Int32 in value
262 param context Int32 in value
263 dlflags notlistable
264 glxflags client-handcode server-handcode
265 category glx
266 glxopcode 26
267
268 CreatePbuffer(config, pbuffer)
269 return void
270 param config Int32 in value
271 param pbuffer Int32 in value
272 dlflags notlistable
273 glxflags client-handcode server-handcode
274 category glx
275 glxopcode 27
276
277 DestroyPbuffer(pbuffer)
278 return void
279 param pbuffer Int32 in value
280 dlflags notlistable
281 glxflags client-handcode
282 category glx
283 glxopcode 28
284
285 GetDrawableAttributes(drawable)
286 return void
287 param drawable Int32 in value
288 dlflags notlistable
289 glxflags client-handcode server-handcode
290 category glx
291 glxopcode 29
292
293 ChangeDrawableAttributes(drawable)
294 return void
295 param drawable Int32 in value
296 dlflags notlistable
297 glxflags client-handcode server-handcode
298 category glx
299 glxopcode 30
300
301 CreateWindow(config, window, glxwindow)
302 return void
303 param config Int32 in value
304 param window Int32 in value
305 param glxwindow Int32 in value
306 dlflags notlistable
307 glxflags client-handcode server-handcode
308 category glx
309 glxopcode 31
310
311 DestroyWindow(glxwindow)
312 return void
313 param glxwindow Int32 in value
314 dlflags notlistable
315 glxflags client-handcode server-handcode
316 category glx
317 glxopcode 32
318
319 ###############################################################################
320 #
321 # IRIX5.3 extension commands
322 #
323 ###############################################################################
324
325 ###############################################################################
326 #
327 # SGI_swap_control extension commands
328 #
329 ###############################################################################
330 SwapIntervalSGI()
331 return void
332 glxflags client-handcode server-handcode
333 category glx
334 dlflags notlistable
335 glxvendorglx 65536
336
337 ###############################################################################
338 #
339 # IRIX5.3-PATCH154 extension commands
340 #
341 ###############################################################################
342
343 ###############################################################################
344 #
345 # SGI_make_current_read extension commands
346 #
347 ###############################################################################
348 MakeCurrentReadSGI(drawable, readdrawable, context)
349 return void
350 param drawable Int32 in value
351 param readdrawable Int32 in value
352 param context Int32 in value
353 glxflags client-handcode server-handcode
354 category glx
355 dlflags notlistable
356 glxvendorglx 65537
357
358 ###############################################################################
359 #
360 # SGIX_video_source extension commands
361 #
362 ###############################################################################
363 CreateGLXVideoSourceSGIX(dpy, screen, server, path, class, node)
364 return void
365 param dpy Int32 in value
366 param screen Int32 in value
367 param server Int32 in value
368 param path Int32 in value
369 param class Int32 in value
370 param node Int32 in value
371 glxflags client-handcode server-handcode
372 category glx
373 dlflags notlistable
374 glxvendorglx 65538
375
376 DestroyGLXVideoSourceSGIX(dpy, glxvideosource)
377 return void
378 param dpy Int32 in value
379 param glxvideosource Int32 in value
380 glxflags client-handcode server-handcode
381 category glx
382 dlflags notlistable
383 glxvendorglx 65539
384
385 ###############################################################################
386 #
387 # IRIX6.2 extension commands
388 #
389 ###############################################################################
390
391 ###############################################################################
392 #
393 # EXT_import_context extension commands
394 #
395 ###############################################################################
396 QueryContextInfoEXT()
397 return void
398 category glx
399 dlflags notlistable
400 glxflags client-handcode server-handcode
401 glxvendorglx 1024
402
403 ###############################################################################
404 #
405 # SGIX_fbconfig extension commands
406 #
407 ###############################################################################
408 GetFBConfigsSGIX()
409 return void
410 category glx
411 dlflags notlistable
412 glxflags client-handcode server-handcode
413 glxvendorglx 65540
414
415 CreateContextWithConfigSGIX(gc_id, screen, config, share_list)
416 return void
417 param gc_id Int32 in value
418 param screen Int32 in value
419 param config Int32 in value
420 param share_list Int32 in value
421 glxflags client-handcode server-handcode
422 category glx
423 dlflags notlistable
424 glxvendorglx 65541
425
426 CreateGLXPixmapWithConfigSGIX(config, pixmap, glxpixmap)
427 return void
428 param config Int32 in value
429 param pixmap Int32 in value
430 param glxpixmap Int32 in value
431 category glx
432 dlflags notlistable
433 glxflags client-handcode server-handcode
434 glxvendorglx 65542
435
436 ###############################################################################
437 #
438 # SGIX_pbuffer extension commands
439 #
440 ###############################################################################
441
442 CreateGLXPbufferSGIX(config, pbuffer)
443 return void
444 param config Int32 in value
445 param pbuffer Int32 in value
446 dlflags notlistable
447 glxflags client-handcode server-handcode
448 category glx
449 glxvendorglx 65543
450
451 DestroyGLXPbufferSGIX(pbuffer)
452 return void
453 param pbuffer Int32 in value
454 dlflags notlistable
455 glxflags client-handcode
456 category glx
457 glxvendorglx 65544
458
459 ChangeDrawableAttributesSGIX(drawable)
460 return void
461 param drawable Int32 in value
462 dlflags notlistable
463 glxflags client-handcode server-handcode
464 category glx
465 glxvendorglx 65545
466
467 GetDrawableAttributesSGIX(drawable)
468 return void
469 param drawable Int32 in value
470 dlflags notlistable
471 glxflags client-handcode server-handcode
472 category glx
473 glxvendorglx 65546
474
475 ###############################################################################
476 #
477 # SGIX_swap_group extension commands
478 #
479 ###############################################################################
480
481 JoinSwapGroupSGIX(window,group)
482 return void
483 param window Int32 in value
484 param group Int32 in value
485 glxflags client-handcode server-handcode
486 category glx
487 dlflags notlistable
488 glxvendorglx 65547
489
490 ###############################################################################
491 #
492 # SGIX_swap_barrier extension commands
493 #
494 ###############################################################################
495
496 BindSwapBarrierSGIX(window,barrier)
497 return void
498 param window Int32 in value
499 param barrier Int32 in value
500 glxflags client-handcode server-handcode
501 category glx
502 dlflags notlistable
503 glxvendorglx 65548
504
505 QueryMaxSwapBarriersSGIX()
506 return void
507 glxflags client-handcode server-handcode
508 category glx
509 dlflags notlistable
510 glxvendorglx 65549
511
512 ###############################################################################
513 #
514 # SGIX_hyperpipe extension commands
515 #
516 ###############################################################################
517
518 QueryHyperpipeNetworkSGIX(dpy, npipes)
519 return GLXHyperpipeNetworkSGIXPointer
520 param dpy Display out reference
521 param npipes int out reference
522 glxflags client-handcode server-handcode
523 category glx
524 dlflags notlistable
525 glxvendorglx 65550
526
527 HyperpipeConfigSGIX(dpy, networkId, npipes, cfg, hpId)
528 return int
529 param dpy Display out reference
530 param networkId int in value
531 param npipes int in value
532 param cfg GLXHyperpipeConfigSGIX in array[npipes]
533 param hpId int out reference
534 glxflags client-handcode server-handcode
535 category glx
536 dlflags notlistable
537 glxvendorglx 65552
538
539 QueryHyperpipeConfigSGIX(dpy, hpId, npipes)
540 return GLXHyperpipeConfigSGIXPointer
541 param dpy Display out reference
542 param hpId int in value
543 param npipes int out reference
544 glxflags client-handcode server-handcode
545 category glx
546 dlflags notlistable
547 glxvendorglx 65551
548
549 DestroyHyperpipeConfigSGIX(dpy, hpId)
550 return int
551 param dpy Display out reference
552 param hpId int in value
553 glxflags client-handcode server-handcode
554 category glx
555 dlflags notlistable
556 glxvendorglx 65553
557
558 BindHyperpipeSGIX(dpy, hpId)
559 return int
560 param dpy Display out reference
561 param hpId int in value
562 glxflags client-handcode server-handcode
563 category glx
564 dlflags notlistable
565 glxvendorglx ???
566
567 QueryHyperpipeBestAttribSGIX(dpy, timeSlice, attrib, size, attribList, returnAttribList)
568 return int
569 param dpy Display out reference
570 param timeSlice int in value
571 param attrib int in value
572 param size int in value
573 param attribList Void in array[size]
574 param returnAttribList Void out array[size]
575 glxflags client-handcode server-handcode
576 category glx
577 dlflags notlistable
578 glxvendorglx ???
579
580 HyperpipeAttribSGIX(dpy, timeSlice, attrib, size, attribList)
581 return int
582 param dpy Display out reference
583 param timeSlice int in value
584 param attrib int in value
585 param size int in value
586 param attribList void in array[size]
587 glxflags client-handcode server-handcode
588 category glx
589 dlflags notlistable
590 glxvendorglx ???
591
592 QueryHyperpipeAttribSGIX(dpy, timeSlice, attrib, size, returnAttribList)
593 return int
594 param dpy Display out reference
595 param timeSlice int in value
596 param attrib int in value
597 param size int in value
598 param returnAttribList void in array[size]
599 glxflags client-handcode server-handcode
600 category glx
601 dlflags notlistable
602 glxvendorglx ???