Be quiet in apt.post{inst,rm}.
[ntk/apt.git] / debian / changelog
1 apt (0.5.4.9) unstable; urgency=low
2
3 * New deb version compare function, that has no integer limits, and
4 supports pre-versions using ~. Code ported from dpkg.
5 * Fix handling of [!arch] for build-dependencies. Closes: #88798, #149595
6 * Fix handling of build-deps on unknown packages. Closes: #88664, #153307
7 * "apt-get --arch-only build-dep" to install only architecture-
8 dependent build dependencies. Bump minor shared lib number to reflect
9 small change in BuildDepend API.
10 * APT::Build-Essential configuration option (defaults to "build-essential")
11 so that "apt-get build-dep" will ensure build essential packages are
12 installed prior to installing other build-dependencies. Closes: #148879
13 * LD_LIBRARY_PATH thing. Closes: #109430, #147529
14 * /usr/doc reference in postinst. Closes: #126189
15 * Doc updates. Closes: #120689
16 * Possible apt-cache segfault. Closes: #120311, #118431, #117915, #135295,
17 #131062, #136749
18 * Print special message for EAI_AGAIN. Closes: #131397
19 * libapt-pkg-dev needs to bring in the apt-inst library if linking
20 is to work. Closes: #133943
21 * Typos, Doc Stuff. Closes: #132772, #129970, #123642, #114892, #113786,
22 #109591, #105920, #103678, #139752, #138186, #138054, #138050,
23 #139994, #142955, #151654, #151834, #147611, #154268, #173971
24 * Fix possibility for tag file parsing to fail in some unlikely situations.
25 Closes: #139328
26 * Use std C++ names for some header files. Closes: #128741
27 * Do not check for free space if --no-download. Closes: #117856
28 * Actually implement or group handling for 'upgrade'. Closes: #133950
29 * "Internal Error, Couldn't configure pre-depend" is not actually an
30 internal error, it is a packaging error and now it says so, and
31 pinpoints the problem dependency. Closes: #155621
32 * Allows failure to write to a pipe for post-invoke stuff. Closes: #89830
33 * Use usr/share/doc for dhelp. Closes: #115701
34 * --print-uris works with 'update'. Closes: #57070
35 * Options Dpkg::MaxArgs,Dpkg::MaxArgBytes to allow a much longer dpkg
36 command line.
37 * Fixed 2 little OR group bugs, thanks to Yann Dirson. Closes: #143995,
38 #142298
39 * Allow an uninstalled package to be marked for removal on an install
40 line (meaning not to automatically install it), also fix some dodgy
41 handling of protected packages. Closes: #92287, #116011
42 * Fix errant prefix matching in version selection. Closes: #105968
43 * Ensure that all files needed to run APT as a user are readable and
44 ignore roots umask for these files. Closes: #108801
45 * Support larger config spaces. Closes: #111914
46 * 'apt-get update' no longer does 'Building Dependency Tree'.
47 * When matching regexs allways print a message. Change regex activation
48 charset. Closes: #147817
49 * Don't die if lines in sources.list are too long. Closes: #146846
50 * Show file name on apt-extracttemplate error messges. Closes: #151835
51 * i18n gettext stuff, based on work from Michael Piefel: Closes: #95933
52 * Some highly unlikely memory faults. Closes: #155842
53 * C++ stuff for G++3.2. Closes: #162617, #165515,
54 * apt-config dumps sends to stdout not stderr now. Closes: #146294
55 * Fix segfault in FindAny when /i is used, and there is no default.
56 Closes: #165891
57 * Add s390x to archtable. Closese: #160992.
58 * Update config.sub/config.guess in cvs, and add support to debian/rules
59 to update them from /usr/share/misc if they exist. Closes: #155014
60 * Remove 'Sorry' from messages. Closes: #148824.
61 * Change wording of 'additional disk space usage' message. Closes:
62 #135021.
63 * apt-extracttemplates now prepends the package name when extracting
64 files. Closes: #132776
65 * Add -n synonym for --names-only for apt-cache. Closes: #130689
66 * Display both current version and new version in apt-get -s. Closes:
67 #92358
68 * Add an options and timeout config item to ssh/rsh. Closes: #90654
69 * libapt-pkg-dev now depends on apt-utils. Closes: #133942.
70 * Change verbose logging output of apt-ftparchive to go to stderr,
71 instead of stdout. Also, errors that occur no longer go to stdout,
72 but stderr. Closes: #161592
73 * Test for timegm in configure. Closes: #165516.
74 * s/st_mtime/mtime/ on our local stat structure in apt-ftparchive, to
75 support compliation on platforms where st_mtime is a macro. Closes:
76 #165518
77 * Check the currently mounted cdrom, to see if it's the one we are
78 interested in. Closes: #154602
79 * Refer to reportbug instead of bug in the man pages. Closes: #173745
80 * Link apt-inst to apt-pkg. Closes: #175055
81 * New apt_preferences man page from Thomas Hood, Susan Kleinmann,
82 and others.
83 * Fix > 300 col screen segfault. Closes: #176052
84 * Rebuild with gcc-3.2. Closes: #177752, #178008.
85 * Fix build-dep handling of | dependencies.
86 Closes: #98640, #145997, #158896, #172901
87 * Double default value of APT::Cache-Limit, until such time as it
88 can be made more dynamic. Closes: #178623.
89 * Report uris with '.gz' when there are errors. Closes: #178435.
90 * When installing build-deps, make sure the new version will
91 satisfy build requirements. Closes: #178121
92 * Split offline and guide documentation into apt-doc. This was done so
93 that binary-arch builds do not require documention deps. Note, that
94 apt-doc is not installed on upgrades.
95 * Use doc-base, instead of dhelp directly. Closes: #110389
96 * Change http message 'Waiting for file' to 'Waiting for headers'.
97 Closes: #178537
98 * Remove trailing lines on package lists in apt-get. Closes: #178736.
99 * Fix origin pins for file:// uris. Closes: #189014.
100 * Apply typo and syntax patch from bug to apt-cache.8.sgml. Closes:
101 #155194
102 * s/dpkg-preconfig/dpkg-preconfigure/ in examples/configure-index.
103 Closes: #153734.
104 * Fix some typos in the apt-get manual. Closes: #163932.
105 * Apply patch from bug, to change frozen to testing, and then do it
106 everywhere else. Closes: #165085.
107 * Update es.po. Closes: #183111.
108 * Add pt_BR translation of apt_preferences(5). Also, build fr manpages.
109 Closes: #183904.
110 * Add a vcg command to apt-cache, similiar to dotty. Closes: #150512.
111 * Add option to apt-get to show versions of packages being
112 upgraded/installed.
113 * Be quiet in apt.post{inst,rm}. Closes: #70685.
114
115 -- Adam Heath <doogie@debian.org> Sun, 02 Feb 2003 02:54:45 -0600
116
117 apt (0.5.4) unstable; urgency=low
118
119 * M68k config.guess patch. Closes: #88913
120 * Bi-yearly test on OpenBSD and Solaris
121 * Doc updates. Closes: #89121, #89854, #99671, #98353, #95823, #93057,
122 #97520, #102867, #101071, #102421, #101565, #98272, #106914,
123 #105606, #105377
124 * Various cosmetic code updates. Closes: #89066, #89066, #89152
125 * Add "pre-auto" as an option for DSelect::Clean (run autoclean after
126 update).
127 * More patches from Alfredo for Vendors and more SHA-1 stuff
128 * Fix for AJ's 'desire to remove perl-5.005' and possibly other
129 similar situations. Closes: #56708, #59432
130 * no_proxy and ftp. Closes: #89671
131 * Philippe Batailler's man page patches.
132 * Fix for display bug. Closes: #92033, #93652, #98468
133 * Use more than 16bits for the dep ID. Some people ran out..
134 Closes: #103020, #97809, #102951, #99974, #107362, #107395, #107362,
135 #106911, #107395, #108968
136 * Reordered some things to make dante and FTP happier. Closes: #92757
137 * James R. Van Zandt's guide.sgml updates. Closes: #90027
138 * apt-ftparchive copes with no uncompressed package files + contents.
139 * French man pages from philippe batailler - well sort of. They
140 don't build yet..
141 * run-parts. Closes: #94286
142 * 'apt-cache policy' preferences debug tool.
143 * Whatever. Closes: #89762
144 * libstdc++ and HURD. Closes: #92025
145 * More apt-utils verbage. Closes: #86954
146 * Fliped comparision operator. Closes: #94618
147 * Used the right copyright file. Closes: #65691
148 * Randolph's G++3 patches.
149 * Fixed no_proxy tokanizing. Closes: #100046
150 * Strip Config-Version when copying status to available. Closes: #97520
151 * Segfault with missing source files. Closes: #100325
152 * EINTR check. Closes: #102293
153 * Various changes to the locking metholodgy for --print-uris.
154 Closes: #100590
155 * Lame LD_LIBRARY_PATH thing. Closes: #98928
156 * apt-cache search searchs provide names too now. Closes: #98695
157 * Checksum and long lines problem. Closes: #106591
158 * .aptignr and empty files are just a warning. Closes: #97364
159
160 -- Jason Gunthorpe <jgg@debian.org> Sat, 18 Aug 2001 17:21:59 -0500
161
162 apt (0.5.3) unstable; urgency=low
163
164 * JoeyH's dpkg::preconfig not working. Closes: #88675
165 * Fixed apt override disparity
166 * Alfredo's SHA-1 and related patches
167
168 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
169
170 apt (0.5.2) unstable; urgency=low
171
172 * Fixed mention of /usr/doc in the long description
173 * JoeyH's downgrade bug -- don't use 0.5.1
174 * Doc bug. Closes: #88538
175 * Fault in building release strings. Closes: #88533
176
177 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
178
179 apt (0.5.1) unstable; urgency=low
180
181 * Fixed #82894 again, or should be and.
182 * Process the option string right. Closes: #86921
183 * Don't eat the last command for pipes. Closes: #86923
184 * Ignore .* for configuration directory processing. Closes: #86923
185 * Alfredo's no_proxy patch
186 * Documentation fixes. Closes: #87091
187 * JoeyH's double slash bug. Closes: #87266
188 * Unintitialized buffer and apt-ftparchive contents generation.
189 Closes: #87612
190 * Build-deps on virtual packages. Closes: #87639
191 * Fixes glibc/libstdc++ symbol dependencies by including glibc and
192 libstdc++ version info in the library soname and in the package
193 provides. Closes: #87426
194 * Updated soname version to 0.3.2
195 * apt-extracttemplates moved from debconf into apt-utils
196 * s390 archtable entry. Closes: #88232
197 * Dan's segfault
198 * Some instances where the status file can source a package in a
199 non-sensical way. Closes: #87390
200 * Work better if there are duplicate sources.list entries.
201 * Fixed the resetting of Dir with "dir {};". Closes: #87323
202
203 -- Randolph Chung <tausq@debian.org> Sat, 3 Mar 2001 15:37:38 -0700
204
205 apt (0.5.0) unstable; urgency=low
206
207 * Fixed an obscure bug with missing final double new lines in
208 package files
209 * Changed the apt-cdrom index copy routine to use the new section
210 rewriter
211 * Added a package file sorter, apt-sortpkgs
212 * Parse obsolete Optional dependencies.
213 * Added Ben's rsh method. Closes: #57794
214 * Added IPv6 FTP support and better DNS rotation support.
215 * Include the server IP in error messages when using a DNS rotation.
216 Closes: #64895
217 * Made most of the byte counters into doubles to prevent 32bit overflow.
218 Closes: #65349
219 * HTTP Authorization. Closes: #61158
220 * Ability to parse and return source index build depends from Randolph.
221 * new 'apt-get build-dep' command from Randolph. Closes: #63982
222 * Added apt-ftparchive the all dancing all singing FTP archive
223 maintinance program
224 * Allow version specifications with =1.2.4-3 and /2.2 or /stable postfixes
225 in apt-get.
226 * Removed useless internal cruft including the xstatus file.
227 * Fixed config parser bugs. Closes: #67848, #71108
228 * Brain Damanged apt-get config options changed, does not change the command
229 line interface, except to allow --enable-* to undo a configuration
230 option:
231 No-Remove -> Remove
232 No-Download -> Download
233 No-Upgrade -> Upgrade
234 * Made this fix configable (DSelect::CheckDir) and default to disabled:
235 * No remove prompt if the archives dir has not changed. Closes: #55709
236 Because it is stupid in the case where no files were downloaded due to
237 a resumed-aborted install, or a full cache! Closes: #65952
238 * Obscure divide by zero problem. Closes: #64394
239 * Update sizetable for mips. Closes: #62288
240 * Fixed a bug with passive FTP connections
241 * Has sizetable entry for sparc64. Closes: #64869
242 * Escape special characters in the ::Label section of the cdroms.lst
243 * Created apt-utils and python-apt packages
244 * Due to the new policy engine, the available file may contain entries
245 from the status file. These are generated if the package is not obsolete
246 but the policy engine prohibits using the version from the package files.
247 They can be identified by the lack of a Filename field.
248 * The new policy engine. Closes: #66509, #66944, #45122, #45094, #40006,
249 #36223, #33468, #22551
250 * Fixed deb-src line for non-us. Closes: #71501, #71601
251 * Fixes for G++ 2.96, s/friend/friend class/
252 * Fixed mis doc of APT::Get::Fix-Missing. Closes: #69269
253 * Confirmed fix for missing new line problem. Closes: #69386
254 * Fixed up dhelp files. Closes: #71312
255 * Added some notes about dselect and offline usage. Closes: #66473, #38316
256 * Lock files on read only file systems are ignored w/ warning.
257 Closes: #61701
258 * apt-get update foo now gives an error! Closes: #42891
259 * Added test for shlibs on hurd. Closes: #71499
260 * Clarified apt-cache document. Closes: #71934
261 * DocBook SGML man pages and some improvements in the text..
262 * sigwinch thing. Closes: #72382
263 * Caching can be turned off by setting the cache file names blank.
264 * Ignores arches it does not know about when autocleaning. Closes: #72862
265 * New function in apt-config to return dirs, files, bools and integers.
266 * Fixed an odd litle bug in MarkInstall and fixed it up to handle
267 complex cases involving OR groups and provides.
268 68754 describes confusing messages which are the result of this..
269 Closes: #63149, #69394, #68754, #77683, #66806, #81486, #78712
270 * Speeling mistake and return code for the 'wicked' resolver error
271 Closes: #72621, #75226, #77464
272 * Solved unable to upgrade libc6 from potato to woody due to 3 package
273 libc6 dependency loop problem.
274 * Leading sources.list spaces. Closes: #76010
275 * Removed a possible infinite loop while processing installations.
276 * Man page updates. Closes: #75411, #75560, #64292, #78469
277 * ReduceSourceList bug. Closes: #76027
278 * --only-source option. Closes: #76320
279 * Typos. Closes: #77812, #77999
280 * Different status messages. Closes: #76652, #78353
281 * /etc/apt/apt.conf.d/ directory for Joey and Matt and pipe protocol 2
282 * OS detection an support for the new pseduo standard of os-arch for the
283 Architecture string. Also uses regexing.. Closes: #39227, #72349
284 * Various i18n stuff. Note that this still needs some i18n wizard
285 to do the last gettextization right. Closes: #62386
286 * Fixed a problem with some odd http servers/proxies that did not return
287 the content size in the header. Closes: #79878, #44379
288 * Little acquire bugs. Closes: #77029, #55820
289 * _POSIX_THREADS may not be defined to anything, just defined..
290 Closes: #78996
291 * Spelling of Ignore-Hold correctly. Closes: #78042
292 * Unlock the dpkg db if in download only mode. Closes: #84851
293 * Brendan O'Dea's dselect admindir stuff. Closes: #62811
294 * Patch from BenC. Closes: #80810
295 * Single output of some names in lists. Closes: #80498, #43286
296 * Nice message for people who can't read syserror output. Closes: #84734
297 * OR search function. Closes: #82894
298 * User's guide updates. Closes: #82469
299 * The AJ/JoeyH var/state to var/lib transition patch. Closes: #59094
300 * Various CD bugs, again thanks to Greenbush
301 Closes: #80946, #76547, #71810, #70049, #69482
302 * Using potato debhelper. Closes: #57977
303 * I cannot self-terminate. Closes: #74928
304
305 -- Jason Gunthorpe <jgg@debian.org> Wed, 21 Feb 2001 00:39:15 -0500
306
307 apt (0.3.19) frozen unstable; urgency=low
308
309 * Updates to apt-cdrom to support integrated non-us nicely, thanks to
310 Paul Wade.
311 * Fixed that apt-get/cdrom deadlock thing. Closes: #59853, #62945, #61976
312 * Fixed hardcoded path. Closes: #59743
313 * Fixed Jay's relative path bug
314 * Allowed source only CDs. Closes: #58952
315 * Space check is supressed if --print-uris is given. Closes: #58965
316 * Clarified the documenation examples for non-us. Closes: #58646
317 * Typo in the package description. Closes: #60230
318 * Man Page typo. Closes: #60347
319 * Typo in Algorithms.cc. Closes: #63577
320 * Evil dotty function in apt-cache for generating dependency graphs
321 with the as-yet-unpackaged GraphVis.
322 * Appears to have been fixed in Janurary.. Closes: #57981
323 * New config.guess/sub for the new archs. Closes: #60874
324 * Fixed error reporting for certain kinds of resolution failures.
325 Closes: #61327
326 * Made autoclean respect 'q' settings. Closes: #63023
327 * Fixed up the example sources.list. Closes: #63676
328 * Added DPkg::FlushSTDIN to control the flushing of stdin before
329 forking dpkg. Closes: #63991
330
331 -- Ben Gertzfield <che@debian.org> Fri, 12 May 2000 21:10:54 -0700
332
333 apt (0.3.18) frozen unstable; urgency=low
334
335 * Changes in the postinst script. Closes: #56855, #57237
336 * Fixed bashism. Closes: #57216, #57335
337 * Doc updates. Closes: #57772, #57069, #57331, #57833, #57896
338
339 -- Ben Gertzfield <che@debian.org> Sun, 13 Feb 2000 01:52:31 -0800
340
341 apt (0.3.17) unstable; urgency=low
342
343 * RFC 2732 usage for CDROM URIs and fixes to apt-cdrom
344 * Fixed the configuration parser to not blow up if ; is in the config
345 string
346 * Applied visual patch to dselect install script . Closes #55214
347 * Included the configure-index example
348 * Minimal CD swaps
349 * Library soname has increased
350 * Fixed default sources.list to have correct URLs for potato when it
351 becomes stable
352 * Added a message about erasing sources.list to dselect setup script
353 Closes: #55755
354 * No remove prompt if the archives dir has not changed. Closes: #55709
355 * Fixed inclusion of 2nd sample config file. Closes: #55374
356 * Made file mtimes of 0 not confuse the methods If-Modifed-Since check.
357 Closes: #55991
358
359 -- Ben Gertzfield <che@debian.org> Mon, 31 Jan 2000 12:12:40 -0800
360
361 apt (0.3.16) unstable; urgency=low
362
363 * Made --no-download work. Closes: #52993
364 * Now compiles on OpenBSD, Solaris and HP-UX
365 * Clarify segfault errors
366 * More debhelper fixes. Closes: #52662, #54566, #52090, #53531, #54769
367 * Fix for Joel's discovery of glibc removal behavoir.
368 * Fix for Ben Collins file: uri from slink upgrade.
369 * Fixed resume code in FTP. Closes: #54323
370 * Take more precautions to prevent the corruption Joey Hess saw.
371 * Fixed --no-list-cleanup
372 * RFC 2732 URI parsing ([] for hostnames).
373 * Typo in apt-cache man page. Closes: #54949
374
375 -- Ben Gertzfield <che@debian.org> Fri, 14 Jan 2000 08:04:15 -0800
376
377 apt (0.3.15) unstable; urgency=low
378
379 * Added DSelect::WaitAfterDownload Closes: #49549
380 * Fixed cast error in byteswap macro and supporting code. Closes: #50093
381 * Fixed buffer overflow for wide terminal sizes. Closes: #50295
382 * Made -s and clean not do anything. Closes: #50238
383 * Problem with Protected packages and the new OR code.
384 * /usr/share/doc stuff. Closes: #51017, #50228, #51141
385 * Remove doesn't require a package to be installable. Closes: #51175
386 * FTP proxy touch ups in the mabn page. Closes: #51315, #51314
387
388 -- Ben Gertzfield <che@debian.org> Sat, 4 Dec 1999 21:17:24 -0800
389
390 apt (0.3.14) unstable; urgency=low
391
392 * Fix Perl or group pre-depends thing Closes: #46091, #46096, #46233, #45901
393 * Fix handling of dpkg's conversions from < -> <= Closes: #46094, #47088
394 * Make unparsable priorities non-fatal Closes: #46266, #46267, #46293, #46298
395 * Fix handling of '/' for the dist name. Closes: #43830, #45640, #45692
396 * Fixed 'Method gave a blank filename' error from IMS queries onto CDs.
397 Closes: #45034, #45695, #46537
398 * Made OR group handling in the problem resolver more elaborate. Closes: #45646
399 * Added APT::Clean-Installed option. Closes: #45973
400 * Moves the free space check to after the calculated size is printed.
401 Closes: #46639, #47498
402 * mipsel arch Closes: #47614
403 * Beautified URI printing to not include passwords Closes: #46857
404 * Fixed little problem with --no-download Closes: #47557
405 * Tweaked Dselect 'update' script to re-gen the avail file even in the
406 event of a failure Closes: #47112
407 * Retries for source archives too Closes: #47529
408 * Unmounts CDROMs iff it mounted them Closes: #45299
409 * Checks for the partial directories before doing downloads Closes: #47392
410 * no_proxy environment variable (http only!) Closes: #43476
411 * apt-cache showsrc Closes: #45799
412 * De-Refs Single Pure virtual packages. Closes: #42437, #43555
413 * Regexs for install. Closes: #35304, #38835
414 * Dependency reports now show OR group relations
415 * Re-Install feature. Cloes: #46961, #37393, #38919
416 * Locks archive directory on clean (woops)
417 * Remove is not 'sticky'. Closes: #48392
418 * Slightly more accurate 'can not find package' message. Closes: #48311
419 * --trivial-only and --no-remove. Closes: #48518
420 * Increased the cache size. Closes: #47648
421 * Comment woopsie. Closes: #48789
422 * Removes existing links when linking sources. Closes: #48775
423 * Problem resolver does not install all virtual packages. Closes: #48591, #49252
424 * Clearer usage message about 'source' Closes: #48858
425 * Immediate configure internal error Closes: #49062, #48884
426
427 -- Ben Gertzfield <che@debian.org> Sun, 7 Nov 1999 20:21:25 -0800
428
429 apt (0.3.13) unstable; urgency=low
430
431 * Fix timestamp miss in FTP. Closes: #44363
432 * Fix sorting of Kept packages. Closes: #44377
433 * Fix Segfault for dselect-upgrade. Closes: #44436
434 * Fix handling of '/' for the dist name. Closes #43830
435 * Added APT::Get::Diff-Only and Tar-Only options. Closes #44384
436 * Add commented-out deb-src URI to default sources.list file.
437
438 -- Ben Gertzfield <che@debian.org> Sun, 19 Sep 1999 18:54:20 -0700
439
440 apt (0.3.12) unstable; urgency=low
441
442 * Fix for typo in the dhelp index. Closes: #40377
443 * Multiple media swap support
444 * Purge support. Closes: #33291, #40694
445 * Better handling of - remove notation. Closes: #41024
446 * Purge support. Closes: #33291, #40694
447 * Error code on failed update. Closes: #41053
448 * apt-cdrom adds entries for source directories. Closes: #41231
449 * Sorts the output of any list. Closes: #41107
450 * Fixes the looping problem. Closes: #41784, #42414, #44022
451 * Fixes the CRC mechanism to lowercase all strings. Closes: #41839
452 * More checks to keep the display sane. Particularly when fail-over is
453 used with local mirrors and CD-Roms. Closes: #42127, #43130, #43668
454 * PThread lockup problem on certain sparc/m68k. Closes: #40628
455 * apt-cdrom understands .gz Package files too. Closes: #42779
456 * Spelling error in dselect method description. Closes: #43251
457 * Added security to the default source list. Closes: #43356
458
459 -- Ben Gertzfield <che@debian.org> Fri, 3 Sep 1999 09:04:28 -0700
460
461 apt (0.3.11) unstable; urgency=low
462
463 * Fix for mis-parsed file: URIs. Closes: #40373, #40366, #40230
464 * Fix for properly upgrading the system from perl 5.004 to 5.005
465
466 -- Ben Gertzfield <che@debian.org> Mon, 28 Jun 1999 21:06:44 -0700
467
468 apt (0.3.9) unstable; urgency=low
469
470 * Spelling error in cachefile.cc. Closes: #39885
471 * Trailing slash in dselect install if you try to use the
472 default config file. Closes: #40011
473 * Simulate works for autoclean. Closes: #39141
474 * Fixed spelling errors. Closes: #39673
475 * Changed url parsing a bit. Closes: #40070, #40069
476 * Version 0.3.8 will be for slink/hamm (GNU libc 2).
477
478 -- Ben Gertzfield <che@debian.org> Thu, 24 Jun 1999 18:02:52 -0700
479
480 apt (0.3.7) unstable; urgency=low
481
482 * Fixed missing text in the apt-get(8) page. Closes: #37596
483 * Made --simulate and friends work with apt-get source. Closes: #37597, #37656
484 * Fixed inclusion of man pages in the -doc/-dev package. Closes: #37633, #38651
485 * Fixed handling of the -q option with not-entirely integer arguments
486 Closes: #37499
487 * Man page typo Closes: #37762
488 * Fixed parsing of the Source: line. Closes: #37679
489 * Dpkg/dpkg-hurd source bug. Closes: #38004, #38032
490 * Added a check for an empty cache directory. Closes: #37963
491 * Return a failure code if -d is given and packages fail to download.
492 Closes: #38127
493 * Arranged for an ftp proxy specifing an http server to work. See the
494 important note in the sources.list man page.
495 * Accounted for resumed files in the cps calculation. Closes: #36787
496 * Deal with duplicate same version different packages. Closes: #30237
497 * Added --no-download. Closes: #38095
498 * Order of apt-cdrom dist detection. Closes: #38139
499 * Fix apt-cdrom chop handling and missing lines. Closes: #37276
500 * IPv6 http support
501 * Suggests dpkg-dev for apt-get source. Closes: #38158
502 * Fixed typo in apt-get help. Closes: #38712
503 * Improved the error message in the case of broken held package. Closes: #38777
504 * Fixed handling of MD5 failures
505 * Documented list notation Closes: #39008
506 * Change the 'b' to 'B'. Closes: #39007
507
508 -- Ben Gertzfield <che@debian.org> Sun, 20 Jun 1999 18:36:20 -0700
509
510 apt (0.3.6) unstable; urgency=low
511
512 * Note that 0.3.5 never made it out the door..
513 * Fix for apt-cdrom and unusual disk label locations. Closes: #35571
514 * Made APT print numbers in decimal. Closes: #35617, #37319
515 * Buffer munching fix for FTP. Closes: #35868
516 * Typo in sample config file. Closes: #35907
517 * Fixed whitespace in version compares. Closes: #35968, #36283, #37051
518 * Changed installed size counter to only count unpacked packages.
519 Closes: #36201
520 * apt-get source support. Closes: #23934, #27190
521 * Renames .debs that fail MD5 checking, provides automatic corruption
522 recovery. Closes: #35931
523 * Fixed autoconf verison. Closes: #37305
524 * Random Segfaulting. Closes: #37312, #37530
525 * Fixed apt-cache man page. Closes: #36904
526 * Added a newline to apt-cache showpkg. Closes: #36903
527
528 -- Ben Gertzfield <che@debian.org> Wed, 12 May 1999 09:18:49 -0700
529
530 apt (0.3.4) unstable; urgency=low
531
532 * Release for Ben while he is out of town.
533 * Checked the size of partial files. Closes: #33705
534 * apt-get should not print progress on non-tty. Closes: #34944
535 * s/guide.text.gz/users-guide.txt.gz/ debian/control: Closes: #35207
536 * Applied cdrom patches from Torsten. Closes: #35140, #35141
537 * smbmounted cdrom fix. Closes: #35470
538 * Changed ie to eg. Closes: #35196
539
540 -- Adam Heath <doogie@debian.org> Sun, 4 Apr 1999 18:26:44 -0500
541
542 apt (0.3.3) unstable; urgency=low
543
544 * Fixes bug with file:/ URIs and multi-CD handling. Closes: #34923
545
546 -- Ben Gertzfield <che@debian.org> Tue, 23 Mar 1999 12:15:44 -0800
547
548 apt (0.3.2) unstable; urgency=low
549
550 * Major release into unstable of v3
551 * These bugs have been fixed, explanations are in the bug system, read
552 the man pages as well..
553 Closes: #21113, #22507, #22675, #22836, #22892, #32883, #33006, #34121,
554 #23984, #24685, #24799, #25001, #25019, #34223, #34296, #34355,
555 #24021, #25022, #25026, #25104, #25176, #31557, #31691, #31853,
556 #25458, #26019, #26433, #26592, #26670, #27100, #27100, #27601,
557 #28184, #28391, #28778, #29293, #29351, #27841, #28172, #30260,
558 #29382, #29441, #29903, #29920, #29983, #30027, #30076, #30112,
559 #31009, #31155, #31381, #31883, #32140, #32395, #32584. #34465,
560 #30383, #30441, #30472, #30643, #30827, #30324, #36425, #34596
561
562 -- Ben Gertzfield <che@debian.org> Mon, 15 Mar 1999 19:14:25 -0800
563
564 apt (0.3.1) experimental; urgency=low
565
566 * Minor release of cvs version.
567 * Added virtual package libapt-pkgx.x
568
569 -- Mitch Blevins <mblevin@debian.org> Wed, 10 Mar 1999 07:52:44 -0500
570
571 apt (0.3.0) experimental; urgency=low
572
573 * New experimental version.
574
575 -- Ben Gertzfield <che@debian.org> Tue, 15 Dec 1998 12:53:21 -0800
576
577 apt (0.1.9) frozen unstable; urgency=low
578
579 * Return to the wacky numbering for when we build 0.1.8 for hamm
580 * Important bug related to APT on the Alpha fixed
581 * apt-get dist-upgrade problems fixed
582 * tiny patch for http method to fix an endless loop
583 * nice fix from /usr/doc/lintian/ to remove rpath nastiness from
584 libtool and add proper shared lib dependancies
585 * now dh_shlibdeps is called with LD_LIBRARY_PATH=debian/tmp/usr/lib
586 in case an old libpkg is installed while building APT to prevent
587 spurious dependancies
588
589 -- Ben Gertzfield <che@debian.org> Thu, 5 Nov 1998 17:43:25 -0800
590
591 apt (0.1.7) unstable; urgency=low
592
593 * New build with libstdc++2.9.
594 * Various fixes; read the Changelog.
595
596 -- Ben Gertzfield <che@debian.org> Thu, 15 Oct 1998 18:29:18 -0700
597
598 apt (0.1.6) unstable; urgency=low
599
600 * Various fixes in the FTP method for error checking. Fixes: #26188.
601 * Spelling corrections in dselect method. Fixes: #25884
602 * Fixes for compilation on alpha/ppc. Fixes: #25313, #26108.
603 * No more bo releases: we're using a normal numbering system now.
604
605 -- Ben Gertzfield <che@debian.org> Tue, 8 Sep 1998 19:27:13 -0700
606
607 apt (0.1.5) unstable; urgency=low
608
609 * Changed sources.list to point to 'unstable' by default, as
610 'frozen' no longer exists!
611
612 -- Ben Gertzfield <che@debian.org> Thu, 23 Jul 1998 22:00:18 -0700
613
614 apt (0.1.3) unstable; urgency=low
615
616 * New upstreamish version.
617 * ftp method rewritten in C. Removes dependancies on all perl/perl
618 related modules. This fixes many of the ftp method bugs.
619
620 -- Ben Gertzfield <che@debian.org> Thu, 16 Jul 1998 22:19:00 -0700
621
622 apt (0.1.1) unstable; urgency=low
623
624 * Release for unstable.
625
626 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:48:30 -0700
627
628 apt (0.1) unstable; urgency=low
629
630 * Kludge to fix problem in libnet-perl with illegal anonymous
631 FTP passwords.
632 * Moved to unstable; apt is in a useable state now.
633 * Fixed version numbering. From now on, numbering will be:
634 0.1 (no actual release) -> 0.1.0bo (release for libc5) ->
635 0.1.1 (release for unstable). Thanks, Manoj.
636
637 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:40:58 -0700
638
639 apt (0.0.17-1) experimental; urgency=low
640
641 * Fixed problem with libc6 version compare
642 * Scott's away for a while, so I'll be packaging apt for the time
643 being.
644
645 -- Ben Gertzfield <che@debian.org> Thu, 25 Jun 1998 19:02:03 -0700
646
647 apt (0.0.16-1) experimental; urgency=low
648
649 * Modifications to make apt-get more friendly when backgrounded.
650 * Updated documentation.
651 * Updates to graphic widgets
652
653 -- Scott K. Ellis <scott@debian.org> Mon, 8 Jun 1998 11:22:02 -0400
654
655 apt (0.0.15-0.2bo) experimental; urgency=low
656
657 * Bo compilation
658 * Bob Hilliards crash
659
660 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
661
662 apt (0.0.15-0.1bo) experimental; urgency=low
663
664 * Bo compilation
665 * libstdc++272 patch
666
667 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
668
669 apt (0.0.15) experimental; urgency=low
670
671 * Clean up source tarball (no user-visible changes)
672
673 -- Scott K. Ellis <scott@debian.org> Tue, 26 May 1998 12:23:53 -0400
674
675 apt (0.0.14) experimental; urgency=low
676
677 * Updates in ordering code to make sure certain upgrades work correctly.
678 * Made dselect/setup understand ftp as well as http
679
680 -- Scott K. Ellis <scott@debian.org> Wed, 20 May 1998 13:33:32 -0400
681
682 apt (0.0.13-bo1) experimental; urgency=low
683
684 * Bo compilation
685
686 -- Jason Gunthorpe <jgg@debian.org> Mon, 18 May 1998 15:10:49 -0600
687
688 apt (0.0.13) experimental; urgency=low
689
690 * Remove hardcoded egcc from debian/rules (#21575)
691 * Fixes for ordering logic when system has a number of unpacked
692 but unconfigured packages installed.
693 * Spelling fix in dselect install method (#22556)
694
695 -- Scott K. Ellis <scott@debian.org> Sun, 17 May 1998 20:08:33 -0400
696
697 apt (0.0.12) experimental; urgency=low
698
699 * Fixed problems with package cache corruption.
700 * Made to depend on libc6 >= 2.0.7pre1 due to timezone problems with
701 earlier versions.
702 * Interface and documentation improvements.
703
704 -- Scott K. Ellis <scott@debian.org> Sat, 16 May 1998 23:17:32 -0400
705
706 apt (0.0.11) experimental; urgency=low
707
708 * Change dependancies to pre-depends since breaking your packaging tools
709 in the middle of an installation isn't very good.
710 * Bug fixes to ftp method and general apt-get code
711
712 -- Scott K. Ellis <scott@debian.org> Fri, 15 May 1998 08:57:38 -0400
713
714 apt (0.0.10) experimental; urgency=low
715
716 * Run "dpkg --configure -a" after an aborted dselect install
717 * Fixed problem with install looping
718 * Support for authenticating proxys: (note this isn't terribly secure)
719 http_proxy="http://user:pass@firewall:port/"
720 * Substitute $ARCH in sources.list
721 * Fixes in the resumption code for ftp
722
723 -- Scott K. Ellis <scott@debian.org> Tue, 12 May 1998 09:14:41 -0400
724
725 apt (0.0.9) experimental; urgency=low
726
727 * Added ftp support.
728 * Various other less visible bug fixes.
729 * Fixed problem with segfault when apt-get invoked in a non-existant
730 directory (Bug #21863)
731 * Bumped policy to 2.4.1
732
733 -- Scott K. Ellis <scott@debian.org> Fri, 1 May 1998 09:18:19 -0400
734
735 apt (0.0.8) experimental; urgency=low
736
737 * Fixed generated available file (Bug #21836)
738 * Added download ETA (Bug #21774).
739 * Fixed hardcoded ARCH (Bug #21751).
740 * Fixed check on http_proxy (Bug #21795).
741 * Added download speed indicator.
742
743 -- Scott K. Ellis <scott@debian.org> Mon, 27 Apr 1998 10:58:32 -0400
744
745 apt (0.0.7) experimental; urgency=low
746
747 * Remove libdeity and apt from package for now, since only apt-get and
748 apt-cache are actually useful right now.
749 * Clean up handling of package installation errors.
750 * Added timeout to http transfers (#21269)
751 * Updated setup for dselect/apt method.
752 * Updated man pages
753 * Long options (added in 0.0.6)
754
755 -- Scott K. Ellis <scott@debian.org> Tue, 21 Apr 1998 09:06:49 -0400
756
757 apt (0.0.6) experimental; urgency=low
758
759 * Spelling changes.
760 * Revamped download status display.
761 * Call apt-get clean after successful install in dselect.
762 * Added "apt-get clean" which deletes package files from /var/cache/apt
763
764 -- Scott K. Ellis <scott@debian.org> Thu, 9 Apr 1998 15:13:59 -0400
765
766 apt (0.0.5) experimental; urgency=low
767
768 * Ignore signals while dpkg is running so we don't leave dpkg running in
769 the background (#20804)
770 * Check Packages as well as Packages.gz for file URIs (#20784)
771 * Spelling cleanup (#20800)
772 * Added -m option to permit upgrade to go on in the case of a bad mirror.
773 This option may result in incomplete upgrades when used with -f.
774
775 -- Scott K. Ellis <scott@debian.org> Tue, 7 Apr 1998 12:40:29 -0400
776
777 apt (0.0.4) experimental; urgency=low
778
779 * New usage guide.
780 * Various documentation updates and cleanup.
781 * Added '-f' option to apt-get attempt to fix broken dependancies.
782
783 -- Scott K. Ellis <scott@debian.org> Sat, 4 Apr 1998 14:36:00 -0500
784
785 apt (0.0.3) experimental; urgency=low
786
787 * Added a shlibs.local file to prevent apt from depending on itself.
788 * Updates to how apt-get handles bad states in installed packages.
789 * Updated rules to make sure build works from a freshly checked out source
790 archive. Building from CVS needs libtool/automake/autoconf, builds from
791 the distributed source package should have no such dependancy.
792
793 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 11:49:47 -0500
794
795 apt (0.0.2) unstable; urgency=low
796
797 * Updates to apt-get and http binding for dselect method (apt).
798 * Updating version number from 0.0.1, which was released only on IRC.
799
800 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 00:35:18 -0500
801
802 apt (0.0.1) unstable; urgency=low
803
804 * Initial Release.
805
806 -- Scott K. Ellis <scott@debian.org> Tue, 31 Mar 1998 12:49:28 -0500
807