use a tmpfile for trustdb.gpg in apt-key
[ntk/apt.git] / debian / apt.postinst
1 #! /bin/sh
2
3 set -e
4
5 # summary of how this script can be called:
6 # * <postinst> `configure' <most-recently-configured-version>
7 # * <old-postinst> `abort-upgrade' <new version>
8 # * <conflictor's-postinst> `abort-remove' `in-favour' <package>
9 # <new-version>
10 # * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
11 # <failed-install-package> <version> `removing'
12 # <conflicting-package> <version>
13 # for details, see http://www.debian.org/doc/debian-policy/ or
14 # the debian-policy package
15
16 case "$1" in
17 configure)
18 if dpkg --compare-versions "$2" lt-nl 0.9.9.5; then
19 # we are using tmpfiles for both
20 rm -f /etc/apt/trustdb.gpg
21 # this removal was done unconditional since 0.8.15.3
22 SECRING='/etc/apt/secring.gpg'
23 # test if secring is an empty normal file
24 if test -f $SECRING -a ! -s $SECRING; then
25 rm -f $SECRING
26 fi
27 fi
28 apt-key update
29
30 # ensure tighter permissons on the logs, see LP: #975199
31 if dpkg --compare-versions "$2" lt-nl 0.9.7.7; then
32 # ensure permissions are right
33 chmod -f 0640 /var/log/apt/term.log* || true
34 fi
35
36 # create kernel autoremoval blacklist on update
37 if dpkg --compare-versions "$2" lt-nl 0.9.9.3; then
38 /etc/kernel/postinst.d/apt-auto-removal
39 fi
40 ;;
41
42 abort-upgrade|abort-remove|abort-deconfigure)
43
44 ;;
45
46 *)
47 echo "postinst called with unknown argument \`$1'" >&2
48 exit 1
49 ;;
50 esac
51
52 # dh_installdeb will replace this with shell code automatically
53 # generated by other debhelper scripts.
54
55 #DEBHELPER#
56
57 exit 0
58
59