* Avoid clobbering configure.in if sed fails
[ntk/apt.git] / debian / rules
1 #!/usr/bin/make -f
2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
5 # $Id: rules,v 1.62 2003/12/24 22:55:30 mdz Exp $
6
7 # LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
8 # dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
9
10 # For the deb builder, you can run 'debian/rules cvs-build', which does all
11 # steps nescessary to produce a proper source tarball with the CVS/ removed.
12 # It builds in debian/cvs-build/apt-<VER>/, and places files in
13 # debian/cvs-build/. Optionally, you can run 'debian/rules cvs-mkul' to
14 # create ../upload-<VER>, with all the files needed to be uploaded placed
15 # in it.
16
17 export DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
18 export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
19
20 # FOR AUTOCONF 2.52 AND NEWER ONLY
21 ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
22 confflags += --build $(DEB_HOST_GNU_TYPE)
23 else
24 confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
25 endif
26
27 # See below
28 -include build/environment.mak
29
30 # Default rule
31 build:
32
33 DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc
34 APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p')
35 APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
36
37 # Determine the build directory to use
38 BASE=.
39 ifdef BUILD
40 BUILD_POSSIBLE := $(BUILD) $(BASE)/$(BUILD)
41 else
42 BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname -m) $(BASE)/build
43 endif
44 BUILDX:= $(foreach i,$(BUILD_POSSIBLE),$(wildcard $(i)/environment.mak*))
45 BUILDX:= $(patsubst %/,%,$(firstword $(dir $(BUILDX))))
46 override BLD := $(BUILDX)
47
48 ifeq ($(words $(BLD)),0)
49 override BLD := ./build
50 endif
51
52 # Rebuild configure.in to have the correct version from the change log
53 ifneq ($(APT_DEBVER),$(APT_CONFVER))
54 .PHONY: configure.in
55 configure.in:
56 sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$ && mv $@.$$$$ $@
57 else
58 configure.in:
59 endif
60
61 # APT Programs in apt-utils
62 APT_UTILS=ftparchive sortpkgs extracttemplates
63
64 # Uncomment this to turn on verbose mode.
65 #export DH_VERBOSE=1
66
67 # Find the libapt-pkg major version for use in other control files
68 export LIBAPTPKG_MAJOR:=$(shell egrep '^MAJOR=' apt-pkg/makefile |cut -d '=' -f 2)
69 export LIBAPTINST_MAJOR:=$(shell egrep '^MAJOR=' apt-inst/makefile |cut -d '=' -f 2)
70
71 # Determine which package we should provide in the control files
72 LIBAPTPKG_PROVIDE=libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER)-$(LIBAPTPKG_MAJOR)
73 LIBAPTINST_PROVIDE=libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER)-$(LIBAPTINST_MAJOR)
74
75 debian/shlibs.local: apt-pkg/makefile
76 # We have 3 shlibs.local files.. One for 'apt', one for 'apt-utils' and
77 # one for the rest of the packages. This ensures that each package gets
78 # the right overrides..
79 rm -rf $@ $@.apt $@.apt-utils
80 echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR)" > $@.apt
81
82 echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@.apt-utils
83 echo "libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR)" >> $@.apt-utils
84
85 echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@
86 echo "libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR) $(LIBAPTINST_PROVIDE)" >> $@
87
88 build: build/build-stamp
89 build-doc: build/build-doc-stamp
90
91 # Note that this is unconditionally done first as part of loading environment.mak
92 # The true is needed to force make to reload environment.mak after running
93 # configure-stamp. Otherwise we can get stale or invalid, or missing config data.
94 build/environment.mak: build/configure-stamp
95 @true
96
97 configure: configure.in
98 build/configure-stamp: configure
99 dh_testdir
100 -mkdir build
101 cp COPYING debian/copyright
102 cd build && ../configure $(confflags)
103 touch $@
104
105 build/build-stamp: build/configure-stamp
106 # Add here commands to compile the package.
107 $(MAKE) binary
108 touch $@
109
110 build/build-doc-stamp: build/configure-stamp
111 # Add here commands to compile the package.
112 $(MAKE) doc
113 touch $@
114
115 clean:
116 dh_testdir
117 # dh_testroot
118 -$(MAKE) clean
119 -$(MAKE) distclean
120
121 rm -rf build
122
123 # Add here commands to clean up after the build process.
124 dh_clean debian/copyright debian/shlibs.local debian/shlibs.local.apt debian/shlibs.local.apt-utils
125
126 binary-indep: apt-doc libapt-pkg-doc
127 # Build architecture-independent files here.
128 libapt-pkg-doc: build-doc debian/shlibs.local
129 dh_testdir -p$@
130 dh_testroot -p$@
131 dh_clean -p$@ -k
132 dh_installdirs -p$@
133 #
134 # libapt-pkg-doc install
135 #
136 dh_installdocs -p$@ $(BLD)/docs/cache* $(BLD)/docs/design* $(BLD)/docs/dpkg-tech* \
137 $(BLD)/docs/files* $(BLD)/docs/method* \
138 doc/libapt-pkg2_to_3.txt doc/style.txt
139 dh_installexamples -p$@
140 # dh_installmenu -p$@
141 # dh_installinit -p$@
142 # dh_installcron -p$@
143 # dh_installman -p$@
144
145 # dh_undocumented -p$@
146 dh_installchangelogs -p$@
147 dh_strip -p$@
148 dh_compress -p$@
149 dh_fixperms -p$@
150 # dh_suidregister -p$@
151 dh_installdeb -p$@
152 dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
153 dh_md5sums -p$@
154 dh_builddeb -p$@
155
156 apt-doc: build-doc
157 dh_testdir -p$@
158 dh_testroot -p$@
159 dh_clean -p$@ -k
160 #
161 # apt-doc install
162 #
163 # Copy the guides
164 dh_installdocs -p$@ $(BLD)/docs/guide*.text $(BLD)/docs/guide*.html \
165 $(BLD)/docs/offline.text $(BLD)/docs/offline.html
166 dh_installchangelogs -p$@
167 dh_compress -p$@
168 dh_fixperms -p$@
169 dh_installdeb -p$@
170 dh_gencontrol -p$@
171 dh_md5sums -p$@
172 dh_builddeb -p$@
173
174
175
176 # Build architecture-dependent files here.
177
178 binary-arch: apt libapt-pkg-dev apt-utils
179 apt: build debian/shlibs.local
180 dh_testdir -p$@
181 dh_testroot -p$@
182 dh_clean -p$@ -k
183 dh_installdirs -p$@ /usr/share/bug/$@
184 #
185 # apt install
186 #
187 cp $(BLD)/bin/apt-* debian/apt/usr/bin/
188
189 # Remove the bits that are in apt-utils
190 rm $(addprefix debian/apt/usr/bin/apt-,$(APT_UTILS))
191
192 # install the shared libs
193 find $(BLD)/bin/ -type f -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/apt/usr/lib/ \;
194 find $(BLD)/bin/ -type l -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/apt/usr/lib/ \;
195
196 cp $(BLD)/bin/methods/* debian/apt/usr/lib/apt/methods/
197
198 cp $(BLD)/scripts/dselect/* debian/apt/usr/lib/dpkg/methods/apt/
199 cp -r $(BLD)/locale debian/apt/usr/share/
200
201 cp debian/bugscript debian/apt/usr/share/bug/apt/script
202
203 # head -n 500 ChangeLog > debian/ChangeLog
204
205 dh_installexamples -p$@ $(BLD)/docs/examples/*
206 dh_installman -p$@
207
208 dh_installdocs -p$@
209 dh_installchangelogs -p$@
210 dh_strip -p$@
211 dh_compress -p$@
212 dh_fixperms -p$@
213 dh_makeshlibs -m$(LIBAPTPKG_MAJOR) -V '$(LIBAPTPKG_PROVIDE)' -papt
214 dh_installdeb -p$@
215 dh_shlibdeps -papt -l`pwd`/debian/apt/usr/lib -- -Ldebian/shlibs.local.apt
216 dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
217 dh_md5sums -p$@
218 dh_builddeb -p$@
219
220 libapt-pkg-dev: build debian/shlibs.local
221 dh_testdir -p$@
222 dh_testroot -p$@
223 dh_clean -p$@ -k
224 dh_installdirs -p$@
225 #
226 # libapt-pkg-dev install
227 #
228 cp -a $(BLD)/bin/libapt-pkg*.so debian/libapt-pkg-dev/usr/lib/
229 cp -a $(BLD)/bin/libapt-inst*.so debian/libapt-pkg-dev/usr/lib/
230 # ln -s libapt-pkg.so.$(LIBAPTPKG_MAJOR) debian/libapt-pkg-dev/usr/lib/libapt-pkg.so
231 cp $(BLD)/include/apt-pkg/*.h debian/libapt-pkg-dev/usr/include/apt-pkg/
232
233 dh_installdocs -p$@
234 # dh_installmenu -p$@
235 # dh_installinit -p$@
236 # dh_installcron -p$@
237 # dh_installman -p$@
238
239 dh_installchangelogs -p$@
240 dh_strip -p$@
241 dh_compress -p$@
242 dh_fixperms -p$@
243 # dh_suidregister -p$@
244 dh_installdeb -p$@
245 dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE) -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
246 dh_md5sums -p$@
247 dh_builddeb -p$@
248
249 apt-utils: build debian/shlibs.local
250 dh_testdir -p$@
251 dh_testroot -p$@
252 dh_clean -p$@ -k
253 dh_installdirs -p$@
254
255 # install the shared libs
256 find $(BLD)/bin/ -type f -name "libapt-inst*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
257 find $(BLD)/bin/ -type l -name "libapt-inst*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
258
259 cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
260 dh_installdocs -p$@
261
262 # Install the man pages..
263 dh_installman -p$@
264
265 dh_installchangelogs -p$@
266 dh_strip -p$@
267 dh_compress -p$@
268 dh_fixperms -p$@
269 dh_makeshlibs -m$(LIBAPTINST_MAJOR) -V '$(LIBAPTINST_PROVIDE)' -p$@
270 dh_installdeb -p$@
271 LD_LIBRARY_PATH=$$LD_LIBRARY_PATH:`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib dh_shlibdeps -p$@ -- -Ldebian/shlibs.local.apt-utils
272 dh_gencontrol -p$@ -u -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
273 dh_md5sums -p$@
274 dh_builddeb -p$@
275
276 source diff:
277 @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
278
279 # Update from CVS
280 l33ch: really-clean
281 cvs update
282 buildlib/mkChangeLog
283
284 # Update from CVS and then configure for build
285 super-l33ch: l33ch Makefile.in
286
287 configure:
288 $(MAKE) configure
289
290 l33ch-stamp: super-l33ch
291 touch $@
292
293 really-clean: clean
294 -find -name Makefile.in -print0 | xargs -0r rm -f
295 find -name ChangeLog | xargs rm -f
296 rm -f l33ch-stamp
297
298 binary: binary-indep binary-arch
299 .PHONY: build clean binary-indep binary-arch binary debian/shlibs.local
300
301
302 # Done by the uploader.
303 #cvs update..
304 #edit debian/changelog
305 # configure.in has the version automatically updated now.
306 # edit configure.in
307 # debian/rules cvs-build
308
309 cvs-build:
310 rm -rf debian/cvs-build
311 cvs update -d
312 $(MAKE) startup
313 $(MAKE) doc
314 tar c --exclude CVS --exclude cvs-build --exclude '.#*' . |\
315 (mkdir -p debian/cvs-build/apt-$(APT_DEBVER);cd debian/cvs-build/apt-$(APT_DEBVER);tar x)
316 (cd debian/cvs-build/apt-$(APT_DEBVER);$(DEB_BUILD_PROG))
317
318 cvs-mkul:
319 -mkdir -p ../upload-$(APT_DEBVER)
320 cp `find debian/cvs-build -maxdepth 1 -type f` ../upload-$(APT_DEBVER)