merged from apt-authentication-reliability
[ntk/apt.git] / debian / apt.postinst
1 #! /bin/sh
2
3 set -e
4
5 # summary of how this script can be called:
6 # * <postinst> `configure' <most-recently-configured-version>
7 # * <old-postinst> `abort-upgrade' <new version>
8 # * <conflictor's-postinst> `abort-remove' `in-favour' <package>
9 # <new-version>
10 # * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
11 # <failed-install-package> <version> `removing'
12 # <conflicting-package> <version>
13 # for details, see http://www.debian.org/doc/debian-policy/ or
14 # the debian-policy package
15
16 case "$1" in
17 configure)
18
19 if ! test -f /etc/apt/trusted.gpg; then
20 cp /usr/share/apt/ubuntu-archive.gpg /etc/apt/trusted.gpg
21 fi
22
23 ;;
24
25 abort-upgrade|abort-remove|abort-deconfigure)
26
27 ;;
28
29 *)
30 echo "postinst called with unknown argument \`$1'" >&2
31 exit 1
32 ;;
33 esac
34
35 # dh_installdeb will replace this with shell code automatically
36 # generated by other debhelper scripts.
37
38 #DEBHELPER#
39
40 exit 0
41
42