merged from lp:~donkult/apt/sid
[ntk/apt.git] / debian / apt.postinst
1 #! /bin/sh
2
3 set -e
4
5 # summary of how this script can be called:
6 # * <postinst> `configure' <most-recently-configured-version>
7 # * <old-postinst> `abort-upgrade' <new version>
8 # * <conflictor's-postinst> `abort-remove' `in-favour' <package>
9 # <new-version>
10 # * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
11 # <failed-install-package> <version> `removing'
12 # <conflicting-package> <version>
13 # for details, see http://www.debian.org/doc/debian-policy/ or
14 # the debian-policy package
15
16 case "$1" in
17 configure)
18 SECRING='/etc/apt/secring.gpg'
19 # test if secring is an empty normal file
20 if test -f $SECRING -a ! -s $SECRING; then
21 rm -f $SECRING
22 fi
23 apt-key update
24
25 # ensure tighter permissons on the logs, see LP: #975199
26 if dpkg --compare-versions "$2" lt-nl 0.9.7.7; then
27 # ensure permissions are right
28 chmod -f 0640 /var/log/apt/term.log* || true
29 fi
30
31 ;;
32
33 abort-upgrade|abort-remove|abort-deconfigure)
34
35 ;;
36
37 *)
38 echo "postinst called with unknown argument \`$1'" >&2
39 exit 1
40 ;;
41 esac
42
43 # dh_installdeb will replace this with shell code automatically
44 # generated by other debhelper scripts.
45
46 #DEBHELPER#
47
48 exit 0
49
50