APT::Immediate-Configure had inverted semantics(false m...
[ntk/apt.git] / debian / changelog
1 apt (0.5.4.9) unstable; urgency=low
2
3 * New deb version compare function, that has no integer limits, and
4 supports pre-versions using ~. Code ported from dpkg.
5 * Fix handling of [!arch] for build-dependencies. Closes: #88798, #149595
6 * Fix handling of build-deps on unknown packages. Closes: #88664, #153307
7 * "apt-get --arch-only build-dep" to install only architecture-
8 dependent build dependencies. Bump minor shared lib number to reflect
9 small change in BuildDepend API.
10 * APT::Build-Essential configuration option (defaults to "build-essential")
11 so that "apt-get build-dep" will ensure build essential packages are
12 installed prior to installing other build-dependencies. Closes: #148879
13 * LD_LIBRARY_PATH thing. Closes: #109430, #147529
14 * /usr/doc reference in postinst. Closes: #126189
15 * Doc updates. Closes: #120689
16 * Possible apt-cache segfault. Closes: #120311, #118431, #117915, #135295,
17 #131062, #136749
18 * Print special message for EAI_AGAIN. Closes: #131397
19 * libapt-pkg-dev needs to bring in the apt-inst library if linking
20 is to work. Closes: #133943
21 * Typos, Doc Stuff. Closes: #132772, #129970, #123642, #114892, #113786,
22 #109591, #105920, #103678, #139752, #138186, #138054, #138050,
23 #139994, #142955, #151654, #151834, #147611, #154268, #173971
24 * Fix possibility for tag file parsing to fail in some unlikely situations.
25 Closes: #139328
26 * Use std C++ names for some header files. Closes: #128741
27 * Do not check for free space if --no-download. Closes: #117856
28 * Actually implement or group handling for 'upgrade'. Closes: #133950
29 * "Internal Error, Couldn't configure pre-depend" is not actually an
30 internal error, it is a packaging error and now it says so, and
31 pinpoints the problem dependency. Closes: #155621
32 * Allows failure to write to a pipe for post-invoke stuff. Closes: #89830
33 * Use usr/share/doc for dhelp. Closes: #115701
34 * --print-uris works with 'update'. Closes: #57070
35 * Options Dpkg::MaxArgs,Dpkg::MaxArgBytes to allow a much longer dpkg
36 command line.
37 * Fixed 2 little OR group bugs, thanks to Yann Dirson. Closes: #143995,
38 #142298
39 * Allow an uninstalled package to be marked for removal on an install
40 line (meaning not to automatically install it), also fix some dodgy
41 handling of protected packages. Closes: #92287, #116011
42 * Fix errant prefix matching in version selection. Closes: #105968
43 * Ensure that all files needed to run APT as a user are readable and
44 ignore roots umask for these files. Closes: #108801
45 * Support larger config spaces. Closes: #111914
46 * 'apt-get update' no longer does 'Building Dependency Tree'.
47 * When matching regexs allways print a message. Change regex activation
48 charset. Closes: #147817
49 * Don't die if lines in sources.list are too long. Closes: #146846
50 * Show file name on apt-extracttemplate error messges. Closes: #151835
51 * i18n gettext stuff, based on work from Michael Piefel: Closes: #95933
52 * Some highly unlikely memory faults. Closes: #155842
53 * C++ stuff for G++3.2. Closes: #162617, #165515,
54 * apt-config dumps sends to stdout not stderr now. Closes: #146294
55 * Fix segfault in FindAny when /i is used, and there is no default.
56 Closes: #165891
57 * Add s390x to archtable. Closese: #160992.
58 * Update config.sub/config.guess in cvs, and add support to debian/rules
59 to update them from /usr/share/misc if they exist. Closes: #155014
60 * Remove 'Sorry' from messages. Closes: #148824.
61 * Change wording of 'additional disk space usage' message. Closes:
62 #135021.
63 * apt-extracttemplates now prepends the package name when extracting
64 files. Closes: #132776
65 * Add -n synonym for --names-only for apt-cache. Closes: #130689
66 * Display both current version and new version in apt-get -s. Closes:
67 #92358
68 * Add an options and timeout config item to ssh/rsh. Closes: #90654
69 * libapt-pkg-dev now depends on apt-utils. Closes: #133942.
70 * Change verbose logging output of apt-ftparchive to go to stderr,
71 instead of stdout. Also, errors that occur no longer go to stdout,
72 but stderr. Closes: #161592
73 * Test for timegm in configure. Closes: #165516.
74 * s/st_mtime/mtime/ on our local stat structure in apt-ftparchive, to
75 support compliation on platforms where st_mtime is a macro. Closes:
76 #165518
77 * Check the currently mounted cdrom, to see if it's the one we are
78 interested in. Closes: #154602
79 * Refer to reportbug instead of bug in the man pages. Closes: #173745
80 * Link apt-inst to apt-pkg. Closes: #175055
81 * New apt_preferences man page from Thomas Hood, Susan Kleinmann,
82 and others.
83 * Fix > 300 col screen segfault. Closes: #176052
84 * Rebuild with gcc-3.2. Closes: #177752, #178008.
85 * Fix build-dep handling of | dependencies.
86 Closes: #98640, #145997, #158896, #172901
87 * Double default value of APT::Cache-Limit, until such time as it
88 can be made more dynamic. Closes: #178623.
89 * Report uris with '.gz' when there are errors. Closes: #178435.
90 * When installing build-deps, make sure the new version will
91 satisfy build requirements. Closes: #178121
92 * Split offline and guide documentation into apt-doc. This was done so
93 that binary-arch builds do not require documention deps. Note, that
94 apt-doc is not installed on upgrades.
95 * Use doc-base, instead of dhelp directly. Closes: #110389
96 * Change http message 'Waiting for file' to 'Waiting for headers'.
97 Closes: #178537
98 * Remove trailing lines on package lists in apt-get. Closes: #178736.
99 * Fix origin pins for file:// uris. Closes: #189014.
100 * Apply typo and syntax patch from bug to apt-cache.8.sgml. Closes:
101 #155194
102 * s/dpkg-preconfig/dpkg-preconfigure/ in examples/configure-index.
103 Closes: #153734.
104 * Fix some typos in the apt-get manual. Closes: #163932.
105 * Apply patch from bug, to change frozen to testing, and then do it
106 everywhere else. Closes: #165085.
107 * Update es.po. Closes: #183111.
108 * Add pt_BR translation of apt_preferences(5). Also, build fr manpages.
109 Closes: #183904.
110 * Add a vcg command to apt-cache, similiar to dotty. Closes: #150512.
111 * Add option to apt-get to show versions of packages being
112 upgraded/installed.
113 * Be quiet in apt.post{inst,rm}. Closes: #70685.
114 * apt-get now prints out suggested and recommended packages. Closes:
115 #54982.
116 * Insert some newlines in the cdrom change media message. Closes:
117 #154601.
118 * Add a rdepends command to apt-cache. Closes: #159864.
119 * When building the dpkg command line, allow for 8192 chars to be used,
120 instead of only 1024.
121 * APT::Immediate-Configure had inverted semantics(false meant it was
122 enabled). Closes: #173619.
123
124 -- Adam Heath <doogie@debian.org> Sun, 02 Feb 2003 02:54:45 -0600
125
126 apt (0.5.4) unstable; urgency=low
127
128 * M68k config.guess patch. Closes: #88913
129 * Bi-yearly test on OpenBSD and Solaris
130 * Doc updates. Closes: #89121, #89854, #99671, #98353, #95823, #93057,
131 #97520, #102867, #101071, #102421, #101565, #98272, #106914,
132 #105606, #105377
133 * Various cosmetic code updates. Closes: #89066, #89066, #89152
134 * Add "pre-auto" as an option for DSelect::Clean (run autoclean after
135 update).
136 * More patches from Alfredo for Vendors and more SHA-1 stuff
137 * Fix for AJ's 'desire to remove perl-5.005' and possibly other
138 similar situations. Closes: #56708, #59432
139 * no_proxy and ftp. Closes: #89671
140 * Philippe Batailler's man page patches.
141 * Fix for display bug. Closes: #92033, #93652, #98468
142 * Use more than 16bits for the dep ID. Some people ran out..
143 Closes: #103020, #97809, #102951, #99974, #107362, #107395, #107362,
144 #106911, #107395, #108968
145 * Reordered some things to make dante and FTP happier. Closes: #92757
146 * James R. Van Zandt's guide.sgml updates. Closes: #90027
147 * apt-ftparchive copes with no uncompressed package files + contents.
148 * French man pages from philippe batailler - well sort of. They
149 don't build yet..
150 * run-parts. Closes: #94286
151 * 'apt-cache policy' preferences debug tool.
152 * Whatever. Closes: #89762
153 * libstdc++ and HURD. Closes: #92025
154 * More apt-utils verbage. Closes: #86954
155 * Fliped comparision operator. Closes: #94618
156 * Used the right copyright file. Closes: #65691
157 * Randolph's G++3 patches.
158 * Fixed no_proxy tokanizing. Closes: #100046
159 * Strip Config-Version when copying status to available. Closes: #97520
160 * Segfault with missing source files. Closes: #100325
161 * EINTR check. Closes: #102293
162 * Various changes to the locking metholodgy for --print-uris.
163 Closes: #100590
164 * Lame LD_LIBRARY_PATH thing. Closes: #98928
165 * apt-cache search searchs provide names too now. Closes: #98695
166 * Checksum and long lines problem. Closes: #106591
167 * .aptignr and empty files are just a warning. Closes: #97364
168
169 -- Jason Gunthorpe <jgg@debian.org> Sat, 18 Aug 2001 17:21:59 -0500
170
171 apt (0.5.3) unstable; urgency=low
172
173 * JoeyH's dpkg::preconfig not working. Closes: #88675
174 * Fixed apt override disparity
175 * Alfredo's SHA-1 and related patches
176
177 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
178
179 apt (0.5.2) unstable; urgency=low
180
181 * Fixed mention of /usr/doc in the long description
182 * JoeyH's downgrade bug -- don't use 0.5.1
183 * Doc bug. Closes: #88538
184 * Fault in building release strings. Closes: #88533
185
186 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
187
188 apt (0.5.1) unstable; urgency=low
189
190 * Fixed #82894 again, or should be and.
191 * Process the option string right. Closes: #86921
192 * Don't eat the last command for pipes. Closes: #86923
193 * Ignore .* for configuration directory processing. Closes: #86923
194 * Alfredo's no_proxy patch
195 * Documentation fixes. Closes: #87091
196 * JoeyH's double slash bug. Closes: #87266
197 * Unintitialized buffer and apt-ftparchive contents generation.
198 Closes: #87612
199 * Build-deps on virtual packages. Closes: #87639
200 * Fixes glibc/libstdc++ symbol dependencies by including glibc and
201 libstdc++ version info in the library soname and in the package
202 provides. Closes: #87426
203 * Updated soname version to 0.3.2
204 * apt-extracttemplates moved from debconf into apt-utils
205 * s390 archtable entry. Closes: #88232
206 * Dan's segfault
207 * Some instances where the status file can source a package in a
208 non-sensical way. Closes: #87390
209 * Work better if there are duplicate sources.list entries.
210 * Fixed the resetting of Dir with "dir {};". Closes: #87323
211
212 -- Randolph Chung <tausq@debian.org> Sat, 3 Mar 2001 15:37:38 -0700
213
214 apt (0.5.0) unstable; urgency=low
215
216 * Fixed an obscure bug with missing final double new lines in
217 package files
218 * Changed the apt-cdrom index copy routine to use the new section
219 rewriter
220 * Added a package file sorter, apt-sortpkgs
221 * Parse obsolete Optional dependencies.
222 * Added Ben's rsh method. Closes: #57794
223 * Added IPv6 FTP support and better DNS rotation support.
224 * Include the server IP in error messages when using a DNS rotation.
225 Closes: #64895
226 * Made most of the byte counters into doubles to prevent 32bit overflow.
227 Closes: #65349
228 * HTTP Authorization. Closes: #61158
229 * Ability to parse and return source index build depends from Randolph.
230 * new 'apt-get build-dep' command from Randolph. Closes: #63982
231 * Added apt-ftparchive the all dancing all singing FTP archive
232 maintinance program
233 * Allow version specifications with =1.2.4-3 and /2.2 or /stable postfixes
234 in apt-get.
235 * Removed useless internal cruft including the xstatus file.
236 * Fixed config parser bugs. Closes: #67848, #71108
237 * Brain Damanged apt-get config options changed, does not change the command
238 line interface, except to allow --enable-* to undo a configuration
239 option:
240 No-Remove -> Remove
241 No-Download -> Download
242 No-Upgrade -> Upgrade
243 * Made this fix configable (DSelect::CheckDir) and default to disabled:
244 * No remove prompt if the archives dir has not changed. Closes: #55709
245 Because it is stupid in the case where no files were downloaded due to
246 a resumed-aborted install, or a full cache! Closes: #65952
247 * Obscure divide by zero problem. Closes: #64394
248 * Update sizetable for mips. Closes: #62288
249 * Fixed a bug with passive FTP connections
250 * Has sizetable entry for sparc64. Closes: #64869
251 * Escape special characters in the ::Label section of the cdroms.lst
252 * Created apt-utils and python-apt packages
253 * Due to the new policy engine, the available file may contain entries
254 from the status file. These are generated if the package is not obsolete
255 but the policy engine prohibits using the version from the package files.
256 They can be identified by the lack of a Filename field.
257 * The new policy engine. Closes: #66509, #66944, #45122, #45094, #40006,
258 #36223, #33468, #22551
259 * Fixed deb-src line for non-us. Closes: #71501, #71601
260 * Fixes for G++ 2.96, s/friend/friend class/
261 * Fixed mis doc of APT::Get::Fix-Missing. Closes: #69269
262 * Confirmed fix for missing new line problem. Closes: #69386
263 * Fixed up dhelp files. Closes: #71312
264 * Added some notes about dselect and offline usage. Closes: #66473, #38316
265 * Lock files on read only file systems are ignored w/ warning.
266 Closes: #61701
267 * apt-get update foo now gives an error! Closes: #42891
268 * Added test for shlibs on hurd. Closes: #71499
269 * Clarified apt-cache document. Closes: #71934
270 * DocBook SGML man pages and some improvements in the text..
271 * sigwinch thing. Closes: #72382
272 * Caching can be turned off by setting the cache file names blank.
273 * Ignores arches it does not know about when autocleaning. Closes: #72862
274 * New function in apt-config to return dirs, files, bools and integers.
275 * Fixed an odd litle bug in MarkInstall and fixed it up to handle
276 complex cases involving OR groups and provides.
277 68754 describes confusing messages which are the result of this..
278 Closes: #63149, #69394, #68754, #77683, #66806, #81486, #78712
279 * Speeling mistake and return code for the 'wicked' resolver error
280 Closes: #72621, #75226, #77464
281 * Solved unable to upgrade libc6 from potato to woody due to 3 package
282 libc6 dependency loop problem.
283 * Leading sources.list spaces. Closes: #76010
284 * Removed a possible infinite loop while processing installations.
285 * Man page updates. Closes: #75411, #75560, #64292, #78469
286 * ReduceSourceList bug. Closes: #76027
287 * --only-source option. Closes: #76320
288 * Typos. Closes: #77812, #77999
289 * Different status messages. Closes: #76652, #78353
290 * /etc/apt/apt.conf.d/ directory for Joey and Matt and pipe protocol 2
291 * OS detection an support for the new pseduo standard of os-arch for the
292 Architecture string. Also uses regexing.. Closes: #39227, #72349
293 * Various i18n stuff. Note that this still needs some i18n wizard
294 to do the last gettextization right. Closes: #62386
295 * Fixed a problem with some odd http servers/proxies that did not return
296 the content size in the header. Closes: #79878, #44379
297 * Little acquire bugs. Closes: #77029, #55820
298 * _POSIX_THREADS may not be defined to anything, just defined..
299 Closes: #78996
300 * Spelling of Ignore-Hold correctly. Closes: #78042
301 * Unlock the dpkg db if in download only mode. Closes: #84851
302 * Brendan O'Dea's dselect admindir stuff. Closes: #62811
303 * Patch from BenC. Closes: #80810
304 * Single output of some names in lists. Closes: #80498, #43286
305 * Nice message for people who can't read syserror output. Closes: #84734
306 * OR search function. Closes: #82894
307 * User's guide updates. Closes: #82469
308 * The AJ/JoeyH var/state to var/lib transition patch. Closes: #59094
309 * Various CD bugs, again thanks to Greenbush
310 Closes: #80946, #76547, #71810, #70049, #69482
311 * Using potato debhelper. Closes: #57977
312 * I cannot self-terminate. Closes: #74928
313
314 -- Jason Gunthorpe <jgg@debian.org> Wed, 21 Feb 2001 00:39:15 -0500
315
316 apt (0.3.19) frozen unstable; urgency=low
317
318 * Updates to apt-cdrom to support integrated non-us nicely, thanks to
319 Paul Wade.
320 * Fixed that apt-get/cdrom deadlock thing. Closes: #59853, #62945, #61976
321 * Fixed hardcoded path. Closes: #59743
322 * Fixed Jay's relative path bug
323 * Allowed source only CDs. Closes: #58952
324 * Space check is supressed if --print-uris is given. Closes: #58965
325 * Clarified the documenation examples for non-us. Closes: #58646
326 * Typo in the package description. Closes: #60230
327 * Man Page typo. Closes: #60347
328 * Typo in Algorithms.cc. Closes: #63577
329 * Evil dotty function in apt-cache for generating dependency graphs
330 with the as-yet-unpackaged GraphVis.
331 * Appears to have been fixed in Janurary.. Closes: #57981
332 * New config.guess/sub for the new archs. Closes: #60874
333 * Fixed error reporting for certain kinds of resolution failures.
334 Closes: #61327
335 * Made autoclean respect 'q' settings. Closes: #63023
336 * Fixed up the example sources.list. Closes: #63676
337 * Added DPkg::FlushSTDIN to control the flushing of stdin before
338 forking dpkg. Closes: #63991
339
340 -- Ben Gertzfield <che@debian.org> Fri, 12 May 2000 21:10:54 -0700
341
342 apt (0.3.18) frozen unstable; urgency=low
343
344 * Changes in the postinst script. Closes: #56855, #57237
345 * Fixed bashism. Closes: #57216, #57335
346 * Doc updates. Closes: #57772, #57069, #57331, #57833, #57896
347
348 -- Ben Gertzfield <che@debian.org> Sun, 13 Feb 2000 01:52:31 -0800
349
350 apt (0.3.17) unstable; urgency=low
351
352 * RFC 2732 usage for CDROM URIs and fixes to apt-cdrom
353 * Fixed the configuration parser to not blow up if ; is in the config
354 string
355 * Applied visual patch to dselect install script . Closes #55214
356 * Included the configure-index example
357 * Minimal CD swaps
358 * Library soname has increased
359 * Fixed default sources.list to have correct URLs for potato when it
360 becomes stable
361 * Added a message about erasing sources.list to dselect setup script
362 Closes: #55755
363 * No remove prompt if the archives dir has not changed. Closes: #55709
364 * Fixed inclusion of 2nd sample config file. Closes: #55374
365 * Made file mtimes of 0 not confuse the methods If-Modifed-Since check.
366 Closes: #55991
367
368 -- Ben Gertzfield <che@debian.org> Mon, 31 Jan 2000 12:12:40 -0800
369
370 apt (0.3.16) unstable; urgency=low
371
372 * Made --no-download work. Closes: #52993
373 * Now compiles on OpenBSD, Solaris and HP-UX
374 * Clarify segfault errors
375 * More debhelper fixes. Closes: #52662, #54566, #52090, #53531, #54769
376 * Fix for Joel's discovery of glibc removal behavoir.
377 * Fix for Ben Collins file: uri from slink upgrade.
378 * Fixed resume code in FTP. Closes: #54323
379 * Take more precautions to prevent the corruption Joey Hess saw.
380 * Fixed --no-list-cleanup
381 * RFC 2732 URI parsing ([] for hostnames).
382 * Typo in apt-cache man page. Closes: #54949
383
384 -- Ben Gertzfield <che@debian.org> Fri, 14 Jan 2000 08:04:15 -0800
385
386 apt (0.3.15) unstable; urgency=low
387
388 * Added DSelect::WaitAfterDownload Closes: #49549
389 * Fixed cast error in byteswap macro and supporting code. Closes: #50093
390 * Fixed buffer overflow for wide terminal sizes. Closes: #50295
391 * Made -s and clean not do anything. Closes: #50238
392 * Problem with Protected packages and the new OR code.
393 * /usr/share/doc stuff. Closes: #51017, #50228, #51141
394 * Remove doesn't require a package to be installable. Closes: #51175
395 * FTP proxy touch ups in the mabn page. Closes: #51315, #51314
396
397 -- Ben Gertzfield <che@debian.org> Sat, 4 Dec 1999 21:17:24 -0800
398
399 apt (0.3.14) unstable; urgency=low
400
401 * Fix Perl or group pre-depends thing Closes: #46091, #46096, #46233, #45901
402 * Fix handling of dpkg's conversions from < -> <= Closes: #46094, #47088
403 * Make unparsable priorities non-fatal Closes: #46266, #46267, #46293, #46298
404 * Fix handling of '/' for the dist name. Closes: #43830, #45640, #45692
405 * Fixed 'Method gave a blank filename' error from IMS queries onto CDs.
406 Closes: #45034, #45695, #46537
407 * Made OR group handling in the problem resolver more elaborate. Closes: #45646
408 * Added APT::Clean-Installed option. Closes: #45973
409 * Moves the free space check to after the calculated size is printed.
410 Closes: #46639, #47498
411 * mipsel arch Closes: #47614
412 * Beautified URI printing to not include passwords Closes: #46857
413 * Fixed little problem with --no-download Closes: #47557
414 * Tweaked Dselect 'update' script to re-gen the avail file even in the
415 event of a failure Closes: #47112
416 * Retries for source archives too Closes: #47529
417 * Unmounts CDROMs iff it mounted them Closes: #45299
418 * Checks for the partial directories before doing downloads Closes: #47392
419 * no_proxy environment variable (http only!) Closes: #43476
420 * apt-cache showsrc Closes: #45799
421 * De-Refs Single Pure virtual packages. Closes: #42437, #43555
422 * Regexs for install. Closes: #35304, #38835
423 * Dependency reports now show OR group relations
424 * Re-Install feature. Cloes: #46961, #37393, #38919
425 * Locks archive directory on clean (woops)
426 * Remove is not 'sticky'. Closes: #48392
427 * Slightly more accurate 'can not find package' message. Closes: #48311
428 * --trivial-only and --no-remove. Closes: #48518
429 * Increased the cache size. Closes: #47648
430 * Comment woopsie. Closes: #48789
431 * Removes existing links when linking sources. Closes: #48775
432 * Problem resolver does not install all virtual packages. Closes: #48591, #49252
433 * Clearer usage message about 'source' Closes: #48858
434 * Immediate configure internal error Closes: #49062, #48884
435
436 -- Ben Gertzfield <che@debian.org> Sun, 7 Nov 1999 20:21:25 -0800
437
438 apt (0.3.13) unstable; urgency=low
439
440 * Fix timestamp miss in FTP. Closes: #44363
441 * Fix sorting of Kept packages. Closes: #44377
442 * Fix Segfault for dselect-upgrade. Closes: #44436
443 * Fix handling of '/' for the dist name. Closes #43830
444 * Added APT::Get::Diff-Only and Tar-Only options. Closes #44384
445 * Add commented-out deb-src URI to default sources.list file.
446
447 -- Ben Gertzfield <che@debian.org> Sun, 19 Sep 1999 18:54:20 -0700
448
449 apt (0.3.12) unstable; urgency=low
450
451 * Fix for typo in the dhelp index. Closes: #40377
452 * Multiple media swap support
453 * Purge support. Closes: #33291, #40694
454 * Better handling of - remove notation. Closes: #41024
455 * Purge support. Closes: #33291, #40694
456 * Error code on failed update. Closes: #41053
457 * apt-cdrom adds entries for source directories. Closes: #41231
458 * Sorts the output of any list. Closes: #41107
459 * Fixes the looping problem. Closes: #41784, #42414, #44022
460 * Fixes the CRC mechanism to lowercase all strings. Closes: #41839
461 * More checks to keep the display sane. Particularly when fail-over is
462 used with local mirrors and CD-Roms. Closes: #42127, #43130, #43668
463 * PThread lockup problem on certain sparc/m68k. Closes: #40628
464 * apt-cdrom understands .gz Package files too. Closes: #42779
465 * Spelling error in dselect method description. Closes: #43251
466 * Added security to the default source list. Closes: #43356
467
468 -- Ben Gertzfield <che@debian.org> Fri, 3 Sep 1999 09:04:28 -0700
469
470 apt (0.3.11) unstable; urgency=low
471
472 * Fix for mis-parsed file: URIs. Closes: #40373, #40366, #40230
473 * Fix for properly upgrading the system from perl 5.004 to 5.005
474
475 -- Ben Gertzfield <che@debian.org> Mon, 28 Jun 1999 21:06:44 -0700
476
477 apt (0.3.9) unstable; urgency=low
478
479 * Spelling error in cachefile.cc. Closes: #39885
480 * Trailing slash in dselect install if you try to use the
481 default config file. Closes: #40011
482 * Simulate works for autoclean. Closes: #39141
483 * Fixed spelling errors. Closes: #39673
484 * Changed url parsing a bit. Closes: #40070, #40069
485 * Version 0.3.8 will be for slink/hamm (GNU libc 2).
486
487 -- Ben Gertzfield <che@debian.org> Thu, 24 Jun 1999 18:02:52 -0700
488
489 apt (0.3.7) unstable; urgency=low
490
491 * Fixed missing text in the apt-get(8) page. Closes: #37596
492 * Made --simulate and friends work with apt-get source. Closes: #37597, #37656
493 * Fixed inclusion of man pages in the -doc/-dev package. Closes: #37633, #38651
494 * Fixed handling of the -q option with not-entirely integer arguments
495 Closes: #37499
496 * Man page typo Closes: #37762
497 * Fixed parsing of the Source: line. Closes: #37679
498 * Dpkg/dpkg-hurd source bug. Closes: #38004, #38032
499 * Added a check for an empty cache directory. Closes: #37963
500 * Return a failure code if -d is given and packages fail to download.
501 Closes: #38127
502 * Arranged for an ftp proxy specifing an http server to work. See the
503 important note in the sources.list man page.
504 * Accounted for resumed files in the cps calculation. Closes: #36787
505 * Deal with duplicate same version different packages. Closes: #30237
506 * Added --no-download. Closes: #38095
507 * Order of apt-cdrom dist detection. Closes: #38139
508 * Fix apt-cdrom chop handling and missing lines. Closes: #37276
509 * IPv6 http support
510 * Suggests dpkg-dev for apt-get source. Closes: #38158
511 * Fixed typo in apt-get help. Closes: #38712
512 * Improved the error message in the case of broken held package. Closes: #38777
513 * Fixed handling of MD5 failures
514 * Documented list notation Closes: #39008
515 * Change the 'b' to 'B'. Closes: #39007
516
517 -- Ben Gertzfield <che@debian.org> Sun, 20 Jun 1999 18:36:20 -0700
518
519 apt (0.3.6) unstable; urgency=low
520
521 * Note that 0.3.5 never made it out the door..
522 * Fix for apt-cdrom and unusual disk label locations. Closes: #35571
523 * Made APT print numbers in decimal. Closes: #35617, #37319
524 * Buffer munching fix for FTP. Closes: #35868
525 * Typo in sample config file. Closes: #35907
526 * Fixed whitespace in version compares. Closes: #35968, #36283, #37051
527 * Changed installed size counter to only count unpacked packages.
528 Closes: #36201
529 * apt-get source support. Closes: #23934, #27190
530 * Renames .debs that fail MD5 checking, provides automatic corruption
531 recovery. Closes: #35931
532 * Fixed autoconf verison. Closes: #37305
533 * Random Segfaulting. Closes: #37312, #37530
534 * Fixed apt-cache man page. Closes: #36904
535 * Added a newline to apt-cache showpkg. Closes: #36903
536
537 -- Ben Gertzfield <che@debian.org> Wed, 12 May 1999 09:18:49 -0700
538
539 apt (0.3.4) unstable; urgency=low
540
541 * Release for Ben while he is out of town.
542 * Checked the size of partial files. Closes: #33705
543 * apt-get should not print progress on non-tty. Closes: #34944
544 * s/guide.text.gz/users-guide.txt.gz/ debian/control: Closes: #35207
545 * Applied cdrom patches from Torsten. Closes: #35140, #35141
546 * smbmounted cdrom fix. Closes: #35470
547 * Changed ie to eg. Closes: #35196
548
549 -- Adam Heath <doogie@debian.org> Sun, 4 Apr 1999 18:26:44 -0500
550
551 apt (0.3.3) unstable; urgency=low
552
553 * Fixes bug with file:/ URIs and multi-CD handling. Closes: #34923
554
555 -- Ben Gertzfield <che@debian.org> Tue, 23 Mar 1999 12:15:44 -0800
556
557 apt (0.3.2) unstable; urgency=low
558
559 * Major release into unstable of v3
560 * These bugs have been fixed, explanations are in the bug system, read
561 the man pages as well..
562 Closes: #21113, #22507, #22675, #22836, #22892, #32883, #33006, #34121,
563 #23984, #24685, #24799, #25001, #25019, #34223, #34296, #34355,
564 #24021, #25022, #25026, #25104, #25176, #31557, #31691, #31853,
565 #25458, #26019, #26433, #26592, #26670, #27100, #27100, #27601,
566 #28184, #28391, #28778, #29293, #29351, #27841, #28172, #30260,
567 #29382, #29441, #29903, #29920, #29983, #30027, #30076, #30112,
568 #31009, #31155, #31381, #31883, #32140, #32395, #32584. #34465,
569 #30383, #30441, #30472, #30643, #30827, #30324, #36425, #34596
570
571 -- Ben Gertzfield <che@debian.org> Mon, 15 Mar 1999 19:14:25 -0800
572
573 apt (0.3.1) experimental; urgency=low
574
575 * Minor release of cvs version.
576 * Added virtual package libapt-pkgx.x
577
578 -- Mitch Blevins <mblevin@debian.org> Wed, 10 Mar 1999 07:52:44 -0500
579
580 apt (0.3.0) experimental; urgency=low
581
582 * New experimental version.
583
584 -- Ben Gertzfield <che@debian.org> Tue, 15 Dec 1998 12:53:21 -0800
585
586 apt (0.1.9) frozen unstable; urgency=low
587
588 * Return to the wacky numbering for when we build 0.1.8 for hamm
589 * Important bug related to APT on the Alpha fixed
590 * apt-get dist-upgrade problems fixed
591 * tiny patch for http method to fix an endless loop
592 * nice fix from /usr/doc/lintian/ to remove rpath nastiness from
593 libtool and add proper shared lib dependancies
594 * now dh_shlibdeps is called with LD_LIBRARY_PATH=debian/tmp/usr/lib
595 in case an old libpkg is installed while building APT to prevent
596 spurious dependancies
597
598 -- Ben Gertzfield <che@debian.org> Thu, 5 Nov 1998 17:43:25 -0800
599
600 apt (0.1.7) unstable; urgency=low
601
602 * New build with libstdc++2.9.
603 * Various fixes; read the Changelog.
604
605 -- Ben Gertzfield <che@debian.org> Thu, 15 Oct 1998 18:29:18 -0700
606
607 apt (0.1.6) unstable; urgency=low
608
609 * Various fixes in the FTP method for error checking. Fixes: #26188.
610 * Spelling corrections in dselect method. Fixes: #25884
611 * Fixes for compilation on alpha/ppc. Fixes: #25313, #26108.
612 * No more bo releases: we're using a normal numbering system now.
613
614 -- Ben Gertzfield <che@debian.org> Tue, 8 Sep 1998 19:27:13 -0700
615
616 apt (0.1.5) unstable; urgency=low
617
618 * Changed sources.list to point to 'unstable' by default, as
619 'frozen' no longer exists!
620
621 -- Ben Gertzfield <che@debian.org> Thu, 23 Jul 1998 22:00:18 -0700
622
623 apt (0.1.3) unstable; urgency=low
624
625 * New upstreamish version.
626 * ftp method rewritten in C. Removes dependancies on all perl/perl
627 related modules. This fixes many of the ftp method bugs.
628
629 -- Ben Gertzfield <che@debian.org> Thu, 16 Jul 1998 22:19:00 -0700
630
631 apt (0.1.1) unstable; urgency=low
632
633 * Release for unstable.
634
635 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:48:30 -0700
636
637 apt (0.1) unstable; urgency=low
638
639 * Kludge to fix problem in libnet-perl with illegal anonymous
640 FTP passwords.
641 * Moved to unstable; apt is in a useable state now.
642 * Fixed version numbering. From now on, numbering will be:
643 0.1 (no actual release) -> 0.1.0bo (release for libc5) ->
644 0.1.1 (release for unstable). Thanks, Manoj.
645
646 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:40:58 -0700
647
648 apt (0.0.17-1) experimental; urgency=low
649
650 * Fixed problem with libc6 version compare
651 * Scott's away for a while, so I'll be packaging apt for the time
652 being.
653
654 -- Ben Gertzfield <che@debian.org> Thu, 25 Jun 1998 19:02:03 -0700
655
656 apt (0.0.16-1) experimental; urgency=low
657
658 * Modifications to make apt-get more friendly when backgrounded.
659 * Updated documentation.
660 * Updates to graphic widgets
661
662 -- Scott K. Ellis <scott@debian.org> Mon, 8 Jun 1998 11:22:02 -0400
663
664 apt (0.0.15-0.2bo) experimental; urgency=low
665
666 * Bo compilation
667 * Bob Hilliards crash
668
669 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
670
671 apt (0.0.15-0.1bo) experimental; urgency=low
672
673 * Bo compilation
674 * libstdc++272 patch
675
676 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
677
678 apt (0.0.15) experimental; urgency=low
679
680 * Clean up source tarball (no user-visible changes)
681
682 -- Scott K. Ellis <scott@debian.org> Tue, 26 May 1998 12:23:53 -0400
683
684 apt (0.0.14) experimental; urgency=low
685
686 * Updates in ordering code to make sure certain upgrades work correctly.
687 * Made dselect/setup understand ftp as well as http
688
689 -- Scott K. Ellis <scott@debian.org> Wed, 20 May 1998 13:33:32 -0400
690
691 apt (0.0.13-bo1) experimental; urgency=low
692
693 * Bo compilation
694
695 -- Jason Gunthorpe <jgg@debian.org> Mon, 18 May 1998 15:10:49 -0600
696
697 apt (0.0.13) experimental; urgency=low
698
699 * Remove hardcoded egcc from debian/rules (#21575)
700 * Fixes for ordering logic when system has a number of unpacked
701 but unconfigured packages installed.
702 * Spelling fix in dselect install method (#22556)
703
704 -- Scott K. Ellis <scott@debian.org> Sun, 17 May 1998 20:08:33 -0400
705
706 apt (0.0.12) experimental; urgency=low
707
708 * Fixed problems with package cache corruption.
709 * Made to depend on libc6 >= 2.0.7pre1 due to timezone problems with
710 earlier versions.
711 * Interface and documentation improvements.
712
713 -- Scott K. Ellis <scott@debian.org> Sat, 16 May 1998 23:17:32 -0400
714
715 apt (0.0.11) experimental; urgency=low
716
717 * Change dependancies to pre-depends since breaking your packaging tools
718 in the middle of an installation isn't very good.
719 * Bug fixes to ftp method and general apt-get code
720
721 -- Scott K. Ellis <scott@debian.org> Fri, 15 May 1998 08:57:38 -0400
722
723 apt (0.0.10) experimental; urgency=low
724
725 * Run "dpkg --configure -a" after an aborted dselect install
726 * Fixed problem with install looping
727 * Support for authenticating proxys: (note this isn't terribly secure)
728 http_proxy="http://user:pass@firewall:port/"
729 * Substitute $ARCH in sources.list
730 * Fixes in the resumption code for ftp
731
732 -- Scott K. Ellis <scott@debian.org> Tue, 12 May 1998 09:14:41 -0400
733
734 apt (0.0.9) experimental; urgency=low
735
736 * Added ftp support.
737 * Various other less visible bug fixes.
738 * Fixed problem with segfault when apt-get invoked in a non-existant
739 directory (Bug #21863)
740 * Bumped policy to 2.4.1
741
742 -- Scott K. Ellis <scott@debian.org> Fri, 1 May 1998 09:18:19 -0400
743
744 apt (0.0.8) experimental; urgency=low
745
746 * Fixed generated available file (Bug #21836)
747 * Added download ETA (Bug #21774).
748 * Fixed hardcoded ARCH (Bug #21751).
749 * Fixed check on http_proxy (Bug #21795).
750 * Added download speed indicator.
751
752 -- Scott K. Ellis <scott@debian.org> Mon, 27 Apr 1998 10:58:32 -0400
753
754 apt (0.0.7) experimental; urgency=low
755
756 * Remove libdeity and apt from package for now, since only apt-get and
757 apt-cache are actually useful right now.
758 * Clean up handling of package installation errors.
759 * Added timeout to http transfers (#21269)
760 * Updated setup for dselect/apt method.
761 * Updated man pages
762 * Long options (added in 0.0.6)
763
764 -- Scott K. Ellis <scott@debian.org> Tue, 21 Apr 1998 09:06:49 -0400
765
766 apt (0.0.6) experimental; urgency=low
767
768 * Spelling changes.
769 * Revamped download status display.
770 * Call apt-get clean after successful install in dselect.
771 * Added "apt-get clean" which deletes package files from /var/cache/apt
772
773 -- Scott K. Ellis <scott@debian.org> Thu, 9 Apr 1998 15:13:59 -0400
774
775 apt (0.0.5) experimental; urgency=low
776
777 * Ignore signals while dpkg is running so we don't leave dpkg running in
778 the background (#20804)
779 * Check Packages as well as Packages.gz for file URIs (#20784)
780 * Spelling cleanup (#20800)
781 * Added -m option to permit upgrade to go on in the case of a bad mirror.
782 This option may result in incomplete upgrades when used with -f.
783
784 -- Scott K. Ellis <scott@debian.org> Tue, 7 Apr 1998 12:40:29 -0400
785
786 apt (0.0.4) experimental; urgency=low
787
788 * New usage guide.
789 * Various documentation updates and cleanup.
790 * Added '-f' option to apt-get attempt to fix broken dependancies.
791
792 -- Scott K. Ellis <scott@debian.org> Sat, 4 Apr 1998 14:36:00 -0500
793
794 apt (0.0.3) experimental; urgency=low
795
796 * Added a shlibs.local file to prevent apt from depending on itself.
797 * Updates to how apt-get handles bad states in installed packages.
798 * Updated rules to make sure build works from a freshly checked out source
799 archive. Building from CVS needs libtool/automake/autoconf, builds from
800 the distributed source package should have no such dependancy.
801
802 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 11:49:47 -0500
803
804 apt (0.0.2) unstable; urgency=low
805
806 * Updates to apt-get and http binding for dselect method (apt).
807 * Updating version number from 0.0.1, which was released only on IRC.
808
809 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 00:35:18 -0500
810
811 apt (0.0.1) unstable; urgency=low
812
813 * Initial Release.
814
815 -- Scott K. Ellis <scott@debian.org> Tue, 31 Mar 1998 12:49:28 -0500
816