* build-depend on libdb4.3 now, fix for kFreeBSD (#317718)
[ntk/apt.git] / debian / rules
1 #!/usr/bin/make -f
2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
5 # $Id: rules,v 1.68 2004/05/30 18:21:43 mdz Exp $
6
7 # LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
8 # dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
9
10 # For the deb builder, you can run 'debian/rules cvs-build', which does all
11 # steps nescessary to produce a proper source tarball with the CVS/ removed.
12 # It builds in debian/cvs-build/apt-<VER>/, and places files in
13 # debian/cvs-build/. Optionally, you can run 'debian/rules cvs-mkul' to
14 # create ../upload-<VER>, with all the files needed to be uploaded placed
15 # in it.
16
17 export DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
18 export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
19
20 # FOR AUTOCONF 2.52 AND NEWER ONLY
21 ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
22 confflags += --build $(DEB_HOST_GNU_TYPE)
23 else
24 confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
25 endif
26
27 # See below
28 -include build/environment.mak
29
30 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
31 export CXXFLAGS = -O0 -g -Wall
32 else
33 export CXXFLAGS = -O2 -g -Wall
34 endif
35
36 # Default rule
37 build:
38
39 DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
40 APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p')
41 APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
42 APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')
43
44 # Determine the build directory to use
45 BASE=.
46 ifdef BUILD
47 BUILD_POSSIBLE := $(BUILD) $(BASE)/$(BUILD)
48 else
49 BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname -m) $(BASE)/build
50 endif
51 BUILDX:= $(foreach i,$(BUILD_POSSIBLE),$(wildcard $(i)/environment.mak*))
52 BUILDX:= $(patsubst %/,%,$(firstword $(dir $(BUILDX))))
53 override BLD := $(BUILDX)
54
55 ifeq ($(words $(BLD)),0)
56 override BLD := ./build
57 endif
58
59 # Rebuild configure.in to have the correct version from the change log
60 ifneq ($(APT_DEBVER),$(APT_CONFVER))
61 ifneq ($(APT_DEBVER),)
62 .PHONY: configure.in
63 configure.in:
64 sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$ && mv $@.$$$$ $@
65 endif
66 else
67 configure.in:
68 endif
69
70 # APT Programs in apt-utils
71 APT_UTILS=ftparchive sortpkgs extracttemplates
72
73 # Uncomment this to turn on verbose mode.
74 #export DH_VERBOSE=1
75
76 # Find the libapt-pkg major version for use in other control files
77 export LIBAPTPKG_MAJOR:=$(shell egrep '^MAJOR=' apt-pkg/makefile |cut -d '=' -f 2)
78 export LIBAPTINST_MAJOR:=$(shell egrep '^MAJOR=' apt-inst/makefile |cut -d '=' -f 2)
79
80 # Determine which package we should provide in the control files
81 LIBAPTPKG_PROVIDE=libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER)-$(LIBAPTPKG_MAJOR)
82 LIBAPTINST_PROVIDE=libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER)-$(LIBAPTINST_MAJOR)
83
84 debian/shlibs.local: apt-pkg/makefile
85 # We have 3 shlibs.local files.. One for 'apt', one for 'apt-utils' and
86 # one for the rest of the packages. This ensures that each package gets
87 # the right overrides..
88 rm -rf $@ $@.apt $@.apt-utils
89 echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR)" > $@.apt
90
91 echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@.apt-utils
92 echo "libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR)" >> $@.apt-utils
93
94 echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@
95 echo "libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR) $(LIBAPTINST_PROVIDE)" >> $@
96
97 build: build/build-stamp
98 build-doc: build/build-doc-stamp
99
100 # Note that this is unconditionally done first as part of loading environment.mak
101 # The true is needed to force make to reload environment.mak after running
102 # configure-stamp. Otherwise we can get stale or invalid, or missing config data.
103 build/environment.mak: build/configure-stamp
104 @true
105
106 configure: configure.in
107 build/configure-stamp: configure
108 dh_testdir
109 -mkdir build
110 cp COPYING debian/copyright
111 cd build && CXXFLAGS="$(confcxxflags)" ../configure $(confflags)
112 touch $@
113
114 build/build-stamp: build/configure-stamp
115 # Add here commands to compile the package.
116 $(MAKE) binary
117 touch $@
118
119 build/build-doc-stamp: build/configure-stamp
120 # Add here commands to compile the package.
121 $(MAKE) doc
122 touch $@
123
124 clean:
125 dh_testdir
126 # dh_testroot
127 -$(MAKE) clean
128 -$(MAKE) distclean
129
130 rm -rf build
131
132 # Add here commands to clean up after the build process.
133 dh_clean debian/copyright debian/shlibs.local debian/shlibs.local.apt debian/shlibs.local.apt-utils
134
135 binary-indep: apt-doc libapt-pkg-doc
136 # Build architecture-independent files here.
137 libapt-pkg-doc: build-doc debian/shlibs.local
138 dh_testdir -p$@
139 dh_testroot -p$@
140 dh_clean -p$@ -k
141 dh_installdirs -p$@
142 #
143 # libapt-pkg-doc install
144 #
145 dh_installdocs -p$@ $(BLD)/docs/cache* $(BLD)/docs/design* $(BLD)/docs/dpkg-tech* \
146 $(BLD)/docs/files* $(BLD)/docs/method* \
147 doc/libapt-pkg2_to_3.txt doc/style.txt
148 dh_installexamples -p$@
149 # dh_installmenu -p$@
150 # dh_installinit -p$@
151 # dh_installcron -p$@
152 # dh_installman -p$@
153
154 # dh_undocumented -p$@
155 dh_installchangelogs -p$@
156 dh_strip -p$@
157 dh_compress -p$@
158 dh_fixperms -p$@
159 # dh_suidregister -p$@
160 dh_installdeb -p$@
161 dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
162 dh_md5sums -p$@
163 dh_builddeb -p$@
164
165 apt-doc: build-doc
166 dh_testdir -p$@
167 dh_testroot -p$@
168 dh_clean -p$@ -k
169 #
170 # apt-doc install
171 #
172 # Copy the guides
173 dh_installdocs -p$@ $(BLD)/docs/guide*.text $(BLD)/docs/guide*.html \
174 $(BLD)/docs/offline*.text $(BLD)/docs/offline*.html
175 dh_installchangelogs -p$@
176 dh_compress -p$@
177 dh_fixperms -p$@
178 dh_installdeb -p$@
179 dh_gencontrol -p$@
180 dh_md5sums -p$@
181 dh_builddeb -p$@
182
183
184
185 # Build architecture-dependent files here.
186
187 binary-arch: apt libapt-pkg-dev apt-utils
188 apt: build debian/shlibs.local
189 dh_testdir -p$@
190 dh_testroot -p$@
191 dh_clean -p$@ -k
192 dh_installdirs -p$@ /usr/share/bug/$@ /usr/share/$@
193 #
194 # apt install
195 #
196 cp $(BLD)/bin/apt-* debian/$@/usr/bin/
197
198 # Remove the bits that are in apt-utils
199 rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS))
200
201 # install the shared libs
202 find $(BLD)/bin/ -type f -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
203 find $(BLD)/bin/ -type l -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
204
205 cp $(BLD)/bin/methods/* debian/$@/usr/lib/apt/methods/
206
207 cp $(BLD)/scripts/dselect/* debian/$@/usr/lib/dpkg/methods/apt/
208 cp -r $(BLD)/locale debian/$@/usr/share/
209
210 cp debian/bugscript debian/$@/usr/share/bug/apt/script
211
212 cp share/debian-archive.gpg debian/$@/usr/share/$@
213
214 # head -n 500 ChangeLog > debian/ChangeLog
215
216 dh_installexamples -p$@ $(BLD)/docs/examples/*
217 dh_installman -p$@
218 dh_installcron -p$@
219 dh_installdocs -p$@
220 dh_installchangelogs -p$@
221 dh_strip -p$@
222 dh_compress -p$@
223 dh_fixperms -p$@
224 dh_makeshlibs -p$@ -m$(LIBAPTPKG_MAJOR) -V '$(LIBAPTPKG_PROVIDE)'
225 dh_installdeb -p$@
226 dh_shlibdeps -p$@ -l`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt
227 dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
228 dh_md5sums -p$@
229 dh_builddeb -p$@
230
231 libapt-pkg-dev: build debian/shlibs.local
232 dh_testdir -p$@
233 dh_testroot -p$@
234 dh_clean -p$@ -k
235 dh_installdirs -p$@
236 #
237 # libapt-pkg-dev install
238 #
239 cp -a $(BLD)/bin/libapt-pkg*.so debian/libapt-pkg-dev/usr/lib/
240 cp -a $(BLD)/bin/libapt-inst*.so debian/libapt-pkg-dev/usr/lib/
241 # ln -s libapt-pkg.so.$(LIBAPTPKG_MAJOR) debian/libapt-pkg-dev/usr/lib/libapt-pkg.so
242 cp $(BLD)/include/apt-pkg/*.h debian/libapt-pkg-dev/usr/include/apt-pkg/
243
244 dh_installdocs -p$@
245 # dh_installmenu -p$@
246 # dh_installinit -p$@
247 # dh_installcron -p$@
248 # dh_installman -p$@
249
250 dh_installchangelogs -p$@
251 dh_strip -p$@
252 dh_compress -p$@
253 dh_fixperms -p$@
254 # dh_suidregister -p$@
255 dh_installdeb -p$@
256 dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE) -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
257 dh_md5sums -p$@
258 dh_builddeb -p$@
259
260 apt-utils: build debian/shlibs.local
261 dh_testdir -p$@
262 dh_testroot -p$@
263 dh_clean -p$@ -k
264 dh_installdirs -p$@
265
266 # install the shared libs
267 find $(BLD)/bin/ -type f -name "libapt-inst*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
268 find $(BLD)/bin/ -type l -name "libapt-inst*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
269
270 cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
271 dh_installdocs -p$@
272 dh_installexamples -p$@
273
274 # Install the man pages..
275 dh_installman -p$@
276
277 dh_installchangelogs -p$@
278 dh_strip -p$@
279 dh_compress -p$@
280 dh_fixperms -p$@
281 dh_makeshlibs -m$(LIBAPTINST_MAJOR) -V '$(LIBAPTINST_PROVIDE)' -p$@
282 dh_installdeb -p$@
283 dh_shlibdeps -p$@ -l`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt-utils
284 dh_gencontrol -p$@ -u -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
285 dh_md5sums -p$@
286 dh_builddeb -p$@
287
288 source diff:
289 @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
290
291 # Update from CVS
292 l33ch: really-clean
293 cvs update
294 buildlib/mkChangeLog
295
296 # Update from CVS and then configure for build
297 super-l33ch: l33ch Makefile.in
298
299 configure:
300 $(MAKE) configure
301
302 l33ch-stamp: super-l33ch
303 touch $@
304
305 really-clean: clean
306 -find -name Makefile.in -print0 | xargs -0r rm -f
307 find -name ChangeLog | xargs rm -f
308 rm -f l33ch-stamp
309
310 binary: binary-indep binary-arch
311 .PHONY: build clean binary-indep binary-arch binary debian/shlibs.local
312
313
314 # Done by the uploader.
315 #cvs update..
316 #edit debian/changelog
317 # configure.in has the version automatically updated now.
318 # edit configure.in
319 # debian/rules cvs-build
320
321 CVS_BUILDDIR=apt-$(APT_DEBVER)
322 CVS_ROOT=$(shell cat CVS/Root)
323 CVS_MODULE=$(shell cat CVS/Repository)
324 cvs-build:
325 rm -rf debian/cvs-build
326 mkdir -p debian/cvs-build
327 (cd debian/cvs-build;cvs -d $(CVS_ROOT) export -r$(APT_CVSTAG) -d apt-$(APT_DEBVER) $(CVS_MODULE))
328 $(MAKE) -C debian/cvs-build/$(CVS_BUILDDIR) startup doc
329 (cd debian/cvs-build/$(CVS_BUILDDIR);$(DEB_BUILD_PROG))
330
331 cvs-mkul:
332 -mkdir -p ../upload-$(APT_DEBVER)
333 cp `find debian/cvs-build -maxdepth 1 -type f` ../upload-$(APT_DEBVER)
334
335 arch-build:
336 rm -rf debian/arch-build
337 mkdir -p debian/arch-build/apt-$(APT_DEBVER)
338 baz inventory -s | xargs cp -a --parents --target=debian/arch-build/apt-$(APT_DEBVER)
339 $(MAKE) -C debian/arch-build/apt-$(APT_DEBVER) startup doc
340 (cd debian/arch-build/apt-$(APT_DEBVER); $(DEB_BUILD_PROG))