Merge remote-tracking branch 'upstream/debian/sid' into bugfix/coverity
[ntk/apt.git] / debian / apt.postinst
1 #! /bin/sh
2
3 set -e
4
5 # summary of how this script can be called:
6 # * <postinst> `configure' <most-recently-configured-version>
7 # * <old-postinst> `abort-upgrade' <new version>
8 # * <conflictor's-postinst> `abort-remove' `in-favour' <package>
9 # <new-version>
10 # * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
11 # <failed-install-package> <version> `removing'
12 # <conflicting-package> <version>
13 # for details, see http://www.debian.org/doc/debian-policy/ or
14 # the debian-policy package
15
16 case "$1" in
17 configure)
18 SECRING='/etc/apt/secring.gpg'
19 # test if secring is an empty normal file
20 if test -f $SECRING -a ! -s $SECRING; then
21 rm -f $SECRING
22 fi
23 apt-key update
24
25 # ensure tighter permissons on the logs, see LP: #975199
26 if dpkg --compare-versions "$2" lt-nl 0.9.7.7; then
27 # ensure permissions are right
28 chmod -f 0640 /var/log/apt/term.log* || true
29 fi
30
31 # create kernel autoremoval blacklist on update
32 if dpkg --compare-versions "$2" lt-nl 0.9.9.3; then
33 /etc/kernel/postinst.d/apt-auto-removal
34 fi
35 ;;
36
37 abort-upgrade|abort-remove|abort-deconfigure)
38
39 ;;
40
41 *)
42 echo "postinst called with unknown argument \`$1'" >&2
43 exit 1
44 ;;
45 esac
46
47 # dh_installdeb will replace this with shell code automatically
48 # generated by other debhelper scripts.
49
50 #DEBHELPER#
51
52 exit 0
53
54