* merged the apt-breaks-iwj branch
[ntk/apt.git] / debian / rules
1 #!/usr/bin/make -f
2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
5 # $Id: rules,v 1.68 2004/05/30 18:21:43 mdz Exp $
6
7 # LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
8 # dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
9
10 # For the deb builder, you can run 'debian/rules cvs-build', which does all
11 # steps nescessary to produce a proper source tarball with the CVS/ removed.
12 # It builds in debian/cvs-build/apt-<VER>/, and places files in
13 # debian/cvs-build/. Optionally, you can run 'debian/rules cvs-mkul' to
14 # create ../upload-<VER>, with all the files needed to be uploaded placed
15 # in it.
16
17 export DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
18 export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
19
20 # FOR AUTOCONF 2.52 AND NEWER ONLY
21 ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
22 confflags += --build $(DEB_HOST_GNU_TYPE)
23 else
24 confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
25 endif
26
27 # See below
28 -include build/environment.mak
29
30 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
31 export CXXFLAGS = -O0 -g -Wall
32 else
33 export CXXFLAGS = -O2 -g -Wall
34 endif
35
36 # Default rule
37 build:
38
39 PKG=apt
40 DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
41 APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p' -e 's/\+.*$$//')
42 APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
43 APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')
44
45 # Determine the build directory to use
46 BASE=.
47 ifdef BUILD
48 BUILD_POSSIBLE := $(BUILD) $(BASE)/$(BUILD)
49 else
50 BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname -m) $(BASE)/build
51 endif
52 BUILDX:= $(foreach i,$(BUILD_POSSIBLE),$(wildcard $(i)/environment.mak*))
53 BUILDX:= $(patsubst %/,%,$(firstword $(dir $(BUILDX))))
54 override BLD := $(BUILDX)
55
56 ifeq ($(words $(BLD)),0)
57 override BLD := ./build
58 endif
59
60 # Rebuild configure.in to have the correct version from the change log
61 ifneq ($(APT_DEBVER),$(APT_CONFVER))
62 ifneq ($(APT_DEBVER),)
63 .PHONY: configure.in
64 configure.in:
65 sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$ && mv $@.$$$$ $@
66 endif
67 else
68 configure.in:
69 endif
70
71 # APT Programs in apt-utils
72 APT_UTILS=ftparchive sortpkgs extracttemplates
73
74 # Uncomment this to turn on verbose mode.
75 #export DH_VERBOSE=1
76
77 # Find the libapt-pkg major version for use in other control files
78 export LIBAPTPKG_MAJOR:=$(shell egrep '^MAJOR=' apt-pkg/makefile |cut -d '=' -f 2)
79 export LIBAPTINST_MAJOR:=$(shell egrep '^MAJOR=' apt-inst/makefile |cut -d '=' -f 2)
80
81 # Determine which package we should provide in the control files
82 LIBAPTPKG_PROVIDE=libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER)-$(LIBAPTPKG_MAJOR)
83 LIBAPTINST_PROVIDE=libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER)-$(LIBAPTINST_MAJOR)
84
85 debian/shlibs.local: apt-pkg/makefile
86 # We have 3 shlibs.local files.. One for 'apt', one for 'apt-utils' and
87 # one for the rest of the packages. This ensures that each package gets
88 # the right overrides..
89 rm -rf $@ $@.apt $@.apt-utils
90 echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR)" > $@.apt
91
92 echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@.apt-utils
93 echo "libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR)" >> $@.apt-utils
94
95 echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@
96 echo "libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR) $(LIBAPTINST_PROVIDE)" >> $@
97
98 build: build/build-stamp
99 build-doc: build/build-doc-stamp
100
101 # Note that this is unconditionally done first as part of loading environment.mak
102 # The true is needed to force make to reload environment.mak after running
103 # configure-stamp. Otherwise we can get stale or invalid, or missing config data.
104 build/environment.mak: build/configure-stamp
105 @true
106
107 configure: configure.in
108 build/configure-stamp: configure
109 dh_testdir
110 -mkdir build
111 cp COPYING debian/copyright
112 cd build && CXXFLAGS="$(confcxxflags)" ../configure $(confflags)
113 touch $@
114
115 build/build-stamp: build/configure-stamp
116 # Add here commands to compile the package.
117 $(MAKE) binary
118 touch $@
119
120 build/build-doc-stamp: build/configure-stamp
121 # Add here commands to compile the package.
122 $(MAKE) doc
123 touch $@
124
125 clean:
126 dh_testdir
127 # dh_testroot
128 -$(MAKE) clean
129 -$(MAKE) distclean
130
131 rm -rf build
132
133 # Add here commands to clean up after the build process.
134 dh_clean debian/copyright debian/shlibs.local debian/shlibs.local.apt debian/shlibs.local.apt-utils
135
136 binary-indep: apt-doc libapt-pkg-doc
137 # Build architecture-independent files here.
138 libapt-pkg-doc: build-doc debian/shlibs.local
139 dh_testdir -p$@
140 dh_testroot -p$@
141 dh_clean -p$@ -k
142 dh_installdirs -p$@
143 #
144 # libapt-pkg-doc install
145 #
146 dh_installdocs -p$@ $(BLD)/docs/cache* $(BLD)/docs/design* $(BLD)/docs/dpkg-tech* \
147 $(BLD)/docs/files* $(BLD)/docs/method* \
148 doc/libapt-pkg2_to_3.txt doc/style.txt
149 dh_installexamples -p$@
150 # dh_installmenu -p$@
151 # dh_installinit -p$@
152 # dh_installcron -p$@
153 # dh_installman -p$@
154
155 # dh_undocumented -p$@
156 dh_installchangelogs -p$@
157 dh_strip -p$@
158 dh_compress -p$@
159 dh_fixperms -p$@
160 # dh_suidregister -p$@
161 dh_installdeb -p$@
162 dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
163 dh_md5sums -p$@
164 dh_builddeb -p$@
165
166 apt-doc: build-doc
167 dh_testdir -p$@
168 dh_testroot -p$@
169 dh_clean -p$@ -k
170 #
171 # apt-doc install
172 #
173 # Copy the guides
174 dh_installdocs -p$@ $(BLD)/docs/guide*.text $(BLD)/docs/guide*.html \
175 $(BLD)/docs/offline*.text $(BLD)/docs/offline*.html
176 dh_installchangelogs -p$@
177 dh_compress -p$@
178 dh_fixperms -p$@
179 dh_installdeb -p$@
180 dh_gencontrol -p$@
181 dh_md5sums -p$@
182 dh_builddeb -p$@
183
184
185
186 # Build architecture-dependent files here.
187
188 binary-arch: apt libapt-pkg-dev apt-utils
189 apt: build debian/shlibs.local
190 dh_testdir -p$@
191 dh_testroot -p$@
192 dh_clean -p$@ -k
193 dh_installdirs -p$@ /usr/share/bug/$@ /usr/share/$@
194 #
195 # apt install
196 #
197 cp $(BLD)/bin/apt-* debian/$@/usr/bin/
198
199 # Remove the bits that are in apt-utils
200 rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS))
201
202 # install the shared libs
203 find $(BLD)/bin/ -type f -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
204 find $(BLD)/bin/ -type l -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
205
206 cp $(BLD)/bin/methods/* debian/$@/usr/lib/apt/methods/
207
208 cp $(BLD)/scripts/dselect/* debian/$@/usr/lib/dpkg/methods/apt/
209 cp -r $(BLD)/locale debian/$@/usr/share/
210
211 cp debian/bugscript debian/$@/usr/share/bug/apt/script
212
213 cp share/debian-archive.gpg debian/$@/usr/share/$@
214 cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
215 # head -n 500 ChangeLog > debian/ChangeLog
216
217 # make rosetta happy and remove pot files in po/ (but leave stuff
218 # in po/domains/* untouched) and cp *.po into each domain dir
219 rm -f build/po/*.pot
220 rm -f po/*.pot
221
222 dh_installexamples -p$@ $(BLD)/docs/examples/*
223 dh_installman -p$@
224 dh_installcron -p$@
225 dh_installdocs -p$@
226 dh_installchangelogs -p$@
227 dh_strip -p$@
228 dh_compress -p$@
229 dh_fixperms -p$@
230 dh_makeshlibs -p$@ -m$(LIBAPTPKG_MAJOR) -V '$(LIBAPTPKG_PROVIDE)'
231 dh_installdeb -p$@
232 dh_shlibdeps -p$@ -l`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt
233 dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
234 dh_md5sums -p$@
235 dh_builddeb -p$@
236
237 libapt-pkg-dev: build debian/shlibs.local
238 dh_testdir -p$@
239 dh_testroot -p$@
240 dh_clean -p$@ -k
241 dh_installdirs -p$@
242 #
243 # libapt-pkg-dev install
244 #
245 cp -a $(BLD)/bin/libapt-pkg*.so debian/libapt-pkg-dev/usr/lib/
246 cp -a $(BLD)/bin/libapt-inst*.so debian/libapt-pkg-dev/usr/lib/
247 # ln -s libapt-pkg.so.$(LIBAPTPKG_MAJOR) debian/libapt-pkg-dev/usr/lib/libapt-pkg.so
248 cp $(BLD)/include/apt-pkg/*.h debian/libapt-pkg-dev/usr/include/apt-pkg/
249
250 dh_installdocs -p$@
251 # dh_installmenu -p$@
252 # dh_installinit -p$@
253 # dh_installcron -p$@
254 # dh_installman -p$@
255
256 dh_installchangelogs -p$@
257 dh_strip -p$@
258 dh_compress -p$@
259 dh_fixperms -p$@
260 # dh_suidregister -p$@
261 dh_installdeb -p$@
262 dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE) -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
263 dh_md5sums -p$@
264 dh_builddeb -p$@
265
266 apt-utils: build debian/shlibs.local
267 dh_testdir -p$@
268 dh_testroot -p$@
269 dh_clean -p$@ -k
270 dh_installdirs -p$@
271
272 # install the shared libs
273 find $(BLD)/bin/ -type f -name "libapt-inst*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
274 find $(BLD)/bin/ -type l -name "libapt-inst*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
275
276 cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
277 dh_installdocs -p$@
278 dh_installexamples -p$@
279
280 # Install the man pages..
281 dh_installman -p$@
282
283 dh_installchangelogs -p$@
284 dh_strip -p$@
285 dh_compress -p$@
286 dh_fixperms -p$@
287 dh_makeshlibs -m$(LIBAPTINST_MAJOR) -V '$(LIBAPTINST_PROVIDE)' -p$@
288 dh_installdeb -p$@
289 dh_shlibdeps -p$@ -l`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt-utils
290 dh_gencontrol -p$@ -u -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
291 dh_md5sums -p$@
292 dh_builddeb -p$@
293
294 source diff:
295 @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
296
297 # Update from CVS
298 l33ch: really-clean
299 cvs update
300 buildlib/mkChangeLog
301
302 # Update from CVS and then configure for build
303 super-l33ch: l33ch Makefile.in
304
305 configure:
306 $(MAKE) configure
307
308 l33ch-stamp: super-l33ch
309 touch $@
310
311 really-clean: clean
312 -find -name Makefile.in -print0 | xargs -0r rm -f
313 find -name ChangeLog | xargs rm -f
314 rm -f l33ch-stamp
315
316 binary: binary-indep binary-arch
317 .PHONY: build clean binary-indep binary-arch binary debian/shlibs.local
318
319
320 # Done by the uploader.
321 #cvs update..
322 #edit debian/changelog
323 # configure.in has the version automatically updated now.
324 # edit configure.in
325 # debian/rules cvs-build
326
327 CVS_BUILDDIR=apt-$(APT_DEBVER)
328 CVS_ROOT=$(shell cat CVS/Root)
329 CVS_MODULE=$(shell cat CVS/Repository)
330 cvs-build:
331 rm -rf debian/cvs-build
332 mkdir -p debian/cvs-build
333 (cd debian/cvs-build;cvs -d $(CVS_ROOT) export -r$(APT_CVSTAG) -d apt-$(APT_DEBVER) $(CVS_MODULE))
334 $(MAKE) -C debian/cvs-build/$(CVS_BUILDDIR) startup doc
335 (cd debian/cvs-build/$(CVS_BUILDDIR);$(DEB_BUILD_PROG))
336
337 cvs-mkul:
338 -mkdir -p ../upload-$(APT_DEBVER)
339 cp `find debian/cvs-build -maxdepth 1 -type f` ../upload-$(APT_DEBVER)
340
341 arch-build:
342 rm -rf debian/arch-build
343 mkdir -p debian/arch-build/apt-$(APT_DEBVER)
344 tar -c --exclude=arch-build --no-recursion -f - `bzr inventory` | (cd debian/arch-build/$(PKG)-$(APT_DEBVER);tar xf -)
345 $(MAKE) -C debian/arch-build/apt-$(APT_DEBVER) startup doc
346 (cd debian/arch-build/apt-$(APT_DEBVER); $(DEB_BUILD_PROG); dpkg-genchanges -S > ../apt_$(APT_DEBVER)_source.changes)