* apt-pkg/deb/dpkgpm.cc:
[ntk/apt.git] / debian / apt.postinst
1 #! /bin/sh
2
3 set -e
4
5 # summary of how this script can be called:
6 # * <postinst> `configure' <most-recently-configured-version>
7 # * <old-postinst> `abort-upgrade' <new version>
8 # * <conflictor's-postinst> `abort-remove' `in-favour' <package>
9 # <new-version>
10 # * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
11 # <failed-install-package> <version> `removing'
12 # <conflicting-package> <version>
13 # for details, see http://www.debian.org/doc/debian-policy/ or
14 # the debian-policy package
15
16 case "$1" in
17 configure)
18 if ! test -f /etc/apt/trusted.gpg; then
19 cp /usr/share/apt/ubuntu-archive.gpg /etc/apt/trusted.gpg
20 fi
21 ;;
22
23 abort-upgrade|abort-remove|abort-deconfigure)
24
25 ;;
26
27 *)
28 echo "postinst called with unknown argument \`$1'" >&2
29 exit 1
30 ;;
31 esac
32
33 # dh_installdeb will replace this with shell code automatically
34 # generated by other debhelper scripts.
35
36 #DEBHELPER#
37
38 exit 0
39
40