- Fix typo in tar error message (Closes: #191424)
[ntk/apt.git] / debian / changelog
1 apt (0.5.6) unstable; urgency=low
2
3 * Adam Heath <doogie@debian.org>
4 - Fix segfault when handling /etc/apt/preferences. Closes: #192409.
5 * Matt Zimmerman <mdz@debian.org>
6 - Clean up some string handling, patch from Peter Lundkvist
7 <p.lundkvist@telia.com> (Closes: #192225)
8 - Don't fall off the end of the buffer when comparing versions.
9 Patch from Koblinger Egmont <egmont@uhulinux.hu> (Closes: #194327)
10 - Minor fixes to apt-ftparchive(1) (Closes: #118156)
11 - Fix typo in apt-ftparchive help text (Closes: #119072)
12 - More typos in apt-ftparchive help text (Closes: #190936)
13 - Update config.guess, config.sub to latest versions
14 - Modify the description for apt-utils to reflect the fact that it is not
15 (any longer) infrequently used (Closes: #138045)
16 - Make setup script for dselect method more explicit about
17 overwriting sources.list (Closes: #151727)
18 - Fix typo in apt-cache(8) (Closes: #161243)
19 - Remove duplicate 'showpkg' from synopsis on apt-cache(8)
20 (Closes: #175611)
21 - Document in apt-get(8) the meaning of the '*' in ShowList, which is that
22 the package is being purged (Closes: #182369)
23 - Fix extra "/" character in apt.conf(5) (Closes: #185545)
24 - Fix typo in tar error message (Closes: #191424)
25
26 --
27
28 apt (0.5.5.1) unstable; urgency=low
29
30 * Move the target of the example docs from doc to binary. Closes:
31 #192331
32 * Fix api breakage that broke apt-ftparchive and apt-cache dumpavail, by
33 backing out change that incorretly attempted to handle Package sections
34 larger than 32k. Closes: #192373
35 * Fix never-ending loop with apt-get install -V. Closes: #192355.
36
37 -- Adam Heath <doogie@debian.org> Mon, 19 May 2003 12:30:16 -0500
38
39 apt (0.5.5) unstable; urgency=low
40
41 * New deb version compare function, that has no integer limits, and
42 supports pre-versions using ~. Code ported from dpkg.
43 * Fix handling of [!arch] for build-dependencies. Closes: #88798, #149595
44 * Fix handling of build-deps on unknown packages. Closes: #88664, #153307
45 * "apt-get --arch-only build-dep" to install only architecture-
46 dependent build dependencies. Bump minor shared lib number to reflect
47 small change in BuildDepend API.
48 * APT::Build-Essential configuration option (defaults to "build-essential")
49 so that "apt-get build-dep" will ensure build essential packages are
50 installed prior to installing other build-dependencies. Closes: #148879
51 * LD_LIBRARY_PATH thing. Closes: #109430, #147529
52 * /usr/doc reference in postinst. Closes: #126189
53 * Doc updates. Closes: #120689
54 * Possible apt-cache segfault. Closes: #120311, #118431, #117915, #135295,
55 #131062, #136749
56 * Print special message for EAI_AGAIN. Closes: #131397
57 * libapt-pkg-dev needs to bring in the apt-inst library if linking
58 is to work. Closes: #133943
59 * Typos, Doc Stuff. Closes: #132772, #129970, #123642, #114892, #113786,
60 #109591, #105920, #103678, #139752, #138186, #138054, #138050,
61 #139994, #142955, #151654, #151834, #147611, #154268, #173971
62 * Fix possibility for tag file parsing to fail in some unlikely situations.
63 Closes: #139328
64 * Use std C++ names for some header files. Closes: #128741
65 * Do not check for free space if --no-download. Closes: #117856
66 * Actually implement or group handling for 'upgrade'. Closes: #133950
67 * "Internal Error, Couldn't configure pre-depend" is not actually an
68 internal error, it is a packaging error and now it says so, and
69 pinpoints the problem dependency. Closes: #155621
70 * Allows failure to write to a pipe for post-invoke stuff. Closes: #89830
71 * Use usr/share/doc for dhelp. Closes: #115701
72 * --print-uris works with 'update'. Closes: #57070
73 * Options Dpkg::MaxArgs,Dpkg::MaxArgBytes to allow a much longer dpkg
74 command line.
75 * Fixed 2 little OR group bugs, thanks to Yann Dirson. Closes: #143995,
76 #142298
77 * Allow an uninstalled package to be marked for removal on an install
78 line (meaning not to automatically install it), also fix some dodgy
79 handling of protected packages. Closes: #92287, #116011
80 * Fix errant prefix matching in version selection. Closes: #105968
81 * Ensure that all files needed to run APT as a user are readable and
82 ignore roots umask for these files. Closes: #108801
83 * Support larger config spaces. Closes: #111914
84 * 'apt-get update' no longer does 'Building Dependency Tree'.
85 * When matching regexs allways print a message. Change regex activation
86 charset. Closes: #147817
87 * Don't die if lines in sources.list are too long. Closes: #146846
88 * Show file name on apt-extracttemplate error messges. Closes: #151835
89 * i18n gettext stuff, based on work from Michael Piefel: Closes: #95933
90 * Some highly unlikely memory faults. Closes: #155842
91 * C++ stuff for G++3.2. Closes: #162617, #165515,
92 * apt-config dumps sends to stdout not stderr now. Closes: #146294
93 * Fix segfault in FindAny when /i is used, and there is no default.
94 Closes: #165891
95 * Add s390x to archtable. Closese: #160992.
96 * Update config.sub/config.guess in cvs, and add support to debian/rules
97 to update them from /usr/share/misc if they exist. Closes: #155014
98 * Remove 'Sorry' from messages. Closes: #148824.
99 * Change wording of 'additional disk space usage' message. Closes:
100 #135021.
101 * apt-extracttemplates now prepends the package name when extracting
102 files. Closes: #132776
103 * Add -n synonym for --names-only for apt-cache. Closes: #130689
104 * Display both current version and new version in apt-get -s. Closes:
105 #92358
106 * Add an options and timeout config item to ssh/rsh. Closes: #90654
107 * libapt-pkg-dev now depends on apt-utils. Closes: #133942.
108 * Change verbose logging output of apt-ftparchive to go to stderr,
109 instead of stdout. Also, errors that occur no longer go to stdout,
110 but stderr. Closes: #161592
111 * Test for timegm in configure. Closes: #165516.
112 * s/st_mtime/mtime/ on our local stat structure in apt-ftparchive, to
113 support compliation on platforms where st_mtime is a macro. Closes:
114 #165518
115 * Check the currently mounted cdrom, to see if it's the one we are
116 interested in. Closes: #154602
117 * Refer to reportbug instead of bug in the man pages. Closes: #173745
118 * Link apt-inst to apt-pkg. Closes: #175055
119 * New apt_preferences man page from Thomas Hood, Susan Kleinmann,
120 and others.
121 * Fix > 300 col screen segfault. Closes: #176052
122 * Rebuild with gcc-3.2. Closes: #177752, #178008.
123 * Fix build-dep handling of | dependencies.
124 Closes: #98640, #145997, #158896, #172901
125 * Double default value of APT::Cache-Limit, until such time as it
126 can be made more dynamic. Closes: #178623.
127 * Report uris with '.gz' when there are errors. Closes: #178435.
128 * When installing build-deps, make sure the new version will
129 satisfy build requirements. Closes: #178121
130 * Split offline and guide documentation into apt-doc. This was done so
131 that binary-arch builds do not require documention deps. Note, that
132 apt-doc is not installed on upgrades.
133 * Use doc-base, instead of dhelp directly. Closes: #110389
134 * Change http message 'Waiting for file' to 'Waiting for headers'.
135 Closes: #178537
136 * Remove trailing lines on package lists in apt-get. Closes: #178736.
137 * Fix origin pins for file:// uris. Closes: #189014.
138 * Apply typo and syntax patch from bug to apt-cache.8.sgml. Closes:
139 #155194
140 * s/dpkg-preconfig/dpkg-preconfigure/ in examples/configure-index.
141 Closes: #153734.
142 * Fix some typos in the apt-get manual. Closes: #163932.
143 * Apply patch from bug, to change frozen to testing, and then do it
144 everywhere else. Closes: #165085.
145 * Update es.po. Closes: #183111.
146 * Add pt_BR translation of apt_preferences(5). Also, build fr manpages.
147 Closes: #183904.
148 * Add a vcg command to apt-cache, similiar to dotty. Closes: #150512.
149 * Add option to apt-get to show versions of packages being
150 upgraded/installed.
151 * Be quiet in apt.post{inst,rm}. Closes: #70685.
152 * apt-get now prints out suggested and recommended packages. Closes:
153 #54982.
154 * Insert some newlines in the cdrom change media message. Closes:
155 #154601.
156 * Add a rdepends command to apt-cache. Closes: #159864.
157 * When building the dpkg command line, allow for 8192 chars to be used,
158 instead of only 1024.
159 * APT::Immediate-Configure had inverted semantics(false meant it was
160 enabled). Closes: #173619.
161 * Fix status file parser so that if a record is larger than 32k, the
162 buffer size will be doubled, and the read attempted again. Closes:
163 #174945.
164
165 -- Adam Heath <doogie@debian.org> Sun, 27 Apr 2003 01:23:12 -0500
166
167 apt (0.5.4) unstable; urgency=low
168
169 * M68k config.guess patch. Closes: #88913
170 * Bi-yearly test on OpenBSD and Solaris
171 * Doc updates. Closes: #89121, #89854, #99671, #98353, #95823, #93057,
172 #97520, #102867, #101071, #102421, #101565, #98272, #106914,
173 #105606, #105377
174 * Various cosmetic code updates. Closes: #89066, #89066, #89152
175 * Add "pre-auto" as an option for DSelect::Clean (run autoclean after
176 update).
177 * More patches from Alfredo for Vendors and more SHA-1 stuff
178 * Fix for AJ's 'desire to remove perl-5.005' and possibly other
179 similar situations. Closes: #56708, #59432
180 * no_proxy and ftp. Closes: #89671
181 * Philippe Batailler's man page patches.
182 * Fix for display bug. Closes: #92033, #93652, #98468
183 * Use more than 16bits for the dep ID. Some people ran out..
184 Closes: #103020, #97809, #102951, #99974, #107362, #107395, #107362,
185 #106911, #107395, #108968
186 * Reordered some things to make dante and FTP happier. Closes: #92757
187 * James R. Van Zandt's guide.sgml updates. Closes: #90027
188 * apt-ftparchive copes with no uncompressed package files + contents.
189 * French man pages from philippe batailler - well sort of. They
190 don't build yet..
191 * run-parts. Closes: #94286
192 * 'apt-cache policy' preferences debug tool.
193 * Whatever. Closes: #89762
194 * libstdc++ and HURD. Closes: #92025
195 * More apt-utils verbage. Closes: #86954
196 * Fliped comparision operator. Closes: #94618
197 * Used the right copyright file. Closes: #65691
198 * Randolph's G++3 patches.
199 * Fixed no_proxy tokanizing. Closes: #100046
200 * Strip Config-Version when copying status to available. Closes: #97520
201 * Segfault with missing source files. Closes: #100325
202 * EINTR check. Closes: #102293
203 * Various changes to the locking metholodgy for --print-uris.
204 Closes: #100590
205 * Lame LD_LIBRARY_PATH thing. Closes: #98928
206 * apt-cache search searchs provide names too now. Closes: #98695
207 * Checksum and long lines problem. Closes: #106591
208 * .aptignr and empty files are just a warning. Closes: #97364
209
210 -- Jason Gunthorpe <jgg@debian.org> Sat, 18 Aug 2001 17:21:59 -0500
211
212 apt (0.5.3) unstable; urgency=low
213
214 * JoeyH's dpkg::preconfig not working. Closes: #88675
215 * Fixed apt override disparity
216 * Alfredo's SHA-1 and related patches
217
218 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
219
220 apt (0.5.2) unstable; urgency=low
221
222 * Fixed mention of /usr/doc in the long description
223 * JoeyH's downgrade bug -- don't use 0.5.1
224 * Doc bug. Closes: #88538
225 * Fault in building release strings. Closes: #88533
226
227 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
228
229 apt (0.5.1) unstable; urgency=low
230
231 * Fixed #82894 again, or should be and.
232 * Process the option string right. Closes: #86921
233 * Don't eat the last command for pipes. Closes: #86923
234 * Ignore .* for configuration directory processing. Closes: #86923
235 * Alfredo's no_proxy patch
236 * Documentation fixes. Closes: #87091
237 * JoeyH's double slash bug. Closes: #87266
238 * Unintitialized buffer and apt-ftparchive contents generation.
239 Closes: #87612
240 * Build-deps on virtual packages. Closes: #87639
241 * Fixes glibc/libstdc++ symbol dependencies by including glibc and
242 libstdc++ version info in the library soname and in the package
243 provides. Closes: #87426
244 * Updated soname version to 0.3.2
245 * apt-extracttemplates moved from debconf into apt-utils
246 * s390 archtable entry. Closes: #88232
247 * Dan's segfault
248 * Some instances where the status file can source a package in a
249 non-sensical way. Closes: #87390
250 * Work better if there are duplicate sources.list entries.
251 * Fixed the resetting of Dir with "dir {};". Closes: #87323
252
253 -- Randolph Chung <tausq@debian.org> Sat, 3 Mar 2001 15:37:38 -0700
254
255 apt (0.5.0) unstable; urgency=low
256
257 * Fixed an obscure bug with missing final double new lines in
258 package files
259 * Changed the apt-cdrom index copy routine to use the new section
260 rewriter
261 * Added a package file sorter, apt-sortpkgs
262 * Parse obsolete Optional dependencies.
263 * Added Ben's rsh method. Closes: #57794
264 * Added IPv6 FTP support and better DNS rotation support.
265 * Include the server IP in error messages when using a DNS rotation.
266 Closes: #64895
267 * Made most of the byte counters into doubles to prevent 32bit overflow.
268 Closes: #65349
269 * HTTP Authorization. Closes: #61158
270 * Ability to parse and return source index build depends from Randolph.
271 * new 'apt-get build-dep' command from Randolph. Closes: #63982
272 * Added apt-ftparchive the all dancing all singing FTP archive
273 maintinance program
274 * Allow version specifications with =1.2.4-3 and /2.2 or /stable postfixes
275 in apt-get.
276 * Removed useless internal cruft including the xstatus file.
277 * Fixed config parser bugs. Closes: #67848, #71108
278 * Brain Damanged apt-get config options changed, does not change the command
279 line interface, except to allow --enable-* to undo a configuration
280 option:
281 No-Remove -> Remove
282 No-Download -> Download
283 No-Upgrade -> Upgrade
284 * Made this fix configable (DSelect::CheckDir) and default to disabled:
285 * No remove prompt if the archives dir has not changed. Closes: #55709
286 Because it is stupid in the case where no files were downloaded due to
287 a resumed-aborted install, or a full cache! Closes: #65952
288 * Obscure divide by zero problem. Closes: #64394
289 * Update sizetable for mips. Closes: #62288
290 * Fixed a bug with passive FTP connections
291 * Has sizetable entry for sparc64. Closes: #64869
292 * Escape special characters in the ::Label section of the cdroms.lst
293 * Created apt-utils and python-apt packages
294 * Due to the new policy engine, the available file may contain entries
295 from the status file. These are generated if the package is not obsolete
296 but the policy engine prohibits using the version from the package files.
297 They can be identified by the lack of a Filename field.
298 * The new policy engine. Closes: #66509, #66944, #45122, #45094, #40006,
299 #36223, #33468, #22551
300 * Fixed deb-src line for non-us. Closes: #71501, #71601
301 * Fixes for G++ 2.96, s/friend/friend class/
302 * Fixed mis doc of APT::Get::Fix-Missing. Closes: #69269
303 * Confirmed fix for missing new line problem. Closes: #69386
304 * Fixed up dhelp files. Closes: #71312
305 * Added some notes about dselect and offline usage. Closes: #66473, #38316
306 * Lock files on read only file systems are ignored w/ warning.
307 Closes: #61701
308 * apt-get update foo now gives an error! Closes: #42891
309 * Added test for shlibs on hurd. Closes: #71499
310 * Clarified apt-cache document. Closes: #71934
311 * DocBook SGML man pages and some improvements in the text..
312 * sigwinch thing. Closes: #72382
313 * Caching can be turned off by setting the cache file names blank.
314 * Ignores arches it does not know about when autocleaning. Closes: #72862
315 * New function in apt-config to return dirs, files, bools and integers.
316 * Fixed an odd litle bug in MarkInstall and fixed it up to handle
317 complex cases involving OR groups and provides.
318 68754 describes confusing messages which are the result of this..
319 Closes: #63149, #69394, #68754, #77683, #66806, #81486, #78712
320 * Speeling mistake and return code for the 'wicked' resolver error
321 Closes: #72621, #75226, #77464
322 * Solved unable to upgrade libc6 from potato to woody due to 3 package
323 libc6 dependency loop problem.
324 * Leading sources.list spaces. Closes: #76010
325 * Removed a possible infinite loop while processing installations.
326 * Man page updates. Closes: #75411, #75560, #64292, #78469
327 * ReduceSourceList bug. Closes: #76027
328 * --only-source option. Closes: #76320
329 * Typos. Closes: #77812, #77999
330 * Different status messages. Closes: #76652, #78353
331 * /etc/apt/apt.conf.d/ directory for Joey and Matt and pipe protocol 2
332 * OS detection an support for the new pseduo standard of os-arch for the
333 Architecture string. Also uses regexing.. Closes: #39227, #72349
334 * Various i18n stuff. Note that this still needs some i18n wizard
335 to do the last gettextization right. Closes: #62386
336 * Fixed a problem with some odd http servers/proxies that did not return
337 the content size in the header. Closes: #79878, #44379
338 * Little acquire bugs. Closes: #77029, #55820
339 * _POSIX_THREADS may not be defined to anything, just defined..
340 Closes: #78996
341 * Spelling of Ignore-Hold correctly. Closes: #78042
342 * Unlock the dpkg db if in download only mode. Closes: #84851
343 * Brendan O'Dea's dselect admindir stuff. Closes: #62811
344 * Patch from BenC. Closes: #80810
345 * Single output of some names in lists. Closes: #80498, #43286
346 * Nice message for people who can't read syserror output. Closes: #84734
347 * OR search function. Closes: #82894
348 * User's guide updates. Closes: #82469
349 * The AJ/JoeyH var/state to var/lib transition patch. Closes: #59094
350 * Various CD bugs, again thanks to Greenbush
351 Closes: #80946, #76547, #71810, #70049, #69482
352 * Using potato debhelper. Closes: #57977
353 * I cannot self-terminate. Closes: #74928
354
355 -- Jason Gunthorpe <jgg@debian.org> Wed, 21 Feb 2001 00:39:15 -0500
356
357 apt (0.3.19) frozen unstable; urgency=low
358
359 * Updates to apt-cdrom to support integrated non-us nicely, thanks to
360 Paul Wade.
361 * Fixed that apt-get/cdrom deadlock thing. Closes: #59853, #62945, #61976
362 * Fixed hardcoded path. Closes: #59743
363 * Fixed Jay's relative path bug
364 * Allowed source only CDs. Closes: #58952
365 * Space check is supressed if --print-uris is given. Closes: #58965
366 * Clarified the documenation examples for non-us. Closes: #58646
367 * Typo in the package description. Closes: #60230
368 * Man Page typo. Closes: #60347
369 * Typo in Algorithms.cc. Closes: #63577
370 * Evil dotty function in apt-cache for generating dependency graphs
371 with the as-yet-unpackaged GraphVis.
372 * Appears to have been fixed in Janurary.. Closes: #57981
373 * New config.guess/sub for the new archs. Closes: #60874
374 * Fixed error reporting for certain kinds of resolution failures.
375 Closes: #61327
376 * Made autoclean respect 'q' settings. Closes: #63023
377 * Fixed up the example sources.list. Closes: #63676
378 * Added DPkg::FlushSTDIN to control the flushing of stdin before
379 forking dpkg. Closes: #63991
380
381 -- Ben Gertzfield <che@debian.org> Fri, 12 May 2000 21:10:54 -0700
382
383 apt (0.3.18) frozen unstable; urgency=low
384
385 * Changes in the postinst script. Closes: #56855, #57237
386 * Fixed bashism. Closes: #57216, #57335
387 * Doc updates. Closes: #57772, #57069, #57331, #57833, #57896
388
389 -- Ben Gertzfield <che@debian.org> Sun, 13 Feb 2000 01:52:31 -0800
390
391 apt (0.3.17) unstable; urgency=low
392
393 * RFC 2732 usage for CDROM URIs and fixes to apt-cdrom
394 * Fixed the configuration parser to not blow up if ; is in the config
395 string
396 * Applied visual patch to dselect install script . Closes #55214
397 * Included the configure-index example
398 * Minimal CD swaps
399 * Library soname has increased
400 * Fixed default sources.list to have correct URLs for potato when it
401 becomes stable
402 * Added a message about erasing sources.list to dselect setup script
403 Closes: #55755
404 * No remove prompt if the archives dir has not changed. Closes: #55709
405 * Fixed inclusion of 2nd sample config file. Closes: #55374
406 * Made file mtimes of 0 not confuse the methods If-Modifed-Since check.
407 Closes: #55991
408
409 -- Ben Gertzfield <che@debian.org> Mon, 31 Jan 2000 12:12:40 -0800
410
411 apt (0.3.16) unstable; urgency=low
412
413 * Made --no-download work. Closes: #52993
414 * Now compiles on OpenBSD, Solaris and HP-UX
415 * Clarify segfault errors
416 * More debhelper fixes. Closes: #52662, #54566, #52090, #53531, #54769
417 * Fix for Joel's discovery of glibc removal behavoir.
418 * Fix for Ben Collins file: uri from slink upgrade.
419 * Fixed resume code in FTP. Closes: #54323
420 * Take more precautions to prevent the corruption Joey Hess saw.
421 * Fixed --no-list-cleanup
422 * RFC 2732 URI parsing ([] for hostnames).
423 * Typo in apt-cache man page. Closes: #54949
424
425 -- Ben Gertzfield <che@debian.org> Fri, 14 Jan 2000 08:04:15 -0800
426
427 apt (0.3.15) unstable; urgency=low
428
429 * Added DSelect::WaitAfterDownload Closes: #49549
430 * Fixed cast error in byteswap macro and supporting code. Closes: #50093
431 * Fixed buffer overflow for wide terminal sizes. Closes: #50295
432 * Made -s and clean not do anything. Closes: #50238
433 * Problem with Protected packages and the new OR code.
434 * /usr/share/doc stuff. Closes: #51017, #50228, #51141
435 * Remove doesn't require a package to be installable. Closes: #51175
436 * FTP proxy touch ups in the mabn page. Closes: #51315, #51314
437
438 -- Ben Gertzfield <che@debian.org> Sat, 4 Dec 1999 21:17:24 -0800
439
440 apt (0.3.14) unstable; urgency=low
441
442 * Fix Perl or group pre-depends thing Closes: #46091, #46096, #46233, #45901
443 * Fix handling of dpkg's conversions from < -> <= Closes: #46094, #47088
444 * Make unparsable priorities non-fatal Closes: #46266, #46267, #46293, #46298
445 * Fix handling of '/' for the dist name. Closes: #43830, #45640, #45692
446 * Fixed 'Method gave a blank filename' error from IMS queries onto CDs.
447 Closes: #45034, #45695, #46537
448 * Made OR group handling in the problem resolver more elaborate. Closes: #45646
449 * Added APT::Clean-Installed option. Closes: #45973
450 * Moves the free space check to after the calculated size is printed.
451 Closes: #46639, #47498
452 * mipsel arch Closes: #47614
453 * Beautified URI printing to not include passwords Closes: #46857
454 * Fixed little problem with --no-download Closes: #47557
455 * Tweaked Dselect 'update' script to re-gen the avail file even in the
456 event of a failure Closes: #47112
457 * Retries for source archives too Closes: #47529
458 * Unmounts CDROMs iff it mounted them Closes: #45299
459 * Checks for the partial directories before doing downloads Closes: #47392
460 * no_proxy environment variable (http only!) Closes: #43476
461 * apt-cache showsrc Closes: #45799
462 * De-Refs Single Pure virtual packages. Closes: #42437, #43555
463 * Regexs for install. Closes: #35304, #38835
464 * Dependency reports now show OR group relations
465 * Re-Install feature. Cloes: #46961, #37393, #38919
466 * Locks archive directory on clean (woops)
467 * Remove is not 'sticky'. Closes: #48392
468 * Slightly more accurate 'can not find package' message. Closes: #48311
469 * --trivial-only and --no-remove. Closes: #48518
470 * Increased the cache size. Closes: #47648
471 * Comment woopsie. Closes: #48789
472 * Removes existing links when linking sources. Closes: #48775
473 * Problem resolver does not install all virtual packages. Closes: #48591, #49252
474 * Clearer usage message about 'source' Closes: #48858
475 * Immediate configure internal error Closes: #49062, #48884
476
477 -- Ben Gertzfield <che@debian.org> Sun, 7 Nov 1999 20:21:25 -0800
478
479 apt (0.3.13) unstable; urgency=low
480
481 * Fix timestamp miss in FTP. Closes: #44363
482 * Fix sorting of Kept packages. Closes: #44377
483 * Fix Segfault for dselect-upgrade. Closes: #44436
484 * Fix handling of '/' for the dist name. Closes #43830
485 * Added APT::Get::Diff-Only and Tar-Only options. Closes #44384
486 * Add commented-out deb-src URI to default sources.list file.
487
488 -- Ben Gertzfield <che@debian.org> Sun, 19 Sep 1999 18:54:20 -0700
489
490 apt (0.3.12) unstable; urgency=low
491
492 * Fix for typo in the dhelp index. Closes: #40377
493 * Multiple media swap support
494 * Purge support. Closes: #33291, #40694
495 * Better handling of - remove notation. Closes: #41024
496 * Purge support. Closes: #33291, #40694
497 * Error code on failed update. Closes: #41053
498 * apt-cdrom adds entries for source directories. Closes: #41231
499 * Sorts the output of any list. Closes: #41107
500 * Fixes the looping problem. Closes: #41784, #42414, #44022
501 * Fixes the CRC mechanism to lowercase all strings. Closes: #41839
502 * More checks to keep the display sane. Particularly when fail-over is
503 used with local mirrors and CD-Roms. Closes: #42127, #43130, #43668
504 * PThread lockup problem on certain sparc/m68k. Closes: #40628
505 * apt-cdrom understands .gz Package files too. Closes: #42779
506 * Spelling error in dselect method description. Closes: #43251
507 * Added security to the default source list. Closes: #43356
508
509 -- Ben Gertzfield <che@debian.org> Fri, 3 Sep 1999 09:04:28 -0700
510
511 apt (0.3.11) unstable; urgency=low
512
513 * Fix for mis-parsed file: URIs. Closes: #40373, #40366, #40230
514 * Fix for properly upgrading the system from perl 5.004 to 5.005
515
516 -- Ben Gertzfield <che@debian.org> Mon, 28 Jun 1999 21:06:44 -0700
517
518 apt (0.3.9) unstable; urgency=low
519
520 * Spelling error in cachefile.cc. Closes: #39885
521 * Trailing slash in dselect install if you try to use the
522 default config file. Closes: #40011
523 * Simulate works for autoclean. Closes: #39141
524 * Fixed spelling errors. Closes: #39673
525 * Changed url parsing a bit. Closes: #40070, #40069
526 * Version 0.3.8 will be for slink/hamm (GNU libc 2).
527
528 -- Ben Gertzfield <che@debian.org> Thu, 24 Jun 1999 18:02:52 -0700
529
530 apt (0.3.7) unstable; urgency=low
531
532 * Fixed missing text in the apt-get(8) page. Closes: #37596
533 * Made --simulate and friends work with apt-get source. Closes: #37597, #37656
534 * Fixed inclusion of man pages in the -doc/-dev package. Closes: #37633, #38651
535 * Fixed handling of the -q option with not-entirely integer arguments
536 Closes: #37499
537 * Man page typo Closes: #37762
538 * Fixed parsing of the Source: line. Closes: #37679
539 * Dpkg/dpkg-hurd source bug. Closes: #38004, #38032
540 * Added a check for an empty cache directory. Closes: #37963
541 * Return a failure code if -d is given and packages fail to download.
542 Closes: #38127
543 * Arranged for an ftp proxy specifing an http server to work. See the
544 important note in the sources.list man page.
545 * Accounted for resumed files in the cps calculation. Closes: #36787
546 * Deal with duplicate same version different packages. Closes: #30237
547 * Added --no-download. Closes: #38095
548 * Order of apt-cdrom dist detection. Closes: #38139
549 * Fix apt-cdrom chop handling and missing lines. Closes: #37276
550 * IPv6 http support
551 * Suggests dpkg-dev for apt-get source. Closes: #38158
552 * Fixed typo in apt-get help. Closes: #38712
553 * Improved the error message in the case of broken held package. Closes: #38777
554 * Fixed handling of MD5 failures
555 * Documented list notation Closes: #39008
556 * Change the 'b' to 'B'. Closes: #39007
557
558 -- Ben Gertzfield <che@debian.org> Sun, 20 Jun 1999 18:36:20 -0700
559
560 apt (0.3.6) unstable; urgency=low
561
562 * Note that 0.3.5 never made it out the door..
563 * Fix for apt-cdrom and unusual disk label locations. Closes: #35571
564 * Made APT print numbers in decimal. Closes: #35617, #37319
565 * Buffer munching fix for FTP. Closes: #35868
566 * Typo in sample config file. Closes: #35907
567 * Fixed whitespace in version compares. Closes: #35968, #36283, #37051
568 * Changed installed size counter to only count unpacked packages.
569 Closes: #36201
570 * apt-get source support. Closes: #23934, #27190
571 * Renames .debs that fail MD5 checking, provides automatic corruption
572 recovery. Closes: #35931
573 * Fixed autoconf verison. Closes: #37305
574 * Random Segfaulting. Closes: #37312, #37530
575 * Fixed apt-cache man page. Closes: #36904
576 * Added a newline to apt-cache showpkg. Closes: #36903
577
578 -- Ben Gertzfield <che@debian.org> Wed, 12 May 1999 09:18:49 -0700
579
580 apt (0.3.4) unstable; urgency=low
581
582 * Release for Ben while he is out of town.
583 * Checked the size of partial files. Closes: #33705
584 * apt-get should not print progress on non-tty. Closes: #34944
585 * s/guide.text.gz/users-guide.txt.gz/ debian/control: Closes: #35207
586 * Applied cdrom patches from Torsten. Closes: #35140, #35141
587 * smbmounted cdrom fix. Closes: #35470
588 * Changed ie to eg. Closes: #35196
589
590 -- Adam Heath <doogie@debian.org> Sun, 4 Apr 1999 18:26:44 -0500
591
592 apt (0.3.3) unstable; urgency=low
593
594 * Fixes bug with file:/ URIs and multi-CD handling. Closes: #34923
595
596 -- Ben Gertzfield <che@debian.org> Tue, 23 Mar 1999 12:15:44 -0800
597
598 apt (0.3.2) unstable; urgency=low
599
600 * Major release into unstable of v3
601 * These bugs have been fixed, explanations are in the bug system, read
602 the man pages as well..
603 Closes: #21113, #22507, #22675, #22836, #22892, #32883, #33006, #34121,
604 #23984, #24685, #24799, #25001, #25019, #34223, #34296, #34355,
605 #24021, #25022, #25026, #25104, #25176, #31557, #31691, #31853,
606 #25458, #26019, #26433, #26592, #26670, #27100, #27100, #27601,
607 #28184, #28391, #28778, #29293, #29351, #27841, #28172, #30260,
608 #29382, #29441, #29903, #29920, #29983, #30027, #30076, #30112,
609 #31009, #31155, #31381, #31883, #32140, #32395, #32584. #34465,
610 #30383, #30441, #30472, #30643, #30827, #30324, #36425, #34596
611
612 -- Ben Gertzfield <che@debian.org> Mon, 15 Mar 1999 19:14:25 -0800
613
614 apt (0.3.1) experimental; urgency=low
615
616 * Minor release of cvs version.
617 * Added virtual package libapt-pkgx.x
618
619 -- Mitch Blevins <mblevin@debian.org> Wed, 10 Mar 1999 07:52:44 -0500
620
621 apt (0.3.0) experimental; urgency=low
622
623 * New experimental version.
624
625 -- Ben Gertzfield <che@debian.org> Tue, 15 Dec 1998 12:53:21 -0800
626
627 apt (0.1.9) frozen unstable; urgency=low
628
629 * Return to the wacky numbering for when we build 0.1.8 for hamm
630 * Important bug related to APT on the Alpha fixed
631 * apt-get dist-upgrade problems fixed
632 * tiny patch for http method to fix an endless loop
633 * nice fix from /usr/doc/lintian/ to remove rpath nastiness from
634 libtool and add proper shared lib dependancies
635 * now dh_shlibdeps is called with LD_LIBRARY_PATH=debian/tmp/usr/lib
636 in case an old libpkg is installed while building APT to prevent
637 spurious dependancies
638
639 -- Ben Gertzfield <che@debian.org> Thu, 5 Nov 1998 17:43:25 -0800
640
641 apt (0.1.7) unstable; urgency=low
642
643 * New build with libstdc++2.9.
644 * Various fixes; read the Changelog.
645
646 -- Ben Gertzfield <che@debian.org> Thu, 15 Oct 1998 18:29:18 -0700
647
648 apt (0.1.6) unstable; urgency=low
649
650 * Various fixes in the FTP method for error checking. Fixes: #26188.
651 * Spelling corrections in dselect method. Fixes: #25884
652 * Fixes for compilation on alpha/ppc. Fixes: #25313, #26108.
653 * No more bo releases: we're using a normal numbering system now.
654
655 -- Ben Gertzfield <che@debian.org> Tue, 8 Sep 1998 19:27:13 -0700
656
657 apt (0.1.5) unstable; urgency=low
658
659 * Changed sources.list to point to 'unstable' by default, as
660 'frozen' no longer exists!
661
662 -- Ben Gertzfield <che@debian.org> Thu, 23 Jul 1998 22:00:18 -0700
663
664 apt (0.1.3) unstable; urgency=low
665
666 * New upstreamish version.
667 * ftp method rewritten in C. Removes dependancies on all perl/perl
668 related modules. This fixes many of the ftp method bugs.
669
670 -- Ben Gertzfield <che@debian.org> Thu, 16 Jul 1998 22:19:00 -0700
671
672 apt (0.1.1) unstable; urgency=low
673
674 * Release for unstable.
675
676 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:48:30 -0700
677
678 apt (0.1) unstable; urgency=low
679
680 * Kludge to fix problem in libnet-perl with illegal anonymous
681 FTP passwords.
682 * Moved to unstable; apt is in a useable state now.
683 * Fixed version numbering. From now on, numbering will be:
684 0.1 (no actual release) -> 0.1.0bo (release for libc5) ->
685 0.1.1 (release for unstable). Thanks, Manoj.
686
687 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:40:58 -0700
688
689 apt (0.0.17-1) experimental; urgency=low
690
691 * Fixed problem with libc6 version compare
692 * Scott's away for a while, so I'll be packaging apt for the time
693 being.
694
695 -- Ben Gertzfield <che@debian.org> Thu, 25 Jun 1998 19:02:03 -0700
696
697 apt (0.0.16-1) experimental; urgency=low
698
699 * Modifications to make apt-get more friendly when backgrounded.
700 * Updated documentation.
701 * Updates to graphic widgets
702
703 -- Scott K. Ellis <scott@debian.org> Mon, 8 Jun 1998 11:22:02 -0400
704
705 apt (0.0.15-0.2bo) experimental; urgency=low
706
707 * Bo compilation
708 * Bob Hilliards crash
709
710 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
711
712 apt (0.0.15-0.1bo) experimental; urgency=low
713
714 * Bo compilation
715 * libstdc++272 patch
716
717 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
718
719 apt (0.0.15) experimental; urgency=low
720
721 * Clean up source tarball (no user-visible changes)
722
723 -- Scott K. Ellis <scott@debian.org> Tue, 26 May 1998 12:23:53 -0400
724
725 apt (0.0.14) experimental; urgency=low
726
727 * Updates in ordering code to make sure certain upgrades work correctly.
728 * Made dselect/setup understand ftp as well as http
729
730 -- Scott K. Ellis <scott@debian.org> Wed, 20 May 1998 13:33:32 -0400
731
732 apt (0.0.13-bo1) experimental; urgency=low
733
734 * Bo compilation
735
736 -- Jason Gunthorpe <jgg@debian.org> Mon, 18 May 1998 15:10:49 -0600
737
738 apt (0.0.13) experimental; urgency=low
739
740 * Remove hardcoded egcc from debian/rules (#21575)
741 * Fixes for ordering logic when system has a number of unpacked
742 but unconfigured packages installed.
743 * Spelling fix in dselect install method (#22556)
744
745 -- Scott K. Ellis <scott@debian.org> Sun, 17 May 1998 20:08:33 -0400
746
747 apt (0.0.12) experimental; urgency=low
748
749 * Fixed problems with package cache corruption.
750 * Made to depend on libc6 >= 2.0.7pre1 due to timezone problems with
751 earlier versions.
752 * Interface and documentation improvements.
753
754 -- Scott K. Ellis <scott@debian.org> Sat, 16 May 1998 23:17:32 -0400
755
756 apt (0.0.11) experimental; urgency=low
757
758 * Change dependancies to pre-depends since breaking your packaging tools
759 in the middle of an installation isn't very good.
760 * Bug fixes to ftp method and general apt-get code
761
762 -- Scott K. Ellis <scott@debian.org> Fri, 15 May 1998 08:57:38 -0400
763
764 apt (0.0.10) experimental; urgency=low
765
766 * Run "dpkg --configure -a" after an aborted dselect install
767 * Fixed problem with install looping
768 * Support for authenticating proxys: (note this isn't terribly secure)
769 http_proxy="http://user:pass@firewall:port/"
770 * Substitute $ARCH in sources.list
771 * Fixes in the resumption code for ftp
772
773 -- Scott K. Ellis <scott@debian.org> Tue, 12 May 1998 09:14:41 -0400
774
775 apt (0.0.9) experimental; urgency=low
776
777 * Added ftp support.
778 * Various other less visible bug fixes.
779 * Fixed problem with segfault when apt-get invoked in a non-existant
780 directory (Bug #21863)
781 * Bumped policy to 2.4.1
782
783 -- Scott K. Ellis <scott@debian.org> Fri, 1 May 1998 09:18:19 -0400
784
785 apt (0.0.8) experimental; urgency=low
786
787 * Fixed generated available file (Bug #21836)
788 * Added download ETA (Bug #21774).
789 * Fixed hardcoded ARCH (Bug #21751).
790 * Fixed check on http_proxy (Bug #21795).
791 * Added download speed indicator.
792
793 -- Scott K. Ellis <scott@debian.org> Mon, 27 Apr 1998 10:58:32 -0400
794
795 apt (0.0.7) experimental; urgency=low
796
797 * Remove libdeity and apt from package for now, since only apt-get and
798 apt-cache are actually useful right now.
799 * Clean up handling of package installation errors.
800 * Added timeout to http transfers (#21269)
801 * Updated setup for dselect/apt method.
802 * Updated man pages
803 * Long options (added in 0.0.6)
804
805 -- Scott K. Ellis <scott@debian.org> Tue, 21 Apr 1998 09:06:49 -0400
806
807 apt (0.0.6) experimental; urgency=low
808
809 * Spelling changes.
810 * Revamped download status display.
811 * Call apt-get clean after successful install in dselect.
812 * Added "apt-get clean" which deletes package files from /var/cache/apt
813
814 -- Scott K. Ellis <scott@debian.org> Thu, 9 Apr 1998 15:13:59 -0400
815
816 apt (0.0.5) experimental; urgency=low
817
818 * Ignore signals while dpkg is running so we don't leave dpkg running in
819 the background (#20804)
820 * Check Packages as well as Packages.gz for file URIs (#20784)
821 * Spelling cleanup (#20800)
822 * Added -m option to permit upgrade to go on in the case of a bad mirror.
823 This option may result in incomplete upgrades when used with -f.
824
825 -- Scott K. Ellis <scott@debian.org> Tue, 7 Apr 1998 12:40:29 -0400
826
827 apt (0.0.4) experimental; urgency=low
828
829 * New usage guide.
830 * Various documentation updates and cleanup.
831 * Added '-f' option to apt-get attempt to fix broken dependancies.
832
833 -- Scott K. Ellis <scott@debian.org> Sat, 4 Apr 1998 14:36:00 -0500
834
835 apt (0.0.3) experimental; urgency=low
836
837 * Added a shlibs.local file to prevent apt from depending on itself.
838 * Updates to how apt-get handles bad states in installed packages.
839 * Updated rules to make sure build works from a freshly checked out source
840 archive. Building from CVS needs libtool/automake/autoconf, builds from
841 the distributed source package should have no such dependancy.
842
843 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 11:49:47 -0500
844
845 apt (0.0.2) unstable; urgency=low
846
847 * Updates to apt-get and http binding for dselect method (apt).
848 * Updating version number from 0.0.1, which was released only on IRC.
849
850 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 00:35:18 -0500
851
852 apt (0.0.1) unstable; urgency=low
853
854 * Initial Release.
855
856 -- Scott K. Ellis <scott@debian.org> Tue, 31 Mar 1998 12:49:28 -0500
857