Add support to debian/rules to update config.sub and co...
[ntk/apt.git] / debian / changelog
1 apt (0.5.5) unstable; urgency=low
2
3 * Fix handling of [!arch] for build-dependencies. Closes: #88798, #149595
4 * Fix handling of build-deps on unknown packages. Closes: #88664, #153307
5 * "apt-get --arch-only build-dep" to install only architecture-
6 dependent build dependencies. Bump minor shared lib number to reflect
7 small change in BuildDepend API.
8 * APT::Build-Essential configuration option (defaults to "build-essential")
9 so that "apt-get build-dep" will ensure build essential packages are
10 installed prior to installing other build-dependencies. Closes: #148879
11 * LD_LIBRARY_PATH thing. Closes: #109430, #147529
12 * /usr/doc reference in postinst. Closes: #126189
13 * Doc updates. Closes: #120689
14 * Possible apt-cache segfault. Closes: #120311, #118431, #117915, #135295,
15 #131062, #136749
16 * Print special message for EAI_AGAIN. Closes: #131397
17 * libapt-pkg-dev needs to bring in the apt-inst library if linking
18 is to work. Closes: #133943
19 * Typos, Doc Stuff. Closes: #132772, #129970, #123642, #114892, #113786,
20 #109591, #105920, #103678, #139752, #138186, #138054, #138050,
21 #139994, #142955, #151654, #151834, #147611, #154268
22 * Fix possibility for tag file parsing to fail in some unlikely situations.
23 Closes: #139328
24 * Use std C++ names for some header files. Closes: #128741
25 * Do not check for free space if --no-download. Closes: #117856
26 * Actually implement or group handling for 'upgrade'. Closes: #133950
27 * "Internal Error, Couldn't configure pre-depend" is not actually an
28 internal error, it is a packaging error and now it says so, and
29 pinpoints the problem dependency. Closes: #155621
30 * Allows failure to write to a pipe for post-invoke stuff. Closes: #89830
31 * Use usr/share/doc for dhelp. Closes: #115701
32 * --print-uris works with 'update'. Closes: #57070
33 * Options Dpkg::MaxArgs,Dpkg::MaxArgBytes to allow a much longer dpkg
34 command line.
35 * Fixed 2 little OR group bugs, thanks to Yann Dirson. Closes: #143995,
36 #142298
37 * Allow an uninstalled package to be marked for removal on an install
38 line (meaning not to automatically install it), also fix some dodgy
39 handling of protected packages. Closes: #92287, #116011
40 * Fix errant prefix matching in version selection. Closes: #105968
41 * Ensure that all files needed to run APT as a user are readable and
42 ignore roots umask for these files. Closes: #108801
43 * Support larger config spaces. Closes: #111914
44 * 'apt-get update' no longer does 'Building Dependency Tree'.
45 * When matching regexs allways print a message. Change regex activation
46 charset. Closes: #147817
47 * Don't die if lines in sources.list are too long. Closes: #146846
48 * Show file name on apt-extracttemplate error messges. Closes: #151835
49 * i18n gettext stuff, based on work from Michael Piefel
50 * Some highly unlikely memory faults. Closes: #155842
51 * C++ stuff for G++3.2. Closes: #162617
52 * apt-config dumps sends to stdout not stderr now. Closes: #146294
53 * Fix segfault in FindAny when /i is used, and there is no default.
54 Closes: #165891
55 * Add s390x to archtable. Closese: #160992.
56 * Update config.sub/config.guess in cvs, and add support to debian/rules
57 to update them from /usr/share/misc if they exist. Closes: #155014
58
59 -- Jason Gunthorpe <jgg@debian.org> Sun, 15 Sep 2002 17:16:59 -0600
60
61 apt (0.5.4) unstable; urgency=low
62
63 * M68k config.guess patch. Closes: #88913
64 * Bi-yearly test on OpenBSD and Solaris
65 * Doc updates. Closes: #89121, #89854, #99671, #98353, #95823, #93057,
66 #97520, #102867, #101071, #102421, #101565, #98272, #106914,
67 #105606, #105377
68 * Various cosmetic code updates. Closes: #89066, #89066, #89152
69 * Add "pre-auto" as an option for DSelect::Clean (run autoclean after
70 update).
71 * More patches from Alfredo for Vendors and more SHA-1 stuff
72 * Fix for AJ's 'desire to remove perl-5.005' and possibly other
73 similar situations. Closes: #56708, #59432
74 * no_proxy and ftp. Closes: #89671
75 * Philippe Batailler's man page patches.
76 * Fix for display bug. Closes: #92033, #93652, #98468
77 * Use more than 16bits for the dep ID. Some people ran out..
78 Closes: #103020, #97809, #102951, #99974, #107362, #107395, #107362,
79 #106911, #107395, #108968
80 * Reordered some things to make dante and FTP happier. Closes: #92757
81 * James R. Van Zandt's guide.sgml updates. Closes: #90027
82 * apt-ftparchive copes with no uncompressed package files + contents.
83 * French man pages from philippe batailler - well sort of. They
84 don't build yet..
85 * run-parts. Closes: #94286
86 * 'apt-cache policy' preferences debug tool.
87 * Whatever. Closes: #89762
88 * libstdc++ and HURD. Closes: #92025
89 * More apt-utils verbage. Closes: #86954
90 * Fliped comparision operator. Closes: #94618
91 * Used the right copyright file. Closes: #65691
92 * Randolph's G++3 patches.
93 * Fixed no_proxy tokanizing. Closes: #100046
94 * Strip Config-Version when copying status to available. Closes: #97520
95 * Segfault with missing source files. Closes: #100325
96 * EINTR check. Closes: #102293
97 * Various changes to the locking metholodgy for --print-uris.
98 Closes: #100590
99 * Lame LD_LIBRARY_PATH thing. Closes: #98928
100 * apt-cache search searchs provide names too now. Closes: #98695
101 * Checksum and long lines problem. Closes: #106591
102 * .aptignr and empty files are just a warning. Closes: #97364
103
104 -- Jason Gunthorpe <jgg@debian.org> Sat, 18 Aug 2001 17:21:59 -0500
105
106 apt (0.5.3) unstable; urgency=low
107
108 * JoeyH's dpkg::preconfig not working. Closes: #88675
109 * Fixed apt override disparity
110 * Alfredo's SHA-1 and related patches
111
112 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
113
114 apt (0.5.2) unstable; urgency=low
115
116 * Fixed mention of /usr/doc in the long description
117 * JoeyH's downgrade bug -- don't use 0.5.1
118 * Doc bug. Closes: #88538
119 * Fault in building release strings. Closes: #88533
120
121 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
122
123 apt (0.5.1) unstable; urgency=low
124
125 * Fixed #82894 again, or should be and.
126 * Process the option string right. Closes: #86921
127 * Don't eat the last command for pipes. Closes: #86923
128 * Ignore .* for configuration directory processing. Closes: #86923
129 * Alfredo's no_proxy patch
130 * Documentation fixes. Closes: #87091
131 * JoeyH's double slash bug. Closes: #87266
132 * Unintitialized buffer and apt-ftparchive contents generation.
133 Closes: #87612
134 * Build-deps on virtual packages. Closes: #87639
135 * Fixes glibc/libstdc++ symbol dependencies by including glibc and
136 libstdc++ version info in the library soname and in the package
137 provides. Closes: #87426
138 * Updated soname version to 0.3.2
139 * apt-extracttemplates moved from debconf into apt-utils
140 * s390 archtable entry. Closes: #88232
141 * Dan's segfault
142 * Some instances where the status file can source a package in a
143 non-sensical way. Closes: #87390
144 * Work better if there are duplicate sources.list entries.
145 * Fixed the resetting of Dir with "dir {};". Closes: #87323
146
147 -- Randolph Chung <tausq@debian.org> Sat, 3 Mar 2001 15:37:38 -0700
148
149 apt (0.5.0) unstable; urgency=low
150
151 * Fixed an obscure bug with missing final double new lines in
152 package files
153 * Changed the apt-cdrom index copy routine to use the new section
154 rewriter
155 * Added a package file sorter, apt-sortpkgs
156 * Parse obsolete Optional dependencies.
157 * Added Ben's rsh method. Closes: #57794
158 * Added IPv6 FTP support and better DNS rotation support.
159 * Include the server IP in error messages when using a DNS rotation.
160 Closes: #64895
161 * Made most of the byte counters into doubles to prevent 32bit overflow.
162 Closes: #65349
163 * HTTP Authorization. Closes: #61158
164 * Ability to parse and return source index build depends from Randolph.
165 * new 'apt-get build-dep' command from Randolph. Closes: #63982
166 * Added apt-ftparchive the all dancing all singing FTP archive
167 maintinance program
168 * Allow version specifications with =1.2.4-3 and /2.2 or /stable postfixes
169 in apt-get.
170 * Removed useless internal cruft including the xstatus file.
171 * Fixed config parser bugs. Closes: #67848, #71108
172 * Brain Damanged apt-get config options changed, does not change the command
173 line interface, except to allow --enable-* to undo a configuration
174 option:
175 No-Remove -> Remove
176 No-Download -> Download
177 No-Upgrade -> Upgrade
178 * Made this fix configable (DSelect::CheckDir) and default to disabled:
179 * No remove prompt if the archives dir has not changed. Closes: #55709
180 Because it is stupid in the case where no files were downloaded due to
181 a resumed-aborted install, or a full cache! Closes: #65952
182 * Obscure divide by zero problem. Closes: #64394
183 * Update sizetable for mips. Closes: #62288
184 * Fixed a bug with passive FTP connections
185 * Has sizetable entry for sparc64. Closes: #64869
186 * Escape special characters in the ::Label section of the cdroms.lst
187 * Created apt-utils and python-apt packages
188 * Due to the new policy engine, the available file may contain entries
189 from the status file. These are generated if the package is not obsolete
190 but the policy engine prohibits using the version from the package files.
191 They can be identified by the lack of a Filename field.
192 * The new policy engine. Closes: #66509, #66944, #45122, #45094, #40006,
193 #36223, #33468, #22551
194 * Fixed deb-src line for non-us. Closes: #71501, #71601
195 * Fixes for G++ 2.96, s/friend/friend class/
196 * Fixed mis doc of APT::Get::Fix-Missing. Closes: #69269
197 * Confirmed fix for missing new line problem. Closes: #69386
198 * Fixed up dhelp files. Closes: #71312
199 * Added some notes about dselect and offline usage. Closes: #66473, #38316
200 * Lock files on read only file systems are ignored w/ warning.
201 Closes: #61701
202 * apt-get update foo now gives an error! Closes: #42891
203 * Added test for shlibs on hurd. Closes: #71499
204 * Clarified apt-cache document. Closes: #71934
205 * DocBook SGML man pages and some improvements in the text..
206 * sigwinch thing. Closes: #72382
207 * Caching can be turned off by setting the cache file names blank.
208 * Ignores arches it does not know about when autocleaning. Closes: #72862
209 * New function in apt-config to return dirs, files, bools and integers.
210 * Fixed an odd litle bug in MarkInstall and fixed it up to handle
211 complex cases involving OR groups and provides.
212 68754 describes confusing messages which are the result of this..
213 Closes: #63149, #69394, #68754, #77683, #66806, #81486, #78712
214 * Speeling mistake and return code for the 'wicked' resolver error
215 Closes: #72621, #75226, #77464
216 * Solved unable to upgrade libc6 from potato to woody due to 3 package
217 libc6 dependency loop problem.
218 * Leading sources.list spaces. Closes: #76010
219 * Removed a possible infinite loop while processing installations.
220 * Man page updates. Closes: #75411, #75560, #64292, #78469
221 * ReduceSourceList bug. Closes: #76027
222 * --only-source option. Closes: #76320
223 * Typos. Closes: #77812, #77999
224 * Different status messages. Closes: #76652, #78353
225 * /etc/apt/apt.conf.d/ directory for Joey and Matt and pipe protocol 2
226 * OS detection an support for the new pseduo standard of os-arch for the
227 Architecture string. Also uses regexing.. Closes: #39227, #72349
228 * Various i18n stuff. Note that this still needs some i18n wizard
229 to do the last gettextization right. Closes: #62386
230 * Fixed a problem with some odd http servers/proxies that did not return
231 the content size in the header. Closes: #79878, #44379
232 * Little acquire bugs. Closes: #77029, #55820
233 * _POSIX_THREADS may not be defined to anything, just defined..
234 Closes: #78996
235 * Spelling of Ignore-Hold correctly. Closes: #78042
236 * Unlock the dpkg db if in download only mode. Closes: #84851
237 * Brendan O'Dea's dselect admindir stuff. Closes: #62811
238 * Patch from BenC. Closes: #80810
239 * Single output of some names in lists. Closes: #80498, #43286
240 * Nice message for people who can't read syserror output. Closes: #84734
241 * OR search function. Closes: #82894
242 * User's guide updates. Closes: #82469
243 * The AJ/JoeyH var/state to var/lib transition patch. Closes: #59094
244 * Various CD bugs, again thanks to Greenbush
245 Closes: #80946, #76547, #71810, #70049, #69482
246 * Using potato debhelper. Closes: #57977
247 * I cannot self-terminate. Closes: #74928
248
249 -- Jason Gunthorpe <jgg@debian.org> Wed, 21 Feb 2001 00:39:15 -0500
250
251 apt (0.3.19) frozen unstable; urgency=low
252
253 * Updates to apt-cdrom to support integrated non-us nicely, thanks to
254 Paul Wade.
255 * Fixed that apt-get/cdrom deadlock thing. Closes: #59853, #62945, #61976
256 * Fixed hardcoded path. Closes: #59743
257 * Fixed Jay's relative path bug
258 * Allowed source only CDs. Closes: #58952
259 * Space check is supressed if --print-uris is given. Closes: #58965
260 * Clarified the documenation examples for non-us. Closes: #58646
261 * Typo in the package description. Closes: #60230
262 * Man Page typo. Closes: #60347
263 * Typo in Algorithms.cc. Closes: #63577
264 * Evil dotty function in apt-cache for generating dependency graphs
265 with the as-yet-unpackaged GraphVis.
266 * Appears to have been fixed in Janurary.. Closes: #57981
267 * New config.guess/sub for the new archs. Closes: #60874
268 * Fixed error reporting for certain kinds of resolution failures.
269 Closes: #61327
270 * Made autoclean respect 'q' settings. Closes: #63023
271 * Fixed up the example sources.list. Closes: #63676
272 * Added DPkg::FlushSTDIN to control the flushing of stdin before
273 forking dpkg. Closes: #63991
274
275 -- Ben Gertzfield <che@debian.org> Fri, 12 May 2000 21:10:54 -0700
276
277 apt (0.3.18) frozen unstable; urgency=low
278
279 * Changes in the postinst script. Closes: #56855, #57237
280 * Fixed bashism. Closes: #57216, #57335
281 * Doc updates. Closes: #57772, #57069, #57331, #57833, #57896
282
283 -- Ben Gertzfield <che@debian.org> Sun, 13 Feb 2000 01:52:31 -0800
284
285 apt (0.3.17) unstable; urgency=low
286
287 * RFC 2732 usage for CDROM URIs and fixes to apt-cdrom
288 * Fixed the configuration parser to not blow up if ; is in the config
289 string
290 * Applied visual patch to dselect install script . Closes #55214
291 * Included the configure-index example
292 * Minimal CD swaps
293 * Library soname has increased
294 * Fixed default sources.list to have correct URLs for potato when it
295 becomes stable
296 * Added a message about erasing sources.list to dselect setup script
297 Closes: #55755
298 * No remove prompt if the archives dir has not changed. Closes: #55709
299 * Fixed inclusion of 2nd sample config file. Closes: #55374
300 * Made file mtimes of 0 not confuse the methods If-Modifed-Since check.
301 Closes: #55991
302
303 -- Ben Gertzfield <che@debian.org> Mon, 31 Jan 2000 12:12:40 -0800
304
305 apt (0.3.16) unstable; urgency=low
306
307 * Made --no-download work. Closes: #52993
308 * Now compiles on OpenBSD, Solaris and HP-UX
309 * Clarify segfault errors
310 * More debhelper fixes. Closes: #52662, #54566, #52090, #53531, #54769
311 * Fix for Joel's discovery of glibc removal behavoir.
312 * Fix for Ben Collins file: uri from slink upgrade.
313 * Fixed resume code in FTP. Closes: #54323
314 * Take more precautions to prevent the corruption Joey Hess saw.
315 * Fixed --no-list-cleanup
316 * RFC 2732 URI parsing ([] for hostnames).
317 * Typo in apt-cache man page. Closes: #54949
318
319 -- Ben Gertzfield <che@debian.org> Fri, 14 Jan 2000 08:04:15 -0800
320
321 apt (0.3.15) unstable; urgency=low
322
323 * Added DSelect::WaitAfterDownload Closes: #49549
324 * Fixed cast error in byteswap macro and supporting code. Closes: #50093
325 * Fixed buffer overflow for wide terminal sizes. Closes: #50295
326 * Made -s and clean not do anything. Closes: #50238
327 * Problem with Protected packages and the new OR code.
328 * /usr/share/doc stuff. Closes: #51017, #50228, #51141
329 * Remove doesn't require a package to be installable. Closes: #51175
330 * FTP proxy touch ups in the mabn page. Closes: #51315, #51314
331
332 -- Ben Gertzfield <che@debian.org> Sat, 4 Dec 1999 21:17:24 -0800
333
334 apt (0.3.14) unstable; urgency=low
335
336 * Fix Perl or group pre-depends thing Closes: #46091, #46096, #46233, #45901
337 * Fix handling of dpkg's conversions from < -> <= Closes: #46094, #47088
338 * Make unparsable priorities non-fatal Closes: #46266, #46267, #46293, #46298
339 * Fix handling of '/' for the dist name. Closes: #43830, #45640, #45692
340 * Fixed 'Method gave a blank filename' error from IMS queries onto CDs.
341 Closes: #45034, #45695, #46537
342 * Made OR group handling in the problem resolver more elaborate. Closes: #45646
343 * Added APT::Clean-Installed option. Closes: #45973
344 * Moves the free space check to after the calculated size is printed.
345 Closes: #46639, #47498
346 * mipsel arch Closes: #47614
347 * Beautified URI printing to not include passwords Closes: #46857
348 * Fixed little problem with --no-download Closes: #47557
349 * Tweaked Dselect 'update' script to re-gen the avail file even in the
350 event of a failure Closes: #47112
351 * Retries for source archives too Closes: #47529
352 * Unmounts CDROMs iff it mounted them Closes: #45299
353 * Checks for the partial directories before doing downloads Closes: #47392
354 * no_proxy environment variable (http only!) Closes: #43476
355 * apt-cache showsrc Closes: #45799
356 * De-Refs Single Pure virtual packages. Closes: #42437, #43555
357 * Regexs for install. Closes: #35304, #38835
358 * Dependency reports now show OR group relations
359 * Re-Install feature. Cloes: #46961, #37393, #38919
360 * Locks archive directory on clean (woops)
361 * Remove is not 'sticky'. Closes: #48392
362 * Slightly more accurate 'can not find package' message. Closes: #48311
363 * --trivial-only and --no-remove. Closes: #48518
364 * Increased the cache size. Closes: #47648
365 * Comment woopsie. Closes: #48789
366 * Removes existing links when linking sources. Closes: #48775
367 * Problem resolver does not install all virtual packages. Closes: #48591, #49252
368 * Clearer usage message about 'source' Closes: #48858
369 * Immediate configure internal error Closes: #49062, #48884
370
371 -- Ben Gertzfield <che@debian.org> Sun, 7 Nov 1999 20:21:25 -0800
372
373 apt (0.3.13) unstable; urgency=low
374
375 * Fix timestamp miss in FTP. Closes: #44363
376 * Fix sorting of Kept packages. Closes: #44377
377 * Fix Segfault for dselect-upgrade. Closes: #44436
378 * Fix handling of '/' for the dist name. Closes #43830
379 * Added APT::Get::Diff-Only and Tar-Only options. Closes #44384
380 * Add commented-out deb-src URI to default sources.list file.
381
382 -- Ben Gertzfield <che@debian.org> Sun, 19 Sep 1999 18:54:20 -0700
383
384 apt (0.3.12) unstable; urgency=low
385
386 * Fix for typo in the dhelp index. Closes: #40377
387 * Multiple media swap support
388 * Purge support. Closes: #33291, #40694
389 * Better handling of - remove notation. Closes: #41024
390 * Purge support. Closes: #33291, #40694
391 * Error code on failed update. Closes: #41053
392 * apt-cdrom adds entries for source directories. Closes: #41231
393 * Sorts the output of any list. Closes: #41107
394 * Fixes the looping problem. Closes: #41784, #42414, #44022
395 * Fixes the CRC mechanism to lowercase all strings. Closes: #41839
396 * More checks to keep the display sane. Particularly when fail-over is
397 used with local mirrors and CD-Roms. Closes: #42127, #43130, #43668
398 * PThread lockup problem on certain sparc/m68k. Closes: #40628
399 * apt-cdrom understands .gz Package files too. Closes: #42779
400 * Spelling error in dselect method description. Closes: #43251
401 * Added security to the default source list. Closes: #43356
402
403 -- Ben Gertzfield <che@debian.org> Fri, 3 Sep 1999 09:04:28 -0700
404
405 apt (0.3.11) unstable; urgency=low
406
407 * Fix for mis-parsed file: URIs. Closes: #40373, #40366, #40230
408 * Fix for properly upgrading the system from perl 5.004 to 5.005
409
410 -- Ben Gertzfield <che@debian.org> Mon, 28 Jun 1999 21:06:44 -0700
411
412 apt (0.3.9) unstable; urgency=low
413
414 * Spelling error in cachefile.cc. Closes: #39885
415 * Trailing slash in dselect install if you try to use the
416 default config file. Closes: #40011
417 * Simulate works for autoclean. Closes: #39141
418 * Fixed spelling errors. Closes: #39673
419 * Changed url parsing a bit. Closes: #40070, #40069
420 * Version 0.3.8 will be for slink/hamm (GNU libc 2).
421
422 -- Ben Gertzfield <che@debian.org> Thu, 24 Jun 1999 18:02:52 -0700
423
424 apt (0.3.7) unstable; urgency=low
425
426 * Fixed missing text in the apt-get(8) page. Closes: #37596
427 * Made --simulate and friends work with apt-get source. Closes: #37597, #37656
428 * Fixed inclusion of man pages in the -doc/-dev package. Closes: #37633, #38651
429 * Fixed handling of the -q option with not-entirely integer arguments
430 Closes: #37499
431 * Man page typo Closes: #37762
432 * Fixed parsing of the Source: line. Closes: #37679
433 * Dpkg/dpkg-hurd source bug. Closes: #38004, #38032
434 * Added a check for an empty cache directory. Closes: #37963
435 * Return a failure code if -d is given and packages fail to download.
436 Closes: #38127
437 * Arranged for an ftp proxy specifing an http server to work. See the
438 important note in the sources.list man page.
439 * Accounted for resumed files in the cps calculation. Closes: #36787
440 * Deal with duplicate same version different packages. Closes: #30237
441 * Added --no-download. Closes: #38095
442 * Order of apt-cdrom dist detection. Closes: #38139
443 * Fix apt-cdrom chop handling and missing lines. Closes: #37276
444 * IPv6 http support
445 * Suggests dpkg-dev for apt-get source. Closes: #38158
446 * Fixed typo in apt-get help. Closes: #38712
447 * Improved the error message in the case of broken held package. Closes: #38777
448 * Fixed handling of MD5 failures
449 * Documented list notation Closes: #39008
450 * Change the 'b' to 'B'. Closes: #39007
451
452 -- Ben Gertzfield <che@debian.org> Sun, 20 Jun 1999 18:36:20 -0700
453
454 apt (0.3.6) unstable; urgency=low
455
456 * Note that 0.3.5 never made it out the door..
457 * Fix for apt-cdrom and unusual disk label locations. Closes: #35571
458 * Made APT print numbers in decimal. Closes: #35617, #37319
459 * Buffer munching fix for FTP. Closes: #35868
460 * Typo in sample config file. Closes: #35907
461 * Fixed whitespace in version compares. Closes: #35968, #36283, #37051
462 * Changed installed size counter to only count unpacked packages.
463 Closes: #36201
464 * apt-get source support. Closes: #23934, #27190
465 * Renames .debs that fail MD5 checking, provides automatic corruption
466 recovery. Closes: #35931
467 * Fixed autoconf verison. Closes: #37305
468 * Random Segfaulting. Closes: #37312, #37530
469 * Fixed apt-cache man page. Closes: #36904
470 * Added a newline to apt-cache showpkg. Closes: #36903
471
472 -- Ben Gertzfield <che@debian.org> Wed, 12 May 1999 09:18:49 -0700
473
474 apt (0.3.4) unstable; urgency=low
475
476 * Release for Ben while he is out of town.
477 * Checked the size of partial files. Closes: #33705
478 * apt-get should not print progress on non-tty. Closes: #34944
479 * s/guide.text.gz/users-guide.txt.gz/ debian/control: Closes: #35207
480 * Applied cdrom patches from Torsten. Closes: #35140, #35141
481 * smbmounted cdrom fix. Closes: #35470
482 * Changed ie to eg. Closes: #35196
483
484 -- Adam Heath <doogie@debian.org> Sun, 4 Apr 1999 18:26:44 -0500
485
486 apt (0.3.3) unstable; urgency=low
487
488 * Fixes bug with file:/ URIs and multi-CD handling. Closes: #34923
489
490 -- Ben Gertzfield <che@debian.org> Tue, 23 Mar 1999 12:15:44 -0800
491
492 apt (0.3.2) unstable; urgency=low
493
494 * Major release into unstable of v3
495 * These bugs have been fixed, explanations are in the bug system, read
496 the man pages as well..
497 Closes: #21113, #22507, #22675, #22836, #22892, #32883, #33006, #34121,
498 #23984, #24685, #24799, #25001, #25019, #34223, #34296, #34355,
499 #24021, #25022, #25026, #25104, #25176, #31557, #31691, #31853,
500 #25458, #26019, #26433, #26592, #26670, #27100, #27100, #27601,
501 #28184, #28391, #28778, #29293, #29351, #27841, #28172, #30260,
502 #29382, #29441, #29903, #29920, #29983, #30027, #30076, #30112,
503 #31009, #31155, #31381, #31883, #32140, #32395, #32584. #34465,
504 #30383, #30441, #30472, #30643, #30827, #30324, #36425, #34596
505
506 -- Ben Gertzfield <che@debian.org> Mon, 15 Mar 1999 19:14:25 -0800
507
508 apt (0.3.1) experimental; urgency=low
509
510 * Minor release of cvs version.
511 * Added virtual package libapt-pkgx.x
512
513 -- Mitch Blevins <mblevin@debian.org> Wed, 10 Mar 1999 07:52:44 -0500
514
515 apt (0.3.0) experimental; urgency=low
516
517 * New experimental version.
518
519 -- Ben Gertzfield <che@debian.org> Tue, 15 Dec 1998 12:53:21 -0800
520
521 apt (0.1.9) frozen unstable; urgency=low
522
523 * Return to the wacky numbering for when we build 0.1.8 for hamm
524 * Important bug related to APT on the Alpha fixed
525 * apt-get dist-upgrade problems fixed
526 * tiny patch for http method to fix an endless loop
527 * nice fix from /usr/doc/lintian/ to remove rpath nastiness from
528 libtool and add proper shared lib dependancies
529 * now dh_shlibdeps is called with LD_LIBRARY_PATH=debian/tmp/usr/lib
530 in case an old libpkg is installed while building APT to prevent
531 spurious dependancies
532
533 -- Ben Gertzfield <che@debian.org> Thu, 5 Nov 1998 17:43:25 -0800
534
535 apt (0.1.7) unstable; urgency=low
536
537 * New build with libstdc++2.9.
538 * Various fixes; read the Changelog.
539
540 -- Ben Gertzfield <che@debian.org> Thu, 15 Oct 1998 18:29:18 -0700
541
542 apt (0.1.6) unstable; urgency=low
543
544 * Various fixes in the FTP method for error checking. Fixes: #26188.
545 * Spelling corrections in dselect method. Fixes: #25884
546 * Fixes for compilation on alpha/ppc. Fixes: #25313, #26108.
547 * No more bo releases: we're using a normal numbering system now.
548
549 -- Ben Gertzfield <che@debian.org> Tue, 8 Sep 1998 19:27:13 -0700
550
551 apt (0.1.5) unstable; urgency=low
552
553 * Changed sources.list to point to 'unstable' by default, as
554 'frozen' no longer exists!
555
556 -- Ben Gertzfield <che@debian.org> Thu, 23 Jul 1998 22:00:18 -0700
557
558 apt (0.1.3) unstable; urgency=low
559
560 * New upstreamish version.
561 * ftp method rewritten in C. Removes dependancies on all perl/perl
562 related modules. This fixes many of the ftp method bugs.
563
564 -- Ben Gertzfield <che@debian.org> Thu, 16 Jul 1998 22:19:00 -0700
565
566 apt (0.1.1) unstable; urgency=low
567
568 * Release for unstable.
569
570 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:48:30 -0700
571
572 apt (0.1) unstable; urgency=low
573
574 * Kludge to fix problem in libnet-perl with illegal anonymous
575 FTP passwords.
576 * Moved to unstable; apt is in a useable state now.
577 * Fixed version numbering. From now on, numbering will be:
578 0.1 (no actual release) -> 0.1.0bo (release for libc5) ->
579 0.1.1 (release for unstable). Thanks, Manoj.
580
581 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:40:58 -0700
582
583 apt (0.0.17-1) experimental; urgency=low
584
585 * Fixed problem with libc6 version compare
586 * Scott's away for a while, so I'll be packaging apt for the time
587 being.
588
589 -- Ben Gertzfield <che@debian.org> Thu, 25 Jun 1998 19:02:03 -0700
590
591 apt (0.0.16-1) experimental; urgency=low
592
593 * Modifications to make apt-get more friendly when backgrounded.
594 * Updated documentation.
595 * Updates to graphic widgets
596
597 -- Scott K. Ellis <scott@debian.org> Mon, 8 Jun 1998 11:22:02 -0400
598
599 apt (0.0.15-0.2bo) experimental; urgency=low
600
601 * Bo compilation
602 * Bob Hilliards crash
603
604 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
605
606 apt (0.0.15-0.1bo) experimental; urgency=low
607
608 * Bo compilation
609 * libstdc++272 patch
610
611 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
612
613 apt (0.0.15) experimental; urgency=low
614
615 * Clean up source tarball (no user-visible changes)
616
617 -- Scott K. Ellis <scott@debian.org> Tue, 26 May 1998 12:23:53 -0400
618
619 apt (0.0.14) experimental; urgency=low
620
621 * Updates in ordering code to make sure certain upgrades work correctly.
622 * Made dselect/setup understand ftp as well as http
623
624 -- Scott K. Ellis <scott@debian.org> Wed, 20 May 1998 13:33:32 -0400
625
626 apt (0.0.13-bo1) experimental; urgency=low
627
628 * Bo compilation
629
630 -- Jason Gunthorpe <jgg@debian.org> Mon, 18 May 1998 15:10:49 -0600
631
632 apt (0.0.13) experimental; urgency=low
633
634 * Remove hardcoded egcc from debian/rules (#21575)
635 * Fixes for ordering logic when system has a number of unpacked
636 but unconfigured packages installed.
637 * Spelling fix in dselect install method (#22556)
638
639 -- Scott K. Ellis <scott@debian.org> Sun, 17 May 1998 20:08:33 -0400
640
641 apt (0.0.12) experimental; urgency=low
642
643 * Fixed problems with package cache corruption.
644 * Made to depend on libc6 >= 2.0.7pre1 due to timezone problems with
645 earlier versions.
646 * Interface and documentation improvements.
647
648 -- Scott K. Ellis <scott@debian.org> Sat, 16 May 1998 23:17:32 -0400
649
650 apt (0.0.11) experimental; urgency=low
651
652 * Change dependancies to pre-depends since breaking your packaging tools
653 in the middle of an installation isn't very good.
654 * Bug fixes to ftp method and general apt-get code
655
656 -- Scott K. Ellis <scott@debian.org> Fri, 15 May 1998 08:57:38 -0400
657
658 apt (0.0.10) experimental; urgency=low
659
660 * Run "dpkg --configure -a" after an aborted dselect install
661 * Fixed problem with install looping
662 * Support for authenticating proxys: (note this isn't terribly secure)
663 http_proxy="http://user:pass@firewall:port/"
664 * Substitute $ARCH in sources.list
665 * Fixes in the resumption code for ftp
666
667 -- Scott K. Ellis <scott@debian.org> Tue, 12 May 1998 09:14:41 -0400
668
669 apt (0.0.9) experimental; urgency=low
670
671 * Added ftp support.
672 * Various other less visible bug fixes.
673 * Fixed problem with segfault when apt-get invoked in a non-existant
674 directory (Bug #21863)
675 * Bumped policy to 2.4.1
676
677 -- Scott K. Ellis <scott@debian.org> Fri, 1 May 1998 09:18:19 -0400
678
679 apt (0.0.8) experimental; urgency=low
680
681 * Fixed generated available file (Bug #21836)
682 * Added download ETA (Bug #21774).
683 * Fixed hardcoded ARCH (Bug #21751).
684 * Fixed check on http_proxy (Bug #21795).
685 * Added download speed indicator.
686
687 -- Scott K. Ellis <scott@debian.org> Mon, 27 Apr 1998 10:58:32 -0400
688
689 apt (0.0.7) experimental; urgency=low
690
691 * Remove libdeity and apt from package for now, since only apt-get and
692 apt-cache are actually useful right now.
693 * Clean up handling of package installation errors.
694 * Added timeout to http transfers (#21269)
695 * Updated setup for dselect/apt method.
696 * Updated man pages
697 * Long options (added in 0.0.6)
698
699 -- Scott K. Ellis <scott@debian.org> Tue, 21 Apr 1998 09:06:49 -0400
700
701 apt (0.0.6) experimental; urgency=low
702
703 * Spelling changes.
704 * Revamped download status display.
705 * Call apt-get clean after successful install in dselect.
706 * Added "apt-get clean" which deletes package files from /var/cache/apt
707
708 -- Scott K. Ellis <scott@debian.org> Thu, 9 Apr 1998 15:13:59 -0400
709
710 apt (0.0.5) experimental; urgency=low
711
712 * Ignore signals while dpkg is running so we don't leave dpkg running in
713 the background (#20804)
714 * Check Packages as well as Packages.gz for file URIs (#20784)
715 * Spelling cleanup (#20800)
716 * Added -m option to permit upgrade to go on in the case of a bad mirror.
717 This option may result in incomplete upgrades when used with -f.
718
719 -- Scott K. Ellis <scott@debian.org> Tue, 7 Apr 1998 12:40:29 -0400
720
721 apt (0.0.4) experimental; urgency=low
722
723 * New usage guide.
724 * Various documentation updates and cleanup.
725 * Added '-f' option to apt-get attempt to fix broken dependancies.
726
727 -- Scott K. Ellis <scott@debian.org> Sat, 4 Apr 1998 14:36:00 -0500
728
729 apt (0.0.3) experimental; urgency=low
730
731 * Added a shlibs.local file to prevent apt from depending on itself.
732 * Updates to how apt-get handles bad states in installed packages.
733 * Updated rules to make sure build works from a freshly checked out source
734 archive. Building from CVS needs libtool/automake/autoconf, builds from
735 the distributed source package should have no such dependancy.
736
737 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 11:49:47 -0500
738
739 apt (0.0.2) unstable; urgency=low
740
741 * Updates to apt-get and http binding for dselect method (apt).
742 * Updating version number from 0.0.1, which was released only on IRC.
743
744 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 00:35:18 -0500
745
746 apt (0.0.1) unstable; urgency=low
747
748 * Initial Release.
749
750 -- Scott K. Ellis <scott@debian.org> Tue, 31 Mar 1998 12:49:28 -0500
751