* merged latest fixes from debian-sid
[ntk/apt.git] / debian / apt.postinst
1 #! /bin/sh
2
3 set -e
4
5 # summary of how this script can be called:
6 # * <postinst> `configure' <most-recently-configured-version>
7 # * <old-postinst> `abort-upgrade' <new version>
8 # * <conflictor's-postinst> `abort-remove' `in-favour' <package>
9 # <new-version>
10 # * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
11 # <failed-install-package> <version> `removing'
12 # <conflicting-package> <version>
13 # for details, see http://www.debian.org/doc/debian-policy/ or
14 # the debian-policy package
15
16 case "$1" in
17 configure)
18 SECRING='/etc/apt/secring.gpg'
19 # test if secring is an empty normal file
20 if test -f $SECRING -a ! -s $SECRING; then
21 rm -f $SECRING
22 fi
23 apt-key update
24 ;;
25
26 abort-upgrade|abort-remove|abort-deconfigure)
27
28 ;;
29
30 *)
31 echo "postinst called with unknown argument \`$1'" >&2
32 exit 1
33 ;;
34 esac
35
36 # dh_installdeb will replace this with shell code automatically
37 # generated by other debhelper scripts.
38
39 #DEBHELPER#
40
41 exit 0
42
43