gnu: Add lierolibre.
[jackhill/guix/guix.git] / gnu / packages / patches / lierolibre-check-unaligned-access.patch
1 Patch copied from Debian:
2
3 https://anonscm.debian.org/cgit/pkg-games/lierolibre.git/tree/debian/patches/0001-Use-unaligned-access-define-over-checking-arch.patch?id=82910748906855f6e6bfe30b3f077e8c793ae424
4
5 From 396f19b6b7743d394307f70f0c0108419824437b Mon Sep 17 00:00:00 2001
6 From: Martin Erik Werner <martinerikwerner@gmail.com>
7 Date: Sun, 28 Jun 2015 16:31:34 +0200
8 Subject: [PATCH 1/3] Use unaligned access define over checking arch
9
10 This todo item seems like it done, and just needed implementing...
11 ---
12 io/encoding.hpp | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15 diff --git a/src/gvl/io/encoding.hpp b/src/gvl/io/encoding.hpp
16 index c491677..89bb612 100644
17 --- a/src/gvl/io/encoding.hpp
18 +++ b/src/gvl/io/encoding.hpp
19 @@ -374,7 +374,7 @@ struct octet_stream_writer
20 // inlining of the common case
21 if(std::size_t(end_ - cur_) >= len)
22 {
23 -#if GVL_X86 || GVL_X86_64 // TODO: A define that says whether unaligned access is allowed
24 +#if GVL_UNALIGNED_ACCESS
25 if(len < 64) // TODO: Tweak this limit
26 {
27 while(len > 4)
28 --
29 2.4.6
30