Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / attr.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;; Copyright © 2012, 2013, 2016 Ludovic Courtès <ludo@gnu.org>
4 ;;; Copyright © 2018 Mark H Weaver <mhw@netris.org>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages attr)
22 #:use-module (guix licenses)
23 #:use-module (gnu packages perl)
24 #:use-module (gnu packages gettext)
25 #:use-module (guix packages)
26 #:use-module (guix download)
27 #:use-module (guix build-system gnu))
28
29 (define-public attr
30 (package
31 (name "attr")
32 (version "2.4.47")
33 (source (origin
34 (method url-fetch)
35 (uri (string-append "mirror://savannah/attr/attr-"
36 version ".src.tar.gz"))
37 (sha256
38 (base32
39 "0nd8y0m6awc9ahv0ciiwf8gy54c8d3j51pw9xg7f7cn579jjyxr5"))))
40 (build-system gnu-build-system)
41 (arguments
42 `(#:phases
43 (modify-phases %standard-phases
44 (add-after 'configure 'patch-makefile-SHELL
45 (lambda _
46 (patch-makefile-SHELL "include/buildmacros")
47 #t))
48 (replace 'install
49 (lambda _
50 (invoke "make"
51 "install"
52 "install-lib"
53 "install-dev")))
54 (replace 'check
55 (lambda* (#:key target #:allow-other-keys)
56 ;; Use the right shell.
57 (substitute* "test/run"
58 (("/bin/sh")
59 (which "sh")))
60
61 ;; When building natively, run the tests.
62 ;;
63 ;; Note that we use system* and unconditionally return #t here
64 ;; to ignore the test result, because the tests will fail when
65 ;; the build is performed on a file system without support for
66 ;; extended attributes, and we wish to allow Guix to be built
67 ;; on such systems.
68 (unless target
69 (system* "make" "tests" "-C" "test"))
70 #t)))))
71 (inputs
72 ;; Perl is needed to run tests; remove it from cross builds.
73 (if (%current-target-system)
74 '()
75 `(("perl" ,perl))))
76 (native-inputs
77 `(("gettext" ,gettext-minimal)))
78
79 (home-page "https://savannah.nongnu.org/projects/attr/")
80 (synopsis "Library and tools for manipulating extended attributes")
81 (description
82 "Portable library and tools for manipulating extended attributes.")
83 (license (list gpl2+ lgpl2.1+))))