gnu: libcaca: Patch for CVE-2021-3410.
[jackhill/guix/guix.git] / gnu / packages / patches / texinfo-5-perl-compat.patch
1 Fix a deprecation warning with newer Perl that breaks some tests.
2
3 --- a/tp/Texinfo/Parser.pm
4 +++ b/tp/Texinfo/Parser.pm
5 @@ -5438,12 +5438,12 @@
6 }
7 } elsif ($command eq 'clickstyle') {
8 # REMACRO
9 - if ($line =~ /^\s+@([[:alnum:]][[:alnum:]\-]*)({})?\s*/) {
10 + if ($line =~ /^\s+@([[:alnum:]][[:alnum:]\-]*)(\{})?\s*/) {
11 $args = ['@'.$1];
12 $self->{'clickstyle'} = $1
13 unless(_ignore_global_commands($self));
14 $remaining = $line;
15 - $remaining =~ s/^\s+@([[:alnum:]][[:alnum:]\-]*)({})?\s*(\@(c|comment)((\@|\s+).*)?)?//;
16 + $remaining =~ s/^\s+@([[:alnum:]][[:alnum:]\-]*)(\{})?\s*(\@(c|comment)((\@|\s+).*)?)?//;
17 $has_comment = 1 if (defined($4));
18 } else {
19 $self->line_error (sprintf($self->__(