gnu: argon2: Update to 20190702.
[jackhill/guix/guix.git] / gnu / packages / password-utils.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Steve Sprang <scs@stevesprang.com>
3 ;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2015 Aljosha Papsch <misc@rpapsch.de>
5 ;;; Copyright © 2016 Christopher Allan Webber <cwebber@dustycloud.org>
6 ;;; Copyright © 2016 Jessica Tallon <tsyesika@tsyesika.se>
7 ;;; Copyright © 2016 Andreas Enge <andreas@enge.fr>
8 ;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox.org>
9 ;;; Copyright © 2016, 2019 Alex Griffin <a@ajgrf.com>
10 ;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
11 ;;; Copyright © 2017, 2018 Clément Lassieur <clement@lassieur.org>
12 ;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
13 ;;; Copyright © 2017 Jelle Licht <jlicht@fsfe.org>
14 ;;; Copyright © 2017, 2019 Eric Bavier <bavier@member.fsf.org>
15 ;;; Copyright © 2017 Nicolas Goaziou <mail@nicolasgoaziou.fr>
16 ;;; Copyright © 2017 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
17 ;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
18 ;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
19 ;;; Copyright © 2018 Konrad Hinsen <konrad.hinsen@fastmail.net>
20 ;;; Copyright © 2018 Thomas Sigurdsen <tonton@riseup.net>
21 ;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
22 ;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
23 ;;; Copyright © 2018 Amirouche Boubekki <amirouche@hypermove.net>
24 ;;; Copyright © 2018, 2019 Tim Gesthuizen <tim.gesthuizen@yahoo.de>
25 ;;; Copyright © 2019 Jens Mølgaard <jens@zete.tk>
26 ;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
27 ;;;
28 ;;; This file is part of GNU Guix.
29 ;;;
30 ;;; GNU Guix is free software; you can redistribute it and/or modify it
31 ;;; under the terms of the GNU General Public License as published by
32 ;;; the Free Software Foundation; either version 3 of the License, or (at
33 ;;; your option) any later version.
34 ;;;
35 ;;; GNU Guix is distributed in the hope that it will be useful, but
36 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
37 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
38 ;;; GNU General Public License for more details.
39 ;;;
40 ;;; You should have received a copy of the GNU General Public License
41 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
42
43 (define-module (gnu packages password-utils)
44 #:use-module ((guix licenses) #:prefix license:)
45 #:use-module (guix build-system cmake)
46 #:use-module (guix build-system gnu)
47 #:use-module (guix build-system trivial)
48 #:use-module (guix download)
49 #:use-module (guix git-download)
50 #:use-module (guix packages)
51 #:use-module (gnu packages)
52 #:use-module (gnu packages admin)
53 #:use-module (gnu packages aidc)
54 #:use-module (gnu packages authentication)
55 #:use-module (gnu packages base)
56 #:use-module (gnu packages check)
57 #:use-module (gnu packages compression)
58 #:use-module (gnu packages crypto)
59 #:use-module (gnu packages curl)
60 #:use-module (gnu packages file)
61 #:use-module (gnu packages freedesktop)
62 #:use-module (gnu packages gettext)
63 #:use-module (gnu packages glib)
64 #:use-module (gnu packages gnupg)
65 #:use-module (gnu packages gtk)
66 #:use-module (gnu packages guile)
67 #:use-module (gnu packages kerberos)
68 #:use-module (gnu packages libffi)
69 #:use-module (gnu packages linux)
70 #:use-module (gnu packages man)
71 #:use-module (gnu packages multiprecision)
72 #:use-module (gnu packages ncurses)
73 #:use-module (gnu packages nss)
74 #:use-module (gnu packages opencl)
75 #:use-module (gnu packages perl)
76 #:use-module (gnu packages pkg-config)
77 #:use-module (gnu packages python)
78 #:use-module (gnu packages python-web)
79 #:use-module (gnu packages python-xyz)
80 #:use-module (gnu packages readline)
81 #:use-module (gnu packages ruby)
82 #:use-module (gnu packages security-token)
83 #:use-module (gnu packages suckless)
84 #:use-module (gnu packages tcl)
85 #:use-module (gnu packages tls)
86 #:use-module (gnu packages qt)
87 #:use-module (gnu packages version-control)
88 #:use-module (gnu packages wxwidgets)
89 #:use-module (gnu packages xdisorg)
90 #:use-module (gnu packages xorg)
91 #:use-module (gnu packages xml)
92 #:use-module (guix build-system python))
93
94 (define-public pwgen
95 (package
96 (name "pwgen")
97 (version "2.08")
98 (source
99 (origin
100 (method url-fetch)
101 (uri (string-append "mirror://sourceforge/pwgen/pwgen/" version
102 "/pwgen-" version ".tar.gz"))
103 (sha256
104 (base32 "0yy90pqrr2pszzhb5hxjishq9qc7dqd290amiibqx9fm1b9kvc6s"))))
105 (build-system gnu-build-system)
106 (arguments
107 `(#:tests? #f)) ; no test suite
108 (home-page "http://pwgen.sourceforge.net/")
109 (synopsis "Password generator")
110 (description "Pwgen generates passwords which can be easily memorized by a
111 human.")
112 (license license:gpl2)))
113
114 (define-public keepassxc
115 (package
116 (name "keepassxc")
117 (version "2.5.2")
118 (source
119 (origin
120 (method url-fetch)
121 (uri (string-append "https://github.com/keepassxreboot/keepassxc"
122 "/releases/download/" version "/keepassxc-"
123 version "-src.tar.xz"))
124 (sha256
125 (base32 "0lvwc3nxyz7d7vymb6cmgwxylb9g6gsjnq247vbh4lk1ifjir58j"))))
126 (build-system cmake-build-system)
127 (arguments
128 '(#:configure-flags '("-DWITH_XC_ALL=YES"
129 "-DWITH_XC_UPDATECHECK=NO")))
130 (inputs
131 `(("argon2" ,argon2)
132 ("libgcrypt" ,libgcrypt)
133 ("libsodium" ,libsodium) ; XC_BROWSER
134 ("libyubikey" ,libyubikey) ; XC_YUBIKEY
135 ("libxi" ,libxi)
136 ("libxtst" ,libxtst)
137 ("qrencode" ,qrencode)
138 ("qtbase" ,qtbase)
139 ("qtsvg" ,qtsvg)
140 ("qtx11extras" ,qtx11extras)
141 ("quazip" ,quazip) ; XC_KEESHARE
142 ("readline" ,readline)
143 ("yubikey-personalization" ,yubikey-personalization) ; XC_YUBIKEY
144 ("zlib" ,zlib)))
145 (native-inputs
146 `(("qttools" ,qttools)))
147 (home-page "https://www.keepassxc.org")
148 (synopsis "Password manager")
149 (description "KeePassXC is a password manager or safe which helps you to
150 manage your passwords in a secure way. You can put all your passwords in one
151 database, which is locked with one master key or a key-file which can be stored
152 on an external storage device. The databases are encrypted using the
153 algorithms AES or Twofish.")
154 ;; While various parts of the software are licensed under different licenses,
155 ;; the combined work falls under the GPLv3.
156 (license license:gpl3)))
157
158 (define-public keepassx
159 (package
160 (name "keepassx")
161 (version "2.0.3")
162 (source
163 (origin
164 (method url-fetch)
165 (uri (string-append "https://www.keepassx.org/releases/" version
166 "/keepassx-" version ".tar.gz"))
167 (sha256
168 (base32
169 "1ia7cqx9ias38mnffsl7da7g1f66bcbjsi23k49sln0c6spb9zr3"))))
170 (build-system cmake-build-system)
171 (inputs
172 `(("libgcrypt" ,libgcrypt)
173 ("libxi" ,libxi)
174 ("libxtst" ,libxtst)
175 ("qt" ,qt-4)))
176 (native-inputs
177 `(("zlib" ,zlib)))
178 (home-page "https://www.keepassx.org")
179 (synopsis "Password manager")
180 (description "KeePassX is a password manager or safe which helps you to
181 manage your passwords in a secure way. You can put all your passwords in one
182 database, which is locked with one master key or a key-file which can be stored
183 on an external storage device. The databases are encrypted using the
184 algorithms AES or Twofish.")
185 ;; Non functional parts use various licences.
186 (license license:gpl3)
187 (properties `((superseded . ,keepassxc)))))
188
189 (define-public pwsafe
190 (package
191 (name "pwsafe")
192 (version "3.50.0")
193 (home-page "https://www.pwsafe.org/")
194 (source
195 (origin
196 (method git-fetch)
197 (uri (git-reference
198 (url "https://github.com/pwsafe/pwsafe.git")
199 (commit version)))
200 (sha256
201 (base32 "01kfssd2vr64yh4dqhch58x36n3aj3hpj5n560f41rsxym69c6qs"))
202 (file-name (git-file-name name version))))
203 (build-system cmake-build-system)
204 (native-inputs
205 `(("gettext" ,gettext-minimal)
206 ("gtest" ,googletest)
207 ("perl" ,perl)
208 ("zip" ,zip)))
209 (inputs `(("curl" ,curl)
210 ("file" ,file)
211 ("libuuid" ,util-linux)
212 ("libxt" ,libxt)
213 ("libxtst" ,libxtst)
214 ("openssl" ,openssl)
215 ("qrencode" ,qrencode)
216 ("wxwidgets" ,wxwidgets)
217 ("xerces-c" ,xerces-c)))
218 (arguments '(#:configure-flags (list "-DNO_GTEST=YES")
219 #:phases (modify-phases %standard-phases
220 (add-after 'unpack 'add-gtest
221 (lambda* (#:key inputs #:allow-other-keys)
222 (chmod "CMakeLists.txt" #o644)
223 (let ((cmake-port (open-file "CMakeLists.txt"
224 "a")))
225 (display "find_package(GTest)
226 add_subdirectory(src/test)\n" cmake-port)
227 (close cmake-port)
228 #t)))
229 (add-after 'add-gtest 'patch-executables
230 (lambda* (#:key inputs #:allow-other-keys)
231 (chmod "src/test/OSTest.cpp" #o644)
232 (substitute* "src/os/unix/media.cpp"
233 (("/usr/bin/file")
234 (string-append (assoc-ref inputs "file")
235 "/bin/file")))
236 #t)))))
237 (synopsis "Password safe with automatic input and key generation")
238 (description "pwsafe is a password manager originally designed by Bruce
239 Schneier. It offers a simple UI to manage passwords for different services.
240 There are other programs that support the file format on different
241 platforms.")
242 (license license:artistic2.0)))
243
244 (define-public shroud
245 (package
246 (name "shroud")
247 (version "0.1.2")
248 (source (origin
249 (method url-fetch)
250 (uri (string-append "https://files.dthompson.us/shroud/shroud-"
251 version ".tar.gz"))
252 (sha256
253 (base32
254 "1l2shrhvcwfzkar9qiwb75nhcqmx25iz55lzmz0c187nbjhqzi9p"))))
255 (build-system gnu-build-system)
256 (native-inputs
257 `(("pkg-config" ,pkg-config)))
258 (arguments
259 `(#:modules ((guix build gnu-build-system)
260 (guix build utils)
261 (ice-9 popen)
262 (ice-9 rdelim))
263 #:phases
264 (modify-phases %standard-phases
265 (add-after 'install 'wrap-shroud
266 (lambda* (#:key inputs outputs #:allow-other-keys)
267 (let* ((out (assoc-ref outputs "out"))
268 (guile (assoc-ref inputs "guile"))
269 (effective (read-line
270 (open-pipe* OPEN_READ
271 (string-append guile "/bin/guile")
272 "-c" "(display (effective-version))")))
273 (ccachedir (string-append out
274 "/lib/guile/" effective "/site-ccache"))
275 (prog (string-append out "/bin/shroud")))
276 (wrap-program prog
277 `("GUILE_LOAD_COMPILED_PATH" ":" prefix (,ccachedir)))
278 #t))))))
279 (inputs
280 `(("guile" ,guile-2.2)
281 ("gnupg" ,gnupg)
282 ("xclip" ,xclip)))
283 (synopsis "GnuPG-based secret manager")
284 (description "Shroud is a simple secret manager with a command line
285 interface. The password database is stored as a Scheme s-expression and
286 encrypted with a GnuPG key. Secrets consist of an arbitrary number of
287 key/value pairs, making Shroud suitable for more than just password storage.
288 For copying and pasting secrets into web browsers and other graphical
289 applications, there is xclip integration." )
290 (home-page "https://dthompson.us/projects/shroud.html")
291 (license license:gpl3+)))
292
293 (define-public yapet
294 (package
295 (name "yapet")
296 (version "2.3")
297 (source
298 (origin
299 (method url-fetch)
300 (uri (string-append "https://yapet.guengel.ch/downloads/yapet-"
301 version ".tar.xz"))
302 (sha256
303 (base32 "1fl4s7v1psl52ndd6i7716i9f493aj8ipl6lgmraadnn5h26l3pm"))))
304 (build-system gnu-build-system)
305 (inputs
306 `(("argon2" ,argon2)
307 ("ncurses" ,ncurses)
308 ("openssl" ,openssl)))
309 (native-inputs
310 `(("cppunit" ,cppunit)
311 ("pkg-config" ,pkg-config)))
312 (synopsis "Yet Another Password Encryption Tool")
313 (description "YAPET is a text based password manager using the Blowfish
314 encryption algorithm. Because of its small footprint and very few library
315 dependencies, it is suited for installing on desktop and server systems alike.
316 The text based user interface allows you to run YAPET easily in a Secure Shell
317 session. Two companion utilities enable users to convert CSV files to YAPET
318 and vice versa.")
319 (home-page "http://www.guengel.ch/myapps/yapet/")
320 (license license:gpl3+)))
321
322 (define-public cracklib
323 (package
324 (name "cracklib")
325 (version "2.9.7")
326 (source
327 (origin
328 (method url-fetch)
329 (uri (string-append "https://github.com/cracklib/cracklib/"
330 "releases/download/v" version "/"
331 "cracklib-" version ".tar.bz2"))
332 (sha256
333 (base32 "1rimpjsdnmw8f5b7k558cic41p2qy2n2yrlqp5vh7mp4162hk0py"))))
334 (build-system gnu-build-system)
335 (arguments
336 `(#:phases
337 (modify-phases %standard-phases
338 (add-after 'install 'install-dict
339 (lambda* (#:key make-flags #:allow-other-keys)
340 (begin
341 (chmod (string-append "util/cracklib-format") #o755)
342 (apply invoke "make" "dict" make-flags)
343 #t))))))
344 (synopsis "Password checking library")
345 (home-page "https://github.com/cracklib/cracklib")
346 (description
347 "CrackLib is a library containing a C function which may be used in a
348 @command{passwd}-like program. The idea is simple: try to prevent users from
349 choosing passwords that could easily be guessed (or \"cracked\") by filtering
350 them out, at the source.")
351 (license license:lgpl2.1)))
352
353 (define-public libpwquality
354 (package
355 (name "libpwquality")
356 (version "1.4.2")
357 (source (origin
358 (method url-fetch)
359 (uri (list
360 (string-append "https://github.com/libpwquality/libpwquality"
361 "/releases/download/libpwquality-" version
362 "/libpwquality-" version ".tar.bz2")
363 (string-append "https://launchpad.net/libpwquality/trunk/"
364 version "/+download/"
365 "libpwquality-" version ".tar.bz2")))
366 (sha256
367 (base32
368 "13hw532fmzc5xjpy75d74rlfdlxf2a8ibb4hyy9c0s92wsgf0qsj"))))
369 (build-system gnu-build-system)
370 (arguments
371 ;; XXX: have RUNPATH issue.
372 '(#:configure-flags '("--disable-python-bindings")))
373 (inputs
374 `(("cracklib" ,cracklib)))
375 (synopsis "Password quality checker")
376 (home-page "https://github.com/libpwquality/libpwquality")
377 (description
378 "Libpwquality is a library for password quality checking and generation of
379 random passwords that pass the checks.")
380 (license license:gpl2+)))
381
382 (define-public assword
383 (package
384 (name "assword")
385 (version "0.11")
386 (source (origin
387 (method url-fetch)
388 (uri (list
389 (string-append
390 "http://http.debian.net/debian/pool/main/a/assword/"
391 "assword_" version ".orig.tar.gz")))
392 (sha256
393 (base32
394 "03gkb6kvsghznbcw5l7nmrc6mn3ixkjd5jcs96ni4zs9l47jf7yp"))))
395 (arguments
396 `(;; irritatingly, tests do run but not there are two problems:
397 ;; - "import gtk" fails for unknown reasons here despite it the
398 ;; program working (indeed, I've found I have to do a logout and log
399 ;; back in in after an install order for some mumbo jumbo environment
400 ;; variable mess to work with pygtk and assword... what's up with
401 ;; that?)
402 ;; - even when the tests fail, they don't return a nonzero status,
403 ;; so I'm not sure how to programmatically get that information
404 #:tests? #f
405 #:phases
406 (modify-phases %standard-phases
407 (add-after 'install 'wrap-assword
408 (lambda* (#:key outputs #:allow-other-keys)
409 (let ((prog (string-append
410 (assoc-ref outputs "out")
411 "/bin/assword"))
412 (gi-typelib-path (getenv "GI_TYPELIB_PATH")))
413 (wrap-program prog
414 `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path)))
415 #t)))
416 (add-after 'install 'manpage
417 (lambda* (#:key outputs #:allow-other-keys)
418 ;; Without this substitution, it fails with
419 ;; ImportError: No module named 'gpg'
420 (substitute* "Makefile"
421 (("PYTHONPATH=.") ""))
422 (invoke "make" "assword.1")
423 (install-file
424 "assword.1"
425 (string-append (assoc-ref outputs "out") "/share/man/man1")))))))
426 (build-system python-build-system)
427 (native-inputs
428 `(("txt2man" ,txt2man)))
429 (inputs
430 `(("gtk+" ,gtk+)
431 ("python-xdo" ,python-xdo)
432 ("python-gpg" ,python-gpg)
433 ("python-pygobject" ,python-pygobject)))
434 (propagated-inputs
435 `(("xclip" ,xclip)))
436 (home-page "https://finestructure.net/assword/")
437 (synopsis "Password manager")
438 (description "assword is a simple password manager using GPG-wrapped
439 JSON files. It has a command line interface as well as a very simple
440 graphical interface, which can even \"type\" your passwords into
441 any X11 window.")
442 (license license:gpl3+)))
443
444 (define-public password-store
445 (package
446 (name "password-store")
447 (version "1.7.3")
448 (source (origin
449 (method url-fetch)
450 (uri
451 (string-append "https://git.zx2c4.com/password-store/snapshot/"
452 name "-" version ".tar.xz"))
453 (sha256
454 (base32
455 "1x53k5dn3cdmvy8m4fqdld4hji5n676ksl0ql4armkmsds26av1b"))))
456 (build-system gnu-build-system)
457 (arguments
458 '(#:phases
459 (modify-phases %standard-phases
460 (delete 'configure)
461 (delete 'build)
462 (add-before 'install 'patch-system-extension-dir
463 (lambda* (#:key outputs #:allow-other-keys)
464 (let* ((out (assoc-ref outputs "out"))
465 (extension-dir (string-append out "/lib/password-store/extensions")))
466 (substitute* "src/password-store.sh"
467 (("^SYSTEM_EXTENSION_DIR=.*$")
468 ;; lead with whitespace to prevent 'make install' from
469 ;; overwriting it again
470 (string-append " SYSTEM_EXTENSION_DIR=\""
471 "${PASSWORD_STORE_SYSTEM_EXTENSION_DIR:-"
472 extension-dir
473 "}\"\n"))))
474 #t))
475 (add-before 'install 'patch-passmenu-path
476 (lambda* (#:key inputs #:allow-other-keys)
477 (substitute* "contrib/dmenu/passmenu"
478 (("dmenu") (string-append (assoc-ref inputs "dmenu")
479 "/bin/dmenu"))
480 (("xdotool") (string-append (assoc-ref inputs "xdotool")
481 "/bin/xdotool")))
482 #t))
483 (add-after 'install 'install-passmenu
484 (lambda* (#:key outputs #:allow-other-keys)
485 (let* ((out (assoc-ref outputs "out"))
486 (bin (string-append out "/bin")))
487 (install-file "contrib/dmenu/passmenu" bin)
488 #t)))
489 (add-after 'install 'wrap-path
490 (lambda* (#:key inputs outputs #:allow-other-keys)
491 (let ((out (assoc-ref outputs "out"))
492 (path (map (lambda (pkg)
493 (string-append (assoc-ref inputs pkg) "/bin"))
494 '("coreutils" "getopt" "git" "gnupg" "qrencode"
495 "sed" "tree" "which" "xclip"))))
496 (wrap-program (string-append out "/bin/pass")
497 `("PATH" ":" prefix (,(string-join path ":"))))
498 #t)))
499 (add-after 'wrap-path 'install-shell-completions
500 (lambda* (#:key outputs #:allow-other-keys)
501 (let* ((out (assoc-ref outputs "out"))
502 (bashcomp (string-append out "/etc/bash_completion.d")))
503 ;; TODO: install fish and zsh completions.
504 (mkdir-p bashcomp)
505 (copy-file "src/completion/pass.bash-completion"
506 (string-append bashcomp "/pass"))
507 #t))))
508 #:make-flags (list "CC=gcc" (string-append "PREFIX=" %output))
509 ;; Parallel tests may cause a race condition leading to a
510 ;; timeout in some circumstances.
511 #:parallel-tests? #f
512 #:test-target "test"))
513 (native-search-paths
514 (list (search-path-specification
515 (variable "PASSWORD_STORE_SYSTEM_EXTENSION_DIR")
516 (separator #f) ;single entry
517 (files '("lib/password-store/extensions")))))
518 (inputs
519 `(("dmenu" ,dmenu)
520 ("getopt" ,util-linux)
521 ("git" ,git)
522 ("gnupg" ,gnupg)
523 ("qrencode" ,qrencode)
524 ("sed" ,sed)
525 ("tree" ,tree)
526 ("which" ,which)
527 ("xclip" ,xclip)
528 ("xdotool" ,xdotool)))
529 (home-page "https://www.passwordstore.org/")
530 (synopsis "Encrypted password manager")
531 (description "Password-store is a password manager which uses GnuPG to
532 store and retrieve passwords. The tool stores each password in its own
533 GnuPG-encrypted file, allowing the program to be simple yet secure.
534 Synchronization is possible using the integrated git support, which commits
535 changes to your password database to a git repository that can be managed
536 through the pass command.")
537 (license license:gpl2+)))
538
539 (define-public pass-otp
540 (package
541 (name "pass-otp")
542 (version "1.2.0")
543 (source
544 (origin
545 (method url-fetch)
546 (uri
547 (string-append "https://github.com/tadfisher/pass-otp/releases/"
548 "download/v" version "/pass-otp-" version ".tar.gz"))
549 (sha256
550 (base32
551 "0rrs3iazq80dn0wbl20xkh270428jd8l99m5gd7hl93s4r4sc82p"))))
552 (build-system gnu-build-system)
553 (arguments
554 '(#:make-flags
555 (let* ((out (assoc-ref %outputs "out"))
556 (bashcomp (string-append out "/etc/bash_completion.d")))
557 (list (string-append "PREFIX=" %output)
558 (string-append "BASHCOMPDIR=" bashcomp)))
559 #:phases
560 (modify-phases %standard-phases
561 (delete 'configure)
562 (add-after 'build 'patch-oath-path
563 (lambda* (#:key inputs #:allow-other-keys)
564 (substitute* "otp.bash"
565 (("^OATH=.*$")
566 (string-append
567 "OATH="
568 (assoc-ref inputs "oath-toolkit")
569 "/bin/oathtool\n")))
570 #t)))
571 #:test-target "test"))
572 (inputs
573 `(("oath-toolkit" ,oath-toolkit)))
574 (native-inputs
575 `(("password-store" ,password-store)
576 ("expect" ,expect)
577 ("git" ,git)
578 ("gnupg" ,gnupg)
579 ("which" ,which)))
580 (home-page "https://github.com/tadfisher/pass-otp")
581 (synopsis "Pass extension for managing one-time-password (OTP) tokens")
582 (description
583 "Pass OTP is an extension for password-store that allows adding
584 one-time-password (OTP) secrets, generating OTP codes, and displaying secret
585 key URIs using the standard otpauth:// scheme.")
586 (license license:gpl3+)))
587
588 (define-public qtpass
589 (package
590 (name "qtpass")
591 (version "1.2.3")
592 (source
593 (origin
594 (method git-fetch)
595 (uri (git-reference
596 (url "https://github.com/IJHack/QtPass.git")
597 (commit (string-append "v" version))))
598 (file-name (git-file-name name version))
599 (sha256
600 (base32
601 "1vfhfyccrxq9snyvayqfzm5rqik8ny2gysyv7nipc91kvhq3bhky"))))
602 (build-system gnu-build-system)
603 (arguments
604 `(#:phases
605 (modify-phases %standard-phases
606 (replace 'configure
607 (lambda* (#:key inputs outputs #:allow-other-keys)
608 (let ((out (assoc-ref outputs "out")))
609 ;; lupdate/lrelease need to find qmake.
610 (setenv "QMAKE" "qmake")
611 ;; qmake needs to find lrelease/lupdate.
612 (invoke "qmake"
613 "QMAKE_LRELEASE=lrelease"
614 "QMAKE_LUPDATE=lupdate"
615 (string-append "PREFIX=" out)))))
616 (add-after 'configure 'reset-resource-timestamps
617 ;; Reset timestamps on localization files for a reproducible build.
618 (lambda _
619 (with-directory-excursion "localization"
620 (for-each (lambda (file)
621 (let* ((base (basename file ".qm"))
622 (src (string-append base ".ts"))
623 (st (stat src)))
624 (set-file-time file st)))
625 (find-files "." ".*\\.qm")))
626 #t))
627 (add-after 'install 'install-auxilliary
628 ;; Install man-page, icon and .desktop file.
629 (lambda* (#:key inputs outputs #:allow-other-keys)
630 (let* ((out (assoc-ref outputs "out"))
631 (applications (string-append out "/share/applications"))
632 (icons (string-append out "/share/icons/hicolor/scalable/apps"))
633 (man (string-append out "/share/man/man1")))
634 (install-file "qtpass.desktop" applications)
635 (install-file "artwork/icon.svg" icons)
636 (rename-file (string-append icons "/icon.svg")
637 (string-append icons "/qtpass-icon.svg"))
638 (install-file "qtpass.1" man)
639 #t)))
640 (add-before 'check 'check-setup
641 ;; Make Qt render "offscreen", required for tests.
642 (lambda _
643 (setenv "QT_QPA_PLATFORM" "offscreen")
644 #t)))))
645 (native-inputs
646 `(("qttools" ,qttools)))
647 (inputs
648 `(("qtbase" ,qtbase)
649 ("qtsvg" ,qtsvg)))
650 (home-page "https://qtpass.org")
651 (synopsis "GUI for password manager password-store")
652 (description
653 "Qt-based graphical user interface for the password manager
654 password-store also known as pass. Can use either pass or gpg to interact
655 with password-store files. Features configurable password generation,
656 templates, clipboard handling, and per folder settings for multi-recipient
657 encryption.")
658 (license license:gpl3+)))
659
660 (define-public rofi-pass
661 (package
662 (name "rofi-pass")
663 (version "2.0.2")
664 (source
665 (origin
666 (method url-fetch)
667 (uri
668 (string-append "https://raw.githubusercontent.com/carnager/rofi-pass/"
669 version "/rofi-pass"))
670 (sha256
671 (base32 "0msldkndqp40nx1s5s7ggcr97ir4nshpmnyzvj5hqw1l7m3gvw6j"))
672 (file-name name)))
673 (build-system trivial-build-system)
674 (arguments
675 `(#:modules ((guix build utils))
676 #:builder
677 (begin
678 (use-modules (guix build utils))
679 (let ((source (string-append (assoc-ref %build-inputs "source")))
680 (script "rofi-pass")
681 (out (assoc-ref %outputs "out")))
682 (copy-file source script)
683 (chmod script #o555)
684 (install-file script (string-append out "/bin"))))))
685 (propagated-inputs
686 `(("password-store" ,password-store)
687 ("rofi" ,rofi)
688 ("xdotool" ,xdotool)))
689 (home-page "https://github.com/carnager/rofi-pass")
690 (synopsis "Rofi frontend for password-store")
691 (description "Rofi-pass provides a way to manipulate information stored
692 using password-store through rofi interface:
693 @enumerate
694 @item open URLs of entries with hotkey;
695 @item type any field from entry;
696 @item auto-typing of user and/or password fields;
697 @item auto-typing username based on path;
698 @item auto-typing of more than one field, using the autotype entry;
699 @item bookmarks mode (open stored URLs in browser, default: Alt+x).
700 @end enumerate")
701 (license license:gpl3)))
702
703 (define-public argon2
704 (package
705 (name "argon2")
706 (version "20190702")
707 (source
708 (origin
709 (method git-fetch)
710 (uri (git-reference
711 (url "https://github.com/P-H-C/phc-winner-argon2")
712 (commit version)))
713 (file-name (git-file-name name version))
714 (sha256
715 (base32
716 "01rwanr4wmr9vm6c712x411wig543q195z2icn388z892a93lc7p"))))
717 (build-system gnu-build-system)
718 (arguments
719 `(#:test-target "test"
720 #:make-flags (list "CC=gcc"
721 (string-append "PREFIX=" (assoc-ref %outputs "out"))
722 "LIBRARY_REL=lib"
723 (string-append "ARGON2_VERSION=" ,version)
724 "OPTTEST=1") ; disable CPU optimization
725 #:phases
726 (modify-phases %standard-phases
727 (delete 'configure)))) ; No configure script.
728 (home-page "https://www.argon2.com/")
729 (synopsis "Password hashing library")
730 (description "Argon2 provides a key derivation function that was declared
731 winner of the 2015 Password Hashing Competition.")
732 ;; Argon2 is dual licensed under CC0 and ASL 2.0. Some of the source
733 ;; files are CC0 only; see README.md and LICENSE for details.
734 (license (list license:cc0 license:asl2.0))))
735
736 (define-public pass-git-helper
737 (package
738 (name "pass-git-helper")
739 (version "1.1.0")
740 (source
741 (origin
742 (method git-fetch)
743 (uri (git-reference
744 (url "https://github.com/languitar/pass-git-helper")
745 (commit (string-append "v" version))))
746 (file-name (git-file-name name version))
747 (sha256
748 (base32
749 "18nvwlp0w4aqj268wly60rnjzqw2d8jl0hbs6bkwp3hpzzz5g6yd"))))
750 (build-system python-build-system)
751 (arguments
752 `(#:phases
753 (modify-phases %standard-phases
754 (add-before 'build 'patch-pass-path
755 (lambda* (#:key inputs #:allow-other-keys)
756 (let* ((password-store (assoc-ref inputs "password-store"))
757 (pass (string-append password-store "/bin/pass")))
758 (substitute* '("passgithelper.py"
759 "test_passgithelper.py")
760 (("'pass'") (string-append "'" pass "'")))
761 #t)))
762 (replace 'check
763 (lambda _
764 (setenv "HOME" (getcwd))
765 (invoke "pytest"))))))
766 (inputs
767 `(("python-pyxdg" ,python-pyxdg)
768 ("password-store" ,password-store)))
769 (native-inputs
770 `(("python-pytest" ,python-pytest)
771 ("python-pytest-mock" ,python-pytest-mock)))
772 (home-page "https://github.com/languitar/pass-git-helper")
773 (synopsis "Git credential helper interfacing with pass")
774 (description "pass-git-helper is a git credential helper which allows to
775 use pass, the standard unix password manager, as the credential backend for
776 your git repositories. This is achieved by explicitly defining mappings
777 between hosts and entries in the password store.")
778 (license license:lgpl3+)))
779
780 (define-public john-the-ripper-jumbo
781 (let ((official-version "1.9.0")
782 (jumbo-version "1"))
783 (package
784 (name "john-the-ripper-jumbo")
785 (version (string-append official-version "-" jumbo-version))
786 (source
787 (origin
788 (method url-fetch)
789 (uri (string-append "http://www.openwall.com/john/j/john-"
790 official-version "-jumbo-" jumbo-version ".tar.xz"))
791 (sha256
792 (base32
793 "0fvz3v41hnaiv1ggpxanfykyfjq79cwp9qcqqn63vic357w27lgm"))))
794 (build-system gnu-build-system)
795 (native-inputs
796 `(("perl" ,perl)))
797 (inputs
798 `(("gmp" ,gmp)
799 ("libpcap" ,libpcap)
800 ("nss" ,nss)
801 ("openssl" ,openssl-1.0)
802 ("python" ,python-2) ; For "python" and "python2" shebangs
803 ("ruby" ,ruby) ; For genincstats.rb
804 ("zlib" ,zlib)))
805 (arguments
806 `(#:configure-flags
807 (list "--with-systemwide"
808 ;; Do not test for instruction set in configure, and do not
809 ;; pass '-march=native' to gcc:
810 "--disable-native-tests"
811 "--disable-native-march"
812 ,(string-append
813 "--enable-simd="
814 (let ((system (or (%current-target-system)
815 (%current-system))))
816 (cond
817 ((or (string-prefix? "x86_64" system)
818 (string-prefix? "i686" system)) "sse2")
819 ((string-prefix? "aarch" system) "neon")
820 (else "no")))))
821 #:phases
822 (modify-phases %standard-phases
823 (add-before 'configure 'chdir-src
824 (lambda _ (chdir "src") #t))
825 (replace 'install
826 (lambda _
827 (let ((bindir (string-append %output "/bin"))
828 (docdir (string-append %output "/share/doc/john"))
829 (execdir (string-append %output "/libexec/john"))
830 (datadir (string-append %output "/share/john"))
831 (install-file-to (lambda (dir)
832 (lambda (f) (install-file f dir))))
833 (symlink? (lambda (_ s) (eq? (stat:type s) 'symlink))))
834 (with-directory-excursion "../run"
835 (for-each (install-file-to bindir)
836 (cons*
837 "john" "makechr" "cprepair" "SIPdump" "tgtsnarf"
838 "genmkvpwd" "mkvcalcproba" "calc_stat" "raw2dyna"
839 (find-files "." "(to|2)?john(-[^.]*)?$")))
840 (for-each (lambda (f) ; Install symlinked aliases
841 (let ((tgt (string-append bindir "/" (basename f))))
842 ;; The use of install-file above dereferences
843 ;; symlinks. We'd rather have the symlinks
844 ;; for clarity, so remove tgt before linking.
845 (when (file-exists? tgt) (delete-file tgt))
846 (symlink "john" tgt)))
847 (find-files "." symlink?))
848 (for-each (install-file-to execdir)
849 (cons* "mailer" "benchmark-unify" "relbench"
850 (find-files "." ".*\\.js")))
851 (for-each (lambda (f)
852 (let* ((base (basename f))
853 (name (substring base 0 (string-index base #\.)))
854 (link (string-append bindir "/" name)))
855 (install-file f execdir)
856 (when (and (executable-file? f)
857 (not (file-exists? link)))
858 (symlink (string-append execdir "/" base) link))))
859 (find-files "." ".*\\.(pl|py|rb|lua)"))
860 (for-each (install-file-to datadir)
861 (append (find-files "." "(stats|dictionary.*)")
862 (find-files "." "(.*\\.chr|.*\\.lst)")
863 (find-files "." ".*\\.conf")))
864 (copy-recursively "rules" (string-append datadir "/rules")))
865 (copy-recursively "../doc" docdir)
866 #t)))
867 (delete 'check) ; Tests need installed .conf files; move after install
868 (add-after 'install 'check
869 (lambda args
870 (setenv "HOME" "/tmp") ; Some tests need to write to ~/.john
871 (setenv "OMP_NUM_THREADS" (number->string (parallel-job-count)))
872 (apply (assoc-ref %standard-phases 'check) args))))))
873 (home-page "http://www.openwall.com/john/")
874 (synopsis "Password cracker")
875 (description "John the Ripper is a fast password cracker. Its primary
876 purpose is to detect weak Unix passwords. Besides several @code{crypt}
877 password hash types most commonly found on various Unix systems, supported out
878 of the box are Windows LM hashes, plus lots of other hashes and ciphers. This
879 is the community-enhanced, \"jumbo\" version of John the Ripper.")
880 (license license:gpl2+))))
881
882 (define-public sala
883 (package
884 (name "sala")
885 (version "1.3")
886 (source
887 (origin
888 (method url-fetch)
889 (uri (pypi-uri "sala" version))
890 (sha256
891 (base32
892 "13qgmc3i2a0cqp8jqrfl93lnphfagb32pgfikc1gza2a14asxzi8"))))
893 (build-system python-build-system)
894 (arguments
895 ;; Sala is supposed to work with Python 3.2 or higher,
896 ;; but it doesn't work with Python 3.6. Better stick
897 ;; to Python 2, which works fine.
898 `(#:python ,python-2))
899 (propagated-inputs
900 `(("gnupg" ,gnupg)
901 ("pwgen" ,pwgen)))
902 (home-page "http://www.digip.org/sala/")
903 (synopsis "Encrypted plaintext password store")
904 (description
905 "Store passwords and other bits of sensitive plain-text information
906 to encrypted files on a directory hierarchy. The information is protected
907 by GnuPG's symmetrical encryption.")
908 (license license:expat)))
909
910 (define-public fpm2
911 (package
912 (name "fpm2")
913 (version "0.79")
914 (source (origin
915 (method url-fetch)
916 (uri (string-append "https://als.regnet.cz/fpm2/download/fpm2-"
917 version ".tar.bz2"))
918 (sha256
919 (base32
920 "19sdy1lygfhkg5nxi2w9a4d9kwvw24nxp0ix0p0lz91qpvk9qpnm"))))
921 (build-system gnu-build-system)
922 (inputs `(("gtk2" ,gtk+-2)
923 ("gnupg" ,gnupg)
924 ("libxml2" ,libxml2)))
925 (native-inputs `(("pkg-config" ,pkg-config)
926 ("intltool" ,intltool)))
927 (arguments
928 `(#:phases
929 (modify-phases %standard-phases
930 (add-before 'configure 'pre-configure
931 ;; The file po/POTFILES.in ends up missing for some reason in
932 ;; both nix and guix builds. Adding the file with contents
933 ;; found during troubleshooting.
934 (lambda _
935 (call-with-output-file "po/POTFILES.in"
936 (lambda (port)
937 (format port "data/fpm2.desktop.in
938 data/fpm2.desktop.in.in
939 fpm2.glade
940 src/callbacks.c
941 src/fpm.c
942 src/fpm_file.c
943 src/interface.c
944 src/support.c
945 fpm2.glade
946 ")))
947 #t)))))
948 (synopsis "Manage, generate and store passwords encrypted")
949 (description "FPM2 is GTK2 port from Figaro's Password Manager
950 originally developed by John Conneely, with some new enhancements.
951
952 Upstream development seems to have stopped. It is therefore recommended
953 to use a different password manager.")
954 (home-page "https://als.regnet.cz/fpm2/")
955 (license license:gpl2+)))
956
957 (define-public pass-rotate
958 (package
959 (name "pass-rotate")
960 (version "0.1")
961 (source
962 (origin
963 (method git-fetch)
964 (uri (git-reference
965 (url "https://github.com/ddevault/pass-rotate")
966 (commit version)))
967 (file-name (git-file-name name version))
968 (sha256
969 (base32
970 "1m067vvdlc85csbpkp8aw4s3ags7q8s3jszrr32kmj9qhk5c254f"))))
971 (build-system python-build-system)
972 (inputs
973 `(("python-beautifulsoup4" ,python-beautifulsoup4)
974 ("python-docopt" ,python-docopt)
975 ("python-html5lib" ,python-html5lib)
976 ("python-requests" ,python-requests)))
977 (home-page "https://github.com/ddevault/pass-rotate")
978 (synopsis "Rotate password on online services")
979 (description "pass-rotate is a command line utility and python library for
980 rotating passwords on various web services. It makes it easier to rotate your
981 passwords, one at a time or in bulk, when security events or routine upkeep of
982 your online accounts makes it necessary.")
983 (license license:expat)))
984
985 (define-public hashcat
986 (package
987 (name "hashcat")
988 (version "5.1.0")
989 (source
990 (origin
991 (method url-fetch)
992 (uri (string-append "https://hashcat.net/files/hashcat-"
993 version ".tar.gz"))
994 (sha256
995 (base32
996 "0f73y4cg8c7a6q7x34qvpfi4g3lw6j9bnn0a13g43aqyiskflfr8"))))
997 (native-inputs
998 `(("opencl-headers" ,opencl-headers)))
999 (build-system gnu-build-system)
1000 (arguments
1001 '(#:tests? #f ;no tests
1002 #:make-flags (list (string-append "PREFIX=" %output))
1003 #:phases
1004 (modify-phases %standard-phases
1005 (delete 'configure))))
1006 (home-page "https://hashcat.net/hashcat/")
1007 (synopsis "Advanced password recovery utility")
1008 (description "Hashcat is an password recovery utility, supporting five
1009 unique modes of attack for over 200 highly-optimized hashing algorithms.
1010 Hashcat currently supports CPUs, GPUs, and other hardware accelerators on
1011 Linux, Windows, and macOS, and has facilities to help enable distributed
1012 password cracking.")
1013 (license license:expat)))
1014
1015 (define-public hashcat-utils
1016 (package
1017 (name "hashcat-utils")
1018 (version "1.9")
1019 (source
1020 (origin
1021 (method url-fetch)
1022 (uri (string-append "https://github.com/hashcat/hashcat-utils/releases/"
1023 "download/v" version "/"
1024 "hashcat-utils-" version ".7z"))
1025 (sha256
1026 (base32 "0kq555kb338691qd7zjmi8vhq4km3apnsl2w63zh0igwzcjx6lx1"))))
1027 (native-inputs
1028 `(("p7zip" ,p7zip)))
1029 (inputs
1030 `(("perl" ,perl)))
1031 (build-system gnu-build-system)
1032 (arguments
1033 `(#:tests? #f ;no tests
1034 #:make-flags (list "CC=gcc"
1035 ;; Upstream bug(?): "make all" seems to remove the
1036 ;; Perl scripts from the source.
1037 "native")
1038 #:phases
1039 (modify-phases %standard-phases
1040 (replace 'unpack
1041 (lambda* (#:key source #:allow-other-keys)
1042 (invoke "7z" "x" source)
1043 (chdir (string-append "hashcat-utils-" ,version "/src"))
1044 #t))
1045 (delete 'configure)
1046 (replace 'install
1047 (lambda* (#:key outputs #:allow-other-keys)
1048 (let ((out (string-append (assoc-ref outputs "out") "/bin")))
1049 (mkdir-p out)
1050 (for-each
1051 (lambda (file)
1052 (copy-file file (string-append out "/"
1053 (basename file ".bin"))))
1054 (find-files "." "\\.bin$"))
1055 (for-each
1056 (lambda (file)
1057 (copy-file file (string-append out "/"
1058 (basename file ".pl"))))
1059 (find-files "../bin" "\\.pl$"))
1060 #t))))))
1061 (home-page "https://github.com/hashcat/hashcat-utils/")
1062 (synopsis "Small utilities that are useful in advanced password cracking")
1063 (description "Hashcat-utils are a set of small utilities that are useful
1064 in advanced password cracking. They all are packed into multiple stand-alone
1065 binaries. All of these utils are designed to execute only one specific
1066 function. Since they all work with @code{STDIN} and @code{STDOUT} you can
1067 group them into chains.")
1068 (license license:expat)))