gnu: texlive: Update to 2013.
[jackhill/guix/guix.git] / gnu / packages / system.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages system)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages ncurses))
26
27 (define-public pies
28 (package
29 (name "pies")
30 (version "1.2")
31 (source
32 (origin
33 (method url-fetch)
34 (uri (string-append "mirror://gnu/pies/pies-"
35 version ".tar.bz2"))
36 (sha256
37 (base32
38 "18w0dbg77i56cx1bwa789w0qi3l4xkkbascxcv2b6gbm0zmjg1g6"))))
39 (build-system gnu-build-system)
40 (home-page "http://www.gnu.org/software/pies/")
41 (synopsis "Program invocation and execution supervisor")
42 (description
43 "The name Pies (pronounced \"p-yes\") stands for Program Invocation
44 and Execution Supervisor. This utility starts and controls execution of
45 external programs, called components. Each component is a stand-alone
46 program, which is executed in the foreground. Upon startup, pies reads
47 the list of components from its configuration file, starts them, and
48 remains in the background, controlling their execution. If any of the
49 components terminates, the default action of Pies is to restart it.
50 However, it can also be programmed to perform a variety of another
51 actions such as, e.g., sending mail notifications to the system
52 administrator, invoking another external program, etc.
53
54 Pies can be used for a wide variety of tasks. Its most obious use is to
55 put in backgound a program which normally cannot detach itself from the
56 controlling terminal, such as, e.g., minicom. It can launch and control
57 components of some complex system, such as Jabberd or MeTA1 (and it
58 offers much more control over them than the native utilities). Finally,
59 it can replace the inetd utility!")
60 (license gpl3+)))
61
62 (define-public inetutils
63 (package
64 (name "inetutils")
65 (version "1.9.1")
66 (source
67 (origin
68 (method url-fetch)
69 (uri (string-append "mirror://gnu/inetutils/inetutils-"
70 version ".tar.gz"))
71 (sha256
72 (base32
73 "0azzg6njgq79byl6960kb0wihfhhzf49snslhxgvi30ribgfpa82"))))
74 (build-system gnu-build-system)
75 (arguments `(#:patches (list (assoc-ref %build-inputs "patch/gets"))
76
77 ;; FIXME: `tftp.sh' relies on `netstat' from utils-linux,
78 ;; which is currently missing.
79 #:tests? #f))
80 (inputs `(("patch/gets" ,(search-patch "diffutils-gets-undeclared.patch"))
81 ("ncurses" ,ncurses)))
82 (home-page "http://www.gnu.org/software/inetutils/")
83 (synopsis "Basic networking utilities")
84 (description
85 "The GNU network utilities suite provides the following tools:
86 ftp(d), hostname, ifconfig, inetd, logger, ping, rcp, rexec(d),
87 rlogin(d), rsh(d), syslogd, talk(d), telnet(d), tftp(d), traceroute,
88 uucpd, and whois.")
89 (license gpl3+)))