gnu: texlive: Update to 2013.
[jackhill/guix/guix.git] / gnu / packages / libphidget.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages libphidget)
20 #:use-module (guix packages)
21 #:use-module (guix download)
22 #:use-module (guix build-system gnu)
23 #:use-module (guix licenses)
24 #:use-module (gnu packages libusb))
25
26 (define-public libphidget
27 (package
28 (name "libphidget")
29 (version "2.1.8.20130320")
30 (source (origin
31 (method url-fetch)
32 (uri (string-append
33 "http://www.phidgets.com/downloads/libraries/libphidget_"
34 version ".tar.gz"))
35 (sha256
36 (base32 "09ibrz1df5ajqcm9vmx6zw8qama2rzf0961yhmmfsy629qfhyrk0"))))
37 (build-system gnu-build-system)
38 (inputs `(("libusb" ,libusb)))
39 (outputs '("out" "debug"))
40 (home-page "http://www.phidgets.com/")
41 (license lgpl3+)
42 (synopsis "C library to manipulate Phidgets")
43 (description synopsis)))