gnu: texlive: Update to 2013.
[jackhill/guix/guix.git] / gnu / packages / irssi.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages irssi)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages glib)
26 #:use-module (gnu packages ncurses)
27 #:use-module (gnu packages perl)
28 #:use-module (gnu packages pkg-config))
29
30 (define-public irssi
31 (package
32 (name "irssi")
33 (version "0.8.15")
34 (source (origin
35 (method url-fetch)
36 (uri (string-append "http://www.irssi.org/files/irssi-"
37 version ".tar.bz2"))
38 (sha256
39 (base32
40 "19m0aah9bhc70dnhh7kpydbsz5n35l0l9knxav1df0sic3xicbf1"))))
41 (build-system gnu-build-system)
42 (arguments
43 `(#:phases
44 (alist-replace
45 'configure
46 (lambda* (#:key inputs outputs #:allow-other-keys)
47 (let ((out (assoc-ref outputs "out"))
48 (ncurses (assoc-ref inputs "ncurses")))
49 (setenv "CONFIG_SHELL" (which "bash"))
50 (zero?
51 (system* "./configure"
52 (string-append "--prefix=" out)
53 (string-append "--with-ncurses=" ncurses)))))
54 %standard-phases)))
55 (inputs
56 `(("glib" ,glib)
57 ("pkg-config" ,pkg-config)
58 ("ncurses" ,ncurses)
59 ("perl" ,perl)))
60 (home-page "http://www.irssi.org/")
61 (synopsis "Irssi, a terminal-based IRC client")
62 (description
63 "Irssi is a terminal based IRC client for UNIX systems. It also supports
64 SILC and ICB protocols via plugins.")
65 (license gpl2+)))