gnu: texlive: Update to 2013.
[jackhill/guix/guix.git] / gnu / packages / cyrus-sasl.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages cyrus-sasl)
21 #:use-module (gnu packages)
22 #:use-module (gnu packages gdbm)
23 #:use-module (gnu packages mit-krb5)
24 #:use-module (gnu packages openssl)
25 #:use-module ((guix licenses)
26 #:renamer (symbol-prefix-proc 'license:))
27 #:use-module (guix packages)
28 #:use-module (guix download)
29 #:use-module (guix build-system gnu))
30
31 (define-public cyrus-sasl
32 (package
33 (name "cyrus-sasl")
34 (version "2.1.26")
35 (source (origin
36 (method url-fetch)
37 (uri (string-append "ftp://ftp.cyrusimap.org/cyrus-sasl/cyrus-sasl-" version
38 ".tar.gz"))
39 (sha256 (base32
40 "1hvvbcsg21nlncbgs0cgn3iwlnb3vannzwsp6rwvnn9ba4v53g4g"))))
41 (build-system gnu-build-system)
42 (inputs `(("gdbm" ,gdbm)
43 ("mit-krb5" ,mit-krb5)
44 ("openssl" ,openssl)))
45 (arguments
46 '(#:configure-flags (list (string-append "--with-plugindir="
47 (assoc-ref %outputs "out")
48 "/lib/sasl2"))))
49 (synopsis "Cyrus SASL, an implementation of the Simple Authentication Security Layer framework")
50 (description
51 "SASL (Simple Authentication Security Layer) is an Internet
52 standards-track method for remote computers to authenticate. The Cyrus SASL
53 library makes supporting various SASL mechanisms easy for both client and
54 server writers.")
55 (license (license:bsd-style "file://COPYING"
56 "See COPYING in the distribution."))
57 (home-page "http://cyrusimap.web.cmu.edu/index.php")))