gnu: texlive: Update to 2013.
[jackhill/guix/guix.git] / gnu / packages / bdw-gc.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages bdw-gc)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu))
24
25 (define-public libgc
26 (package
27 (name "libgc")
28 (version "7.2d")
29 (source (origin
30 (method url-fetch)
31 (uri (string-append
32 "http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/gc-"
33 version ".tar.gz"))
34 (sha256
35 (base32
36 "0phwa5driahnpn79zqff14w9yc8sn3599cxz91m78hqdcpl0mznr"))))
37 (build-system gnu-build-system)
38 (arguments
39 ;; Make it so that we don't rely on /proc. This is especially useful in
40 ;; an initrd run before /proc is mounted.
41 '(#:configure-flags '("CPPFLAGS=-DUSE_LIBC_PRIVATES")))
42 (outputs '("out" "debug"))
43 (synopsis "The Boehm-Demers-Weiser conservative garbage collector
44 for C and C++")
45 (description
46 "The Boehm-Demers-Weiser conservative garbage collector can be used
47 as a garbage collecting replacement for C malloc or C++ new. It allows
48 you to allocate memory basically as you normally would, without
49 explicitly deallocating memory that is no longer useful. The collector
50 automatically recycles memory when it determines that it can no longer
51 be otherwise accessed.
52
53 The collector is also used by a number of programming language
54 implementations that either use C as intermediate code, want to
55 facilitate easier interoperation with C libraries, or just prefer the
56 simple collector interface.
57
58 Alternatively, the garbage collector may be used as a leak detector for
59 C or C++ programs, though that is not its primary goal.")
60 (home-page "http://www.hpl.hp.com/personal/Hans_Boehm/gc/")
61
62 ;; permissive X11-style license:
63 ;; http://www.hpl.hp.com/personal/Hans_Boehm/gc/license.txt
64 (license x11)))