gnu: gnome-shell-extension-paperwm: Install compiled gschemas.
[jackhill/guix/guix.git] / gnu / packages / gnome-xyz.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2019 Leo Prikler <leo.prikler@student.tugraz.at>
3 ;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
4 ;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
5 ;;; Copyright © 2020 Alex Griffin <a@ajgrf.com>
6 ;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
7 ;;;
8 ;;; This file is part of GNU Guix.
9 ;;;
10 ;;; GNU Guix is free software; you can redistribute it and/or modify it
11 ;;; under the terms of the GNU General Public License as published by
12 ;;; the Free Software Foundation; either version 3 of the License, or (at
13 ;;; your option) any later version.
14 ;;;
15 ;;; GNU Guix is distributed in the hope that it will be useful, but
16 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
17 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
18 ;;; GNU General Public License for more details.
19 ;;;
20 ;;; You should have received a copy of the GNU General Public License
21 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
22
23 (define-module (gnu packages gnome-xyz)
24 #:use-module (guix build-system trivial)
25 #:use-module (guix build-system gnu)
26 #:use-module (guix build-system copy)
27 #:use-module (guix git-download)
28 #:use-module (guix packages)
29 #:use-module ((guix licenses) #:prefix license:)
30 #:use-module (gnu packages base)
31 #:use-module (gnu packages bash)
32 #:use-module (gnu packages glib)
33 #:use-module (gnu packages gnome)
34 #:use-module (gnu packages gtk)
35 #:use-module (gnu packages pkg-config)
36 #:use-module (gnu packages ruby)
37 #:use-module (gnu packages xml))
38
39 (define-public matcha-theme
40 (package
41 (name "matcha-theme")
42 (version "2019-11-02")
43 (source
44 (origin
45 (method git-fetch)
46 (uri
47 (git-reference
48 (url "https://github.com/vinceliuice/matcha")
49 (commit version)))
50 (file-name (git-file-name name version))
51 (sha256
52 (base32
53 "0wci9ahap8kynq8cbyxr7aba9ndb1d4kiq42xvzr34vw1rhcahrr"))))
54 (build-system trivial-build-system)
55 (arguments
56 '(#:modules ((guix build utils))
57 #:builder
58 (begin
59 (use-modules (guix build utils))
60 (let* ((out (assoc-ref %outputs "out"))
61 (source (assoc-ref %build-inputs "source"))
62 (bash (assoc-ref %build-inputs "bash"))
63 (coreutils (assoc-ref %build-inputs "coreutils"))
64 (themesdir (string-append out "/share/themes")))
65 (setenv "PATH"
66 (string-append coreutils "/bin:"
67 (string-append bash "/bin:")))
68 (copy-recursively source (getcwd))
69 (patch-shebang "Install")
70 (mkdir-p themesdir)
71 (invoke "./Install" "-d" themesdir)
72 #t))))
73 (inputs
74 `(("gtk-engines" ,gtk-engines)))
75 (native-inputs
76 `(("bash" ,bash)
77 ("coreutils" ,coreutils)))
78 (synopsis "Flat design theme for GTK 3, GTK 2 and GNOME-Shell")
79 (description "Matcha is a flat Design theme for GTK 3, GTK 2 and
80 Gnome-Shell which supports GTK 3 and GTK 2 based desktop environments
81 like Gnome, Unity, Budgie, Pantheon, XFCE, Mate and others.")
82 (home-page "https://github.com/vinceliuice/matcha")
83 (license license:gpl3+)))
84
85 (define-public delft-icon-theme
86 (package
87 (name "delft-icon-theme")
88 (version "1.10")
89 (source
90 (origin
91 (method git-fetch)
92 (uri (git-reference
93 (url "https://github.com/madmaxms/iconpack-delft.git")
94 (commit (string-append "v" version))))
95 (sha256
96 (base32
97 "0vw3yw9f9ygzfd2k3zrfih3r0vkzlhk1bmsk8sapvk7np24i1z9s"))
98 (file-name (git-file-name name version))))
99 (build-system trivial-build-system)
100 (arguments
101 `(#:modules ((guix build utils))
102 #:builder
103 (begin
104 (use-modules (guix build utils))
105 (copy-recursively (assoc-ref %build-inputs "source") "icons")
106 (substitute* "icons/Delft/index.theme"
107 (("gnome") "Adwaita"))
108 (delete-file "icons/README.md")
109 (delete-file "icons/LICENSE")
110 (delete-file "icons/logo.jpg")
111 (copy-recursively "icons" (string-append %output "/share/icons")))))
112 (home-page "https://www.gnome-look.org/p/1199881/")
113 (synopsis "Continuation of Faenza icon theme with up to date app icons")
114 (description "Delft is a fork of the popular icon theme Faenza with up to
115 date app icons. It will stay optically close to the original Faenza icons,
116 which haven't been updated for some years. The new app icons are ported from
117 the Obsidian icon theme.")
118 (license license:gpl3)))
119
120 (define-public gnome-shell-extension-appindicator
121 (package
122 (name "gnome-shell-extension-appindicator")
123 (version "30")
124 (source (origin
125 (method git-fetch)
126 (uri (git-reference
127 (url
128 "https://github.com/ubuntu/gnome-shell-extension-appindicator.git")
129 (commit (string-append "v" version))))
130 (sha256
131 (base32
132 "1fjhx23jqwv3d0smwhnjvc35gqhwk9p5f96ic22pfax653cn5vh8"))
133 (file-name (git-file-name name version))))
134 (build-system trivial-build-system)
135 (arguments
136 '(#:modules ((guix build utils))
137 #:builder
138 (begin
139 (use-modules (guix build utils))
140 (let* ((source (assoc-ref %build-inputs "source"))
141 (install-dir (string-append (assoc-ref %outputs "out")
142 "/share/gnome-shell/extensions"
143 "/appindicatorsupport@rgcjonas.gmail.com")))
144 (mkdir-p install-dir)
145 (copy-recursively source install-dir)
146 #t))))
147 (synopsis "Adds KStatusNotifierItem support to GNOME Shell")
148 (description "This extension integrates Ubuntu AppIndicators
149 and KStatusNotifierItems (KDE's successor of the systray) into
150 GNOME Shell.")
151 (home-page "https://github.com/ubuntu/gnome-shell-extension-appindicator/")
152 (license license:gpl2+)))
153
154 (define-public gnome-shell-extension-dash-to-dock
155 (package
156 (name "gnome-shell-extension-dash-to-dock")
157 (version "66")
158 (source (origin
159 (method git-fetch)
160 (uri (git-reference
161 (url "https://github.com/micheleg/dash-to-dock.git")
162 (commit (string-append "extensions.gnome.org-v"
163 version))))
164 (sha256
165 (base32
166 "04krl6rxlp1qc97psraf2kwin7h0mx4c7pnfpi7vhplmvasrwkfh"))
167 (file-name (git-file-name name version))))
168 (build-system gnu-build-system)
169 (arguments
170 '(#:tests? #f
171 #:make-flags (list (string-append "INSTALLBASE="
172 (assoc-ref %outputs "out")
173 "/share/gnome-shell/extensions"))
174 #:phases
175 (modify-phases %standard-phases
176 (delete 'bootstrap)
177 (delete 'configure))))
178 (native-inputs
179 `(("glib:bin" ,glib "bin")
180 ("intltool" ,intltool)
181 ("pkg-config" ,pkg-config)))
182 (propagated-inputs
183 `(("glib" ,glib)))
184 (synopsis "Transforms GNOME's dash into a dock")
185 (description "This extension moves the dash out of the
186 overview, transforming it into a dock for easier application launching and
187 faster window switching.")
188 (home-page "https://micheleg.github.io/dash-to-dock/")
189 (license license:gpl2+)))
190
191 (define-public gnome-shell-extension-hide-app-icon
192 (let ((commit "4188aa5f4ba24901a053a0c3eb0d83baa8625eab")
193 (revision "0"))
194 (package
195 (name "gnome-shell-extension-hide-app-icon")
196 (version (git-version "2.7" revision commit))
197 (source
198 (origin
199 (method git-fetch)
200 (uri (git-reference
201 (url (string-append "https://github.com/michael-rapp"
202 "/gnome-shell-extension-hide-app-icon.git"))
203 (commit commit)))
204 (sha256
205 (base32
206 "1i28n4bz6wrhn07vpxkr6l1ljyn7g8frp5xrr11z3z32h2hxxcd6"))
207 (file-name (git-file-name name version))))
208 (build-system gnu-build-system)
209 (arguments
210 '(#:tests? #f ; no test target
211 #:make-flags (list (string-append "EXTENSIONS_DIR="
212 (assoc-ref %outputs "out")
213 "/share/gnome-shell/extensions"))
214 #:phases
215 (modify-phases %standard-phases
216 (delete 'configure) ; no configure script
217 (replace 'install
218 (lambda* (#:key outputs #:allow-other-keys)
219 (let ((out (assoc-ref outputs "out"))
220 (pre "/share/gnome-shell/extensions/")
221 (dir "hide-app-icon@mrapp.sourceforge.com"))
222 (copy-recursively dir (string-append out pre dir))
223 #t))))))
224 (native-inputs
225 `(("glib" ,glib "bin")
226 ("intltool" ,intltool)))
227 (propagated-inputs
228 `(("glib" ,glib)))
229 (synopsis "Hide app icon from GNOME's panel")
230 (description "This extension allows to hide the icon and/or title of the
231 currently focused application in the top panel of the GNOME shell.")
232 (home-page
233 "https://github.com/michael-rapp/gnome-shell-extension-hide-app-icon/")
234 (license
235 ;; README.md and LICENSE.txt disagree -- the former claims v3, the
236 ;; latter v2. No mention of "or later" in either place or in the code.
237 (list license:gpl2
238 license:gpl3)))))
239
240 (define-public gnome-shell-extension-dash-to-panel
241 (package
242 (name "gnome-shell-extension-dash-to-panel")
243 (version "26")
244 (source (origin
245 (method git-fetch)
246 (uri (git-reference
247 (url "https://github.com/home-sweet-gnome/dash-to-panel.git")
248 (commit (string-append "v" version))))
249 (sha256
250 (base32
251 "1phfx2pblygpcvsppsqqqflm7qnz46mqkw29hj0nv2dn69hf4xbc"))
252 (file-name (git-file-name name version))))
253 (build-system gnu-build-system)
254 (arguments
255 `(#:tests? #f
256 #:make-flags (list (string-append "INSTALLBASE="
257 (assoc-ref %outputs "out")
258 "/share/gnome-shell/extensions")
259 (string-append "VERSION="
260 ,(package-version
261 gnome-shell-extension-dash-to-panel)))
262 #:phases
263 (modify-phases %standard-phases
264 (delete 'bootstrap)
265 (delete 'configure))))
266 (native-inputs
267 `(("intltool" ,intltool)
268 ("pkg-config" ,pkg-config)))
269 (propagated-inputs
270 `(("glib" ,glib)
271 ("glib" ,glib "bin")))
272 (synopsis "Icon taskbar for GNOME Shell")
273 (description "This extension moves the dash into the gnome main
274 panel so that the application launchers and system tray are combined
275 into a single panel, similar to that found in KDE Plasma and Windows 7+.")
276 (home-page "https://github.com/home-sweet-gnome/dash-to-panel/")
277 (license license:gpl2+)))
278
279 (define-public gnome-shell-extension-noannoyance
280 (package
281 (name "gnome-shell-extension-noannoyance")
282 (version "5")
283 (source (origin
284 (method git-fetch)
285 (uri (git-reference
286 (url "https://github.com/BjoernDaase/noannoyance.git")
287 (commit "e37b5b3c31f577b4698bc6659bc9fec5ea9ac5d4")))
288 (sha256
289 (base32
290 "0fa8l3xlh8kbq07y4385wpb908zm6x53z81q16xlmin97dln32hh"))
291 (file-name (git-file-name name version))))
292 (build-system trivial-build-system)
293 (arguments
294 '(#:modules ((guix build utils))
295 #:builder
296 (begin
297 (use-modules (guix build utils))
298 (let ((dst (string-append
299 (assoc-ref %outputs "out")
300 "/share/gnome-shell/extensions/"
301 "noannoyance@daase.net")))
302 (mkdir-p dst)
303 (copy-recursively (assoc-ref %build-inputs "source") dst)))))
304 (synopsis "Removes 'Window is ready' annotation")
305 (description "One of the many extensions, that remove this message.
306 It uses ES6 syntax and claims to be more actively maintained than others.")
307 (home-page "https://extensions.gnome.org/extension/2182/noannoyance/")
308 (license license:gpl2)))
309
310 (define-public gnome-shell-extension-paperwm
311 (package
312 (name "gnome-shell-extension-paperwm")
313 (version "34.3")
314 (source (origin
315 (method git-fetch)
316 (uri (git-reference
317 (url "https://github.com/paperwm/PaperWM.git")
318 (commit version)))
319 (file-name (git-file-name name version))
320 (sha256
321 (base32
322 "1qry75f696pgmd9yzqvwhq5h6cipin2fvk7h881g29cjcpxim37a"))
323 (snippet
324 '(begin (delete-file "schemas/gschemas.compiled")))))
325 (build-system copy-build-system)
326 (arguments
327 '(#:install-plan
328 '(("." "share/gnome-shell/extensions/paperwm@hedning:matrix.org"
329 #:include-regexp ("\\.js(on)?$" "\\.css$" "\\.ui$" "\\.png$"
330 "\\.xml$" "\\.compiled$")))
331 #:phases
332 (modify-phases %standard-phases
333 (add-before 'install 'compile-schemas
334 (lambda _
335 (with-directory-excursion "schemas"
336 (invoke "make"))
337 #t)))))
338 (native-inputs
339 `(("glib:bin" ,glib "bin"))) ; for glib-compile-schemas
340 (home-page "https://github.com/paperwm/PaperWM")
341 (synopsis "Tiled scrollable window management for GNOME Shell")
342 (description "PaperWM is an experimental GNOME Shell extension providing
343 scrollable tiling of windows and per monitor workspaces. It's inspired by paper
344 notebooks and tiling window managers.")
345 (license license:gpl3)))
346
347 (define-public numix-theme
348 (package
349 (name "numix-theme")
350 (version "2.6.7")
351 (source (origin
352 (method git-fetch)
353 (uri (git-reference
354 (url "https://github.com/numixproject/numix-gtk-theme.git")
355 (commit version)))
356 (file-name (git-file-name name version))
357 (sha256
358 (base32
359 "12mw0kr0kkvg395qlbsvkvaqccr90cmxw5rrsl236zh43kj8grb7"))))
360 (build-system gnu-build-system)
361 (arguments
362 '(#:make-flags (list (string-append "DESTDIR=" (assoc-ref %outputs "out")))
363 #:phases
364 (modify-phases %standard-phases
365 (delete 'configure)
366 (delete 'check))))
367 (native-inputs
368 `(("glib:bin" ,glib "bin") ; for glib-compile-schemas
369 ("gnome-shell" ,gnome-shell)
370 ("gtk+" ,gtk+)
371 ("xmllint" ,libxml2)
372 ("ruby-sass" ,ruby-sass)))
373 (synopsis "Flat theme with light and dark elements")
374 (description "Numix is a modern flat theme with a combination of light and
375 dark elements. It supports GNOME, Unity, Xfce, and Openbox.")
376 (home-page "https://numixproject.github.io")
377 (license license:gpl3+)))
378
379 (define-public papirus-icon-theme
380 (let ((version "0.0.0") ;; The package does not use semver
381 (revision "0")
382 (tag "20191201"))
383 (package
384 (name "papirus-icon-theme")
385 (version (git-version version revision tag))
386 (source
387 (origin
388 (method git-fetch)
389 (uri (git-reference
390 (url "https://github.com/PapirusDevelopmentTeam/papirus-icon-theme.git")
391 (commit tag)))
392 (sha256
393 (base32
394 "0lnz1kmz28xh1f4slbsx7ycji5hgszyiyprbf5w5fbjhvi5gzw1h"))
395 (file-name (git-file-name name version))))
396 (build-system gnu-build-system)
397 (arguments
398 '(#:tests? #f
399 #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
400 #:phases
401 (modify-phases %standard-phases
402 (delete 'bootstrap)
403 (delete 'configure)
404 (delete 'build))))
405 (native-inputs
406 `(("gtk+:bin" ,gtk+ "bin")))
407 (home-page "https://git.io/papirus-icon-theme")
408 (synopsis "Fork of Paper icon theme with a lot of new icons and a few extras")
409 (description "Papirus is a fork of the icon theme Paper with a lot of new icons
410 and a few extra features.")
411 (license license:gpl3))))