gnu: calibre: Wrap QTWEBENGINEPROCESS_PATH.
[jackhill/guix/guix.git] / gnu / packages / moreutils.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
3 ;;; Copyright © 2016, 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2016, 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages moreutils)
22 #:use-module ((guix licenses) #:prefix l:)
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix build-system gnu)
26 #:use-module (gnu packages perl)
27 #:use-module (gnu packages xml)
28 #:use-module (gnu packages docbook))
29
30 (define-public moreutils
31 (package
32 (name "moreutils")
33 (version "0.63")
34 (source
35 (origin
36 (method url-fetch)
37 (uri (list
38 (string-append
39 "https://git.joeyh.name/index.cgi/moreutils.git/snapshot/"
40 name "-" version ".tar.gz")
41 (string-append
42 "http://drabczyk.org/"
43 name "-" version ".tar.gz")))
44 (sha256
45 (base32
46 "07c3wqf1sx3nhj4cs71a9ajcfl6arjjvvnhwqz7a0xm2m1b6vj2g"))))
47 (build-system gnu-build-system)
48 ;; For building the manual pages.
49 (native-inputs
50 `(("docbook-xml" ,docbook-xml-4.4)
51 ("docbook-xsl" ,docbook-xsl)
52 ("libxml2" ,libxml2)
53 ("libxslt" ,libxslt)))
54 (inputs
55 `(("perl" ,perl)
56 ("perl-timedate" ,perl-timedate)
57 ("perl-time-duration" ,perl-time-duration)))
58 (arguments
59 `(#:phases
60 (modify-phases %standard-phases
61 (add-after 'install 'wrap-program
62 (lambda* (#:key outputs #:allow-other-keys)
63 (let* ((out (assoc-ref outputs "out")))
64 (wrap-program
65 (string-append out "/bin/ts")
66 `("PERL5LIB" ":" prefix (,(getenv "PERL5LIB")))))
67 #t))
68 (delete 'configure)) ; no configure script
69 #:make-flags
70 (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
71 (string-append "DOCBOOKXSL="
72 (assoc-ref %build-inputs "docbook-xsl") "/xml/xsl/"
73 ,(package-name docbook-xsl) "-"
74 ,(package-version docbook-xsl))
75 "CC=gcc")))
76 (home-page "https://joeyh.name/code/moreutils/")
77 (synopsis "Miscellaneous general-purpose command-line tools")
78 (description
79 "Moreutils is a collection of general-purpose command-line tools to
80 augment the traditional Unix toolbox.")
81 (license l:gpl2+)))