gnu: calibre: Wrap QTWEBENGINEPROCESS_PATH.
[jackhill/guix/guix.git] / gnu / packages / matrix.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2020 Alex ter Weele <alex.ter.weele@gmail.com>
3 ;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages matrix)
21 #:use-module ((guix licenses) #:prefix license:)
22 #:use-module (gnu packages check)
23 #:use-module (gnu packages databases)
24 #:use-module (gnu packages monitoring)
25 #:use-module (gnu packages python-crypto)
26 #:use-module (gnu packages python-web)
27 #:use-module (gnu packages python-xyz)
28 #:use-module (gnu packages xml)
29 #:use-module (guix build-system python)
30 #:use-module (guix download)
31 #:use-module (guix packages))
32
33 (define-public python-matrix-synapse-ldap3
34 (package
35 (name "python-matrix-synapse-ldap3")
36 (version "0.1.4")
37 (source
38 (origin
39 (method url-fetch)
40 (uri (pypi-uri "matrix-synapse-ldap3" version))
41 (sha256
42 (base32
43 "01bms89sl16nyh9f141idsz4mnhxvjrc3gj721wxh1fhikps0djx"))))
44 (build-system python-build-system)
45 (arguments
46 ;; tests require synapse, creating a circular dependency.
47 '(#:tests? #f))
48 (propagated-inputs
49 `(("python-twisted" ,python-twisted)
50 ("python-ldap3" ,python-ldap3)
51 ("python-service-identity" ,python-service-identity)))
52 (home-page "https://github.com/matrix-org/matrix-synapse-ldap3")
53 (synopsis "LDAP3 auth provider for Synapse")
54 (description
55 "This package allows Synapse to use LDAP as a password provider.
56 This lets users log in to Synapse with their username and password from
57 an LDAP server.")
58 (license license:asl2.0)))
59
60 (define-public synapse
61 (package
62 (name "synapse")
63 (version "1.14.0")
64 (source (origin
65 (method url-fetch)
66 (uri (pypi-uri "matrix-synapse" version))
67 (sha256
68 (base32
69 "09drdqcjvpk9s3hq5rx9yxsxq0wak5fg5gfaiqfnbnxav2c2v7kq"))))
70 (build-system python-build-system)
71 ;; TODO Run tests with ‘PYTHONPATH=. trial3 tests’.
72 (propagated-inputs
73 `(("python-simplejson" ,python-simplejson) ; not attested but required
74 ;; requirements (synapse/python_dependencies.py)
75 ("python-jsonschema" ,python-jsonschema)
76 ("python-frozendict" ,python-frozendict)
77 ("python-unpaddedbase64" ,python-unpaddedbase64)
78 ("python-canonicaljson" ,python-canonicaljson)
79 ("python-signedjson" ,python-signedjson)
80 ("python-pynacl" ,python-pynacl)
81 ("python-idna" ,python-idna)
82 ("python-service-identity" ,python-service-identity)
83 ("python-twisted" ,python-twisted)
84 ("python-treq" ,python-treq)
85 ("python-pyopenssl" ,python-pyopenssl)
86 ("python-pyyaml" ,python-pyyaml)
87 ("python-pyasn1" ,python-pyasn1)
88 ("python-pyasn1-modules" ,python-pyasn1-modules)
89 ("python-daemonize" ,python-daemonize)
90 ("python-bcrypt" ,python-bcrypt)
91 ("python-pillow" ,python-pillow)
92 ("python-sortedcontainers" ,python-sortedcontainers)
93 ("python-pymacaroons" ,python-pymacaroons)
94 ("python-msgpack" ,python-msgpack)
95 ("python-phonenumbers" ,python-phonenumbers)
96 ("python-six" ,python-six)
97 ("python-prometheus-client" ,python-prometheus-client)
98 ("python-attrs" ,python-attrs)
99 ("python-netaddr" ,python-netaddr)
100 ("python-jinja2" ,python-jinja2)
101 ("python-bleach" ,python-bleach)
102 ("python-typing-extensions" ,python-typing-extensions)
103 ;; conditional requirements (synapse/python_dependencies.py)
104 ;;("python-hiredis" ,python-hiredis)
105 ("python-matrix-synapse-ldap3" ,python-matrix-synapse-ldap3)
106 ("python-psycopg2" ,python-psycopg2)
107 ("python-jinja2" ,python-jinja2)
108 ("python-txacme" ,python-txacme)
109 ("python-pysaml2" ,python-pysaml2)
110 ("python-lxml" ,python-lxml)
111 ;; sentry-sdk, jaeger-client, and opentracing could be included, but
112 ;; all are monitoring aids and not essential.
113 ("python-pyjwt" ,python-pyjwt)))
114 (native-inputs
115 `(("python-mock" ,python-mock)
116 ("python-parameterized" ,python-parameterized)))
117 (home-page "https://github.com/matrix-org/synapse")
118 (synopsis "Matrix reference homeserver")
119 (description "Synapse is a reference \"homeserver\" implementation of
120 Matrix from the core development team at matrix.org, written in
121 Python/Twisted. It is intended to showcase the concept of Matrix and let
122 folks see the spec in the context of a codebase and let you run your own
123 homeserver and generally help bootstrap the ecosystem.")
124 (license license:asl2.0)))