gnu: calibre: Wrap QTWEBENGINEPROCESS_PATH.
[jackhill/guix/guix.git] / gnu / packages / abduco.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015, 2016 Leo Famulari <leo@famulari.name>
3 ;;; Copyright © 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages abduco)
21 #:use-module (guix build-system gnu)
22 #:use-module (guix download)
23 #:use-module (guix licenses)
24 #:use-module (guix packages))
25
26 (define-public abduco
27 (package
28 (name "abduco")
29 (version "0.6")
30 (source (origin
31 (method url-fetch)
32 (uri (string-append
33 "https://www.brain-dump.org/projects/abduco/abduco-"
34 version ".tar.gz"))
35 (sha256
36 (base32
37 "1x1m58ckwsprljgmdy93mvgjyg9x3cqrzdf3mysp0mx97zhhj2f9"))))
38 (build-system gnu-build-system)
39 (arguments
40 `(#:make-flags (list "CC=gcc"
41 (string-append "PREFIX=" (assoc-ref %outputs "out")))
42 #:phases (modify-phases %standard-phases
43 (delete 'configure)
44 (delete 'check)))) ; no test suite
45 (synopsis "Session management in a clean and simple way")
46 (description "abduco provides session management i.e. it allows programs to
47 be run independently from their controlling terminal. That is, programs can
48 be detached---run in the background---and then later reattached.")
49 (home-page "https://www.brain-dump.org/projects/abduco/")
50 (license isc)))