gnu: fvwm: Update to 2.6.6.
[jackhill/guix/guix.git] / gnu / packages / fvwm.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages fvwm)
21 #:use-module ((guix licenses) #:select (gpl2+))
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages fribidi)
26 #:use-module (gnu packages gnome)
27 #:use-module (gnu packages image)
28 #:use-module (gnu packages perl)
29 #:use-module (gnu packages pkg-config)
30 #:use-module (gnu packages readline)
31 #:use-module (gnu packages xml)
32 #:use-module (gnu packages xorg))
33
34 (define-public fvwm
35 (package
36 (name "fvwm")
37 (version "2.6.6")
38 (source (origin
39 (method url-fetch)
40 (uri (string-append
41 "https://github.com/fvwmorg/fvwm/releases/download/"
42 "version-" (string-join (string-split version #\.) "_")
43 "/" name "-" version ".tar.gz"))
44 (sha256
45 (base32
46 "0b6w0vk6cpqaz0ws3vl4by0mycv33r42a0m806j2h8avy9ghipn5"))))
47 (build-system gnu-build-system)
48 (native-inputs
49 `(("perl" ,perl)
50 ("pkg-config" ,pkg-config)
51 ("xsltproc" ,libxslt)))
52 (inputs
53 `(("fribidi" ,fribidi)
54 ("libpng" ,libpng)
55 ("librsvg" ,librsvg)
56 ("libxcursor" ,libxcursor)
57 ("libxext" ,libxext)
58 ("libxft" ,libxft)
59 ("libxinerama" ,libxinerama)
60 ("libxpm" ,libxpm)
61 ("libxt" ,libxt)
62 ("readline" ,readline)))
63 (synopsis "Virtual window manager for X11")
64 (description
65 "FVWM is an extremely powerful ICCCM-compliant multiple virtual desktop
66 window manager for the X Window system.")
67 (home-page "http://www.fvwm.org/")
68 (license gpl2+)))