Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / webkit.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
3 ;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
4 ;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
5 ;;; Copyright © 2015, 2016, 2017, 2018, 2019 Mark H Weaver <mhw@netris.org>
6 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
7 ;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
8 ;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
9 ;;;
10 ;;; This file is part of GNU Guix.
11 ;;;
12 ;;; GNU Guix is free software; you can redistribute it and/or modify it
13 ;;; under the terms of the GNU General Public License as published by
14 ;;; the Free Software Foundation; either version 3 of the License, or (at
15 ;;; your option) any later version.
16 ;;;
17 ;;; GNU Guix is distributed in the hope that it will be useful, but
18 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
19 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
20 ;;; GNU General Public License for more details.
21 ;;;
22 ;;; You should have received a copy of the GNU General Public License
23 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
24
25 (define-module (gnu packages webkit)
26 #:use-module ((guix licenses) #:prefix license:)
27 #:use-module (guix packages)
28 #:use-module (guix download)
29 #:use-module (guix utils)
30 #:use-module (guix build-system cmake)
31 #:use-module (guix build-system gnu)
32 #:use-module (gnu packages)
33 #:use-module (gnu packages base)
34 #:use-module (gnu packages bison)
35 #:use-module (gnu packages docbook)
36 #:use-module (gnu packages enchant)
37 #:use-module (gnu packages flex)
38 #:use-module (gnu packages freedesktop)
39 #:use-module (gnu packages gcc)
40 #:use-module (gnu packages gettext)
41 #:use-module (gnu packages gl)
42 #:use-module (gnu packages glib)
43 #:use-module (gnu packages gnome)
44 #:use-module (gnu packages gnupg)
45 #:use-module (gnu packages gperf)
46 #:use-module (gnu packages gstreamer)
47 #:use-module (gnu packages gtk)
48 #:use-module (gnu packages icu4c)
49 #:use-module (gnu packages image)
50 #:use-module (gnu packages libreoffice)
51 #:use-module (gnu packages linux)
52 #:use-module (gnu packages perl)
53 #:use-module (gnu packages pkg-config)
54 #:use-module (gnu packages python)
55 #:use-module (gnu packages ruby)
56 #:use-module (gnu packages sqlite)
57 #:use-module (gnu packages tls)
58 #:use-module (gnu packages video)
59 #:use-module (gnu packages virtualization)
60 #:use-module (gnu packages xml)
61 #:use-module (gnu packages xdisorg)
62 #:use-module (gnu packages xorg))
63
64 (define-public libwpe
65 (package
66 (name "libwpe")
67 (version "1.6.0")
68 (source (origin
69 (method url-fetch)
70 (uri (string-append "https://wpewebkit.org/releases/libwpe-"
71 version ".tar.xz"))
72 (sha256
73 (base32
74 "141w35b488jjhanl3nrm0awrbcy6hb579fk8n9vbpx07m2wcd1rm"))))
75 (build-system cmake-build-system)
76 (arguments
77 `(#:tests? #f)) ;no tests
78 (native-inputs
79 `(("pkg-config" ,pkg-config)))
80 (inputs
81 `(("mesa" ,mesa)))
82 (propagated-inputs
83 `(;; In Requires of wpe-1.0.pc.
84 ("libxkbcommon" ,libxkbcommon)))
85 (home-page "https://wpewebkit.org/")
86 (synopsis "Platform agnostic WebKit interfaces")
87 (description
88 "@code{libwpe} is a small library that defines programming interfaces
89 for use by WebKit, and provides a mechanism for loading a platform-specific
90 backend which implements them.")
91 (license license:bsd-2)))
92
93 (define-public wpebackend-fdo
94 (package
95 (name "wpebackend-fdo")
96 (version "1.6.0")
97 (source (origin
98 (method url-fetch)
99 (uri (string-append "https://wpewebkit.org/releases/"
100 "wpebackend-fdo-" version ".tar.xz"))
101 (sha256
102 (base32
103 "0rzm16m3mw9dh2jis9avk2rhz7bijanrzlywyiaicyzrv2wxfnvz"))))
104 (build-system cmake-build-system)
105 (arguments
106 `(#:tests? #f)) ;no tests
107 (native-inputs
108 `(("pkg-config" ,pkg-config)))
109 (inputs
110 `(("glib" ,glib)
111 ("libwpe" ,libwpe)
112 ("mesa" ,mesa)
113 ("wayland" ,wayland)))
114 (home-page "https://wpewebkit.org/")
115 (synopsis "Wayland WPE backend")
116 (description
117 "This package provides a backend implementation for the WPE WebKit
118 engine that uses Wayland for graphics output.")
119 (license license:bsd-2)))
120
121 (define-public webkitgtk
122 (package
123 (name "webkitgtk")
124 (version "2.28.0")
125 (source (origin
126 (method url-fetch)
127 (uri (string-append "https://www.webkitgtk.org/releases/"
128 "webkitgtk-" version ".tar.xz"))
129 (sha256
130 (base32
131 "12qfs9w93c5kiyi14ynm4rf4ad3c213dvzmdrc9c3ab2iwbks7rn"))))
132 (build-system cmake-build-system)
133 (outputs '("out" "doc"))
134 (arguments
135 '(#:tests? #f ; no tests
136 #:build-type "Release" ; turn off debugging symbols to save space
137 #:configure-flags (list
138 "-DPORT=GTK"
139 "-DENABLE_GTKDOC=ON" ; No doc by default
140 (string-append ; uses lib64 by default
141 "-DLIB_INSTALL_DIR="
142 (assoc-ref %outputs "out") "/lib")
143
144 ;; XXX Adding GStreamer GL support would apparently
145 ;; require adding gst-plugins-bad to the inputs,
146 ;; which might entail a security risk as a result of
147 ;; the plugins of dubious code quality that are
148 ;; included. More investigation is needed. For
149 ;; now, we explicitly disable it to prevent an error
150 ;; at configuration time.
151 "-DUSE_GSTREAMER_GL=OFF"
152
153 ;; XXX Disable WOFF2 ‘web fonts’. These were never
154 ;; supported in our previous builds. Enabling them
155 ;; requires building libwoff2 and possibly woff2dec.
156 "-DUSE_WOFF2=OFF")
157 #:phases
158 (modify-phases %standard-phases
159 (add-after 'unpack 'patch-gtk-doc-scan
160 (lambda* (#:key inputs #:allow-other-keys)
161 (for-each (lambda (file)
162 (substitute* file
163 (("http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd")
164 (string-append (assoc-ref inputs "docbook-xml")
165 "/xml/dtd/docbook/docbookx.dtd"))))
166 (find-files "Source" "\\.sgml$"))
167 #t))
168 (add-after 'unpack 'embed-absolute-wpebackend-reference
169 (lambda* (#:key inputs #:allow-other-keys)
170 (let ((wpebackend-fdo (assoc-ref inputs "wpebackend-fdo")))
171 (substitute* "Source/WebKit/UIProcess/glib/WebProcessPoolGLib.cpp"
172 (("libWPEBackend-fdo-([\\.0-9]+)\\.so" all version)
173 (string-append wpebackend-fdo "/lib/" all)))
174 #t)))
175 (add-after 'install 'move-doc-files
176 (lambda* (#:key outputs #:allow-other-keys)
177 (let ((out (assoc-ref outputs "out"))
178 (doc (assoc-ref outputs "doc")))
179 (mkdir-p (string-append doc "/share"))
180 (rename-file (string-append out "/share/gtk-doc")
181 (string-append doc "/share/gtk-doc"))
182 #t))))))
183 (native-inputs
184 `(("bison" ,bison)
185 ("gettext" ,gettext-minimal)
186 ("glib:bin" ,glib "bin") ; for glib-mkenums, etc.
187 ("gobject-introspection" ,gobject-introspection)
188 ("gperf" ,gperf)
189 ("perl" ,perl)
190 ("pkg-config" ,pkg-config)
191 ("python" ,python-wrapper)
192 ("gtk-doc" ,gtk-doc) ; For documentation generation
193 ("docbook-xml" ,docbook-xml) ; For documentation generation
194 ("ruby" ,ruby)))
195 (propagated-inputs
196 `(("gtk+" ,gtk+)
197 ("libsoup" ,libsoup)))
198 (inputs
199 `(("at-spi2-core" ,at-spi2-core)
200 ("bubblewrap" ,bubblewrap)
201 ("enchant" ,enchant)
202 ("geoclue" ,geoclue)
203 ("gst-plugins-base" ,gst-plugins-base)
204 ("gtk+-2" ,gtk+-2)
205 ("harfbuzz" ,harfbuzz)
206 ("hyphen" ,hyphen)
207 ("icu4c" ,icu4c)
208 ("libgcrypt" ,libgcrypt)
209 ("libjpeg" ,libjpeg-turbo)
210 ("libnotify" ,libnotify)
211 ("libpng" ,libpng)
212 ("libseccomp" ,libseccomp)
213 ("libsecret" ,libsecret)
214 ("libtasn1" ,libtasn1)
215 ("libwebp" ,libwebp)
216 ("libwpe" ,libwpe)
217 ("libxcomposite" ,libxcomposite)
218 ("libxml2" ,libxml2)
219 ("libxslt" ,libxslt)
220 ("libxt" ,libxt)
221 ("mesa" ,mesa)
222 ("openjpeg" ,openjpeg)
223 ("sqlite" ,sqlite)
224 ("wpebackend-fdo" ,wpebackend-fdo)
225 ("xdg-dbus-proxy" ,xdg-dbus-proxy)))
226 (home-page "https://www.webkitgtk.org/")
227 (synopsis "Web content engine for GTK+")
228 (description
229 "WebKitGTK+ is a full-featured port of the WebKit rendering engine,
230 suitable for projects requiring any kind of web integration, from hybrid
231 HTML/CSS applications to full-fledged web browsers.")
232 ;; WebKit's JavaScriptCore and WebCore components are available under
233 ;; the GNU LGPL, while the rest is available under a BSD-style license.
234 (license (list license:lgpl2.0
235 license:lgpl2.1+
236 license:bsd-2
237 license:bsd-3))))