gnu: packages: Use 'search-patches' everywhere.
[jackhill/guix/guix.git] / gnu / packages / wm.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
3 ;;; Copyright © 2015 Siniša Biđin <sinisa@bidin.eu>
4 ;;; Copyright © 2015, 2016 Eric Bavier <bavier@member.fsf.org>
5 ;;; Copyright © 2015 xd1le <elisp.vim@gmail.com>
6 ;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
7 ;;; Copyright © 2016 Danny Milosavljevic <dannym@scratchpost.org>
8 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
9 ;;;
10 ;;; This file is part of GNU Guix.
11 ;;;
12 ;;; GNU Guix is free software; you can redistribute it and/or modify it
13 ;;; under the terms of the GNU General Public License as published by
14 ;;; the Free Software Foundation; either version 3 of the License, or (at
15 ;;; your option) any later version.
16 ;;;
17 ;;; GNU Guix is distributed in the hope that it will be useful, but
18 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
19 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
20 ;;; GNU General Public License for more details.
21 ;;;
22 ;;; You should have received a copy of the GNU General Public License
23 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
24
25 (define-module (gnu packages wm)
26 #:use-module ((guix licenses) #:prefix license:)
27 #:use-module (guix packages)
28 #:use-module (gnu packages)
29 #:use-module (gnu packages linux)
30 #:use-module (guix build-system gnu)
31 #:use-module (guix build-system haskell)
32 #:use-module (gnu packages haskell)
33 #:use-module (gnu packages base)
34 #:use-module (gnu packages pkg-config)
35 #:use-module (gnu packages perl)
36 #:use-module (gnu packages xorg)
37 #:use-module (gnu packages xdisorg)
38 #:use-module (gnu packages qt)
39 #:use-module (gnu packages asciidoc)
40 #:use-module (gnu packages xml)
41 #:use-module (gnu packages m4)
42 #:use-module (gnu packages docbook)
43 #:use-module (gnu packages image)
44 #:use-module (gnu packages pcre)
45 #:use-module (gnu packages gtk)
46 #:use-module (gnu packages libevent)
47 #:use-module (gnu packages fribidi)
48 #:use-module (gnu packages maths)
49 #:use-module (gnu packages web)
50 #:use-module (gnu packages fontutils)
51 #:use-module (guix download)
52 #:use-module (guix git-download))
53
54 (define-public libconfuse
55 (package
56 (name "libconfuse")
57 (version "2.7")
58 (source (origin
59 (method url-fetch)
60 (uri (string-append "http://savannah.nongnu.org/download/confuse/"
61 "confuse-" version ".tar.gz"))
62 (sha256
63 (base32
64 "0y47r2ashz44wvnxdb18ivpmj8nxhw3y9bf7v9w0g5byhgyp89g3"))))
65 (build-system gnu-build-system)
66 (home-page "http://www.nongnu.org/confuse/")
67 (synopsis "Configuration file parser library")
68 (description "libconfuse is a configuration file parser library. It
69 supports sections and (lists of) values (strings, integers, floats, booleans
70 or other sections), as well as some other features (such as
71 single/double-quoted strings, environment variable expansion, functions and
72 nested include statements).")
73 (license license:isc)))
74
75 (define-public bspwm
76 (package
77 (name "bspwm")
78 (version "0.9")
79 (source
80 (origin
81 (file-name (string-append name "-" version ".tar.gz"))
82 (method url-fetch)
83 (uri (string-append
84 "https://github.com/baskerville/bspwm/archive/"
85 version ".tar.gz"))
86 (sha256
87 (base32
88 "1pig0h2jk8wipyz90j69c4bk37bfyq60asnn0v0bqld2p2vjvyqy"))))
89 (build-system gnu-build-system)
90 (inputs
91 `(("libxcb" ,libxcb)
92 ("libxinerama" ,libxinerama)
93 ("sxhkd" ,sxhkd)
94 ("xcb-util" ,xcb-util)
95 ("xcb-util-keysyms" ,xcb-util-keysyms)
96 ("xcb-util-wm" ,xcb-util-wm)))
97 (arguments
98 '(#:phases (alist-delete 'configure %standard-phases)
99 #:tests? #f ; no check target
100 #:make-flags (list "CC=gcc"
101 (string-append "PREFIX=" %output))))
102 (home-page "https://github.com/baskerville/bspwm")
103 (synopsis "Tiling window manager based on binary space partitioning")
104 (description "bspwm is a tiling window manager that represents windows as
105 the leaves of a full binary tree.")
106 (license license:bsd-2)))
107
108 (define-public i3status
109 (package
110 (name "i3status")
111 (version "2.9")
112 (source (origin
113 (method url-fetch)
114 (uri (string-append "http://i3wm.org/i3status/i3status-"
115 version ".tar.bz2"))
116 (sha256
117 (base32
118 "1qwxbrga2fi5wf742hh9ajwa8b2kpzkjjnhjlz4wlpv21i80kss2"))))
119 (build-system gnu-build-system)
120 (arguments
121 `(#:make-flags (list "CC=gcc" (string-append "PREFIX=" %output))
122 #:phases
123 (modify-phases %standard-phases
124 (delete 'configure))
125 #:tests? #f)) ; no test suite
126 (inputs
127 `(("openlibm" ,openlibm)
128 ("libconfuse" ,libconfuse)
129 ("libyajl" ,libyajl)
130 ("alsa-lib" ,alsa-lib)
131 ("wireless-tools" ,wireless-tools)
132 ("libcap" ,libcap)
133 ("asciidoc" ,asciidoc)))
134 (home-page "http://i3wm.org/i3status/")
135 (synopsis "Status bar for i3bar, dzen2, xmobar or similar programs")
136 (description "i3status is a small program for generating a status bar for
137 i3bar, dzen2, xmobar or similar programs. It is designed to be very efficient
138 by issuing a very small number of system calls, as one generally wants to
139 update such a status line every second. This ensures that even under high
140 load, your status bar is updated correctly. Also, it saves a bit of energy by
141 not hogging your CPU as much as spawning the corresponding amount of shell
142 commands would.")
143 (license license:bsd-3)))
144
145 (define-public i3-wm
146 (package
147 (name "i3-wm")
148 (version "4.12")
149 (source (origin
150 (method url-fetch)
151 (uri (string-append "http://i3wm.org/downloads/i3-"
152 version ".tar.bz2"))
153 (sha256
154 (base32
155 "1d3q3lgpjbkmcwzjhp0dfr0jq847silcfg087slcnj95ikh1r7p1"))))
156 (build-system gnu-build-system)
157 (arguments
158 `(#:make-flags (list "CC=gcc" (string-append "PREFIX=" %output))
159 #:phases
160 (modify-phases %standard-phases
161 (delete 'configure))
162 #:tests? #f)) ; no test suite
163 (inputs
164 `(("libxcb" ,libxcb)
165 ("xcb-util" ,xcb-util)
166 ("xcb-util-cursor" ,xcb-util-cursor)
167 ("xcb-util-keysyms" ,xcb-util-keysyms)
168 ("xcb-util-wm" ,xcb-util-wm)
169 ("libxkbcommon" ,libxkbcommon)
170 ("libev" ,libev)
171 ("libyajl" ,libyajl)
172 ("asciidoc" ,asciidoc)
173 ("xmlto" ,xmlto)
174 ("perl-pod-simple" ,perl-pod-simple)
175 ("docbook-xml" ,docbook-xml)
176 ("libx11" ,libx11)
177 ("pcre" ,pcre)
178 ("startup-notification" ,startup-notification)
179 ("pango" ,pango)
180 ("cairo" ,cairo)))
181 (native-inputs
182 `(("which" ,which)
183 ("perl" ,perl)
184 ("pkg-config" ,pkg-config)))
185 (home-page "http://i3wm.org/")
186 (synopsis "Improved tiling window manager")
187 (description "A tiling window manager, completely written
188 from scratch. i3 is primarily targeted at advanced users and
189 developers.")
190 (license license:bsd-3)))
191
192 (define-public xmonad
193 (package
194 (name "xmonad")
195 (version "0.11.1")
196 (synopsis "Tiling window manager")
197 (source (origin
198 (method url-fetch)
199 (uri (string-append "http://hackage.haskell.org/package/xmonad/"
200 name "-" version ".tar.gz"))
201 (sha256
202 (base32
203 "1pfjssamiwpwjp1qqkm9m9p9s35pv381m0cwg6jxg0ppglibzq1r"))
204 (modules '((guix build utils)))
205 (snippet
206 ;; Here we update the constraints on the utf8-string package in
207 ;; the Cabal file. We allow a newer version which is compatible
208 ;; with GHC 7.10.2. The same change is applied on Hackage. See
209 ;; <https://hackage.haskell.org/package/xmonad-0.11.1/revisions/>.
210 '(substitute* "xmonad.cabal"
211 (("utf8-string >= 0.3 && < 0.4")
212 "utf8-string >= 0.3 && < 1.1")))))
213 (build-system haskell-build-system)
214 (inputs
215 `(("ghc-mtl" ,ghc-mtl)
216 ("ghc-utf8-string" ,ghc-utf8-string)
217 ("ghc-extensible-exceptions" ,ghc-extensible-exceptions)
218 ("ghc-x11" ,ghc-x11)))
219 (arguments
220 `(#:phases
221 (modify-phases %standard-phases
222 (add-after
223 'install 'install-xsession
224 (lambda _
225 (let* ((xsessions (string-append %output "/share/xsessions")))
226 (mkdir-p xsessions)
227 (call-with-output-file
228 (string-append xsessions "/xmonad.desktop")
229 (lambda (port)
230 (format port "~
231 [Desktop Entry]~@
232 Name=~a~@
233 Comment=~a~@
234 Exec=~a/bin/xmonad~@
235 Type=Application~%" ,name ,synopsis %output)))))))))
236 (home-page "http://xmonad.org")
237 (description
238 "Xmonad is a tiling window manager for X. Windows are arranged
239 automatically to tile the screen without gaps or overlap, maximising screen
240 use. All features of the window manager are accessible from the keyboard: a
241 mouse is strictly optional. Xmonad is written and extensible in Haskell.
242 Custom layout algorithms, and other extensions, may be written by the user in
243 config files. Layouts are applied dynamically, and different layouts may be
244 used on each workspace. Xinerama is fully supported, allowing windows to be
245 tiled on several screens.")
246 (license license:bsd-3)))
247
248 (define-public ghc-xmonad-contrib
249 (package
250 (name "ghc-xmonad-contrib")
251 (version "0.11.4")
252 (source
253 (origin
254 (method url-fetch)
255 (uri (string-append "http://hackage.haskell.org/package/xmonad-contrib/"
256 "xmonad-contrib-" version ".tar.gz"))
257 (sha256
258 (base32
259 "1g5cw9vvnfbiyi599fngk02zlmdhrf82x0bndhypkn6kybab6yd3"))))
260 (build-system haskell-build-system)
261 (propagated-inputs
262 `(("ghc-mtl" ,ghc-mtl)
263 ("ghc-old-time" ,ghc-old-time)
264 ("ghc-random" ,ghc-random)
265 ("ghc-utf8-string" ,ghc-utf8-string)
266 ("ghc-extensible-exceptions" ,ghc-extensible-exceptions)
267 ("ghc-x11" ,ghc-x11)
268 ("ghc-x11-xft" ,ghc-x11-xft)
269 ("xmonad" ,xmonad)))
270 (home-page "http://xmonad.org")
271 (synopsis "Third party extensions for xmonad")
272 (description
273 "Third party tiling algorithms, configurations, and scripts to Xmonad, a
274 tiling window manager for X.")
275 (license license:bsd-3)))
276
277 (define-public evilwm
278 (package
279 (name "evilwm")
280 (version "1.1.1")
281 (source
282 (origin
283 (method url-fetch)
284 (uri (string-append "http://www.6809.org.uk/evilwm/evilwm-"
285 version ".tar.gz"))
286 (sha256
287 (base32
288 "0ak0yajzk3v4dg5wmaghv6acf7v02a4iw8qxmq5yw5ard8lrqn3r"))
289 (patches (search-patches "evilwm-lost-focus-bug.patch"))))
290 (build-system gnu-build-system)
291 (inputs
292 `(("libx11" ,libx11)
293 ("libxext" ,libxext)
294 ("libxrandr" ,libxrandr)))
295 (arguments
296 `(#:modules ((srfi srfi-26)
297 (guix build utils)
298 (guix build gnu-build-system))
299 #:make-flags (let ((inputs (map (cut assoc-ref %build-inputs <>)
300 '("libx11" "libxext" "libxrandr")))
301 (join (lambda (proc strs)
302 (string-join (map proc strs) " ")))
303 (dash-I (cut string-append "-I" <> "/include"))
304 (dash-L (cut string-append "-L" <> "/lib")))
305 `("desktopfilesdir=$(prefix)/share/xsessions"
306 ,(string-append "prefix=" (assoc-ref %outputs "out"))
307 ,(string-append "CPPFLAGS=" (join dash-I inputs))
308 ,(string-append "LDFLAGS=" (join dash-L inputs))))
309 #:tests? #f ;no tests
310 #:phases (modify-phases %standard-phases
311 (delete 'configure)))) ;no configure script
312 (home-page "http://www.6809.org.uk/evilwm/")
313 (synopsis "Minimalist window manager for the X Window System")
314 (description
315 "evilwm is a minimalist window manager based on aewm, extended to feature
316 many keyboard controls with repositioning and maximize toggles, solid window
317 drags, snap-to-border support, and virtual desktops.")
318 (license (license:x11-style "file:///README"))))
319
320 (define-public fluxbox
321 (package
322 (name "fluxbox")
323 (version "1.3.7")
324 (synopsis "Small and fast window manager")
325 (source (origin
326 (method url-fetch)
327 (uri (string-append "mirror://sourceforge/fluxbox/"
328 version "/fluxbox-" version ".tar.xz"))
329 (sha256
330 (base32
331 "1h1f70y40qd225dqx937vzb4k2cz219agm1zvnjxakn5jkz7b37w"))))
332 (build-system gnu-build-system)
333 (arguments
334 `(#:make-flags '("CPPFLAGS=-U__TIME__") ;ugly, but for reproducibility
335 #:phases
336 (modify-phases %standard-phases
337 (add-after
338 'install 'install-xsession
339 (lambda _
340 (let ((xsessions (string-append %output "/share/xsessions")))
341 (mkdir-p xsessions)
342 (call-with-output-file
343 (string-append xsessions "/fluxbox.desktop")
344 (lambda (port)
345 (format port "~
346 [Desktop Entry]~@
347 Name=~a~@
348 Comment=~a~@
349 Exec=~a/bin/startfluxbox~@
350 Type=Application~%" ,name ,synopsis %output)))))))))
351 (native-inputs
352 `(("pkg-config" ,pkg-config)))
353 (inputs
354 `(("freetype" ,freetype)
355 ("fribidi" ,fribidi)
356 ("imlib2" ,imlib2)
357 ("libx11" ,libx11)
358 ("libxext" ,libxext)
359 ("libxft" ,libxft)
360 ("libxinerama" ,libxinerama)
361 ("libxpm" ,libxpm)
362 ("libxrandr" ,libxrandr)
363 ("libxrender" ,libxrender)))
364 (description "Fluxbox is a window manager. It is light on resources
365 and easy to handle yet full of features to make an easy and fast desktop
366 experience.")
367 (home-page "http://fluxbox.org/")
368 (license license:expat)))