gnu: packages: Use 'search-patches' everywhere.
[jackhill/guix/guix.git] / gnu / packages / vtk.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages vtk)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix licenses)
24 #:use-module (guix build-system cmake)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages xorg)
27 #:use-module (gnu packages gl))
28
29 (define-public vtk
30 (package
31 (name "vtk")
32 (version "6.1.0")
33 (source (origin
34 (method url-fetch)
35 (uri (string-append "http://www.vtk.org/files/release/"
36 (substring version 0
37 (string-rindex version #\.))
38 "/VTK-" version ".tar.gz"))
39 (sha256
40 (base32
41 "0d7shccdkyj4mbh2riilslgx3gd28in4c7xpm0lxa1ln8w5g2zdx"))
42 (patches (search-patches "vtk-mesa-10.patch"))))
43 (build-system cmake-build-system)
44 (arguments
45 ;; Build without '-g' to save space.
46 '(#:configure-flags '("-DCMAKE_BUILD_TYPE=Release")
47 #:tests? #f)) ;XXX: no "test" target
48 (inputs
49 `(("libXt" ,libxt)
50 ("xproto" ,xproto)
51 ("libX11" ,libx11)
52 ("mesa" ,mesa)
53 ("glu" ,glu)))
54 (home-page "http://www.vtk.org/")
55 (synopsis "Libraries for 3D computer graphics")
56 (description
57 "The Visualization Toolkit (VTK) is a C++ library for 3D computer graphics,
58 image processing and visualization. It supports a wide variety of
59 visualization algorithms including: scalar, vector, tensor, texture, and
60 volumetric methods; and advanced modeling techniques such as: implicit
61 modeling, polygon reduction, mesh smoothing, cutting, contouring, and Delaunay
62 triangulation. VTK has an extensive information visualization framework, has
63 a suite of 3D interaction widgets, supports parallel processing, and
64 integrates with various databases on GUI toolkits such as Qt and Tk.")
65 (license bsd-3)))