gnu: packages: Use 'search-patches' everywhere.
[jackhill/guix/guix.git] / gnu / packages / lirc.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Alex Kost <alezost@gmail.com>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages lirc)
20 #:use-module (guix packages)
21 #:use-module (guix download)
22 #:use-module (guix build-system gnu)
23 #:use-module ((guix licenses) #:prefix license:)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages pkg-config)
26 #:use-module (gnu packages linux)
27 #:use-module (gnu packages xml)
28 #:use-module (gnu packages xorg)
29 #:use-module (gnu packages python))
30
31 (define-public lirc
32 (package
33 (name "lirc")
34 (version "0.9.3")
35 (source (origin
36 (method url-fetch)
37 (uri (string-append "mirror://sourceforge/lirc/lirc-"
38 version ".tar.bz2"))
39 (sha256
40 (base32
41 "19c6ldjsdnk1md66q3nb035ja1xj217k8iabhxpsb8rs10a6kwi6"))
42 (patches (search-patches "lirc-localstatedir.patch"))))
43 (build-system gnu-build-system)
44 (arguments
45 '(#:configure-flags '("--localstatedir=/var")))
46 (native-inputs
47 `(("pkg-config" ,pkg-config)
48 ("libxslt" ,libxslt)))
49 (inputs
50 `(("libx11" ,libx11)
51 ("alsa-lib" ,alsa-lib)
52 ("python" ,python)))
53 (home-page "http://www.lirc.org/")
54 (synopsis "Linux Infrared Remote Control")
55 (description
56 "LIRC allows computers to send and receive IR signals of many commonly
57 used remote controls. The most important part of LIRC is the 'lircd' daemon
58 that decodes IR signals received by the device drivers. The second daemon
59 program 'lircmd' allows to translate IR signals to mouse movements. The
60 user space applications allow you to control your computer with a remote
61 control: you can send X events to applications, start programs and much more
62 on just one button press.")
63 (license license:gpl2+)))