gnu: Add dfc.
[jackhill/guix/guix.git] / gnu / packages / libdaemon.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages libdaemon)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu))
24
25 (define-public libdaemon
26 (package
27 (name "libdaemon")
28 (version "0.14")
29 (source (origin
30 (method url-fetch)
31 (uri (string-append
32 "http://0pointer.de/lennart/projects/libdaemon/libdaemon-"
33 version
34 ".tar.gz"))
35 (sha256
36 (base32
37 "0d5qlq5ab95wh1xc87rqrh1vx6i8lddka1w3f1zcqvcqdxgyn8zx"))))
38 (build-system gnu-build-system)
39 (home-page "http://0pointer.de/lennart/projects/libdaemon/")
40 (synopsis "Lightweight C library that eases the writing of UNIX daemons")
41 (description
42 "libdaemon is a lightweight C library that eases the writing of UNIX
43 daemons. It consists of the following parts:
44
45 • A wrapper around fork() which does the correct daemonization procedure of
46 a process
47
48 • A wrapper around syslog() for simpler and compatible log output to Syslog
49 or STDERR
50
51 • An API for writing PID files
52
53 • An API for serializing UNIX signals into a pipe for usage with select() or
54 poll()
55
56 • An API for running subprocesses with STDOUT and STDERR redirected to
57 syslog.
58
59 APIs like these are used in most daemon software available. It is not that
60 simple to get it done right and code duplication is not a goal.")
61 (license lgpl2.1+)))