gnu: Add dfc.
[jackhill/guix/guix.git] / gnu / packages / gkrellm.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages gkrellm)
20 #:use-module ((guix licenses)
21 #:renamer (symbol-prefix-proc 'license:))
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module ((gnu packages gettext)
26 #:renamer (symbol-prefix-proc 'gnu:))
27 #:use-module (gnu packages gtk)
28 #:use-module (gnu packages pkg-config)
29 #:use-module (gnu packages xorg))
30
31 (define-public gkrellm
32 (package
33 (name "gkrellm")
34 (version "2.3.5")
35 (source
36 (origin
37 (method url-fetch)
38 (uri (string-append "http://members.dslextreme.com/users/billw/gkrellm/gkrellm-"
39 version ".tar.bz2"))
40 (sha256
41 (base32
42 "12rc6zaa7kb60b9744lbrlfkxxfniprm6x0mispv63h4kh75navh"))))
43 (build-system gnu-build-system)
44 (inputs
45 `(("gettext" ,gnu:gettext)
46 ("gtk+" ,gtk+)
47 ("libice" ,libice)
48 ("libsm" ,libsm)))
49 (native-inputs
50 `(("pkg-config" ,pkg-config)))
51 (arguments
52 `(#:tests? #f ; there is no check target
53 #:phases
54 (alist-delete
55 'configure
56 %standard-phases)
57 #:make-flags
58 (let ((out (assoc-ref %outputs "out")))
59 (list (string-append "INSTALLROOT=" out)
60 "CC=gcc"
61 "X11_LIBS = -lX11 -lSM -lICE -lgmodule-2.0"))))
62 (home-page "http://members.dslextreme.com/users/billw/gkrellm/gkrellm.html")
63 (synopsis "System monitors")
64 (description
65 "GKrellM is a single process stack of system monitors which supports
66 applying themes to match its appearance to your window manager, Gtk, or any
67 other theme.")
68 (license license:gpl3+)))