gnu: autogen: Update to 5.18.5.
[jackhill/guix/guix.git] / gnu / packages / autogen.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013,2014 Eric Bavier <bavier@member.fsf.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages autogen)
20 #:use-module (guix packages)
21 #:use-module (guix licenses)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages perl)
26 #:use-module (gnu packages pkg-config)
27 #:use-module (gnu packages base)
28 #:use-module (gnu packages guile))
29
30 (define-public autogen
31 (package
32 (name "autogen")
33 (version "5.18.5")
34 (source
35 (origin
36 (method url-fetch)
37 (uri (string-append "mirror://gnu/autogen/rel"
38 version "/autogen-"
39 version ".tar.gz"))
40 (sha256
41 (base32
42 "1flnbnmkbqmbfgammkl8m36wrlk6rhpgnf9pdm6gdfhqalxvggbv"))))
43 (build-system gnu-build-system)
44 (native-inputs `(("perl" ,perl) ;for doc generator mdoc
45 ("pkg-config" ,pkg-config)))
46 (inputs `(("which" ,which)
47 ("guile" ,guile-2.0)))
48 (arguments
49 '(#:phases (alist-cons-before
50 'patch-source-shebangs 'patch-test-scripts
51 (lambda _
52 (let ((sh (which "sh")))
53 (substitute*
54 (append (find-files "agen5/test" "\\.test$")
55 (find-files "autoopts/test" "\\.(test|in)$"))
56 (("/bin/sh") sh)
57 (("/usr/bin/tr") "tr"))))
58 %standard-phases)))
59 (home-page "http://www.gnu.org/software/autogen/")
60 (synopsis "Automated program generator")
61 (description
62 "AutoGen is a program to ease the maintenance of programs that contain
63 large amounts of repetitive text. It automates the construction of these
64 sections of the code, simplifying the task of keeping the text in sync. It
65 also includes an add-on package called AutoOpts, which is specialized for the
66 maintenance and documentation of program options.")
67 (license gpl3+)))