gnu: gd: Fix-CVE-2016-3074.
[jackhill/guix/guix.git] / gnu / packages / patches / binutils-ld-new-dtags.patch
1 Turn on --enable-new-dtags by default to make the linker set RUNPATH
2 instead of RPATH on binaries. This is important because RUNPATH can
3 be overriden using LD_LIBRARY_PATH at runtime.
4
5 Patch from Nixpkgs by Eelco Dolstra <eelco.dolstra@logicblox.com>.
6
7 --- binutils/ld/ldmain.c
8 +++ binutils/ld/ldmain.c
9 @@ -296,6 +296,7 @@ main (int argc, char **argv)
10
11 link_info.allow_undefined_version = TRUE;
12 link_info.keep_memory = TRUE;
13 + link_info.new_dtags = TRUE;
14 link_info.combreloc = TRUE;
15 link_info.strip_discarded = TRUE;
16 link_info.callbacks = &link_callbacks;