gnu: Add clutter.
[jackhill/guix/guix.git] / gnu / packages / gnucash.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages gnucash)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages gnome)
26 #:use-module (gnu packages glib)
27 #:use-module (gnu packages gtk)
28 #:use-module (gnu packages guile)
29 #:use-module (gnu packages icu4c)
30 #:use-module (gnu packages pkg-config)
31 #:use-module (gnu packages webkit)
32 #:use-module (gnu packages xml))
33
34 (define-public gnucash
35 (package
36 (name "gnucash")
37 (version "2.6.6")
38 (source
39 (origin
40 (method url-fetch)
41 (uri (string-append "mirror://sourceforge/gnucash/gnucash-"
42 version ".tar.bz2"))
43 (sha256
44 (base32
45 "103ir5qg6k8m2mmg9b99c3gn8myxh1gsqyr0mfhmrhqya68wfdr3"))))
46 (build-system gnu-build-system)
47 (arguments
48 `(#:tests? #f ;FIXME: failing at /qof/gnc-date/qof print date dmy buff
49 #:configure-flags '("--disable-dbi")))
50 (inputs
51 `(("guile" ,guile-2.0)
52 ("icu4c" ,icu4c)
53 ("glib" ,glib)
54 ("gtk" ,gtk+-2)
55 ("goffice" ,goffice-0.8)
56 ("libgnomecanvas" ,libgnomecanvas)
57 ("libxml2" ,libxml2)
58 ("libxslt" ,libxslt)
59 ("webkitgtk" ,webkitgtk/gtk+-2)))
60 (native-inputs
61 `(("glib" ,glib "bin") ; glib-compile-schemas, etc.
62 ("intltool" ,intltool)
63 ("pkg-config" ,pkg-config)))
64 (home-page "https://gnu.org/software/gnucash")
65 (synopsis "Personal and small business financial accounting software")
66 (description
67 "GnuCash is personal and professional financial-accounting software.
68 It can be used to track bank accounts, stocks, income and expenses, based on
69 the double-entry accounting practice. It includes support for QIF/OFX/HBCI
70 import and transaction matching. It also automates several tasks, such as
71 financial calculations or scheduled transactions.")
72 (license gpl3+)))