gnu: Add clutter.
[jackhill/guix/guix.git] / gnu / packages / curl.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2015 Tomáš Čech <sleep_walker@suse.cz>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages curl)
22 #:use-module ((guix licenses) #:prefix license:)
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix build-system gnu)
26 #:use-module (gnu packages)
27 #:use-module (gnu packages compression)
28 #:use-module (gnu packages gnutls)
29 #:use-module (gnu packages groff)
30 #:use-module (gnu packages gsasl)
31 #:use-module (gnu packages libidn)
32 #:use-module (gnu packages openldap)
33 #:use-module (gnu packages perl)
34 #:use-module (gnu packages pkg-config)
35 #:use-module (gnu packages python)
36 #:use-module (gnu packages ssh))
37
38 (define-public curl
39 (package
40 (name "curl")
41 (version "7.42.1")
42 (source (origin
43 (method url-fetch)
44 (uri (string-append "http://curl.haxx.se/download/curl-"
45 version ".tar.lzma"))
46 (sha256
47 (base32
48 "0ircrhi4i9iviq0d9044rq288sdrww19d0ci6vmb4fh8nmm1jv1x"))))
49 (build-system gnu-build-system)
50 (inputs `(("gnutls" ,gnutls)
51 ("gss" ,gss)
52 ("libidn" ,libidn)
53 ("libssh2" ,libssh2)
54 ("openldap" ,openldap)
55 ("zlib" ,zlib)))
56 (native-inputs
57 `(("perl" ,perl)
58 ;; to enable the --manual option and make test 1026 pass
59 ("groff" ,groff)
60 ("pkg-config" ,pkg-config)
61 ("python" ,python-2)))
62 (arguments
63 `(#:configure-flags '("--with-gnutls" "--with-gssapi")
64 ;; Add a phase to patch '/bin/sh' occurances in tests/runtests.pl
65 #:phases
66 (alist-replace
67 'check
68 (lambda _
69 (substitute* "tests/runtests.pl"
70 (("/bin/sh") (which "sh")))
71 ;; Test #1135 requires extern-scan.pl, which is not part of the
72 ;; tarball due to a mistake. It has been fixed upstream. We can
73 ;; simply disable the test as it is specific to VMS and OS/400.
74 (delete-file "tests/data/test1135")
75
76 ;; The top-level "make check" does "make -C tests quiet-test", which
77 ;; is too quiet. Use the "test" target instead, which is more
78 ;; verbose.
79 (zero? (system* "make" "-C" "tests" "test")))
80 %standard-phases)))
81 (synopsis "Command line tool for transferring data with URL syntax")
82 (description
83 "curl is a command line tool for transferring data with URL syntax,
84 supporting DICT, FILE, FTP, FTPS, Gopher, HTTP, HTTPS, IMAP, IMAPS, LDAP,
85 LDAPS, POP3, POP3S, RTMP, RTSP, SCP, SFTP, SMTP, SMTPS, Telnet and TFTP.
86 curl supports SSL certificates, HTTP POST, HTTP PUT, FTP uploading,
87 HTTP form based upload, proxies, cookies, user+password authentication
88 (Basic, Digest, NTLM, Negotiate, kerberos...), file transfer resume,
89 proxy tunneling, and so on")
90 (license (license:non-copyleft "file://COPYING"
91 "See COPYING in the distribution."))
92 (home-page "http://curl.haxx.se/")))