gnu: retroarch: Use shared zlib.
[jackhill/guix/guix.git] / gnu / packages / conkeror.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Cyrill Schenkel <cyrill.schenkel@gmail.com>
3 ;;; Copyright © 2014, 2015 Eric Bavier <bavier@member.fsf.org>
4 ;;; Copyright © 2016 John J. Foerch <jjfoerch@earthlink.net>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages conkeror)
22 #:use-module ((guix licenses) #:prefix license:)
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix build-system gnu)
26 #:use-module (gnu packages)
27 #:use-module (gnu packages gnuzilla))
28
29 (define-public conkeror
30 (package
31 (name "conkeror")
32 (version "1.1.0")
33 (source (origin
34 (method url-fetch)
35 (uri
36 (string-append "http://repo.or.cz/conkeror.git/snapshot/"
37 version ".tar.gz"))
38 (file-name (string-append name "-" version ".tar.gz"))
39 (sha256
40 (base32
41 "0jz216mjwis7f03j98s4wkcrrq2j3f41fb2y47a5qszc340zhdzv"))))
42 (build-system gnu-build-system)
43 (inputs `(("icecat" ,icecat)))
44 (arguments
45 `(#:tests? #f ;no tests
46 #:make-flags `("CC=gcc"
47 ,(string-append "PREFIX=" (assoc-ref %outputs "out")))
48 #:phases
49 (modify-phases %standard-phases
50 (delete 'configure)
51 (add-after
52 'install 'install-app-launcher
53 (lambda* (#:key inputs outputs #:allow-other-keys)
54 ;; This overwrites the installed launcher, which execs xulrunner,
55 ;; with one that execs 'icecat --app'
56 (let* ((out (assoc-ref outputs "out"))
57 (datadir (string-append out "/share/conkeror"))
58 (launcher (string-append out "/bin/conkeror")))
59 (call-with-output-file launcher
60 (lambda (p)
61 (format p "#!~a/bin/bash
62 exec ~a/bin/icecat --app ~a \"$@\"~%"
63 (assoc-ref inputs "bash") ;implicit input
64 (assoc-ref inputs "icecat")
65 (string-append datadir
66 "/application.ini"))))
67 (chmod launcher #o555)))))))
68 (synopsis "Keyboard focused web browser with Emacs look and feel")
69 (description "Conkeror is a highly-programmable web browser based on
70 Mozilla XULRunner which is the base of all Mozilla products including Firefox.
71 Conkeror has a sophisticated keyboard system for running commands and
72 interacting with web page content, modelled after Emacs and Lynx. It is
73 self-documenting and extensible with JavaScript.
74
75 It comes with builtin support for several Web 2.0 sites like several Google
76 services (Search, Gmail, Maps, Reader, etc.), Del.icio.us, Reddit, Last.fm and
77 YouTube. For easier editing of form fields, it can spawn external editors.")
78 (home-page "http://conkeror.org")
79 ;; Conkeror is triple licensed.
80 (license (list
81 ;; MPL 1.1 -- this license is not GPL compatible
82 license:gpl2
83 license:lgpl2.1))))