gnu: cvs-fast-export: Update to 1.56.
[jackhill/guix/guix.git] / gnu / packages / tryton.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2017 Adriano Peluso <catonano@gmail.com>
3 ;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages tryton)
21 #:use-module ((guix licenses) #:prefix license:)
22 #:use-module (gnu packages)
23 #:use-module (gnu packages check)
24 #:use-module (gnu packages databases)
25 #:use-module (gnu packages finance)
26 #:use-module (gnu packages glib)
27 #:use-module (gnu packages gnome)
28 #:use-module (gnu packages gtk)
29 #:use-module (gnu packages python)
30 #:use-module (gnu packages python-crypto)
31 #:use-module (gnu packages python-web)
32 #:use-module (gnu packages python-xyz)
33 #:use-module (gnu packages time)
34 #:use-module (gnu packages xml)
35 #:use-module (guix packages)
36 #:use-module (guix download)
37 #:use-module (guix utils)
38 #:use-module (guix build-system python))
39
40 (define-public trytond
41 (package
42 (name "trytond")
43 (version "5.8.2")
44 (source
45 (origin
46 (method url-fetch)
47 (uri (pypi-uri "trytond" version))
48 (sha256
49 (base32 "1h1x0cmmmxvjclbglvvxkv634jw6av5ilymbix1lln5lq0gd39yy"))))
50 (build-system python-build-system)
51 (inputs
52 `(("python-dateutil" ,python-dateutil)
53 ("python-genshi" ,python-genshi)
54 ("python-lxml" ,python-lxml)
55 ("python-magic" ,python-magic)
56 ("python-passlib" ,python-passlib)
57 ("python-polib" ,python-polib)
58 ("python-psycopg2" ,python-psycopg2)
59 ("python-relatorio" ,python-relatorio)
60 ("python-sql" ,python-sql)
61 ("python-werkzeug" ,python-werkzeug)
62 ("python-wrapt" ,python-wrapt)))
63 (native-inputs
64 `(("python-mock" ,python-mock)))
65 (arguments
66 `(#:phases
67 (modify-phases %standard-phases
68 (add-before 'check 'preparations
69 (lambda _
70 (setenv "DB_NAME" ":memory:")
71 (setenv "HOME" "/tmp")
72 #t)))))
73 (home-page "https://www.tryton.org/")
74 (synopsis "Tryton Server")
75 (description "Tryton is a three-tier high-level general purpose
76 application platform using PostgreSQL as its main database engine. It is the
77 core base of a complete business solution providing modularity, scalability
78 and security.")
79 (license license:gpl3+)))
80
81 (define-public python-trytond
82 (deprecated-package "python-trytond" trytond))
83
84 (define-public tryton
85 (package
86 (name "tryton")
87 (version "5.8.2")
88 (source
89 (origin
90 (method url-fetch)
91 (uri (pypi-uri "tryton" version))
92 (sha256
93 (base32 "0kr5ngmmldgb9a9d5ylkmppy5p8vlf9d8iwv9lnci2fyxg2705wh"))))
94 (build-system python-build-system)
95 (arguments
96 `(#:phases
97 (modify-phases %standard-phases
98 (add-before 'check 'change-home
99 (lambda _
100 ;; Change from /homeless-shelter to /tmp for write permission.
101 (setenv "HOME" "/tmp")))
102 (add-after 'install 'wrap-gi-python
103 (lambda* (#:key inputs outputs #:allow-other-keys)
104 (let ((out (assoc-ref outputs "out"))
105 (gi-typelib-path (getenv "GI_TYPELIB_PATH")))
106 (wrap-program (string-append out "/bin/tryton")
107 `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))))
108 #t)))))
109 (native-inputs
110 `(("glib-compile-schemas" ,glib "bin")
111 ("gobject-introspection" ,gobject-introspection)))
112 (inputs
113 `(("gdk-pixbuf" ,gdk-pixbuf+svg)
114 ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
115 ("gtk+" ,gtk+)
116 ("python-dateutil" ,python-dateutil)
117 ("python-pycairo" ,python-pycairo)
118 ("python-pygobject" ,python-pygobject)))
119 (home-page "https://www.tryton.org/")
120 (synopsis "Tryton Client")
121 (description
122 "This package provides the Tryton GTK client.")
123 (license license:gpl3+)))
124
125 (define-public python-proteus
126 (package
127 (name "python-proteus")
128 (version "5.8.1")
129 (source
130 (origin
131 (method url-fetch)
132 (uri (pypi-uri "proteus" version))
133 (sha256
134 (base32 "03z5ssvjcvxv1p10y7c1y0jah0k3yyc9hlyi7xax98sfqyk13bnw"))))
135 (build-system python-build-system)
136 ;; Tests require python-trytond-party which requires python-proteus.
137 (arguments
138 `(#:tests? #f))
139 (propagated-inputs
140 `(("python-dateutil" ,python-dateutil)))
141 (home-page "http://www.tryton.org/")
142 (synopsis "Library to access a Tryton server as a client")
143 (description
144 "This package provides a library to access Tryton server as a client.")
145 (license license:lgpl3+)))
146
147 ;;;
148 ;;; Tryton modules - please sort alphabetically
149 ;;;
150
151 (define-public python-trytond-account
152 (package
153 (name "python-trytond-account")
154 (version "5.8.1")
155 (source
156 (origin
157 (method url-fetch)
158 (uri (pypi-uri "trytond_account" version))
159 (sha256
160 (base32 "16ny67vcnxk9ngcxd56cfixm441vs9jxv3apmb16xsi47yk2xd7w"))))
161 (build-system python-build-system)
162 (arguments
163 `(#:phases
164 (modify-phases %standard-phases
165 (replace 'check
166 (let ((runtest
167 (string-append
168 (assoc-ref %build-inputs "trytond")
169 "/lib/python"
170 ,(version-major+minor (package-version python))
171 "/site-packages/trytond/tests/run-tests.py")))
172 (lambda* (#:key inputs outputs #:allow-other-keys)
173 (add-installed-pythonpath inputs outputs)
174 (invoke "python" runtest "-m" "account")))))))
175 (native-inputs
176 `(("python-genshi" ,python-genshi)
177 ("python-lxml" ,python-lxml)
178 ("python-magic" ,python-magic)
179 ("python-passlib" ,python-passlib)
180 ("python-polib" ,python-polib)
181 ("python-proteus" ,python-proteus)
182 ("python-relatorio" ,python-relatorio)
183 ("python-werkzeug" ,python-werkzeug)
184 ("python-wrapt" ,python-wrapt)))
185 (propagated-inputs
186 `(("python-dateutil" ,python-dateutil)
187 ("python-simpleeval" ,python-simpleeval)
188 ("python-sql" ,python-sql)
189 ("python-trytond-company"
190 ,python-trytond-company)
191 ("python-trytond-currency"
192 ,python-trytond-currency)
193 ("python-trytond-party" ,python-trytond-party)
194 ("trytond" ,trytond)))
195 (home-page "https://www.tryton.org/")
196 (synopsis "Tryton module for accounting")
197 (description
198 "This package provides a Tryton module that defines the fundamentals for
199 most of accounting needs.")
200 (license license:gpl3+)))
201
202 (define-public python-trytond-account-invoice
203 (package
204 (name "python-trytond-account-invoice")
205 (version "5.8.1")
206 (source
207 (origin
208 (method url-fetch)
209 (uri (pypi-uri "trytond_account_invoice" version))
210 (sha256
211 (base32 "0drccambg6855p7ai8654c7f9v85jzwicwpxmagyrr09qz6qzgcz"))))
212 (build-system python-build-system)
213 (arguments
214 `(#:phases
215 (modify-phases %standard-phases
216 (replace 'check
217 (let ((runtest
218 (string-append
219 (assoc-ref %build-inputs "trytond")
220 "/lib/python"
221 ,(version-major+minor (package-version python))
222 "/site-packages/trytond/tests/run-tests.py")))
223 (lambda* (#:key inputs outputs #:allow-other-keys)
224 (add-installed-pythonpath inputs outputs)
225 (invoke "python" runtest "-m" "account_invoice")))))))
226 (native-inputs
227 `(("python-genshi" ,python-genshi)
228 ("python-lxml" ,python-lxml)
229 ("python-magic" ,python-magic)
230 ("python-passlib" ,python-passlib)
231 ("python-polib" ,python-polib)
232 ("python-proteus" ,python-proteus)
233 ("python-relatorio" ,python-relatorio)
234 ("python-werkzeug" ,python-werkzeug)
235 ("python-wrapt" ,python-wrapt)))
236 (propagated-inputs
237 `(("python-dateutil" ,python-dateutil)
238 ("python-sql" ,python-sql)
239 ("python-trytond-account"
240 ,python-trytond-account)
241 ("python-trytond-account-product"
242 ,python-trytond-account-product)
243 ("python-trytond-company"
244 ,python-trytond-company)
245 ("python-trytond-currency"
246 ,python-trytond-currency)
247 ("python-trytond-party" ,python-trytond-party)
248 ("python-trytond-product"
249 ,python-trytond-product)
250 ("trytond" ,trytond)))
251 (home-page "https://www.tryton.org/")
252 (synopsis "Tryton module for invoicing")
253 (description
254 "This package provides a Tryton module that adds the invoice, payment
255 term.")
256 (license license:gpl3+)))
257
258 (define-public python-trytond-account-invoice-stock
259 (package
260 (name "python-trytond-account-invoice-stock")
261 (version "5.8.1")
262 (source
263 (origin
264 (method url-fetch)
265 (uri (pypi-uri
266 "trytond_account_invoice_stock"
267 version))
268 (sha256
269 (base32 "02m6ikcc38ac41ddzg5xp5l9jz0k6j7j1g2xa62ki4v093yn4z5v"))))
270 (build-system python-build-system)
271 (arguments
272 `(#:phases
273 (modify-phases %standard-phases
274 (replace 'check
275 (let ((runtest
276 (string-append
277 (assoc-ref %build-inputs "trytond")
278 "/lib/python"
279 ,(version-major+minor (package-version python))
280 "/site-packages/trytond/tests/run-tests.py")))
281 (lambda* (#:key inputs outputs #:allow-other-keys)
282 (add-installed-pythonpath inputs outputs)
283 (invoke "python" runtest "-m" "account_invoice_stock")))))))
284 (native-inputs
285 `(("python-dateutil" ,python-dateutil)
286 ("python-genshi" ,python-genshi)
287 ("python-lxml" ,python-lxml)
288 ("python-magic" ,python-magic)
289 ("python-passlib" ,python-passlib)
290 ("python-polib" ,python-polib)
291 ("python-proteus" ,python-proteus)
292 ("python-relatorio" ,python-relatorio)
293 ("python-sql" ,python-sql)
294 ("python-werkzeug" ,python-werkzeug)
295 ("python-wrapt" ,python-wrapt)))
296 (propagated-inputs
297 `(("python-trytond-account-invoice"
298 ,python-trytond-account-invoice)
299 ("python-trytond-product"
300 ,python-trytond-product)
301 ("python-trytond-stock" ,python-trytond-stock)
302 ("trytond" ,trytond)))
303 (home-page "https://www.tryton.org/")
304 (synopsis "Tryton module to link stock and invoice")
305 (description
306 "This package provides a Tryton module that adds link between invoice
307 lines and stock moves. The unit price of the stock move is updated with the
308 average price of the posted invoice lines that are linked to it.")
309 (license license:gpl3+)))
310
311 (define-public python-trytond-account-product
312 (package
313 (name "python-trytond-account-product")
314 (version "5.8.1")
315 (source
316 (origin
317 (method url-fetch)
318 (uri (pypi-uri "trytond_account_product" version))
319 (sha256
320 (base32 "10bpbkkmllbh9lm5ajydmc5nvqm9bbdn9rmm03jqgik23s5kyx2z"))))
321 (build-system python-build-system)
322 (arguments
323 `(#:phases
324 (modify-phases %standard-phases
325 (replace 'check
326 (let ((runtest
327 (string-append
328 (assoc-ref %build-inputs "trytond")
329 "/lib/python"
330 ,(version-major+minor (package-version python))
331 "/site-packages/trytond/tests/run-tests.py")))
332 (lambda* (#:key inputs outputs #:allow-other-keys)
333 (add-installed-pythonpath inputs outputs)
334 (invoke "python" runtest "-m" "account_product")))))))
335 (native-inputs
336 `(("python-dateutil" ,python-dateutil)
337 ("python-genshi" ,python-genshi)
338 ("python-lxml" ,python-lxml)
339 ("python-magic" ,python-magic)
340 ("python-passlib" ,python-passlib)
341 ("python-polib" ,python-polib)
342 ("python-proteus" ,python-proteus)
343 ("python-relatorio" ,python-relatorio)
344 ("python-sql" ,python-sql)
345 ("python-werkzeug" ,python-werkzeug)
346 ("python-wrapt" ,python-wrapt)))
347 (propagated-inputs
348 `(("python-trytond-account"
349 ,python-trytond-account)
350 ("python-trytond-analytic-account"
351 ,python-trytond-analytic-account)
352 ("python-trytond-company"
353 ,python-trytond-company)
354 ("python-trytond-product"
355 ,python-trytond-product)
356 ("trytond" ,trytond)))
357 (home-page "https://www.tryton.org/")
358 (synopsis "Tryton module to add accounting on product")
359 (description
360 "This package provides a Tryton module that adds accounting on product
361 and category.")
362 (license license:gpl3+)))
363
364 (define-public python-trytond-analytic-account
365 (package
366 (name "python-trytond-analytic-account")
367 (version "5.8.1")
368 (source
369 (origin
370 (method url-fetch)
371 (uri (pypi-uri "trytond_analytic_account" version))
372 (sha256
373 (base32 "10rn2rf1ji7d1gxmgca368yvabql1ahklqg7p8sh5bl79vn5qx5x"))))
374 (build-system python-build-system)
375 (arguments
376 `(#:phases
377 (modify-phases %standard-phases
378 (replace 'check
379 (let ((runtest
380 (string-append
381 (assoc-ref %build-inputs "trytond")
382 "/lib/python"
383 ,(version-major+minor (package-version python))
384 "/site-packages/trytond/tests/run-tests.py")))
385 (lambda* (#:key inputs outputs #:allow-other-keys)
386 (add-installed-pythonpath inputs outputs)
387 (invoke "python" runtest "-m" "analytic_account")))))))
388 (native-inputs
389 `(("python-dateutil" ,python-dateutil)
390 ("python-genshi" ,python-genshi)
391 ("python-lxml" ,python-lxml)
392 ("python-magic" ,python-magic)
393 ("python-passlib" ,python-passlib)
394 ("python-polib" ,python-polib)
395 ("python-proteus" ,python-proteus)
396 ("python-relatorio" ,python-relatorio)
397 ("python-werkzeug" ,python-werkzeug)
398 ("python-wrapt" ,python-wrapt)))
399 (propagated-inputs
400 `(("python-sql" ,python-sql)
401 ("python-trytond-account"
402 ,python-trytond-account)
403 ("python-trytond-company"
404 ,python-trytond-company)
405 ("python-trytond-currency"
406 ,python-trytond-currency)
407 ("python-trytond-party" ,python-trytond-party)
408 ("trytond" ,trytond)))
409 (home-page "https://www.tryton.org/")
410 (synopsis "Tryton module for analytic accounting")
411 (description
412 "This package provides a Tryton module that adds the fundamentals
413 required to analyse accounting using multiple different axes.")
414 (license license:gpl3+)))
415
416 (define-public python-trytond-company
417 (package
418 (name "python-trytond-company")
419 (version "5.8.1")
420 (source
421 (origin
422 (method url-fetch)
423 (uri (pypi-uri "trytond_company" version))
424 (sha256
425 (base32 "1bwy2rkgfw32cwhq5fh3rpy7bx425h44ap10i9kjx5ak86bfnpz9"))))
426 (build-system python-build-system)
427 (arguments
428 `(#:phases
429 (modify-phases %standard-phases
430 (replace 'check
431 (let ((runtest
432 (string-append
433 (assoc-ref %build-inputs "trytond")
434 "/lib/python"
435 ,(version-major+minor (package-version python))
436 "/site-packages/trytond/tests/run-tests.py")))
437 (lambda* (#:key inputs outputs #:allow-other-keys)
438 (add-installed-pythonpath inputs outputs)
439 (invoke "python" runtest "-m" "company")))))))
440 (native-inputs
441 `(("python-dateutil" ,python-dateutil)
442 ("python-genshi" ,python-genshi)
443 ("python-lxml" ,python-lxml)
444 ("python-magic" ,python-magic)
445 ("python-passlib" ,python-passlib)
446 ("python-polib" ,python-polib)
447 ("python-proteus" ,python-proteus)
448 ("python-relatorio" ,python-relatorio)
449 ("python-sql" ,python-sql)
450 ("python-werkzeug" ,python-werkzeug)
451 ("python-wrapt" ,python-wrapt)))
452 (propagated-inputs
453 `(("python-trytond-currency"
454 ,python-trytond-currency)
455 ("python-trytond-party" ,python-trytond-party)
456 ("trytond" ,trytond)))
457 (home-page "https://www.tryton.org/")
458 (synopsis "Tryton module with companies and employees")
459 (description
460 "This package provides a Tryton module that defines the concepts of
461 company and employee and extend the user model.")
462 (license license:gpl3+)))
463
464 (define-public python-trytond-country
465 (package
466 (name "python-trytond-country")
467 (version "5.8.1")
468 (source
469 (origin
470 (method url-fetch)
471 (uri (pypi-uri "trytond_country" version))
472 (sha256
473 (base32 "1lkspk5w5pb0gg2h27zb7vwcj993gkm1f84qdxmqlpkc8raqvicj"))))
474 (build-system python-build-system)
475 (arguments
476 `(#:phases
477 (modify-phases %standard-phases
478 (replace 'check
479 (let ((runtest
480 (string-append
481 (assoc-ref %build-inputs "trytond")
482 "/lib/python"
483 ,(version-major+minor (package-version python))
484 "/site-packages/trytond/tests/run-tests.py")))
485 (lambda* (#:key inputs outputs #:allow-other-keys)
486 (add-installed-pythonpath inputs outputs)
487 ;; Doctest contains one test that requires internet access.
488 (invoke "python" runtest "-m" "country" "--no-doctest")))))))
489 (native-inputs
490 `(("python-dateutil" ,python-dateutil)
491 ("python-genshi" ,python-genshi)
492 ("python-lxml" ,python-lxml)
493 ("python-magic" ,python-magic)
494 ("python-passlib" ,python-passlib)
495 ("python-polib" ,python-polib)
496 ("python-proteus" ,python-proteus)
497 ("python-relatorio" ,python-relatorio)
498 ("python-sql" ,python-sql)
499 ("python-werkzeug" ,python-werkzeug)
500 ("python-wrapt" ,python-wrapt)))
501 (propagated-inputs
502 `(("python-pycountry" ,python-pycountry)
503 ("trytond" ,trytond)))
504 (home-page "http://www.tryton.org/")
505 (synopsis "Tryton module with countries")
506 (description
507 "This package provides a Tryton module with countries.")
508 (license license:gpl3+)))
509
510 (define-public python-trytond-currency
511 (package
512 (name "python-trytond-currency")
513 (version "5.8.1")
514 (source
515 (origin
516 (method url-fetch)
517 (uri (pypi-uri "trytond_currency" version))
518 (sha256
519 (base32 "0b5p7ibil7nlsv7f31j69rka4xj5za798262algx7xa88a6h7mmx"))))
520 (build-system python-build-system)
521 (arguments
522 `(#:phases
523 (modify-phases %standard-phases
524 (replace 'check
525 (let ((runtest
526 (string-append
527 (assoc-ref %build-inputs "trytond")
528 "/lib/python"
529 ,(version-major+minor (package-version python))
530 "/site-packages/trytond/tests/run-tests.py")))
531 (lambda* (#:key inputs outputs #:allow-other-keys)
532 (add-installed-pythonpath inputs outputs)
533 (invoke "python" runtest "-m" "currency")))))))
534 (native-inputs
535 `(("python-dateutil" ,python-dateutil)
536 ("python-genshi" ,python-genshi)
537 ("python-forex-python" ,python-forex-python)
538 ("python-lxml" ,python-lxml)
539 ("python-magic" ,python-magic)
540 ("python-passlib" ,python-passlib)
541 ("python-polib" ,python-polib)
542 ("python-proteus" ,python-proteus)
543 ("python-pycountry" ,python-pycountry)
544 ("python-relatorio" ,python-relatorio)
545 ("python-werkzeug" ,python-werkzeug)
546 ("python-wrapt" ,python-wrapt)))
547 (propagated-inputs
548 `(("python-sql" ,python-sql)
549 ("trytond" ,trytond)))
550 (home-page "https://www.tryton.org/")
551 (synopsis "Tryton module with currencies")
552 (description
553 "This package provides a Tryton module that defines the concepts of
554 currency and rate.")
555 (license license:gpl3+)))
556
557 (define-public python-trytond-party
558 (package
559 (name "python-trytond-party")
560 (version "5.8.1")
561 (source
562 (origin
563 (method url-fetch)
564 (uri (pypi-uri "trytond_party" version))
565 (sha256
566 (base32 "1hapfq7ip99s4qp9xra1m40q4n379p9pmfnz2x4ggd79ss76bghc"))))
567 (build-system python-build-system)
568 (arguments
569 `(#:phases
570 (modify-phases %standard-phases
571 (replace 'check
572 (let ((runtest
573 (string-append
574 (assoc-ref %build-inputs "trytond")
575 "/lib/python"
576 ,(version-major+minor (package-version python))
577 "/site-packages/trytond/tests/run-tests.py")))
578 (lambda* (#:key inputs outputs #:allow-other-keys)
579 (add-installed-pythonpath inputs outputs)
580 ;; Doctest 'scenario_party_phone_number.rst' fails.
581 (invoke "python" runtest "-m" "party" "--no-doctest")))))))
582 (native-inputs
583 `(("python-dateutil" ,python-dateutil)
584 ("python-genshi" ,python-genshi)
585 ("python-lxml" ,python-lxml)
586 ("python-magic" ,python-magic)
587 ("python-passlib" ,python-passlib)
588 ("python-polib" ,python-polib)
589 ("python-proteus" ,python-proteus)
590 ("python-relatorio" ,python-relatorio)
591 ("python-werkzeug" ,python-werkzeug)
592 ("python-wrapt" ,python-wrapt)))
593 (propagated-inputs
594 `(("python-sql" ,python-sql)
595 ("python-stnum" ,python-stdnum)
596 ("python-trytond-country" ,python-trytond-country)
597 ("trytond" ,trytond)))
598 (home-page "https://www.tryton.org/")
599 (synopsis "Tryton module for parties and addresses")
600 (description
601 "This package provides a Tryton module for (counter)parties and
602 addresses.")
603 (license license:gpl3+)))
604
605 (define-public python-trytond-product
606 (package
607 (name "python-trytond-product")
608 (version "5.8.1")
609 (source
610 (origin
611 (method url-fetch)
612 (uri (pypi-uri "trytond_product" version))
613 (sha256
614 (base32 "0x18ngpjyrdwjwg17bz98jph4jv5gcv0qc0p2kxpam4lqsy34ic2"))))
615 (build-system python-build-system)
616 (arguments
617 `(#:phases
618 (modify-phases %standard-phases
619 (replace 'check
620 (let ((runtest
621 (string-append
622 (assoc-ref %build-inputs "trytond")
623 "/lib/python"
624 ,(version-major+minor (package-version python))
625 "/site-packages/trytond/tests/run-tests.py")))
626 (lambda* (#:key inputs outputs #:allow-other-keys)
627 (add-installed-pythonpath inputs outputs)
628 (invoke "python" runtest "-m" "product")))))))
629 (native-inputs
630 `(("python-dateutil" ,python-dateutil)
631 ("python-genshi" ,python-genshi)
632 ("python-lxml" ,python-lxml)
633 ("python-magic" ,python-magic)
634 ("python-passlib" ,python-passlib)
635 ("python-polib" ,python-polib)
636 ("python-proteus" ,python-proteus)
637 ("python-relatorio" ,python-relatorio)
638 ("python-werkzeug" ,python-werkzeug)
639 ("python-wrapt" ,python-wrapt)))
640 (propagated-inputs
641 `(("python-sql" ,python-sql)
642 ("python-stdnum" ,python-stdnum)
643 ("python-trytond-company"
644 ,python-trytond-company)
645 ("trytond" ,trytond)))
646 (home-page "https://www.tryton.org/")
647 (synopsis "Tryton module with products")
648 (description
649 "This package provides a Tryton module that defines two concepts: Product
650 Template and Product.")
651 (license license:gpl3+)))
652
653 (define-public python-trytond-purchase
654 (package
655 (name "python-trytond-purchase")
656 (version "5.8.1")
657 (source
658 (origin
659 (method url-fetch)
660 (uri (pypi-uri "trytond_purchase" version))
661 (sha256
662 (base32 "0na74zijj46b12gypy9si3las02a96rh5ygl503c7razha61g1b0"))))
663 (build-system python-build-system)
664 (arguments
665 `(#:phases
666 (modify-phases %standard-phases
667 (replace 'check
668 (let ((runtest
669 (string-append
670 (assoc-ref %build-inputs "trytond")
671 "/lib/python"
672 ,(version-major+minor (package-version python))
673 "/site-packages/trytond/tests/run-tests.py")))
674 (lambda* (#:key inputs outputs #:allow-other-keys)
675 (add-installed-pythonpath inputs outputs)
676 (invoke "python" runtest "-m" "purchase")))))))
677 (native-inputs
678 `(("python-dateutil" ,python-dateutil)
679 ("python-genshi" ,python-genshi)
680 ("python-lxml" ,python-lxml)
681 ("python-magic" ,python-magic)
682 ("python-passlib" ,python-passlib)
683 ("python-polib" ,python-polib)
684 ("python-proteus" ,python-proteus)
685 ("python-relatorio" ,python-relatorio)
686 ("python-werkzeug" ,python-werkzeug)
687 ("python-wrapt" ,python-wrapt)))
688 (propagated-inputs
689 `(("python-sql" ,python-sql)
690 ("python-trytond-account"
691 ,python-trytond-account)
692 ("python-trytond-account-invoice"
693 ,python-trytond-account-invoice)
694 ("python-trytond-account-invoice-stock"
695 ,python-trytond-account-invoice-stock)
696 ("python-trytond-account-product"
697 ,python-trytond-account-product)
698 ("python-trytond-company"
699 ,python-trytond-company)
700 ("python-trytond-currency"
701 ,python-trytond-currency)
702 ("python-trytond-party" ,python-trytond-party)
703 ("python-trytond-product"
704 ,python-trytond-product)
705 ("python-trytond-stock" ,python-trytond-stock)
706 ("trytond" ,trytond)))
707 (home-page "https://www.tryton.org/")
708 (synopsis "Tryton module for purchase")
709 (description
710 "This package provides a Tryton module that defines the Purchase model.")
711 (license license:gpl3+)))
712
713 (define-public python-trytond-purchase-request
714 (package
715 (name "python-trytond-purchase-request")
716 (version "5.8.1")
717 (source
718 (origin
719 (method url-fetch)
720 (uri (pypi-uri "trytond_purchase_request" version))
721 (sha256
722 (base32 "1m92snnvgisnv083nml6cz5qgnfdg539rd5bwg3lqrknm7343w16"))))
723 (build-system python-build-system)
724 (arguments
725 `(#:phases
726 (modify-phases %standard-phases
727 (replace 'check
728 (let ((runtest
729 (string-append
730 (assoc-ref %build-inputs "trytond")
731 "/lib/python"
732 ,(version-major+minor (package-version python))
733 "/site-packages/trytond/tests/run-tests.py")))
734 (lambda* (#:key inputs outputs #:allow-other-keys)
735 (add-installed-pythonpath inputs outputs)
736 ;; Doctest 'scenario_purchase_request.rst' fails.
737 (invoke "python" runtest
738 "-m" "purchase_request" "--no-doctest")))))))
739 (native-inputs
740 `(("python-dateutil" ,python-dateutil)
741 ("python-genshi" ,python-genshi)
742 ("python-lxml" ,python-lxml)
743 ("python-magic" ,python-magic)
744 ("python-passlib" ,python-passlib)
745 ("python-polib" ,python-polib)
746 ("python-proteus" ,python-proteus)
747 ("python-relatorio" ,python-relatorio)
748 ("python-sql" ,python-sql)
749 ("python-werkzeug" ,python-werkzeug)
750 ("python-wrapt" ,python-wrapt)))
751 (propagated-inputs
752 `(("python-trytond-product"
753 ,python-trytond-product)
754 ("python-trytond-purchase"
755 ,python-trytond-purchase)
756 ("trytond" ,trytond)))
757 (home-page "https://www.tryton.org/")
758 (synopsis "Tryton module for purchase requests")
759 (description
760 "This package provides a Tryton module that introduces the concept of
761 Purchase Requests which are central points to collect purchase requests
762 generated by other process from Tryton.")
763 (license license:gpl3+)))
764
765 (define-public python-trytond-stock
766 (package
767 (name "python-trytond-stock")
768 (version "5.8.2")
769 (source
770 (origin
771 (method url-fetch)
772 (uri (pypi-uri "trytond_stock" version))
773 (sha256
774 (base32 "0yb8kd3alwqkivrlpx0ni4jxv3x14i37lmwism9yi81xwchyrcjk"))))
775 (build-system python-build-system)
776 (arguments
777 `(#:phases
778 (modify-phases %standard-phases
779 (replace 'check
780 (let ((runtest
781 (string-append
782 (assoc-ref %build-inputs "trytond")
783 "/lib/python"
784 ,(version-major+minor (package-version python))
785 "/site-packages/trytond/tests/run-tests.py")))
786 (lambda* (#:key inputs outputs #:allow-other-keys)
787 (add-installed-pythonpath inputs outputs)
788 (invoke "python" runtest "-m" "stock")))))))
789 (native-inputs
790 `(("python-genshi" ,python-genshi)
791 ("python-lxml" ,python-lxml)
792 ("python-magic" ,python-magic)
793 ("python-passlib" ,python-passlib)
794 ("python-polib" ,python-polib)
795 ("python-proteus" ,python-proteus)
796 ("python-relatorio" ,python-relatorio)
797 ("python-werkzeug" ,python-werkzeug)
798 ("python-wrapt" ,python-wrapt)))
799 (propagated-inputs
800 `(("python-simpleeval" ,python-simpleeval)
801 ("python-sql" ,python-sql)
802 ("python-trytond-company"
803 ,python-trytond-company)
804 ("python-trytond-currency"
805 ,python-trytond-currency)
806 ("python-trytond-party" ,python-trytond-party)
807 ("python-trytond-product"
808 ,python-trytond-product)
809 ("trytond" ,trytond)))
810 (home-page "https://www.tryton.org/")
811 (synopsis "Tryton module for stock and inventory")
812 (description
813 "This package provides a Tryton module that defines the fundamentals for
814 all stock management situations: Locations where products are stored, moves
815 between these locations, shipments for product arrivals and departures and
816 inventory to control and update stock levels.")
817 (license license:gpl3+)))
818
819 (define-public python-trytond-stock-lot
820 (package
821 (name "python-trytond-stock-lot")
822 (version "5.8.2")
823 (source
824 (origin
825 (method url-fetch)
826 (uri (pypi-uri "trytond_stock_lot" version))
827 (sha256
828 (base32 "0w2f62cfzm7j8wnw8igmjslpxc1a8s82dkdizyvim5qhjg6mrsym"))))
829 (build-system python-build-system)
830 (arguments
831 `(#:phases
832 (modify-phases %standard-phases
833 (replace 'check
834 (let ((runtest
835 (string-append
836 (assoc-ref %build-inputs "trytond")
837 "/lib/python"
838 ,(version-major+minor (package-version python))
839 "/site-packages/trytond/tests/run-tests.py")))
840 (lambda* (#:key inputs outputs #:allow-other-keys)
841 (add-installed-pythonpath inputs outputs)
842 (invoke "python" runtest "-m" "stock_lot")))))))
843 (native-inputs
844 `(("python-dateutil" ,python-dateutil)
845 ("python-genshi" ,python-genshi)
846 ("python-lxml" ,python-lxml)
847 ("python-magic" ,python-magic)
848 ("python-passlib" ,python-passlib)
849 ("python-polib" ,python-polib)
850 ("python-proteus" ,python-proteus)
851 ("python-relatorio" ,python-relatorio)
852 ("python-sql" ,python-sql)
853 ("python-werkzeug" ,python-werkzeug)
854 ("python-wrapt" ,python-wrapt)))
855 (propagated-inputs
856 `(("python-trytond-product"
857 ,python-trytond-product)
858 ("python-trytond-stock" ,python-trytond-stock)
859 ("trytond" ,trytond)))
860 (home-page "https://www.tryton.org/")
861 (synopsis "Tryton module for lot of products")
862 (description
863 "This package provides a Tryton module that defines lot of products.")
864 (license license:gpl3+)))
865
866 (define-public python-trytond-stock-supply
867 (package
868 (name "python-trytond-stock-supply")
869 (version "5.8.1")
870 (source
871 (origin
872 (method url-fetch)
873 (uri (pypi-uri "trytond_stock_supply" version))
874 (sha256
875 (base32 "01cgpxlznldrba79a3xmj4d0csyfc3ccgs66c490j8v8rdnqpbww"))))
876 (build-system python-build-system)
877 (arguments
878 `(#:phases
879 (modify-phases %standard-phases
880 (replace 'check
881 (let ((runtest
882 (string-append
883 (assoc-ref %build-inputs "trytond")
884 "/lib/python"
885 ,(version-major+minor (package-version python))
886 "/site-packages/trytond/tests/run-tests.py")))
887 (lambda* (#:key inputs outputs #:allow-other-keys)
888 (add-installed-pythonpath inputs outputs)
889 (invoke "python" runtest "-m" "stock_supply")))))))
890 (native-inputs
891 `(("python-dateutil" ,python-dateutil)
892 ("python-genshi" ,python-genshi)
893 ("python-lxml" ,python-lxml)
894 ("python-magic" ,python-magic)
895 ("python-passlib" ,python-passlib)
896 ("python-polib" ,python-polib)
897 ("python-proteus" ,python-proteus)
898 ("python-relatorio" ,python-relatorio)
899 ("python-werkzeug" ,python-werkzeug)
900 ("python-wrapt" ,python-wrapt)))
901 (propagated-inputs
902 `(("python-sql" ,python-sql)
903 ("python-trytond-account"
904 ,python-trytond-account)
905 ("python-trytond-party" ,python-trytond-party)
906 ("python-trytond-product"
907 ,python-trytond-product)
908 ("python-trytond-purchase"
909 ,python-trytond-purchase)
910 ("python-trytond-purchase-request"
911 ,python-trytond-purchase-request)
912 ("python-trytond-stock" ,python-trytond-stock)
913 ("trytond" ,trytond)))
914 (home-page "https://www.tryton.org/")
915 (synopsis "Tryton module for stock supply")
916 (description
917 "This package provides a Tryton module that adds automatic supply
918 mechanisms and introduces the concepts of order point.")
919 (license license:gpl3+)))