gnu: cvs-fast-export: Update to 1.56.
[jackhill/guix/guix.git] / gnu / packages / rcm.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2019 Josh Holland <josh@inv.alid.pw>
3 ;;; Copyright © 2021 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages rcm)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (guix licenses)
25 #:use-module (gnu packages python-xyz)
26 #:use-module (gnu packages perl))
27
28 (define-public rcm
29 (package
30 (name "rcm")
31 (version "1.3.4")
32 (source (origin
33 (method url-fetch)
34 (uri (string-append "https://thoughtbot.github.io/rcm/dist/rcm-"
35 version ".tar.gz"))
36 (sha256
37 (base32 "0jn2crdqcna0fyg7w7x1mcyjblzykd3lh4vdxhsd5x4w8hvsw4cv"))))
38 (build-system gnu-build-system)
39 (arguments '(#:phases
40 (modify-phases %standard-phases
41 (add-after 'patch-source-shebangs 'patch-tests
42 (lambda _
43 (substitute* '("test/rcrc-tilde.t"
44 "test/rcdn-hooks-run-in-order.t"
45 "test/rcup-hooks-run-in-order.t")
46 (("/bin/sh") (which "sh")))
47 (substitute* "test/rcup-hooks.t"
48 (("/usr/bin/env") (which "env")))
49 #t)))
50 #:parallel-tests? #f))
51 (native-inputs `(("perl" ,perl)
52 ("python-cram" ,python-cram)))
53 (synopsis "Management suite for dotfiles")
54 (description "The rcm suite of tools is for managing dotfiles directories. This is
55 a directory containing all the @code{.*rc} files in your home directory
56 (@code{.zshrc}, @code{.vimrc}, and so on). These files have gone by many
57 names in history, such as “rc files” because they typically end in rc
58 or “dotfiles” because they begin with a period. This suite is useful
59 for committing your rc files to a central repository to share, but it also
60 scales to a more complex situation such as multiple source directories
61 shared between computers with some host-specific or task-specific files.")
62 (license bsd-3)
63 (home-page "https://github.com/thoughtbot/rcm")))