gnu: cvs-fast-export: Update to 1.56.
[jackhill/guix/guix.git] / gnu / packages / openbox.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Julien Lepiller <julien@lepiller.eu>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2017 Nikita <nikita@n0.is>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages openbox)
22 #:use-module ((guix licenses) #:select (gpl2+))
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix build-system gnu)
26 #:use-module (gnu packages freedesktop)
27 #:use-module (gnu packages gettext)
28 #:use-module (gnu packages gnome)
29 #:use-module (gnu packages gtk)
30 #:use-module (gnu packages image)
31 #:use-module (gnu packages pkg-config)
32 #:use-module (gnu packages python)
33 #:use-module (gnu packages xdisorg)
34 #:use-module (gnu packages xml)
35 #:use-module (gnu packages xorg))
36
37 (define-public openbox
38 (package
39 (name "openbox")
40 (version "3.6.1")
41 (source (origin
42 (method url-fetch)
43 (uri (string-append
44 "http://openbox.org/dist/openbox/" name "-"
45 version ".tar.xz"))
46 (sha256
47 (base32
48 "0vg2y1qddsdxkjv806mzpvmkgzliab8ll4s7zm7ma5jnriamirxb"))))
49 (build-system gnu-build-system)
50 (native-inputs `(("pkg-config" ,pkg-config)))
51 (propagated-inputs `(("python2-pyxdg" ,python2-pyxdg)))
52 (inputs `(("imlib2" ,imlib2)
53 ("libxml2" ,libxml2)
54 ("librsvg" ,librsvg)
55 ("libsm" ,libsm)
56 ("libxcursor" ,libxcursor)
57 ("libxinerama" ,libxinerama)
58 ("libxml2" ,libxml2)
59 ("libxrandr" ,libxrandr)
60 ("libxft" ,libxft)
61 ("pango" ,pango)
62 ("python-2" ,python-2)))
63 (synopsis "Box style window manager")
64 (description
65 "Openbox is a highly configurable, next generation window manager with
66 extensive standards support. The *box visual style is well known for its
67 minimalistic appearance. Openbox uses the *box visual style, while providing
68 a greater number of options for theme developers than previous *box
69 implementations.")
70 (home-page "http://openbox.org/wiki/Main_Page")
71 (license gpl2+)))
72
73 (define-public obconf
74 (package
75 (name "obconf")
76 (version "2.0.4")
77 (source
78 (origin
79 (method url-fetch)
80 (uri (string-append "http://openbox.org/dist/" name
81 "/" name "-" version ".tar.gz"))
82 (sha256
83 (base32
84 "1fanjdmd8727kk74x5404vi8v7s4kpq48l583d12fsi4xvsfb8vi"))))
85 (inputs
86 `(("gtk+-2" ,gtk+-2)
87 ("imlib2" ,imlib2)
88 ("libglade" ,libglade)
89 ("openbox" ,openbox)
90 ("startup-notification" ,startup-notification)
91 ("libsm" ,libsm)
92 ("librsvg" ,librsvg)
93 ("libxft" ,libxft)))
94 (native-inputs
95 `(("gettext" ,gettext-minimal)
96 ("pkg-config" ,pkg-config)))
97 (build-system gnu-build-system)
98 (arguments
99 `(#:configure-flags (list "--enable-nls")))
100 (home-page "http://openbox.org/wiki/ObConf:About")
101 (synopsis "Openbox configuration tool")
102 (description
103 "Obconf is a tool for configuring the Openbox window manager.
104 You can configure its appearance, themes, and much more.")
105 (license gpl2+)))
106
107 ;;; openbox.scm ends here