gnu: cvs-fast-export: Update to 1.56.
[jackhill/guix/guix.git] / gnu / packages / microcom.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 John Darrington <jmd@gnu.org>
3 ;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages microcom)
21 #:use-module (guix packages)
22 #:use-module (guix licenses)
23 #:use-module (guix git-download)
24 #:use-module (guix download)
25 #:use-module (gnu packages autotools)
26 #:use-module (gnu packages readline)
27 #:use-module (guix build-system gnu))
28
29 (define-public microcom
30 (package
31 (name "microcom")
32 (version "2017.03.0")
33 (source (origin
34 (method git-fetch)
35 (uri (git-reference
36 (url "https://git.pengutronix.de/git/tools/microcom.git")
37 (commit (string-append "v" version))))
38 (file-name (git-file-name name version))
39 (sha256
40 (base32 "060q42lf1bx403smxm97cz8r4ksq942mq5z708vavy6syv3fkap4"))))
41 (build-system gnu-build-system)
42 (inputs `(("readline" ,readline)))
43 (native-inputs `(("automake" ,automake)
44 ("autoconf" ,autoconf)))
45 (home-page "https://git.pengutronix.de/?p=tools/microcom.git")
46 (synopsis "Minimalistic serial line terminal program")
47 (description "Microcom is a minimalistic terminal program for accessing
48 devices via a serial connection. It features connection via RS232 serial
49 interfaces (including setting of transfer rates) as well as in @code{telnetmode}
50 as specified in rfc2217 and a (Linux specific) CAN mode.")
51 (license gpl2+)))