gnu: cvs-fast-export: Update to 1.56.
[jackhill/guix/guix.git] / gnu / packages / kde-plasma.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 Thomas Danckaert <post@thomasdanckaert.be>
3 ;;; Copyright © 2018 Meiyo Peng <meiyo.peng@gmail.com>
4 ;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
5 ;;; Copyright © 2017, 2019, 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
6 ;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
7 ;;; Copyright © 2020 Zheng Junjie <873216071@qq.com>
8 ;;;
9 ;;; This file is part of GNU Guix.
10 ;;;
11 ;;; GNU Guix is free software; you can redistribute it and/or modify it
12 ;;; under the terms of the GNU General Public License as published by
13 ;;; the Free Software Foundation; either version 3 of the License, or (at
14 ;;; your option) any later version.
15 ;;;
16 ;;; GNU Guix is distributed in the hope that it will be useful, but
17 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
18 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
19 ;;; GNU General Public License for more details.
20 ;;;
21 ;;; You should have received a copy of the GNU General Public License
22 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
23
24 (define-module (gnu packages kde-plasma)
25 #:use-module (guix packages)
26 #:use-module (guix download)
27 #:use-module ((guix licenses) #:prefix license:)
28 #:use-module (guix build-system cmake)
29 #:use-module (guix build-system qt)
30 #:use-module (gnu packages compression)
31 #:use-module (gnu packages freedesktop)
32 #:use-module (gnu packages glib)
33 #:use-module (gnu packages kde-frameworks)
34 #:use-module (gnu packages linux)
35 #:use-module (gnu packages pkg-config)
36 #:use-module (gnu packages qt)
37 #:use-module (gnu packages xorg))
38
39 (define-public breeze
40 (package
41 (name "breeze")
42 (version "5.19.5")
43 (source (origin
44 (method url-fetch)
45 (uri (string-append "mirror://kde/stable/plasma/" version "/"
46 name "-" version ".tar.xz"))
47 (sha256
48 (base32
49 "0dpk1w7zcafrzf46j060i1qb0fwqpsflkfzr6gcar81llmjnc4b1"))))
50 (build-system qt-build-system)
51 ;; TODO: Warning at /gnu/store/…-kpackage-5.34.0/…/KF5PackageMacros.cmake:
52 ;; warnings during generation of metainfo for org.kde.breezedark.desktop:
53 ;; Package type "Plasma/LookAndFeel" not found
54 ;; TODO: Check whether is makes sence splitting into several outputs, like
55 ;; Debian does:
56 ;; - breeze-cursor-theme
57 ;; - "out", "devel"
58 ;; - kde-style-breeze - Widget style
59 ;; - kde-style-breeze-qt4 - propably not useful
60 ;; - kwin-style-breeze
61 ;; - qml-module-qtquick-controls-styles-breeze - QtQuick style
62 (native-inputs
63 `(("extra-cmake-modules" ,extra-cmake-modules)
64 ("pkg-config" ,pkg-config)))
65 (inputs
66 `(("kcmutils" ,kcmutils) ; optional
67 ("kconfigwidgets" ,kconfigwidgets)
68 ("kcoreaddons" ,kcoreaddons)
69 ("kde-frameworkintegration" ,kde-frameworkintegration) ; optional
70 ("kdecoration" ,kdecoration)
71 ("kguiaddons" ,kguiaddons)
72 ("ki18n" ,ki18n)
73 ("kiconthemes" ,kiconthemes) ; for optional kde-frameworkintegration
74 ("kpackage" ,kpackage)
75 ("kwayland" ,kwayland) ; optional
76 ("kwindowsystem" ,kwindowsystem)
77 ("qtbase" ,qtbase)
78 ("qtdeclarative" ,qtdeclarative) ; optional
79 ("qtx11extras" ,qtx11extras)))
80 (home-page "https://invent.kde.org/plasma/breeze")
81 (synopsis "Default KDE Plasma theme")
82 (description "Artwork, styles and assets for the Breeze visual style for
83 the Plasma Desktop. Breeze is the default theme for the KDE Plasma desktop.")
84 (license license:gpl2+)))
85
86 (define-public kdecoration
87 (package
88 (name "kdecoration")
89 (version "5.19.5")
90 (source (origin
91 (method url-fetch)
92 (uri (string-append "mirror://kde/stable/plasma/" version
93 "/kdecoration-" version ".tar.xz"))
94 (sha256
95 (base32
96 "0pn8n7zyb0adzjnn92vmbcf7pmpss60k9k1rk5llamj016xzfgnf"))))
97 (build-system qt-build-system)
98 (native-inputs
99 `(("extra-cmake-modules" ,extra-cmake-modules)))
100 (inputs
101 `(("ki18n" ,ki18n)
102 ("qtbase" ,qtbase)))
103 (home-page "https://invent.kde.org/plasma/kdecoration")
104 (synopsis "Plugin based library to create window decorations")
105 (description "KDecoration is a library to create window decorations.
106 These window decorations can be used by for example an X11 based window
107 manager which re-parents a Client window to a window decoration frame.")
108 (license license:lgpl3+)))
109
110 (define-public ksshaskpass
111 (package
112 (name "ksshaskpass")
113 (version "5.19.5")
114 (source (origin
115 (method url-fetch)
116 (uri (string-append "mirror://kde/stable/plasma/" version
117 "/ksshaskpass-" version ".tar.xz"))
118 (sha256
119 (base32
120 "1k2va2v9051f71w78dn3gihk642iyy5yzrkcfnp97fag8g6dpisi"))))
121 (build-system qt-build-system)
122 (native-inputs
123 `(("extra-cmake-modules" ,extra-cmake-modules)
124 ("kdoctools" ,kdoctools)))
125 (inputs
126 `(("kcoreaddons" ,kcoreaddons)
127 ("ki18n" ,ki18n)
128 ("kwallet" ,kwallet)
129 ("kwidgetsaddons" ,kwidgetsaddons)
130 ("qtbase" ,qtbase)))
131 (home-page "https://invent.kde.org/plasma/ksshaskpass")
132 (synopsis "Front-end for ssh-add using kwallet")
133 (description "Ksshaskpass is a front-end for @code{ssh-add} which stores the
134 password of the ssh key in KWallet. Ksshaskpass is not meant to be executed
135 directly, you need to tell @code{ssh-add} about it. @code{ssh-add} will then
136 call it if it is not associated to a terminal.")
137 (license license:gpl2+)))
138
139 (define-public kscreenlocker
140 (package
141 (name "kscreenlocker")
142 (version "5.19.5")
143 (source (origin
144 (method url-fetch)
145 (uri (string-append "mirror://kde/stable/plasma/" version
146 "/kscreenlocker-" version ".tar.xz"))
147 (sha256
148 (base32
149 "1fd5sqaqx9kj3kr0bgxpllhcm5arf8bc9pkpd9yk9c8xjy0j0fxi"))))
150 (build-system qt-build-system)
151 (arguments
152 `(#:tests? #f ;; TODO: make tests pass
153 #:phases
154 (modify-phases %standard-phases
155 (add-before 'check 'check-setup
156 (lambda* (#:key inputs outputs #:allow-other-keys)
157 (system (string-append (assoc-ref inputs "xorg-server")
158 "/bin/Xvfb :1 -screen 0 640x480x24 &"))
159 (setenv "DISPLAY" ":1")
160 #t))
161 (delete 'check)
162 ;; Tests use the installed library and require a DBus session.
163 (add-after 'install 'check
164 (lambda* (#:key tests? #:allow-other-keys)
165 (if tests?
166 (begin
167 (setenv "CTEST_OUTPUT_ON_FAILURE" "1")
168 (invoke "dbus-launch" "ctest" ".")))
169 #t)))))
170 (native-inputs
171 `(("extra-cmake-modules" ,extra-cmake-modules)
172 ("pkg-config" ,pkg-config)
173 ;; For tests.
174 ("dbus" ,dbus)
175 ("xorg-server" ,xorg-server-for-tests)))
176 (inputs
177 `(("kcmutils" ,kcmutils)
178 ("kcrash" ,kcrash)
179 ("kdeclarative" ,kdeclarative)
180 ("kglobalaccel" ,kglobalaccel)
181 ("ki18n" ,ki18n)
182 ("kidletime" ,kidletime)
183 ("knotifications" ,knotifications)
184 ("ktextwidgets" ,ktextwidgets)
185 ("kwayland" ,kwayland)
186 ("kwindowsystem" ,kwindowsystem)
187 ("kxmlgui" ,kxmlgui)
188 ("libseccomp" ,libseccomp) ;for sandboxing the look'n'feel package
189 ("libxcursor" ,libxcursor) ;missing in CMakeList.txt
190 ("libxi" ,libxi) ;XInput, required for grabbing XInput2 devices
191 ("linux-pam" ,linux-pam)
192 ("logind" ,elogind) ;optional loginctl support
193 ("qtbase" ,qtbase)
194 ("qtdeclarative" ,qtdeclarative)
195 ("qtx11extras" ,qtx11extras)
196 ("solid" ,solid)
197 ("wayland" ,wayland)
198 ("xcb-util-keysyms" ,xcb-util-keysyms)))
199 (home-page "https://invent.kde.org/plasma/kscreenlocker")
200 (synopsis "Screen locking library")
201 (description
202 "@code{kscreenlocker} is a library for creating secure lock screens.")
203 (license license:gpl2+)))
204
205 (define-public libkscreen
206 (package
207 (name "libkscreen")
208 (version "5.19.5")
209 (source
210 (origin
211 (method url-fetch)
212 (uri (string-append "mirror://kde/stable/plasma/" version "/"
213 name "-" version ".tar.xz"))
214 (sha256
215 (base32 "0rf1pm0yyc069f4n5s9ipdx4glzfr9zvv5cbrmn4q9i4v6z1qd8i"))))
216 (build-system qt-build-system)
217 (native-inputs
218 `(("extra-cmake-modules" ,extra-cmake-modules)
219 ;; For testing.
220 ("dbus" ,dbus)))
221 (inputs
222 `(("kwayland" ,kwayland)
223 ("libxrandr" ,libxrandr)
224 ("qtbase" ,qtbase)
225 ("qtx11extras" ,qtx11extras)))
226 (arguments
227 '(#:tests? #f)) ; FIXME: 55% tests passed, 5 tests failed out of 11
228 (home-page "https://community.kde.org/Solid/Projects/ScreenManagement")
229 (synopsis "KDE's screen management software")
230 (description "KScreen is the new screen management software for KDE Plasma
231 Workspaces which tries to be as magic and automatic as possible for users with
232 basic needs and easy to configure for those who want special setups.")
233 (license license:gpl2+)))
234
235 (define-public libksysguard
236 (package
237 (name "libksysguard")
238 (version "5.19.5")
239 (source
240 (origin
241 (method url-fetch)
242 (uri (string-append "mirror://kde//stable/plasma/" version
243 "/libksysguard-" version ".tar.xz"))
244 (sha256
245 (base32 "1kd0h3p8bf9k5pqp0frhr81pa0yyrpkckg9zznirk9p1v88v7bfq"))))
246 (native-inputs
247 `(("extra-cmake-modules" ,extra-cmake-modules)
248 ("pkg-config" ,pkg-config)))
249 (inputs
250 `(("kconfigwidgets" ,kconfigwidgets)
251 ("kiconthemes" ,kiconthemes)
252 ("kwindowsystem" ,kwindowsystem)
253 ("ki18n" ,ki18n)
254 ("kauth" ,kauth)
255 ("kcompletion" ,kcompletion)
256 ("kconfig" ,kconfig)
257 ("kcoreaddons" ,kcoreaddons)
258 ("kdeclarative" ,kdeclarative)
259 ("kglobalaccel" ,kglobalaccel)
260 ("kio" ,kio)
261 ("knewstuff" ,knewstuff)
262 ("kwidgetsaddons" ,kwidgetsaddons)
263 ("kservice" ,kservice)
264 ("qtbase" ,qtbase)
265 ("qtdeclarative" ,qtdeclarative)
266 ("qtscript" ,qtscript)
267 ("qtwebkit" ,qtwebkit)
268 ("qtx11extras" ,qtx11extras)
269 ("plasma" ,plasma-framework)
270 ("zlib" ,zlib)))
271 (build-system qt-build-system)
272 (arguments
273 `(#:configure-flags
274 `(,(string-append "-DKDE_INSTALL_DATADIR="
275 (assoc-ref %outputs "out") "/share"))
276 #:phases
277 (modify-phases %standard-phases
278 (add-before 'configure 'patch-cmakelists
279 (lambda _
280 ;; TODO: Verify: This should no longer be necessary, since
281 ;; KF5AuthConfig.cmake.in contains this already.
282 (substitute* "processcore/CMakeLists.txt"
283 (("KAUTH_HELPER_INSTALL_DIR") "KDE_INSTALL_LIBEXECDIR"))))
284 (replace 'check
285 (lambda _
286 ;; TODO: Fix this failing test-case
287 (invoke "ctest" "-E" "processtest"))))))
288 (home-page "https://userbase.kde.org/KSysGuard")
289 (synopsis "Network enabled task and system monitoring")
290 (description "KSysGuard can obtain information on system load and
291 manage running processes. It obtains this information by interacting
292 with a ksysguardd daemon, which may also run on a remote system.")
293 (license license:gpl3+)))
294