gnu: cvs-fast-export: Update to 1.56.
[jackhill/guix/guix.git] / gnu / packages / inklingreader.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Roel Janssen <roel@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages inklingreader)
20 #:use-module ((guix licenses) #:prefix license:)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages autotools)
26 #:use-module (gnu packages glib)
27 #:use-module (gnu packages gnome)
28 #:use-module (gnu packages gtk)
29 #:use-module (gnu packages libusb)
30 #:use-module (gnu packages pkg-config))
31
32 (define-public inklingreader
33 (package
34 (name "inklingreader")
35 (version "0.8")
36 (source (origin
37 (method url-fetch)
38 (uri (string-append
39 "ftp://alpha.gnu.org/gnu/inklingreader/inklingreader-"
40 version ".tar.gz"))
41 (sha256
42 (base32
43 "0ikg95mgwfqh0bq4dzvkfmdiycacqvv27g91hl6adwk5y3gzl96g"))))
44 (build-system gnu-build-system)
45 (inputs
46 `(("glib" ,glib)
47 ("cairo" ,cairo)
48 ("gtk+" ,gtk+)
49 ("librsvg" ,librsvg)
50 ("libusb" ,libusb)))
51 (native-inputs
52 `(("pkg-config" ,pkg-config)))
53 (home-page "https://www.gnu.org/software/inklingreader/")
54 (synopsis "Wacom Inkling sketch format conversion and manipulation")
55 (description
56 "GNU InklingReader is a package to support the Wacom Inkling device,
57 including data conversion to various free formats, basic editing features,
58 and an Inkscape plugin.")
59 (license license:gpl3+)))