gnu: cvs-fast-export: Update to 1.56.
[jackhill/guix/guix.git] / gnu / packages / education.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 Danny Milosavljevic <dannym@scratchpost.org>
3 ;;; Copyright © 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
4 ;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
5 ;;; Copyright © 2017, 2018, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
6 ;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
7 ;;; Copyright © 2018, 2019, 2020, 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
8 ;;; Copyright © 2020 Robert Smith <robertsmith@posteo.net>
9 ;;; Copyright © 2020 Guy Fleury Iteriteka <gfleury@disroot.org>
10 ;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
11 ;;; Copyright © 2020 Prafulla Giri <pratheblackdiamond@gmail.com>
12 ;;;
13 ;;; This file is part of GNU Guix.
14 ;;;
15 ;;; GNU Guix is free software; you can redistribute it and/or modify it
16 ;;; under the terms of the GNU General Public License as published by
17 ;;; the Free Software Foundation; either version 3 of the License, or (at
18 ;;; your option) any later version.
19 ;;;
20 ;;; GNU Guix is distributed in the hope that it will be useful, but
21 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
22 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
23 ;;; GNU General Public License for more details.
24 ;;;
25 ;;; You should have received a copy of the GNU General Public License
26 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
27
28 (define-module (gnu packages education)
29 #:use-module (ice-9 regex)
30 #:use-module (gnu packages)
31 #:use-module (gnu packages audio)
32 #:use-module (gnu packages base)
33 #:use-module (gnu packages bash)
34 #:use-module (gnu packages compression)
35 #:use-module (gnu packages curl)
36 #:use-module (gnu packages databases)
37 #:use-module (gnu packages flex)
38 #:use-module (gnu packages fonts)
39 #:use-module (gnu packages freedesktop)
40 #:use-module (gnu packages game-development)
41 #:use-module (gnu packages gettext)
42 #:use-module (gnu packages glib)
43 #:use-module (gnu packages gnome)
44 #:use-module (gnu packages golang)
45 #:use-module (gnu packages gtk)
46 #:use-module (gnu packages image)
47 #:use-module (gnu packages javascript)
48 #:use-module (gnu packages kde)
49 #:use-module (gnu packages kde-frameworks) ; extra-cmake-modules
50 #:use-module (gnu packages mp3)
51 #:use-module (gnu packages ncurses)
52 #:use-module (gnu packages perl)
53 #:use-module (gnu packages pkg-config)
54 #:use-module (gnu packages python)
55 #:use-module (gnu packages python-web)
56 #:use-module (gnu packages python-xyz)
57 #:use-module (gnu packages qt)
58 #:use-module (gnu packages readline)
59 #:use-module (gnu packages sdl)
60 #:use-module (gnu packages sqlite)
61 #:use-module (gnu packages texinfo)
62 #:use-module (gnu packages tls)
63 #:use-module (gnu packages video)
64 #:use-module (gnu packages xorg)
65 #:use-module (gnu packages xml)
66 #:use-module ((guix licenses) #:prefix license:)
67 #:use-module (guix packages)
68 #:use-module (guix download)
69 #:use-module (guix git-download)
70 #:use-module (guix svn-download)
71 #:use-module (guix utils)
72 #:use-module (guix build-system cmake)
73 #:use-module (guix build-system gnu)
74 #:use-module (guix build-system go)
75 #:use-module (guix build-system python)
76 #:use-module (guix build-system qt)
77 #:use-module (guix build-system trivial)
78 #:use-module (srfi srfi-1))
79
80 (define-public gcompris
81 (package
82 (name "gcompris")
83 (version "17.05")
84 (source (origin
85 (method url-fetch)
86 (uri (string-append "http://gcompris.net/download/gtk/src/gcompris-"
87 version ".tar.bz2"))
88 (sha256
89 (base32
90 "18y483alb4r4vfmh80nnl0pah5gv0b8frcm6l1drb9njn5xlcpgc"))))
91 (build-system gnu-build-system)
92 (arguments
93 `(#:configure-flags
94 ;; Use SDL mixer because otherwise GCompris would need an old version
95 ;; of Gstreamer.
96 (list "--enable-sdlmixer"
97 "LDFLAGS=-lgmodule-2.0")
98 #:phases
99 (modify-phases %standard-phases
100 (add-after 'set-paths 'set-sdl-paths
101 (lambda* (#:key inputs #:allow-other-keys)
102 (setenv "CPATH"
103 (string-append (assoc-ref inputs "sdl-mixer")
104 "/include/SDL:"
105 (or (getenv "CPATH") "")))
106 #t)))))
107 (inputs
108 `(("gtk+" ,gtk+-2)
109 ("librsvg" ,librsvg)
110 ("libxml2" ,libxml2)
111 ("sdl-mixer" ,sdl-mixer)
112 ("sqlite" ,sqlite)
113 ("glib:bin" ,glib)
114 ("python" ,python)))
115 (native-inputs
116 `(("intltool" ,intltool)
117 ("texinfo" ,texinfo)
118 ("texi2html" ,texi2html)
119 ("glib:bin" ,glib "bin")
120 ("pkg-config" ,pkg-config)))
121 (home-page "https://gcompris.net")
122 (synopsis "Educational software suite")
123 (description "GCompris is an educational software suite comprising of
124 numerous activities for children aged 2 to 10. Some of the activities are
125 game orientated, but nonetheless still educational. Below you can find a list
126 of categories with some of the activities available in that category.
127
128 @enumerate
129 @item computer discovery: keyboard, mouse, different mouse gestures, ...
130 @item arithmetic: table memory, enumeration, double entry table, mirror image, ...
131 @item science: the canal lock, the water cycle, the submarine, electric simulation ...
132 @item geography: place the country on the map
133 @item games: chess, memory, connect 4, oware, sudoku ...
134 @item reading: reading practice
135 @item other: learn to tell time, puzzle of famous paintings, vector drawing, cartoon making, ...
136 @end enumerate
137 ")
138 (license license:gpl3+)))
139
140 (define-public gcompris-qt
141 (package
142 (name "gcompris-qt")
143 (version "1.0")
144 (source
145 (origin
146 (method url-fetch)
147 (uri (string-append
148 "https://gcompris.net/download/qt/src/gcompris-qt-"
149 version ".tar.xz"))
150 (sha256
151 (base32 "08dw1q0h4qz2q0ksa5pbmb9v60hr1zv9skx6z8dlq9b1i7harnds"))))
152 (build-system cmake-build-system)
153 (arguments
154 `(#:phases
155 (modify-phases %standard-phases
156 (add-before 'check 'start-xorg-server
157 (lambda* (#:key inputs #:allow-other-keys)
158 ;; The test suite requires a running X server.
159 (system (string-append (assoc-ref inputs "xorg-server")
160 "/bin/Xvfb :1 &"))
161 (setenv "DISPLAY" ":1")
162 ;; The test suite wants to write to /homeless-shelter
163 (setenv "HOME" (getcwd))
164 #t))
165 (add-after 'install 'wrap-executable
166 (lambda* (#:key inputs outputs #:allow-other-keys)
167 (let ((out (assoc-ref outputs "out")))
168 (wrap-program (string-append out "/bin/gcompris-qt")
169 `("QT_PLUGIN_PATH" ":" prefix
170 ,(map (lambda (label)
171 (string-append (assoc-ref inputs label)
172 "/lib/qt5/plugins"))
173 '("qtbase" "qtdeclarative" "qtmultimedia" "qtsvg")))
174 `("QML2_IMPORT_PATH" ":" prefix
175 ,(map (lambda (label)
176 (string-append (assoc-ref inputs label)
177 "/lib/qt5/qml"))
178 '("qtdeclarative" "qtgraphicaleffects"
179 "qtmultimedia" "qtquickcontrols"))))
180 #t))))
181 #:configure-flags (list "-DQML_BOX2D_MODULE=disabled"
182 "-DBUILD_TESTING=TRUE")))
183 (native-inputs
184 `(("extra-cmake-modules" ,extra-cmake-modules)
185 ("gettext" ,gettext-minimal)
186 ("kdoctools" ,kdoctools)
187 ("perl" ,perl)
188 ("qttools" ,qttools)
189 ("xorg-server" ,xorg-server-for-tests)))
190 (inputs
191 `(("openssl" ,openssl)
192 ("python" ,python-wrapper)
193 ("qtbase" ,qtbase)
194 ("qtdeclarative" ,qtdeclarative)
195 ("qtgraphicaleffects" ,qtgraphicaleffects)
196 ("qtmultimedia" ,qtmultimedia)
197 ("qtquickcontrols" ,qtquickcontrols)
198 ("qtsensors" ,qtsensors)
199 ("qtsvg" ,qtsvg)
200 ("qtxmlpatterns" ,qtxmlpatterns)))
201 (home-page "https://gcompris.net/index-en.html")
202 (synopsis "Educational games for small children")
203 (description
204 "Gcompris offers a large collection of educational games for small
205 children, designed to be a unified interface to integrate more educational
206 games. Language-oriented games contain vocabulary, sounds, and voices for
207 many different languages.
208 Currently available boards include:
209 @enumerate
210 @item learning how to use a mouse and keyboard
211 @item learning simple arithmetic
212 @item learning how to read an analog clock
213 @item recognize letters after hearing their names
214 @item reading practice
215 @item small games (memory games, jigsaw puzzles, ...)
216 @end enumerate\n")
217 (license (list license:silofl1.1 ; bundled fonts
218 license:gpl3+))))
219
220 (define-public tipp10
221 (package
222 (name "tipp10")
223 (version "2.1.0")
224 (source (origin
225 (method url-fetch)
226 ;; guix download is not able to handle the download links on the
227 ;; home-page, which use '<meta http-equiv="refresh" …>'
228 (uri (string-append "mirror://debian/pool/main/"
229 "t/tipp10/tipp10_2.1.0.orig.tar.gz"))
230 (sha256
231 (base32
232 "0d387b404j88gsv6kv0rb7wxr23v5g5vl6s5l7602x8pxf7slbbx"))
233 ;; Apply patches in the order determined by Debian
234 (patches (search-patches "tipp10-fix-compiling.patch"
235 "tipp10-remove-license-code.patch"
236 "tipp10-disable-downloader.patch"
237 "tipp10-qt5.patch"))))
238 (build-system cmake-build-system)
239 (arguments
240 `(#:tests? #f ; packages has no tests
241 #:phases
242 (modify-phases %standard-phases
243 (add-after 'unpack 'disable-new-version-check
244 (lambda _
245 ;; Make new version check to default to false.
246 ;; TODO: Remove the checkbox from the dialog and the check itself
247 (substitute* '("widget/settingspages.cpp" "widget/mainwindow.cpp")
248 (("settings.value(\"check_new_version\", true)")
249 "settings.value(\"check_new_version\", false)"))
250 #t))
251 (replace 'configure
252 (lambda* (#:key outputs #:allow-other-keys)
253 (let ((out (assoc-ref outputs "out")))
254 ;; Make program honor $PREFIX
255 (substitute* "tipp10.pro"
256 (("\\.path = /usr/") (string-append ".path = " out "/")))
257 (substitute* "def/defines.h"
258 (("\"/usr/") (string-append "\"" out "/")))
259 ;; Recreate Makefile
260 (invoke "qmake")))))))
261 (inputs
262 `(("qtbase" ,qtbase)
263 ("qtmultimedia" ,qtmultimedia)))
264 (home-page "https://www.tipp10.com/")
265 (synopsis "Touch typing tutor")
266 (description "Tipp10 is a touch typing tutor. The ingenious thing about
267 the software is its intelligence feature: characters that are mistyped are
268 repeated more frequently. Beginners will find their way around right away so
269 they can start practicing without a hitch.
270
271 Useful support functions and an extensive progress tracker, topical lessons
272 and the ability to create your own practice lessons make learning to type
273 easy.")
274 (license license:gpl2)))
275
276 (define-public snap
277 (package
278 (name "snap")
279 (version "6.6.0")
280 (source
281 (origin
282 (method git-fetch)
283 (uri (git-reference
284 (url "https://github.com/jmoenig/Snap")
285 (commit (string-append "v" version))))
286 (file-name (git-file-name name version))
287 (sha256
288 (base32 "1k0j0sp6zz2hnh7zc7f086zc3sld01h7sk277j6fak914yv6slzy"))))
289 (build-system trivial-build-system)
290 (arguments
291 `(#:modules ((guix build utils))
292 #:builder
293 (begin
294 (use-modules (guix build utils))
295 (let* ((source (assoc-ref %build-inputs "source"))
296 (out (assoc-ref %outputs "out"))
297 (share (string-append out "/share/snap")))
298 (copy-recursively source share)
299 ;; Replace the sole minified file in the package.
300 (with-directory-excursion (string-append share "/src")
301 (delete-file "FileSaver.min.js")
302 (symlink (string-append (assoc-ref %build-inputs "js-filesaver")
303 "/share/javascript/FileSaver.min.js")
304 "FileSaver.min.js"))
305 ;; Create a "snap" executable.
306 (let* ((bin (string-append out "/bin"))
307 (script (string-append bin "/snap"))
308 (snap (string-append share "/snap.html"))
309 (bash (string-append (assoc-ref %build-inputs "bash")
310 "/bin/sh"))
311 (xdg-open (string-append (assoc-ref %build-inputs "xdg-utils")
312 "/bin/xdg-open")))
313 (mkdir-p bin)
314 (call-with-output-file script
315 (lambda (port)
316 (format port "#!~a\n~a '~a'" bash xdg-open snap)))
317 (chmod script #o555)))
318 #t)))
319 (inputs
320 `(("bash" ,bash-minimal)
321 ("js-filesaver" ,js-filesaver)
322 ("xdg-utils" ,xdg-utils)))
323 (home-page "https://snap.berkeley.edu")
324 (synopsis "Visual, blocks based programming language")
325 (description "Snap! (formerly BYOB) is a visual, drag-and-drop
326 programming language. It is an extended reimplementation of Scratch (a
327 project of the Lifelong Kindergarten Group at the MIT Media Lab) that
328 allows you to Build Your Own Blocks. It also features first class
329 lists, first class procedures, and continuations. These added
330 capabilities make it suitable for a serious introduction to computer
331 science for high school or college students.
332
333 This package provides a @command{snap} executable calling @command{xdg-open}
334 to open the application in a web browser, for offline usage.")
335 (license license:agpl3+)))
336
337 (define-public toutenclic
338 (package
339 (name "toutenclic")
340 (version "7.00")
341 (source
342 (origin
343 (method url-fetch)
344 (uri (string-append "http://www.bipede.fr/downloads/logiciels/"
345 "ToutEnClic-" version "-src.zip"))
346 (sha256
347 (base32 "0xg24p925rl5bfqsq3jb2lrkidb0f3kbmay5iyxxmjsn3ra0blyh"))))
348 (build-system python-build-system)
349 (arguments
350 `(#:tests? #f ; no tests
351 #:phases
352 (modify-phases %standard-phases
353 (delete 'build)
354 (replace 'install
355 (lambda* (#:key outputs #:allow-other-keys)
356 (let* ((out (assoc-ref outputs "out"))
357 (share (string-append out "/share/toutenclic"))
358 (pixmaps (string-append out "/share/pixmaps"))
359 (doc (string-append out "share/doc/" ,name "-" ,version))
360 (bin (string-append out "/bin"))
361 (executable "toutenclic"))
362 ;; Install icon.
363 (install-file "toutenclic.png" pixmaps)
364 ;; Move files into "share/" directory.
365 (for-each (lambda (f) (install-file f share))
366 (find-files "." "\\.py$"))
367 ;; Install documentation.
368 (install-file "ToutEnClic.pdf" doc)
369 ;; Create executable in "bin/".
370 (mkdir-p bin)
371 (with-directory-excursion bin
372 (symlink (string-append share "/" executable ".py")
373 executable)))
374 #t))
375 (add-after 'install 'create-desktop-file
376 (lambda* (#:key outputs #:allow-other-keys)
377 (let* ((out (assoc-ref outputs "out"))
378 (applications (string-append out "/share/applications")))
379 (mkdir-p applications)
380 (call-with-output-file
381 (string-append applications "/toutenclic.desktop")
382 (lambda (file)
383 (format file
384 "[Desktop Entry]~@
385 Name=ToutEnClic~@
386 Comment=For schooling without difference~@
387 Exec=~a/bin/toutenclic~@
388 TryExec=~@*~a/bin/toutenclic~@
389 Terminal=false~@
390 Icon=toutenclic~@
391 Type=Application~%"
392 out)))
393 #t))))))
394 (native-inputs
395 `(("unzip" ,unzip)))
396 (inputs
397 `(("python-pyqt" ,python-pyqt)))
398 (synopsis "School tools for physically disabled children")
399 (description "ToutEnClic is intended to facilitate the schooling
400 of physically disabled children in ordinary schools. It is both
401 a multi-page virtual exercise book and a kit including pencil,
402 scissors, glue, ruler, compass, protractor and square. A virtual
403 keyboard is also available if the child does not have any other
404 specialized device.")
405 (home-page "https://bipede.fr/contrib/")
406 (license license:gpl3)))
407
408 (define-public childsplay
409 (package
410 (name "childsplay")
411 (version "3.4")
412 (source (origin
413 (method url-fetch)
414 (uri (string-append
415 "mirror://sourceforge/schoolsplay/"
416 "childsplay-" version ".tgz"))
417 (sha256
418 (base32
419 "0z7yp2swjnbz51vn2zyfnjn40jq38l5mbh15yafmx1z3vn2z1m77"))))
420 (build-system python-build-system)
421 (arguments
422 `(#:python ,python-2
423 #:tests? #f
424 #:phases
425 (modify-phases %standard-phases
426 (add-after 'unpack 'unbundle-dejavu-font
427 (lambda* (#:key inputs #:allow-other-keys)
428 (let* ((dejavu-dir
429 (string-append (assoc-ref inputs "font-dejavu")
430 "/share/fonts/truetype"))
431 (dejavu-font
432 (string-append dejavu-dir
433 "/DejaVuSansCondensed-Bold.ttf")))
434 (substitute* "SPConstants.py"
435 (("^(TTF(BOLD)? = ).*" _ prefix)
436 (string-append prefix "'" dejavu-font "'\n")))
437 (for-each (lambda (f) (delete-file f))
438 (find-files "lib/SPData" "DejaVu"))
439 #t)))
440 (delete 'build)
441 (replace 'install
442 (lambda* (#:key outputs #:allow-other-keys)
443 (let* ((out (assoc-ref outputs "out"))
444 (pixmaps (string-append out "/share/pixmaps"))
445 (share (string-append out "/share/childsplay"))
446 (doc (string-append out "/share/doc/" ,name "-",version)))
447 ;; Install icon.
448 (install-file "lib/SPData/themes/childsplay/logo_cp.svg" pixmaps)
449 ;; Install data.
450 (mkdir-p share)
451 (for-each (lambda (f)
452 (copy-recursively f (string-append share "/" f)))
453 '("alphabet-sounds" "lib" "locale" "SPWidgets"))
454 (for-each (lambda (f) (install-file f share))
455 (find-files "." "\\.(py|dev|db)$"))
456 ;; Install documentation.
457 (mkdir-p doc)
458 (copy-recursively "docs" doc)
459 #t)))
460 (add-after 'install 'create-executable
461 (lambda* (#:key outputs inputs #:allow-other-keys)
462 (let* ((python (string-append (assoc-ref inputs "python")
463 "/bin/python"))
464 (out (assoc-ref outputs "out"))
465 (bin (string-append out "/bin"))
466 (executable (string-append bin "/childsplay")))
467 (mkdir-p bin)
468 (call-with-output-file executable
469 (lambda (file)
470 (format file
471 "~a ~a"
472 python
473 (string-append out "/share/childsplay/childsplay.py"))))
474 (chmod executable #o555)
475 #t)))
476 (add-after 'install 'create-desktop-file
477 (lambda* (#:key outputs #:allow-other-keys)
478 (let* ((out (assoc-ref outputs "out"))
479 (applications (string-append out "/share/applications")))
480 (mkdir-p applications)
481 (call-with-output-file
482 (string-append applications "/childsplay.desktop")
483 (lambda (file)
484 (format file
485 "[Desktop Entry]~@
486 Name=Childsplay~@
487 Comment=Suite of educational games for young children~@
488 Comment[ca]=Conjunt de jocs educatius per a xiquets~@
489 Comment[es]=Conjunto de juegos educativos para niños~@
490 Comment[de]=Sammlung mit lehrreichen Spielen für kleine Kinder~@
491 Exec=~a/bin/childsplay~@
492 Terminal=false~@
493 Icon=logo_cp.svg~@
494 Type=Application~@
495 Categories=Application;Game;Education;KidsGame;~@
496 Keywords=suite;children;games;young;educational;~%"
497 out)))
498 #t))))))
499 (inputs
500 `(("font-dejavu" ,font-dejavu)
501 ("pygame" ,python2-pygame)
502 ("sqlalchemy" ,python2-sqlalchemy)))
503 (synopsis "Suite of educational games for young children")
504 (description "Childsplay is a collection of educational activities
505 for young children. Childsplay can be used at home, kindergartens and
506 pre-schools. Childsplay is a fun and safe way to let young children
507 use the computer and at the same time teach them a little math,
508 letters of the alphabet, spelling, eye-hand coordination, etc.")
509 (home-page "http://www.schoolsplay.org")
510 (license license:gpl3+)))
511
512 (define-public omnitux
513 (package
514 (name "omnitux")
515 (version "1.2.1")
516 (source
517 (origin
518 (method url-fetch)
519 (uri (string-append "mirror://sourceforge/omnitux/omnitux/"
520 "v" version "/omnitux-" version ".tar.bz2"))
521 (sha256
522 (base32 "1wmmmbzmxd0blhn00d4g91xwavnab143a31ca3i8hrqgzh6qz9w6"))
523 (modules '((guix build utils)))
524 (snippet
525 '(begin
526 ;; Remove pre-compiled .pyc files from source.
527 (for-each delete-file (find-files "bin" "\\.pyc$"))
528 #t))))
529 (build-system python-build-system)
530 (inputs
531 `(("python2-pygame" ,python2-pygame)
532 ("python2-pygtk" ,python2-pygtk)))
533 (arguments
534 `(#:tests? #f ;no test
535 #:python ,python-2
536 #:phases
537 (modify-phases %standard-phases
538 (delete 'build) ;no setup.py
539 (replace 'install
540 (lambda* (#:key outputs #:allow-other-keys)
541 (let* ((out (assoc-ref outputs "out"))
542 (share (string-append out "/share"))
543 (data (string-append share "/omnitux")))
544 ;; Install documentation.
545 (let ((doc (string-append share "/doc/" ,name "-" ,version)))
546 (for-each (lambda (f) (install-file f doc))
547 '("LICENSE.txt" "README.txt")))
548 ;; Install data.
549 (install-file "omnitux.sh" data)
550 (for-each (lambda (d)
551 (copy-recursively d (string-append data "/" d)))
552 '("bin" "data"))
553 ;; Install the launcher.
554 (let* ((bin (string-append out "/bin"))
555 (script (string-append bin "/omnitux"))
556 (bash (string-append (assoc-ref %build-inputs "bash")
557 "/bin/bash"))
558 (python (string-append (assoc-ref %build-inputs "python")
559 "/bin/python2")))
560 (mkdir-p bin)
561 (with-output-to-file script
562 (lambda ()
563 (format #t "#!~a~%" bash)
564 (format #t
565 "cd ~a; ~a menu.py~%"
566 (string-append data "/bin")
567 python)))
568 (chmod script #o755))
569 ;; Install icon and desktop file.
570 (let ((pixmaps (string-append share "/pixmaps")))
571 (install-file "data/default/icons/Omnitux_logo.svg" pixmaps))
572 (let ((apps (string-append out "/share/applications")))
573 (mkdir-p apps)
574 (with-output-to-file (string-append apps "/omnitux.desktop")
575 (lambda _
576 (format #t
577 "[Desktop Entry]~@
578 Name=Omnitux~@
579 GenericName=Omnitux
580 Comment=An educational game based on multimedia elements.~@
581 Comment[fr]=Un jeu ludo-éducatif basé sur des éléments multimédias.~@
582 Exec=~a/bin/omnitux~@
583 Type=Application~@
584 Categories=Game;Education;~@
585 Terminal=false~@
586 Icon=Omnitux_logo.svg~@"
587 out))))
588 #t))))))
589 (home-page "http://omnitux.sourceforge.net/")
590 (synopsis "Educational activities based on multimedia elements")
591 (description "The project aims to provide various educational
592 activities around multimedia elements (images, sounds, texts). Types
593 of activities include:
594 @itemize
595 @item associations,
596 @item items to place on a map or a schema,
597 @item counting activities,
598 @item puzzles,
599 @item card faces to remember,
600 @item find differences between two pictures,
601 @item ...
602 @end itemize
603
604 Activities are available in English, French, German, Polish,
605 Portuguese, Spanish and Italian.")
606 ;; Project's license is GPL3+, but multimedia elements are
607 ;; released under various licenses.
608 (license (list license:gpl3+
609 license:gpl2+
610 license:cc-by-sa2.0
611 license:cc-by-sa3.0
612 license:public-domain))))
613
614 (define-public fet
615 (package
616 (name "fet")
617 (version "5.49.1")
618 (source
619 (origin
620 (method url-fetch)
621 (uri (string-append "https://www.lalescu.ro/liviu/fet/download/"
622 "fet-" version ".tar.bz2"))
623 (sha256
624 (base32 "1aa8xnhwvbhvp7yigcdk7qdwqh59yyfknqbpn3ybgjljc22m8w5n"))))
625 (build-system gnu-build-system)
626 (arguments
627 `(#:phases
628 (modify-phases %standard-phases
629 (add-after 'unpack 'fix-hardcoded-directories
630 (lambda* (#:key outputs #:allow-other-keys)
631 (substitute* (list "fet.pro"
632 "src/src.pro"
633 "src/src-cl.pro"
634 "src/interface/fet.cpp")
635 (("/usr") (assoc-ref outputs "out")))
636 #t))
637 (replace 'configure
638 (lambda _ (invoke "qmake" "fet.pro"))))))
639 (inputs
640 `(("qtbase" ,qtbase)))
641 (home-page "https://www.lalescu.ro/liviu/fet/")
642 (synopsis "Timetabling software")
643 (description
644 "FET is a program for automatically scheduling the timetable of a school,
645 high-school or university. It uses a fast and efficient timetabling
646 algorithm.
647
648 Usually, FET is able to solve a complicated timetable in maximum 5-20 minutes.
649 For extremely difficult timetables, it may take a longer time, a matter of
650 hours.")
651 (license license:agpl3+)))
652
653 (define-public klavaro
654 (package
655 (name "klavaro")
656 (version "3.11")
657 (source
658 (origin
659 (method url-fetch)
660 (uri (string-append "mirror://sourceforge/klavaro/klavaro-"
661 version ".tar.bz2"))
662 (sha256
663 (base32 "1rkxaqb62w4mv86fcnmr32lq6y0h4hh92wmsy5ddb9a8jnzx6r7w"))))
664 (build-system gnu-build-system)
665 (native-inputs
666 `(("intltool" ,intltool)
667 ("pkg-config" ,pkg-config)))
668 (inputs
669 `(("cairo" ,cairo)
670 ("curl" ,curl)
671 ("gtk+" ,gtk+)
672 ("pango" ,pango)))
673 (home-page "https://klavaro.sourceforge.io/en/index.html")
674 (synopsis "Touch typing tutor")
675 (description
676 "Klavaro is a simple tutor to teach correct typing, almost independently of
677 language and very flexible regarding to new or unknown keyboard layouts.")
678 (license license:gpl3+)))
679
680 (define-public ktouch
681 (package
682 (name "ktouch")
683 (version "20.12.1")
684 (source
685 (origin
686 (method url-fetch)
687 (uri (string-append "mirror://kde/stable/release-service/"
688 version "/src/ktouch-" version ".tar.xz"))
689 (sha256
690 (base32 "10lm2p8w26c9n6lhvw3301myfss0dq7hl7rawzb3hsy1lqvmvdib"))))
691 (build-system qt-build-system)
692 (native-inputs
693 `(("extra-cmake-modules" ,extra-cmake-modules)
694 ("kdoctools" ,kdoctools)
695 ("pkg-config" ,pkg-config)))
696 (inputs
697 `(("kcmutils" ,kcmutils)
698 ("kcompletion" ,kcompletion)
699 ("kconfig" ,kconfig)
700 ("kconfigwidgets" ,kconfigwidgets)
701 ("kcoreaddons" ,kcoreaddons)
702 ("kdeclarative" ,kdeclarative)
703 ("ki18n" ,ki18n)
704 ("kiconthemes" ,kiconthemes)
705 ("kitemviews" ,kitemviews)
706 ("kqtquickcharts" ,kqtquickcharts)
707 ("ktextwidgets" ,ktextwidgets)
708 ("kwidgetsaddons" ,kwidgetsaddons)
709 ("kwindowsystem" ,kwindowsystem)
710 ("kxmlgui" ,kxmlgui)
711 ("libxcb" ,libxcb)
712 ("libxkbfile" ,libxkbfile)
713 ("qtbase" ,qtbase)
714 ("qtdeclarative" ,qtdeclarative)
715 ("qtgraphicaleffects" ,qtgraphicaleffects)
716 ("qtquickcontrols2" ,qtquickcontrols2)
717 ("qtx11extras" ,qtx11extras)
718 ("qtxmlpatterns" ,qtxmlpatterns)))
719 (home-page "https://edu.kde.org/ktouch/")
720 (synopsis "Touch typing tutor")
721 (description
722 "KTouch is an aid for learning how to type with speed and accuracy. It
723 provides a sample text to type and indicates which fingers should be used for
724 each key. A collection of lessons are included for a wide range of different
725 languages and keyboard layouts, and typing statistics are used to dynamically
726 adjust the level of difficulty.")
727 (license license:gpl2)))
728
729 (define-public anki
730 (package
731 (name "anki")
732 ;; Later versions have dependencies on npm packages not yet in Guix.
733 (version "2.1.16")
734 (source
735 (origin
736 (method url-fetch)
737 (uri (string-append "https://apps.ankiweb.net/downloads/archive/anki-"
738 version "-source.tgz"))
739 (sha256
740 (base32 "1gfr51rnllkyzli73p4r51h5ypzfa3m7lic3m3rzpywmqwrxs07k"))
741 (patches (search-patches "anki-mpv-args.patch"))))
742 (build-system gnu-build-system)
743 (arguments
744 `(#:make-flags (list (string-append "PREFIX=" %output))
745 #:tests? #f ;no check target
746 #:modules ((guix build gnu-build-system)
747 (guix build utils)
748 (ice-9 match))
749 #:phases
750 (modify-phases %standard-phases
751 (add-after 'unpack 'disable-update-check
752 ;; Don't ‘phone home’ unasked to check for updates.
753 (lambda _
754 (substitute* "aqt/update.py"
755 (("requests\\.post")
756 "throw.an.exception.instead"))
757 #t))
758 (delete 'configure) ;no configure script
759 (add-after 'install 'wrap
760 (lambda* (#:key inputs outputs #:allow-other-keys)
761 (let ((bin (string-append (assoc-ref outputs "out") "/bin"))
762 ;; List of paths to the site-packages directories of Python
763 ;; library inputs.
764 (site-packages
765 (map (lambda (pyinput)
766 (string-append
767 (cdr pyinput)
768 "/lib/python"
769 ;; Calculate the python version to avoid breaking
770 ;; with future 3.X releases.
771 ,(version-major+minor
772 (package-version python-wrapper))
773 "/site-packages"))
774 (filter (match-lambda
775 ((label . _)
776 (string-prefix? "python-" label)))
777 inputs)))
778 (qtwebengineprocess
779 (string-append (assoc-ref inputs "qtwebengine")
780 "/lib/qt5/libexec/QtWebEngineProcess")))
781 ;; The program fails to find the QtWebEngineProcess program, so
782 ;; we set QTWEBENGINEPROCESS_PATH to help it. PYTHONPATH is
783 ;; wrapped to avoid declaring Python libraries as propagated
784 ;; inputs.
785 (for-each (lambda (program)
786 (wrap-program program
787 `("QTWEBENGINEPROCESS_PATH" =
788 (,qtwebengineprocess))
789 `("PATH" prefix (,(string-append
790 (assoc-ref inputs "mpv")
791 "/bin")))
792 `("PYTHONPATH" = ,site-packages)))
793 (find-files bin ".")))
794 #t)))))
795 (native-inputs
796 `(("xdg-utils" ,xdg-utils)))
797 (inputs
798 `(("lame" ,lame)
799 ("mpv" ,mpv)
800 ("python" ,python-wrapper)
801 ("python-beautifulsoup4" ,python-beautifulsoup4)
802 ("python-decorator" ,python-decorator)
803 ("python-distro" ,python-distro)
804 ("python-jsonschema" ,python-jsonschema)
805 ("python-markdown" ,python-markdown)
806 ("python-pyaudio" ,python-pyaudio)
807 ;; `python-pyqtwebengine' must precede `python-pyqt' in PYTHONPATH.
808 ("python-pyqtwebengine" ,python-pyqtwebengine)
809 ("python-pyqt" ,python-pyqt)
810 ("python-requests" ,python-requests)
811 ("python-send2trash" ,python-send2trash)
812 ("python-sip" ,python-sip)
813 ;; `qtwebengine' is included in `pyqtwebengine', included here for easy
814 ;; wrapping.
815 ("qtwebengine" ,qtwebengine)))
816 (home-page "https://apps.ankiweb.net/")
817 (synopsis "Powerful, intelligent flash cards")
818 (description "Anki is a program which makes remembering things
819 easy. Because it's a lot more efficient than traditional study
820 methods, you can either greatly decrease your time spent studying, or
821 greatly increase the amount you learn.
822
823 Anyone who needs to remember things in their daily life can benefit
824 from Anki. Since it is content-agnostic and supports images, audio,
825 videos and scientific markup (via LaTeX), the possibilities are
826 endless. For example:
827 @itemize
828 @item Learning a language
829 @item Studying for medical and law exams
830 @item Memorizing people's names and faces
831 @item Brushing up on geography
832 @item Mastering long poems
833 @item Even practicing guitar chords!
834 @end itemize")
835 (license license:agpl3+)))
836
837 (define-public t4k-common
838 (package
839 (name "t4k-common")
840 (version "0.1.1")
841 (source
842 (origin
843 (method git-fetch)
844 (uri (git-reference
845 (url "https://github.com/tux4kids/t4kcommon")
846 (commit (string-append "upstream/" version))))
847 (file-name (git-file-name name version))
848 (sha256
849 (base32 "13q02xpmps9qg8zrzzy2gzv4a6afgi28lxk4z242j780v0gphchp"))
850 (patches
851 (search-patches "t4k-common-libpng16.patch"))))
852 (build-system cmake-build-system)
853 (arguments
854 `(#:tests? #f ;FIXME: cannot find how to run tests
855 #:phases
856 (modify-phases %standard-phases
857 (add-after 'set-paths 'set-sdl-paths
858 (lambda* (#:key inputs #:allow-other-keys)
859 (setenv "CPATH" (string-append (assoc-ref inputs "sdl")
860 "/include/SDL:"
861 (or (getenv "CPATH") "")))))
862 (add-after 'unpack 'fix-andika-font-path
863 (lambda* (#:key inputs #:allow-other-keys)
864 (substitute* "src/t4k_sdl.c"
865 (("(/usr/share/.*?)/AndikaDesRevG\\.ttf")
866 (string-append (assoc-ref inputs "font-andika")
867 "/share/fonts/truetype")))
868 #t)))))
869 (native-inputs
870 `(("pkg-config" ,pkg-config)))
871 (inputs
872 `(("font-andika" ,font-sil-andika)
873 ("libpng" ,libpng)
874 ("librsvg" ,librsvg)
875 ("libxml2" ,libxml2)
876 ("sdl" ,(sdl-union (list sdl sdl-image sdl-mixer sdl-net sdl-pango)))))
877 (home-page "https://github.com/tux4kids/t4kcommon")
878 (synopsis "Library of code shared between TuxMath and TuxType")
879 (description "Tux4Kids-Common is a library of code shared between
880 TuxMath and TuxType.")
881 (license license:gpl3+)))
882
883 (define-public tuxmath
884 (package
885 (name "tuxmath")
886 (version "2.0.3")
887 (source
888 (origin
889 (method git-fetch)
890 (uri (git-reference
891 (url "https://github.com/tux4kids/tuxmath")
892 (commit (string-append "upstream/" version))))
893 (file-name (git-file-name name version))
894 (sha256
895 (base32 "1f1pz83w6d3mbik2h6xavfxmk5apxlngxbkh80x0m55lhniwkdxv"))
896 (modules '((guix build utils)))
897 ;; Unbundle fonts.
898 (snippet
899 `(begin
900 (for-each delete-file (find-files "data/fonts" "\\.ttf$"))
901 #t))))
902 (build-system gnu-build-system)
903 (arguments
904 `(#:tests? #f ;no test
905 #:phases
906 (modify-phases %standard-phases
907 (add-after 'set-paths 'set-sdl-paths
908 (lambda* (#:key inputs #:allow-other-keys)
909 (setenv "CPATH"
910 (string-append (assoc-ref inputs "sdl")
911 "/include/SDL:"
912 (or (getenv "CPATH") "")))
913 #t))
914 (add-after 'install 'install-desktop-file
915 (lambda* (#:key outputs #:allow-other-keys)
916 (let* ((out (assoc-ref outputs "out"))
917 (apps (string-append out "/share/applications"))
918 (pixmaps (string-append out "/share/pixmaps")))
919 (install-file "tuxmath.desktop" apps)
920 (for-each (lambda (f) (install-file f pixmaps))
921 (find-files "data/images/icons/"
922 "tuxmath\\.(png|ico|svg)$"))
923 #t))))))
924 (native-inputs
925 `(("pkg-config" ,pkg-config)))
926 (inputs
927 `(("librsvg" ,librsvg)
928 ("libxml2" ,libxml2)
929 ("sdl" ,(sdl-union (list sdl sdl-image sdl-mixer sdl-net sdl-pango)))
930 ("t4k-common" ,t4k-common)))
931 (home-page "https://github.com/tux4kids/tuxmath")
932 (synopsis "Educational math tutorial game")
933 (description "@emph{Tux, of Math Command} is an educational math
934 tutorial game starring Tux, the Linux penguin, in which you play the
935 part of Commander Tux, as he defends his friends from an attack of
936 math equations. Comets are crashing towards the friendly penguins in
937 their igloos, and you must destroy the comets by solving their
938 equations.
939
940 TuxMath also includes Factoroids, a game that gives practice in
941 factoring numbers and simplifying fractions, as well as zapping rocks
942 floating through space.")
943 (license license:gpl3+)))
944
945 (define-public mdk
946 (package
947 (name "mdk")
948 (version "1.3.0")
949 (source
950 (origin
951 (method url-fetch)
952 (uri (string-append "mirror://gnu/mdk/v" version "/mdk-"
953 version ".tar.gz"))
954 (sha256
955 (base32
956 "0bhk3c82kyp8167h71vdpbcr852h5blpnwggcswqqwvvykbms7lb"))))
957 (build-system gnu-build-system)
958 (arguments
959 `(#:configure-flags (list "--enable-gui=yes" "-with-readline=yes")))
960 (native-inputs
961 `(("flex" ,flex)
962 ("intltool" ,intltool)
963 ("pkg-config" ,pkg-config)))
964 (inputs
965 `(("glib" ,glib)
966 ("gtk+" ,gtk+)
967 ("libglade" ,libglade)
968 ("ncurses" ,ncurses)
969 ("pango" ,pango)
970 ("readline" ,readline)))
971 (home-page "https://www.gnu.org/software/mdk/manual/")
972 (synopsis "Virtual development environment for Knuth's MIX")
973 (description
974 "GNU MDK is the Mix Development Kit, an emulation of the pedagogical
975 computer MIX and its assembly language MIXAL. MIX has a virtual CPU with
976 standard features such as registers, memory cells, an overflow toggle,
977 comparison flags, input-output devices, and a set of binary instructions.
978 The package includes a compiler, a virtual machine, a GUI for the virtual
979 machine, and more.")
980 (license license:gpl3+)))
981
982 (define-public exercism
983 (package
984 (name "exercism")
985 (version "3.0.13")
986 (source
987 (origin
988 (method git-fetch)
989 (uri (git-reference
990 (url "https://github.com/exercism/cli")
991 (commit (string-append "v" version))))
992 (file-name (git-file-name name version))
993 (sha256
994 (base32
995 "17gvz9a0sn4p36hf4l77bxhhfipf4x998iay31layqwbnzmb4xy7"))
996 (patches (search-patches "exercism-disable-self-update.patch"))))
997 (build-system go-build-system)
998 (arguments
999 `(#:import-path "github.com/exercism/cli/exercism"
1000 #:unpack-path "github.com/exercism/cli"
1001 #:install-source? #f))
1002 (inputs
1003 `(("github.com/blang/semver" ,go-github-com-blang-semver)
1004 ("github.com/spf13/cobra" ,go-github-com-spf13-cobra)
1005 ("github.com/spf13/pflag" ,go-github-com-spf13-pflag)
1006 ("github.com/spf13/viper" ,go-github-com-spf13-viper)
1007 ("golang.org/x/net" ,go-golang-org-x-net)
1008 ("golang.org/x/text" ,go-golang-org-x-text)))
1009 (home-page "https://exercism.io")
1010 (synopsis "Mentored learning for programming languages")
1011 (description "Commandline client for exercism.io, a free service providing
1012 mentored learning for programming languages.")
1013 (license license:expat)))