gnu: cvs-fast-export: Update to 1.56.
[jackhill/guix/guix.git] / gnu / packages / cinnamon.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2017 Nikita <nikita@n0.is>
3 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages cinnamon)
22 #:use-module ((guix licenses) #:prefix license:)
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix git-download)
26 #:use-module (guix utils)
27 #:use-module (guix build-system gnu)
28 #:use-module (gnu packages)
29 #:use-module (gnu packages autotools)
30 #:use-module (gnu packages freedesktop)
31 #:use-module (gnu packages gettext)
32 #:use-module (gnu packages glib)
33 #:use-module (gnu packages gtk)
34 #:use-module (gnu packages gnome)
35 #:use-module (gnu packages pkg-config)
36 #:use-module (gnu packages pulseaudio)
37 #:use-module (gnu packages python)
38 #:use-module (gnu packages xorg))
39
40 (define-public cinnamon-desktop
41 (package
42 (name "cinnamon-desktop")
43 (version "3.4.2")
44 (source (origin
45 (method git-fetch)
46 (uri (git-reference
47 (url "https://github.com/linuxmint/cinnamon-desktop")
48 (commit version)))
49 (file-name (git-file-name name version))
50 (sha256
51 (base32
52 "18mjy80ly9361npjhxpm3n0pkmrwviaqr2kixjb7hyxa6kzzh5xw"))))
53 (build-system gnu-build-system)
54 ;; TODO: package 'libgsystem'.
55 (inputs
56 `(("accountsservice" ,accountsservice)
57 ("gtk+" ,gtk+)
58 ("glib" ,glib)
59 ("gobject-introspection" ,gobject-introspection)
60 ("gnome-common" ,gnome-common)
61 ("libxkbfile" ,libxkbfile)
62 ("libxrandr" ,libxrandr)
63 ("python-2" ,python-2)
64 ("pulseaudio" ,pulseaudio)
65 ("xkeyboard-config" ,xkeyboard-config)))
66 (native-inputs
67 `(("autoconf" ,autoconf)
68 ("automake" ,automake)
69 ("gettext" ,gettext-minimal)
70 ("glib" ,glib "bin") ; glib-gettextize
71 ("intltool" ,intltool)
72 ("libtool" ,libtool)
73 ("pkg-config" ,pkg-config)))
74 (home-page "https://github.com/linuxmint/cinnamon-desktop/")
75 (synopsis "Library for the Cinnamon Desktop")
76 (description
77 "The cinnamon-desktop package contains the libcinnamon-desktop library,
78 as well as some desktop-wide documents.")
79 (license (list license:gpl2+ license:lgpl2.0+
80 license:expat)))) ;display-name.c , edid-parse.c