gnu: webkitgtk: Update to 2.28.2.
[jackhill/guix/guix.git] / gnu / packages / nano.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2016 Rene Saavedra <rennes@openmailbox.org>
5 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
21
22 (define-module (gnu packages nano)
23 #:use-module (guix licenses)
24 #:use-module (gnu packages gettext)
25 #:use-module (gnu packages ncurses)
26 #:use-module (guix packages)
27 #:use-module (guix download)
28 #:use-module (guix build-system gnu))
29
30 (define-public nano
31 (package
32 (name "nano")
33 (version "4.9.2")
34 (source
35 (origin
36 (method url-fetch)
37 (uri (string-append "mirror://gnu/nano/nano-" version ".tar.xz"))
38 (sha256
39 (base32 "1xifbn1xaklrrf7knxvqif0hy0wgnas7w0wfggay5kifjkm5x8nq"))))
40 (build-system gnu-build-system)
41 (inputs
42 `(("gettext" ,gettext-minimal)
43 ("ncurses" ,ncurses)))
44 (home-page "https://www.nano-editor.org/")
45 (synopsis "Small, user-friendly console text editor")
46 (description
47 "GNU nano is a small and simple text editor for use in a terminal. Besides
48 basic editing, it supports: undo/redo, syntax highlighting, spell checking,
49 justifying, auto-indentation, bracket matching, interactive search-and-replace
50 (with regular expressions), and the editing of multiple files.")
51 (license gpl3+))) ; some files are under GPLv2+